source: projects/specs/trunk/s/shflags/shflags-vl.spec @ 7356

Revision 7356, 2.3 KB checked in by iwaim, 11 years ago (diff)

shflags 1.0.3-1

Line 
1%define ver 1.0.3
2%define rel 1
3
4Name:       shflags
5Version:    %{ver}
6Release:    %{rel}%{?_dist_release}
7Summary:    Simple handling of command-line flags in Bourne based Unix scripts
8
9Group:      Development/Languages
10License:    LGPLv2
11URL:        http://code.google.com/p/shflags/
12Source0:    http://shflags.googlecode.com/files/shflags-1.0.3.tgz
13
14BuildArch:  noarch
15
16Requires:       util-linux
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: iwaim
21
22%description
23Shell Flags (shFlags) is a library written to greatly simplify the handling of
24command-line flags in Bourne based Unix shell scripts (bash, dash, ksh, sh, zsh)
25on many Unix OSes (Linux, Solaris, Mac OS X, etc.).
26
27Most shell scripts use getopt for flags processing, but the different versions
28of getopt on various OSes make writing portable shell scripts difficult. shFlags
29instead provides an API that doesn't change across shell and OS versions so the
30script writer can be confident that the script will work.
31
32shFlags is a port of the google-gflags C++/Python library.
33
34%prep
35%setup -q
36
37# Make the examples non-executable.. we're putting them in /usr/share.
38chmod -x examples/*.sh
39
40%build
41# This section is empty because this package ccontains shell scripts
42# to be sourced: there's nothing to build
43
44%check
45pushd src
46sh shflags_test_defines.sh
47sh shflags_test_parsing.sh
48sh shflags_test_public.sh
49sh shflags_test_private.sh
50sh shflags_test.sh
51popd
52
53%install
54mkdir -p %{buildroot}/%{_datadir}/%{name}
55cp -p src/shflags %{buildroot}/%{_datadir}/%{name}/.
56
57%files
58%doc README.txt README.html doc/ examples/
59%{_datadir}/%{name}
60
61%changelog
62* Fri Jan 18 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.3-1
63- initial build for Vine Linux
64
65* Mon Dec 17 2012 Ralph Bean <rbean@redhat.com> - 1.0.3-4
66- Updated the license field to LGPLv2 after receiving feedback from upstream.
67
68* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-3
69- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
70
71* Fri Jul 06 2012 Ralph Bean <rbean@redhat.com> - 1.0.3-2
72- Updated the license field to LGPLv2+
73- Removed BuildRequires util-linux.  Superfluous!
74- Ownership taken for %%{_datadir}/%%{name}
75- Copying with '-p' to preserve
76- Made examples non-exectuable.
77- Added %%check section.
78
79* Mon Jun 25 2012 Ralph Bean <rbean@redhat.com> - 1.0.3-1
80- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.