source: projects/specs/trunk/s/shadow-utils/shadow-utils-vl.spec @ 521

Revision 521, 13.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define WITH_SELINUX 0
2
3Summary: Utilities for managing accounts and shadow password files.
4Summary(ja): シャドウパスワードファイルとアカウントを管理するユーティリティ
5Name: shadow-utils
6Version: 4.1.4.1
7Release: 1%{?_dist_release}
8Epoch: 2
9URL: http://pkg-shadow.alioth.debian.org/
10License: BSD
11Group: System Environment/Base
12
13Source0: http://pkg-shadow.alioth.debian.org/shadow-%{version}.tar.bz2
14Source1: shadow-4.0.17-login.defs
15Source2: shadow-4.0.18.1-useradd
16#Source100: shadow-4.0.16-ja.po
17Patch0: shadow-4.1.4-redhat.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: autoconf, automake, libtool, gettext
21Obsoletes: adduser
22
23%description
24The shadow-utils package includes the necessary programs for
25converting UNIX password files to the shadow password format, plus
26programs for managing user and group accounts. The pwconv command
27converts passwords to the shadow password format. The pwunconv command
28unconverts shadow passwords and generates an npasswd file (a standard
29UNIX password file). The pwck command checks the integrity of password
30and shadow files. The lastlog command prints out the last login times
31for all users. The useradd, userdel, and usermod commands are used for
32managing user accounts. The groupadd, groupdel, and groupmod commands
33are used for managing group accounts.
34
35%description -l ja
36shadow-utilsパッケージはUNIXパスワードファイルをシャドウパスワー
37ドフォーマットに変換するのに必要なプログラムとユーザやグループア
38カウントを管理するプログラムを含みます。
39pwconvコマンドはパスワードをシャドウパスワードフォーマットに変換
40します。pwunconvコマンドはシャドウパスワードを逆変換し、npasswd
41ファイル(標準のUNIXパスワードファイル)を生成します。pwckコマンド
42はパスワードファイルとシャドウパスワードファイルの完全性をチェッ
43クします。lastlogコマンドは全ユーザの最後にログインした時間を出
44力します。useradd、userdelやusermodコマンドはユーザーアカウント
45を管理するのに使用されます。groupadd、groupdelやgroupmodコマンド
46はグループアカウントを管理するのに使用されます。
47 
48
49%prep
50%setup -q -n shadow-%{version}
51%patch0 -p1 -b .redhat-vine
52
53autoreconf -f -i
54
55%build
56%configure \
57        --disable-desrpc \
58        --enable-shadowgrp \
59        --without-libcrack \
60        --with-libcrypt \
61%if %{WITH_SELINUX}
62        --with-selinux \
63%else
64        --without-selinux \
65%endif
66        --without-libpam \
67        --disable-shared
68make
69
70%install
71rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT gnulocaledir=$RPM_BUILD_ROOT/%{_datadir}/locale MKINSTALLDIRS=`pwd`/mkinstalldirs
73install -d -m 755 $RPM_BUILD_ROOT/etc/default
74install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT/etc/login.defs
75install -c -m 0600 %{SOURCE2} $RPM_BUILD_ROOT/etc/default/useradd
76
77
78ln -s useradd $RPM_BUILD_ROOT%{_sbindir}/adduser
79ln -s %{_mandir}/man8/useradd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/adduser.8
80for subdir in $RPM_BUILD_ROOT/%{_mandir}/{??,??_??,??_??.*}/man* ; do
81        test -d $subdir && test -e $subdir/useradd.8 && echo ".so man8/useradd.8" > $subdir/adduser.8
82done
83
84# Remove binaries we don't use.
85rm $RPM_BUILD_ROOT/%{_bindir}/chfn
86rm $RPM_BUILD_ROOT/%{_bindir}/chsh
87rm $RPM_BUILD_ROOT/%{_bindir}/expiry
88rm $RPM_BUILD_ROOT/%{_bindir}/groups
89rm $RPM_BUILD_ROOT/%{_bindir}/login
90rm $RPM_BUILD_ROOT/%{_bindir}/passwd
91rm $RPM_BUILD_ROOT/%{_bindir}/su
92rm $RPM_BUILD_ROOT/%{_sbindir}/logoutd
93rm $RPM_BUILD_ROOT/%{_sbindir}/vipw
94rm $RPM_BUILD_ROOT/%{_sbindir}/vigr
95rm $RPM_BUILD_ROOT/%{_sbindir}/nologin
96rm $RPM_BUILD_ROOT/%{_sbindir}/chgpasswd
97rm $RPM_BUILD_ROOT/%{_mandir}/man1/chfn.*
98rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/chfn.*
99rm $RPM_BUILD_ROOT/%{_mandir}/man1/chsh.*
100rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/chsh.*
101rm $RPM_BUILD_ROOT/%{_mandir}/man1/expiry.*
102rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/expiry.*
103rm $RPM_BUILD_ROOT/%{_mandir}/man1/groups.*
104rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/groups.*
105rm $RPM_BUILD_ROOT/%{_mandir}/man1/login.*
106rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/login.*
107rm $RPM_BUILD_ROOT/%{_mandir}/man1/passwd.*
108rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/passwd.*
109rm $RPM_BUILD_ROOT/%{_mandir}/man1/su.*
110rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/su.*
111rm $RPM_BUILD_ROOT/%{_mandir}/man5/limits.*
112rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/limits.*
113rm $RPM_BUILD_ROOT/%{_mandir}/man5/login.access.*
114rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/login.access.*
115rm $RPM_BUILD_ROOT/%{_mandir}/man5/passwd.*
116rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/passwd.*
117rm $RPM_BUILD_ROOT/%{_mandir}/man5/porttime.*
118rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/porttime.*
119rm $RPM_BUILD_ROOT/%{_mandir}/man5/suauth.*
120rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/suauth.*
121rm $RPM_BUILD_ROOT/%{_mandir}/man8/logoutd.*
122rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/logoutd.*
123rm $RPM_BUILD_ROOT/%{_mandir}/man8/vipw.*
124rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/vipw.*
125rm $RPM_BUILD_ROOT/%{_mandir}/man8/nologin.*
126rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/nologin.*
127rm $RPM_BUILD_ROOT/%{_mandir}/man8/vigr.*
128rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/vigr.*
129rm $RPM_BUILD_ROOT/%{_mandir}/man8/chgpasswd.*
130rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/chgpasswd.*
131
132%find_lang shadow
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files -f shadow.lang
138%defattr(-,root,root)
139%doc NEWS doc/HOWTO README
140%dir /etc/default
141%attr(0644,root,root)   %config /etc/limits
142%attr(0644,root,root)   %config /etc/login.defs
143%attr(0644,root,root)   %config /etc/login.access
144%attr(0600,root,root)   %config /etc/default/useradd
145%{_bindir}/sg
146%{_bindir}/chage
147%{_bindir}/faillog
148%{_bindir}/gpasswd
149%{_bindir}/lastlog
150%{_bindir}/newgrp
151%{_sbindir}/adduser
152%{_sbindir}/user*
153%{_sbindir}/group*
154%{_sbindir}/grpck
155%{_sbindir}/pwck
156%{_sbindir}/*conv
157%{_sbindir}/chpasswd
158%{_sbindir}/newusers
159%{_mandir}/man1/chage.1*
160%{_mandir}/*/man1/chage.1*
161%{_mandir}/man1/gpasswd.1*
162%{_mandir}/*/man1/gpasswd.1*
163%{_mandir}/man1/sg.1*
164%{_mandir}/*/man1/sg.1*
165%{_mandir}/man1/newgrp.1*
166%{_mandir}/*/man1/newgrp.1*
167%{_mandir}/man3/shadow.3*
168%{_mandir}/*/man3/shadow.3*
169%{_mandir}/man3/getspnam.3*
170%{_mandir}/*/man3/getspnam.3*
171%{_mandir}/man5/shadow.5*
172%{_mandir}/*/man5/shadow.5*
173%{_mandir}/man5/login.defs.5*
174%{_mandir}/*/man5/login.defs.5*
175%{_mandir}/man5/gshadow.5*
176%{_mandir}/*/man5/gshadow.5*
177%{_mandir}/man5/faillog.5*
178%{_mandir}/*/man5/faillog.5*
179%{_mandir}/man8/adduser.8*
180%{_mandir}/*/man8/adduser.8*
181%{_mandir}/man8/group*.8*
182%{_mandir}/*/man8/group*.8*
183%{_mandir}/man8/user*.8*
184%{_mandir}/*/man8/user*.8*
185%{_mandir}/man8/pwck.8*
186%{_mandir}/*/man8/pwck.8*
187%{_mandir}/man8/grpck.8*
188%{_mandir}/*/man8/grpck.8*
189%{_mandir}/man8/chpasswd.8*
190%{_mandir}/*/man8/chpasswd.8*
191%{_mandir}/man8/newusers.8*
192%{_mandir}/*/man8/newusers.8*
193%{_mandir}/man8/*conv.8*
194%{_mandir}/*/man8/*conv.8*
195%{_mandir}/man8/lastlog.8*
196%{_mandir}/*/man8/lastlog.8*
197%{_mandir}/man8/faillog.8*
198%{_mandir}/*/man8/faillog.8*
199
200%changelog
201* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.1.4.1-1
202- new upstream release
203  - NEW UPSTREAM: http://pkg-shadow.alioth.debian.org/
204  - update URL:, SOURCES: to new upstream
205
206* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2:4.0.16-1vl5
207- applied new versioning policy, spec in utf-8
208
209* Tue Aug 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.16-0vl3
210- update Patch0 to fix <BTS:0499>
211  - select smaller gid value for system account
212
213* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.16-0vl2
214- update ja.po from debian-doc (committed in upstream)
215
216* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.16-0vl1
217- new upstream release
218- add Japanese Summary and descriptions from spec file translation project.
219- convert Japanese man pages to EUC-JP from UTF-8
220- import changes from FC pacakge.
221
222* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1:4.0.3-35vl2
223- rebuild for VineSeed
224
225* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2:4.0.3-35vl1.1
226- added a security patch (shadow-4.0.3-can-2004-1001.patch) for CAN-2004-1001.
227
228* Mon Oct 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.3-35vl1
229- import Patch1[3-7] from fedora development.
230- fixed username/groupname limits. (vine-users:54797)
231
232* Sat Apr 10 2004 <tkoba@vinelinux.org> 4.0.3-21vl1
233- sync to fedora
234
235* Fri Jun 08 2001 <sagami@vinelinux.org>
236- 20000902-1vl1: added ja.po from 19990827-10vl2
237- disable patch9 (creating mailspool in /var/mail)
238
239* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 20000902-1
240- Create an empty mailspool when creating a user so non-setuid/non-setgid
241  MDAs (postfix+procmail) can deliver mail (#41811)
242- 20000902
243- adapt patches
244
245* Fri Mar  9 2001 Nalin Dahyabhai <nalin@redhat.com>
246- don't overwrite user dot files in useradd (#19982)
247- truncate new files when moving overwriting files with the contents of other
248  files while moving directories (keeps files from looking weird later on)
249- configure using %%{_prefix} as the prefix
250
251* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
252- langify
253
254* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
255- Fix up chage behavior (Bug #15883)
256
257* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
258- 20000826
259- Fix up useradd man page (Bug #17036)
260
261* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
262- check for vipw lock before adding or deleting users (Bug #6489)
263
264* Mon Aug  7 2000 Nalin Dahyabhai <nalin@redhat.com>
265- take LOG_CONS out of the openlog() call so that we don't litter the
266  screen during text-mode upgrades
267
268* Tue Jul 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
269- Remove a fixed-size buffer that caused problems when adding a huge number
270  of users to a group (>8192 bytes) (Bugs #3809, #11930)
271
272* Tue Jul 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
273- remove dependency on util-linux because it causes prereq loops
274
275* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
276- change symlinked man pages to includers
277- require /usr/bin/newgrp (util-linux) so that /usr/bin/sg isn't left dangling
278
279* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
280- automatic rebuild
281
282* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
283- use mandir for FHS
284- added patches in src/ and po/ to honor DESTDIR
285- use make install DESTDIR=$RPM_BUILD_ROOT
286
287* Wed Feb 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
288- Fix up usermod's symlink behavior (Bug #5458)
289
290* Fri Feb 11 2000 Cristian Gafton <gafton@redhat.com>
291- get rid of mkpasswd
292
293* Mon Feb  7 2000 Nalin Dahyabhai <nalin@redhat.com>
294- fix usermod patch to check for shadow before doing any shadow-specific stuff
295  and merge it into the pwlock patch
296
297* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
298- fix man symlinks
299
300* Wed Feb  2 2000 Nalin Dahyabhai <gafton@redhat.com>
301- make -p only change shadow password (bug #8923)
302
303* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
304- rebuild to fix dependeencies
305- man pages are compressed
306
307* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
308- Fix a security bug (adduser could overwrite previously existing
309  groups, Bug #8609)
310
311* Sun Jan  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
312- unset LINGUAS before building
313- Fix typo in newusers manpage (Bug #8258)
314- libtoolize
315
316* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
317- fix segfault for userdel when the primary group for the user is not
318  defined
319
320* Tue Sep 21 1999 Cristian Gafton <gafton@redhat.com>
321- Serial: 1 because now we are using 19990827 (why the heck can't they have
322  a normal version just like everybody else?!)
323- ported all patches to the new code base
324
325* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
326- SIGHUP nscd from usermod, too
327
328* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
329- added usermod password locking from Chris Adams <cadams@ro.com>
330
331* Thu Apr 08 1999 Bill Nottingham <notting@redhat.com>
332- have things that modify users/groups SIGHUP nscd on exit
333
334* Wed Mar 31 1999 Michael K. Johnson <johnsonm@redhat.com>
335- have userdel remove user private groups when it is safe to do so
336- allow -f to force user removal even when user appears busy in utmp
337
338* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
339- edit out unused CHFN fields from login.defs.
340
341* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
342- auto rebuild in the new build environment (release 7)
343
344* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
345- configure fix for arm
346
347* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
348- build against glibc 2.1
349
350* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
351- Note that /usr/sbin/mkpasswd conflicts with /usr/bin/mkpasswd;
352  one of these (I think /usr/sbin/mkpasswd but other opinions are valid)
353  should probably be renamed.  In any case, mkpasswd.8 from this package
354  needs to be installed. (problem #823)
355
356* Fri May 08 1998 Prospector System <bugs@redhat.com>
357- translations modified for de, fr, tr
358
359* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
360- updated to 980403
361- redid the patches
362
363* Tue Dec 30 1997 Cristian Gafton <gafton@redhat.com>
364- updated the spec file
365- updated the patch so that new accounts created on shadowed system won't
366  confuse pam_pwdb anymore ('!!' default password instead on '!')
367- fixed a bug that made useradd -G segfault
368- the check for the ut_user is now patched into configure
369
370* Thu Nov 13 1997 Erik Troan <ewt@redhat.com>
371- added patch for XOPEN oddities in glibc headers
372- check for ut_user before checking for ut_name -- this works around some
373  confusion on glibc 2.1 due to the utmpx header not defining the ut_name
374  compatibility stuff. I used a gross sed hack here because I couldn't make
375  automake work properly on the sparc (this could be a glibc 2.0.99 problem
376  though). The utuser patch works fine, but I don't apply it.
377- sleep after running autoconf
378
379* Thu Nov 06 1997 Cristian Gafton <gafton@redhat.com>
380- added forgot lastlog command to the spec file
381
382* Mon Oct 26 1997 Cristian Gafton <gafton@redhat.com>
383- obsoletes adduser
384
385* Thu Oct 23 1997 Cristian Gafton <gafton@redhat.com>
386- modified groupadd; updated the patch
387
388* Fri Sep 12 1997 Cristian Gafton <gafton@redhat.com>
389- updated to 970616
390- changed useradd to meet RH specs
391- fixed some bugs
392
393* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
394- built against glibc
Note: See TracBrowser for help on using the repository browser.