source: projects/specs/trunk/s/shadow-utils/shadow-utils-vl.spec @ 811

Revision 811, 14.2 KB checked in by daisuke, 14 years ago (diff)

shadow-utils: add missing files

Line 
1%define WITH_SELINUX 0
2
3Summary: Utilities for managing accounts and shadow password files.
4Summary(ja): シャドウパスワードファイルとアカウントを管理するユーティリティ
5Name: shadow-utils
6Version: 4.1.4.2
7Release: 1%{?_dist_release}
8Epoch: 2
9URL: http://pkg-shadow.alioth.debian.org/
10License: BSD
11Group: System Environment/Base
12
13Source0: http://pkg-shadow.alioth.debian.org/shadow-%{version}.tar.bz2
14Source1: shadow-4.0.17-login.defs
15Source2: shadow-utils.useradd
16Patch0: shadow-4.1.4.2-redhat.patch
17Patch1: shadow-4.1.4.1-goodname.patch
18Patch2: shadow-4.1.4.2-leak.patch
19Patch3: shadow-4.1.4.2-fixes.patch
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22#BuildRequires: autoconf, automake, libtool, gettext
23Obsoletes: adduser
24
25%description
26The shadow-utils package includes the necessary programs for
27converting UNIX password files to the shadow password format, plus
28programs for managing user and group accounts. The pwconv command
29converts passwords to the shadow password format. The pwunconv command
30unconverts shadow passwords and generates an npasswd file (a standard
31UNIX password file). The pwck command checks the integrity of password
32and shadow files. The lastlog command prints out the last login times
33for all users. The useradd, userdel, and usermod commands are used for
34managing user accounts. The groupadd, groupdel, and groupmod commands
35are used for managing group accounts.
36
37%description -l ja
38shadow-utilsパッケージはUNIXパスワードファイルをシャドウパスワー
39ドフォーマットに変換するのに必要なプログラムとユーザやグループア
40カウントを管理するプログラムを含みます。
41pwconvコマンドはパスワードをシャドウパスワードフォーマットに変換
42します。pwunconvコマンドはシャドウパスワードを逆変換し、npasswd
43ファイル(標準のUNIXパスワードファイル)を生成します。pwckコマンド
44はパスワードファイルとシャドウパスワードファイルの完全性をチェッ
45クします。lastlogコマンドは全ユーザの最後にログインした時間を出
46力します。useradd、userdelやusermodコマンドはユーザーアカウント
47を管理するのに使用されます。groupadd、groupdelやgroupmodコマンド
48はグループアカウントを管理するのに使用されます。
49 
50
51%prep
52%setup -q -n shadow-%{version}
53%patch0 -p1 -b .redhat-vine
54%patch1 -p1 -b .goodname
55%patch2 -p1 -b .leak
56%patch3 -p1 -b .fixes
57
58#autoreconf -f -i
59
60%build
61%configure \
62        --enable-shadowgrp \
63        --without-libcrack \
64        --with-sha-crypt \
65%if %{WITH_SELINUX}
66        --with-selinux \
67%else
68        --without-selinux \
69%endif
70        --without-libpam \
71        --disable-shared \
72        --with-group-name-max-length=32
73make
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install DESTDIR=$RPM_BUILD_ROOT gnulocaledir=$RPM_BUILD_ROOT/%{_datadir}/locale MKINSTALLDIRS=`pwd`/mkinstalldirs
78install -d -m 755 $RPM_BUILD_ROOT/etc/default
79install -c -m 0644 %{SOURCE1} $RPM_BUILD_ROOT/etc/login.defs
80install -c -m 0600 %{SOURCE2} $RPM_BUILD_ROOT/etc/default/useradd
81
82
83ln -s useradd $RPM_BUILD_ROOT%{_sbindir}/adduser
84ln -s useradd.8 $RPM_BUILD_ROOT/%{_mandir}/man8/adduser.8
85for subdir in $RPM_BUILD_ROOT/%{_mandir}/{??,??_??,??_??.*}/man* ; do
86        test -d $subdir && test -e $subdir/useradd.8 && echo ".so man8/useradd.8" > $subdir/adduser.8
87done
88
89# Remove binaries we don't use.
90rm $RPM_BUILD_ROOT/%{_bindir}/chfn
91rm $RPM_BUILD_ROOT/%{_bindir}/chsh
92rm $RPM_BUILD_ROOT/%{_bindir}/expiry
93rm $RPM_BUILD_ROOT/%{_bindir}/groups
94rm $RPM_BUILD_ROOT/%{_bindir}/login
95rm $RPM_BUILD_ROOT/%{_bindir}/passwd
96rm $RPM_BUILD_ROOT/%{_bindir}/su
97rm $RPM_BUILD_ROOT/%{_sysconfdir}/login.access
98rm $RPM_BUILD_ROOT/%{_sysconfdir}/limits
99rm $RPM_BUILD_ROOT/%{_sbindir}/logoutd
100rm $RPM_BUILD_ROOT/%{_sbindir}/nologin
101rm $RPM_BUILD_ROOT/%{_sbindir}/chgpasswd
102rm $RPM_BUILD_ROOT/%{_mandir}/man1/chfn.*
103rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/chfn.*
104rm $RPM_BUILD_ROOT/%{_mandir}/man1/chsh.*
105rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/chsh.*
106rm $RPM_BUILD_ROOT/%{_mandir}/man1/expiry.*
107rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/expiry.*
108rm $RPM_BUILD_ROOT/%{_mandir}/man1/groups.*
109rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/groups.*
110rm $RPM_BUILD_ROOT/%{_mandir}/man1/login.*
111rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/login.*
112rm $RPM_BUILD_ROOT/%{_mandir}/man1/passwd.*
113rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/passwd.*
114rm $RPM_BUILD_ROOT/%{_mandir}/man1/su.*
115rm $RPM_BUILD_ROOT/%{_mandir}/*/man1/su.*
116rm $RPM_BUILD_ROOT/%{_mandir}/man5/limits.*
117rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/limits.*
118rm $RPM_BUILD_ROOT/%{_mandir}/man5/login.access.*
119rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/login.access.*
120rm $RPM_BUILD_ROOT/%{_mandir}/man5/passwd.*
121rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/passwd.*
122rm $RPM_BUILD_ROOT/%{_mandir}/man5/porttime.*
123rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/porttime.*
124rm $RPM_BUILD_ROOT/%{_mandir}/man5/suauth.*
125rm $RPM_BUILD_ROOT/%{_mandir}/*/man5/suauth.*
126rm $RPM_BUILD_ROOT/%{_mandir}/man8/logoutd.*
127rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/logoutd.*
128rm $RPM_BUILD_ROOT/%{_mandir}/man8/nologin.*
129rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/nologin.*
130rm $RPM_BUILD_ROOT/%{_mandir}/man8/chgpasswd.*
131rm $RPM_BUILD_ROOT/%{_mandir}/*/man8/chgpasswd.*
132
133%find_lang shadow
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%files -f shadow.lang
139%defattr(-,root,root)
140%doc NEWS doc/HOWTO README
141%dir /etc/default
142%attr(0644,root,root)   %config /etc/login.defs
143%attr(0600,root,root)   %config /etc/default/useradd
144%{_bindir}/sg
145%{_bindir}/chage
146%{_bindir}/faillog
147%{_bindir}/gpasswd
148%{_bindir}/lastlog
149%{_bindir}/newgrp
150%{_sbindir}/adduser
151%{_sbindir}/user*
152%{_sbindir}/group*
153%{_sbindir}/grpck
154%{_sbindir}/pwck
155%{_sbindir}/*conv
156%{_sbindir}/chpasswd
157%{_sbindir}/newusers
158%{_sbindir}/vipw
159%{_sbindir}/vigr
160%{_mandir}/man1/chage.1*
161%{_mandir}/*/man1/chage.1*
162%{_mandir}/man1/gpasswd.1*
163%{_mandir}/*/man1/gpasswd.1*
164%{_mandir}/man1/sg.1*
165%{_mandir}/*/man1/sg.1*
166%{_mandir}/man1/newgrp.1*
167%{_mandir}/*/man1/newgrp.1*
168%{_mandir}/man3/shadow.3*
169%{_mandir}/*/man3/shadow.3*
170%{_mandir}/man3/getspnam.3*
171%{_mandir}/*/man3/getspnam.3*
172%{_mandir}/man5/shadow.5*
173%{_mandir}/*/man5/shadow.5*
174%{_mandir}/man5/login.defs.5*
175%{_mandir}/*/man5/login.defs.5*
176%{_mandir}/man5/gshadow.5*
177%{_mandir}/*/man5/gshadow.5*
178%{_mandir}/man5/faillog.5*
179%{_mandir}/*/man5/faillog.5*
180%{_mandir}/man8/adduser.8*
181%{_mandir}/*/man8/adduser.8*
182%{_mandir}/man8/group*.8*
183%{_mandir}/*/man8/group*.8*
184%{_mandir}/man8/user*.8*
185%{_mandir}/*/man8/user*.8*
186%{_mandir}/man8/pwck.8*
187%{_mandir}/*/man8/pwck.8*
188%{_mandir}/man8/grpck.8*
189%{_mandir}/*/man8/grpck.8*
190%{_mandir}/man8/chpasswd.8*
191%{_mandir}/*/man8/chpasswd.8*
192%{_mandir}/man8/newusers.8*
193%{_mandir}/*/man8/newusers.8*
194%{_mandir}/man8/*conv.8*
195%{_mandir}/*/man8/*conv.8*
196%{_mandir}/man8/lastlog.8*
197%{_mandir}/*/man8/lastlog.8*
198%{_mandir}/man8/faillog.8*
199%{_mandir}/*/man8/faillog.8*
200%{_mandir}/man8/vipw.8*
201%{_mandir}/*/man8/vipw.8*
202%{_mandir}/man8/vigr.8*
203%{_mandir}/*/man8/vigr.8*
204
205%changelog
206* Mon Apr 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.1.4.2-1
207- new upstream release
208- add vipw/vigr (moved from util-linux-ng)
209- max group name length set to 32 characters
210- update Patch0
211  - increase threshold for uid/gid reservations to 200
212- import Patch1,2,3 from fedora
213- disable autoreconf
214
215* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.1.4.1-1
216- new upstream release
217  - NEW UPSTREAM: http://pkg-shadow.alioth.debian.org/
218  - update URL:, SOURCES: to new upstream
219
220* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2:4.0.16-1vl5
221- applied new versioning policy, spec in utf-8
222
223* Tue Aug 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.16-0vl3
224- update Patch0 to fix <BTS:0499>
225  - select smaller gid value for system account
226
227* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.16-0vl2
228- update ja.po from debian-doc (committed in upstream)
229
230* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.16-0vl1
231- new upstream release
232- add Japanese Summary and descriptions from spec file translation project.
233- convert Japanese man pages to EUC-JP from UTF-8
234- import changes from FC pacakge.
235
236* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1:4.0.3-35vl2
237- rebuild for VineSeed
238
239* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2:4.0.3-35vl1.1
240- added a security patch (shadow-4.0.3-can-2004-1001.patch) for CAN-2004-1001.
241
242* Mon Oct 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2:4.0.3-35vl1
243- import Patch1[3-7] from fedora development.
244- fixed username/groupname limits. (vine-users:54797)
245
246* Sat Apr 10 2004 <tkoba@vinelinux.org> 4.0.3-21vl1
247- sync to fedora
248
249* Fri Jun 08 2001 <sagami@vinelinux.org>
250- 20000902-1vl1: added ja.po from 19990827-10vl2
251- disable patch9 (creating mailspool in /var/mail)
252
253* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 20000902-1
254- Create an empty mailspool when creating a user so non-setuid/non-setgid
255  MDAs (postfix+procmail) can deliver mail (#41811)
256- 20000902
257- adapt patches
258
259* Fri Mar  9 2001 Nalin Dahyabhai <nalin@redhat.com>
260- don't overwrite user dot files in useradd (#19982)
261- truncate new files when moving overwriting files with the contents of other
262  files while moving directories (keeps files from looking weird later on)
263- configure using %%{_prefix} as the prefix
264
265* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
266- langify
267
268* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
269- Fix up chage behavior (Bug #15883)
270
271* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
272- 20000826
273- Fix up useradd man page (Bug #17036)
274
275* Tue Aug  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
276- check for vipw lock before adding or deleting users (Bug #6489)
277
278* Mon Aug  7 2000 Nalin Dahyabhai <nalin@redhat.com>
279- take LOG_CONS out of the openlog() call so that we don't litter the
280  screen during text-mode upgrades
281
282* Tue Jul 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
283- Remove a fixed-size buffer that caused problems when adding a huge number
284  of users to a group (>8192 bytes) (Bugs #3809, #11930)
285
286* Tue Jul 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
287- remove dependency on util-linux because it causes prereq loops
288
289* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
290- change symlinked man pages to includers
291- require /usr/bin/newgrp (util-linux) so that /usr/bin/sg isn't left dangling
292
293* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
294- automatic rebuild
295
296* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
297- use mandir for FHS
298- added patches in src/ and po/ to honor DESTDIR
299- use make install DESTDIR=$RPM_BUILD_ROOT
300
301* Wed Feb 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
302- Fix up usermod's symlink behavior (Bug #5458)
303
304* Fri Feb 11 2000 Cristian Gafton <gafton@redhat.com>
305- get rid of mkpasswd
306
307* Mon Feb  7 2000 Nalin Dahyabhai <nalin@redhat.com>
308- fix usermod patch to check for shadow before doing any shadow-specific stuff
309  and merge it into the pwlock patch
310
311* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
312- fix man symlinks
313
314* Wed Feb  2 2000 Nalin Dahyabhai <gafton@redhat.com>
315- make -p only change shadow password (bug #8923)
316
317* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
318- rebuild to fix dependeencies
319- man pages are compressed
320
321* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
322- Fix a security bug (adduser could overwrite previously existing
323  groups, Bug #8609)
324
325* Sun Jan  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
326- unset LINGUAS before building
327- Fix typo in newusers manpage (Bug #8258)
328- libtoolize
329
330* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
331- fix segfault for userdel when the primary group for the user is not
332  defined
333
334* Tue Sep 21 1999 Cristian Gafton <gafton@redhat.com>
335- Serial: 1 because now we are using 19990827 (why the heck can't they have
336  a normal version just like everybody else?!)
337- ported all patches to the new code base
338
339* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
340- SIGHUP nscd from usermod, too
341
342* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
343- added usermod password locking from Chris Adams <cadams@ro.com>
344
345* Thu Apr 08 1999 Bill Nottingham <notting@redhat.com>
346- have things that modify users/groups SIGHUP nscd on exit
347
348* Wed Mar 31 1999 Michael K. Johnson <johnsonm@redhat.com>
349- have userdel remove user private groups when it is safe to do so
350- allow -f to force user removal even when user appears busy in utmp
351
352* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
353- edit out unused CHFN fields from login.defs.
354
355* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
356- auto rebuild in the new build environment (release 7)
357
358* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
359- configure fix for arm
360
361* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
362- build against glibc 2.1
363
364* Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
365- Note that /usr/sbin/mkpasswd conflicts with /usr/bin/mkpasswd;
366  one of these (I think /usr/sbin/mkpasswd but other opinions are valid)
367  should probably be renamed.  In any case, mkpasswd.8 from this package
368  needs to be installed. (problem #823)
369
370* Fri May 08 1998 Prospector System <bugs@redhat.com>
371- translations modified for de, fr, tr
372
373* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
374- updated to 980403
375- redid the patches
376
377* Tue Dec 30 1997 Cristian Gafton <gafton@redhat.com>
378- updated the spec file
379- updated the patch so that new accounts created on shadowed system won't
380  confuse pam_pwdb anymore ('!!' default password instead on '!')
381- fixed a bug that made useradd -G segfault
382- the check for the ut_user is now patched into configure
383
384* Thu Nov 13 1997 Erik Troan <ewt@redhat.com>
385- added patch for XOPEN oddities in glibc headers
386- check for ut_user before checking for ut_name -- this works around some
387  confusion on glibc 2.1 due to the utmpx header not defining the ut_name
388  compatibility stuff. I used a gross sed hack here because I couldn't make
389  automake work properly on the sparc (this could be a glibc 2.0.99 problem
390  though). The utuser patch works fine, but I don't apply it.
391- sleep after running autoconf
392
393* Thu Nov 06 1997 Cristian Gafton <gafton@redhat.com>
394- added forgot lastlog command to the spec file
395
396* Mon Oct 26 1997 Cristian Gafton <gafton@redhat.com>
397- obsoletes adduser
398
399* Thu Oct 23 1997 Cristian Gafton <gafton@redhat.com>
400- modified groupadd; updated the patch
401
402* Fri Sep 12 1997 Cristian Gafton <gafton@redhat.com>
403- updated to 970616
404- changed useradd to meet RH specs
405- fixed some bugs
406
407* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
408- built against glibc
Note: See TracBrowser for help on using the repository browser.