source: projects/specs/trunk/s/sgml-common/sgml-common-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Common SGML catalog and DTD files.
2Name:           sgml-common
3Version:        0.6.3
4Release:        33%{?_dist_release}
5Group:          Applications/Text
6
7License:        GPL+
8URL:            http://www.iso.ch/cate/3524030.html
9
10BuildArch:      noarch
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  libxml2 >= 2.4.8
13BuildRequires:  automake14
14Requires:       /bin/basename
15
16Source0: ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/%{name}-%{version}.tgz
17#Source1: sgml-common-CHANGES
18#Source2: sgml-common-automake.tar.gz
19# From openjade:
20Source1: xml.dcl
21Source2: xml.soc
22Source3: html.dcl
23Source4: html.soc
24Patch0: sgml-common-umask.patch
25Patch1: sgml-common-xmldir.patch
26Patch2: sgml-common-quotes.patch
27Patch3: sgml-common-automake.patch
28Patch4: sgml-common-0.6.3-docdir.patch
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34The sgml-common package contains a collection of entities and DTDs
35that are useful for processing SGML, but that don't need to be
36included in multiple packages.  Sgml-common also includes an
37up-to-date Open Catalog file.
38
39%package -n xml-common
40Group: Applications/Text
41Summary: Common XML catalog and DTD files.
42License: GPL+
43
44%description -n xml-common
45The xml-common package contains a collection of entities and DTDs
46that are useful for processing XML, but that don't need to be
47included in multiple packages.
48
49%prep
50%setup -q
51%patch0 -p1 -b .umask
52%patch1 -p1 -b .xmldir
53%patch2 -p1 -b .quotes
54
55#rm install-sh missing mkinstalldirs
56#tar zxf %{SOURCE2}
57#%patch3 -p1 -b .automake
58#%patch4 -p1 -b .docdir
59#touch configure
60#find -name '*.in' | xargs touch
61#touch aclocal.m4
62
63# replace bogus links with files
64for file in COPYING INSTALL install-sh missing mkinstalldirs; do
65   rm $file
66   cp -p /usr/share/automake-1.4/$file .
67done
68
69%build
70%configure
71
72%install
73[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT htmldir='%{_datadir}/doc' INSTALL='install -p'
75
76#cp %{SOURCE1} CHANGES
77mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xml
78mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sgml/docbook
79mkdir -p $RPM_BUILD_ROOT%{_datadir}/sgml/docbook
80# Touch SGML catalog
81touch $RPM_BUILD_ROOT%{_sysconfdir}/sgml/catalog
82# Create an empty XML catalog.
83XMLCATALOG=$RPM_BUILD_ROOT%{_sysconfdir}/xml/catalog
84%{_bindir}/xmlcatalog --noout --create $XMLCATALOG
85# Now put the common DocBook entries in it
86%{_bindir}/xmlcatalog --noout --add "delegatePublic" \
87        "-//OASIS//ENTITIES DocBook XML" \
88        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
89%{_bindir}/xmlcatalog --noout --add "delegatePublic" \
90        "-//OASIS//DTD DocBook XML" \
91        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
92%{_bindir}/xmlcatalog --noout --add "delegatePublic" \
93        "ISO 8879:1986" \
94        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
95%{_bindir}/xmlcatalog --noout --add "delegateSystem" \
96        "http://www.oasis-open.org/docbook/" \
97        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
98%{_bindir}/xmlcatalog --noout --add "delegateURI" \
99        "http://www.oasis-open.org/docbook/" \
100        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
101# Also create the common DocBook catalog
102%{_bindir}/xmlcatalog --noout --create \
103        $RPM_BUILD_ROOT%{_sysconfdir}/sgml/docbook/xmlcatalog
104ln -sf %{_sysconfdir}/sgml/docbook/xmlcatalog\
105        $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/xmlcatalog
106
107rm -f $RPM_BUILD_ROOT%{_datadir}/sgml/xml.dcl
108install -p -m0644 %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
109        $RPM_BUILD_ROOT%{_datadir}/sgml
110rm -rf $RPM_BUILD_ROOT%{_datadir}/xml/*
111
112# remove installed doc file and prepare installation with %%doc
113rm -f $RPM_BUILD_ROOT%{_datadir}/doc/*.html
114rm -rf __dist_doc/html/
115mkdir -p __dist_doc/html/
116cp -p doc/HTML/*.html __dist_doc/html/
117
118%clean
119[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
120
121%files
122%defattr (-,root,root)
123%doc __dist_doc/html/ AUTHORS NEWS ChangeLog README
124%dir %{_sysconfdir}/sgml
125%config(noreplace) %{_sysconfdir}/sgml/sgml.conf
126%ghost %verify(not md5 size mtime) %config(noreplace,missingok) %{_sysconfdir}/sgml/catalog
127%dir %{_datadir}/sgml
128%dir %{_datadir}/sgml/sgml-iso-entities-8879.1986
129%{_datadir}/sgml/sgml-iso-entities-8879.1986/*
130%{_datadir}/sgml/xml.dcl
131%{_datadir}/sgml/xml.soc
132%{_datadir}/sgml/html.dcl
133%{_datadir}/sgml/html.soc
134%{_bindir}/sgmlwhich
135%{_bindir}/install-catalog
136%{_mandir}/man8/install-catalog.8*
137
138%files -n xml-common
139%defattr (-,root,root)
140%dir %{_sysconfdir}/xml
141%dir %{_sysconfdir}/sgml/docbook
142%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/xml/catalog
143%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sgml/docbook/xmlcatalog
144%dir %{_datadir}/sgml
145%dir %{_datadir}/sgml/docbook
146%{_datadir}/sgml/docbook/xmlcatalog
147%dir %{_datadir}/xml
148
149#post
150#if [ -f %{_libdir}/sgml/CATALOG ]; then
151#        rm %{_libdir}/sgml/CATALOG
152#fi
153#
154#{_bindir}/install-catalog --add %{_sysconfdir}/sgml/sgml-iso-entities-8879.1986 %{_datadir}/sgml/sgml-iso-entities-8879.1986/catalog >/dev/null
155
156#preun
157#if [ "$1" = "0" ]; then
158#       %{_bindir}/install-catalog --remove %{_sysconfdir}/sgml/sgml-iso-entities-8879.1986 %{_datadir}/sgml/sgml-iso-entities-8879.1986/catalog >/dev/null
159#fi
160
161%changelog
162* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.3-33
163- updated based on FC 0.6.3-32
164  * Tue Jul 01 2008 Ondrej Vasik <ovasik@redhat.com> 0.6.3-25
165  - mark xmlcatalog config(noreplace) to prevent overwriting
166    of the content, move it to sysconfdir and make symlink for
167    it to silence rpmlint
168  * Mon Jun 30 2008 Ondrej Vasik <ovasik@redhat.com> 0.6.3-24
169  - mark catalog files as (not md5 size mtime) for verify to
170    prevent info about changed files
171  * Thu Nov 15 2007 Ondrej Vasik <ovasik@redhat.com> 0.6.3-22
172  - Merge Review(226415)
173  - changed: License Tag, using RPM macros instead of hardcoded
174    dirs, summary ended with dot, added URL, removed CHANGES
175    file as obsolete, preserved timestamps and some other cosmetic
176    changes
177  - no longer shipping old automake tarball, fixed issue with man8_DATA,
178    BuildRequire:Automake,Autoconf again(see MergeReview discussion)
179
180* Sun Jun  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.3-22
181- updated Requires: coreutils instead of sh-utils fileutils textutils
182- applied new versioning policy
183
184* Sun Jul  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.3-21vl1
185- s/Copyright/License/
186- rebuilt based on Fedora development package 0.6.3-21
187  * Mon May 28 2007 Ondrej Vasik <ovasik@redhat.com> 0.6.3-21
188  - Fixed broken URL (changed to XML entity declarations) (bug #237726)
189  * Tue May 15 2007 Tim Waugh <twaugh@redhat.com> 0.6.3-20
190  - Added dist tag.
191  - Fixed summary.
192  - Removed build dependency on autoconf/automake.
193  * Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com> 0.6.3-19
194  - Removed stale URL (bug #210848).
195
196* Tue Jun  3 2003 Jun Nishii <jun@vinelinux.org> 0.6.3-14vl2
197- added install-catalog process in post/preun scripts
198
199* Sat Apr 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.6.3-14vl1
200- sync Rawhide 0.6.3-14
201
202* Thu Jan 31 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.6.3-8vl1
203- sync Rawhide 0.6.3-8
204  - added BuildRequires: libxml2 >= 2.4.8
205  - Use (and handle) catalog files with quotes in install-catalog.
206    (sgml-common-quotes.patch)
207  - added sgml-common-xmldir.patch
208  - use rpmmacros
209- obsoleted sgml-common-oldsyntax.patch ( upstream merged )
210
211
212* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5-7vl1
213- Rebuild for Vine.
214- Added a script to remove old catalog file.
215
216* Wed May 23 2001 Tim Waugh <twaugh@redhat.com> 0.5-7
217- Remove execute bit from data files.
218
219* Mon May 21 2001 Tim Waugh <twaugh@redhat.com> 0.5-6
220- install-catalog needs to make sure that it creates world-readable files
221  (bug #41552).
222
223* Wed Mar 14 2001 Tim Powers <timp@redhat.com> 0.5-5
224- fixed license
225
226* Wed Jan 24 2001 Tim Waugh <twaugh@redhat.com>
227- Make install-catalog quieter during normal operation.
228
229* Tue Jan 23 2001 Tim Waugh <twaugh@redhat.com>
230- Require textutils, fileutils, grep (bug #24719).
231
232* Wed Jan 17 2001 Tim Waugh <twaugh@redhat.com>
233- Require sh-utils.
234
235* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
236- Don't play so many macro games.
237- Fix typo in install-catalog patch.
238
239* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
240- Change group.
241- Install by hand (man/en/...).  Use %%{_mandir}.
242- Use %%{_tmppath}.
243- Make install-catalog fail silently if given the old syntax.
244- Add CHANGES file.
245- Change Copyright: to License:.
246- Remove Packager: line.
247
248* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
249- Based on Eric Bischoff's new-trials packages.
Note: See TracBrowser for help on using the repository browser.