source: projects/specs/trunk/s/sgml-common/sgml-common-vl.spec @ 9094

Revision 9094, 9.5 KB checked in by inagaki, 9 years ago (diff)

2014-11-16 Ryoichi INAGAKI <ryo1@…>

  • gtk2, sgml-common: updated


Line 
1%global xmlxsdver 2009/01
2
3Summary:        Common SGML catalog and DTD files.
4Summary(ja):    共用 SGML カタログ及び DTD ファイル集
5Name:           sgml-common
6Version:        0.6.3
7Release:        41%{?_dist_release}
8
9License:        GPL+
10Group:          Applications/Text
11#Actually - there is no homepage of this project, on that URL
12#page you could get complete ISO 8879 listing as was on the
13#old page - only part of it is included in sgml-common package.
14URL: http://www.w3.org/2003/entities/
15
16Source0: ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/%{name}-%{version}.tgz
17# From openjade:
18Source1: xml.dcl
19Source2: xml.soc
20Source3: html.dcl
21Source4: html.soc
22Source5: http://www.w3.org/%{xmlxsdver}/xml.xsd
23Patch0: sgml-common-umask.patch
24Patch1: sgml-common-xmldir.patch
25Patch2: sgml-common-quotes.patch
26
27BuildArch:      noarch
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29BuildRequires:  libxml2 >= 2.4.8
30BuildRequires:  automake
31Requires:       /bin/basename
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37The sgml-common package contains a collection of entities and DTDs
38that are useful for processing SGML, but that don't need to be
39included in multiple packages.  Sgml-common also includes an
40up-to-date Open Catalog file.
41
42%package -n xml-common
43Summary: Common XML catalog and DTD files.
44Summary(ja): 共用 XML カタログ及び DTD ファイル集
45License: GPL+
46Group: Applications/Text
47Requires(pre): %{_bindir}/xmlcatalog
48
49%description -n xml-common
50The xml-common package contains a collection of entities and DTDs
51that are useful for processing XML, but that don't need to be
52included in multiple packages.
53
54%prep
55%setup -q
56%patch0 -p1 -b .umask
57%patch1 -p1 -b .xmldir
58%patch2 -p1 -b .quotes
59
60# replace bogus links with files
61automakedir=`ls -1d /usr/share/automake* | head -n +1`
62for file in COPYING INSTALL install-sh missing mkinstalldirs; do
63   rm $file
64   cp -p $automakedir/$file .
65done
66
67%build
68%configure
69
70%install
71[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
72make install DESTDIR=$RPM_BUILD_ROOT htmldir='%{_datadir}/doc' INSTALL='install -p'
73
74#cp %{SOURCE1} CHANGES
75mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xml
76mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sgml/docbook
77mkdir -p $RPM_BUILD_ROOT%{_datadir}/sgml/docbook
78# Touch SGML catalog
79touch $RPM_BUILD_ROOT%{_sysconfdir}/sgml/catalog
80# Create an empty XML catalog.
81XMLCATALOG=$RPM_BUILD_ROOT%{_sysconfdir}/xml/catalog
82%{_bindir}/xmlcatalog --noout --create $XMLCATALOG
83# ...and add xml.xsd in it
84for type in system uri ; do
85        for path in 2001 %{xmlxsdver} ; do
86                %{_bindir}/xmlcatalog --noout --add $type \
87                        "http://www.w3.org/$path/xml.xsd" \
88                        "file://%{_datadir}/xml/xml.xsd" $XMLCATALOG
89        done
90done
91
92# Now put the common DocBook entries in it
93%{_bindir}/xmlcatalog --noout --add "delegatePublic" \
94        "-//OASIS//ENTITIES DocBook XML" \
95        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
96%{_bindir}/xmlcatalog --noout --add "delegatePublic" \
97        "-//OASIS//DTD DocBook XML" \
98        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
99%{_bindir}/xmlcatalog --noout --add "delegatePublic" \
100        "ISO 8879:1986" \
101        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
102%{_bindir}/xmlcatalog --noout --add "delegateSystem" \
103        "http://www.oasis-open.org/docbook/" \
104        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
105%{_bindir}/xmlcatalog --noout --add "delegateURI" \
106        "http://www.oasis-open.org/docbook/" \
107        "file://%{_sysconfdir}/sgml/docbook/xmlcatalog" $XMLCATALOG
108# Also create the common DocBook catalog
109%{_bindir}/xmlcatalog --noout --create \
110        $RPM_BUILD_ROOT%{_sysconfdir}/sgml/docbook/xmlcatalog
111ln -sf %{_sysconfdir}/sgml/docbook/xmlcatalog\
112        $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/xmlcatalog
113
114rm -f $RPM_BUILD_ROOT%{_datadir}/sgml/xml.dcl
115install -p -m0644 %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
116        $RPM_BUILD_ROOT%{_datadir}/sgml
117rm -rf $RPM_BUILD_ROOT%{_datadir}/xml/*
118install -p -m0644 %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/xml
119
120# remove installed doc file and prepare installation with %%doc
121rm -f $RPM_BUILD_ROOT%{_datadir}/doc/*.html
122rm -rf __dist_doc/html/
123mkdir -p __dist_doc/html/
124cp -p doc/HTML/*.html __dist_doc/html/
125
126%clean
127[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
128
129%pre -n xml-common
130if [ $1 -gt 1 ] && [ -e %{_sysconfdir}/xml/catalog ]; then
131        for type in system uri ; do
132                for path in 2001 %{xmlxsdver} ; do
133                        %{_bindir}/xmlcatalog --noout --add $type \
134                                "http://www.w3.org/$path/xml.xsd" \
135                                "file://%{_datadir}/xml/xml.xsd" \
136                                %{_sysconfdir}/xml/catalog
137                done
138        done
139fi
140
141%files
142%defattr (-,root,root)
143%doc __dist_doc/html/ AUTHORS NEWS ChangeLog COPYING README
144%dir %{_sysconfdir}/sgml
145%config(noreplace) %{_sysconfdir}/sgml/sgml.conf
146%ghost %verify(not md5 size mtime) %config(noreplace,missingok) %{_sysconfdir}/sgml/catalog
147%dir %{_datadir}/sgml
148%dir %{_datadir}/sgml/sgml-iso-entities-8879.1986
149%{_datadir}/sgml/sgml-iso-entities-8879.1986/*
150%{_datadir}/sgml/xml.dcl
151%{_datadir}/sgml/xml.soc
152%{_datadir}/sgml/html.dcl
153%{_datadir}/sgml/html.soc
154%{_bindir}/sgmlwhich
155%{_bindir}/install-catalog
156%{_mandir}/man8/install-catalog.8*
157
158%files -n xml-common
159%defattr (-,root,root)
160%doc AUTHORS NEWS ChangeLog COPYING README
161%dir %{_sysconfdir}/xml
162%dir %{_sysconfdir}/sgml/docbook
163%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/xml/catalog
164%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sgml/docbook/xmlcatalog
165%dir %{_datadir}/sgml
166%dir %{_datadir}/sgml/docbook
167%{_datadir}/sgml/docbook/xmlcatalog
168%dir %{_datadir}/xml
169%{_datadir}/xml/xml.xsd
170
171
172%changelog
173* Sun Nov 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.3-41
174- updated based on Fedora 0.6.3-41
175  * Thu Oct 11 2012 Ondrej Vasik <ovasik@redhat.com> 0.6.3-38
176  - get rid of the explicit automake14 requirement
177  * Sun Oct 30 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.6.3-35
178  - Include xml.xsd in xml-common (#750073).
179 
180* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.3-35
181- rebuild with VineSeed environment
182
183* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 0.6.3-34
184- sync Fedora 0.6.3-34
185 * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-34
186 -  Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
187 * Mon Jul 12 2010 Ondrej Vasik <ovasik@redhat.com> 0.6.3-33
188 - ship COPYING file with both sgml-common and xml-common
189 - ship documentation with xml-common
190
191* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.3-33
192- updated based on FC 0.6.3-32
193  * Tue Jul 01 2008 Ondrej Vasik <ovasik@redhat.com> 0.6.3-25
194  - mark xmlcatalog config(noreplace) to prevent overwriting
195    of the content, move it to sysconfdir and make symlink for
196    it to silence rpmlint
197  * Mon Jun 30 2008 Ondrej Vasik <ovasik@redhat.com> 0.6.3-24
198  - mark catalog files as (not md5 size mtime) for verify to
199    prevent info about changed files
200  * Thu Nov 15 2007 Ondrej Vasik <ovasik@redhat.com> 0.6.3-22
201  - Merge Review(226415)
202  - changed: License Tag, using RPM macros instead of hardcoded
203    dirs, summary ended with dot, added URL, removed CHANGES
204    file as obsolete, preserved timestamps and some other cosmetic
205    changes
206  - no longer shipping old automake tarball, fixed issue with man8_DATA,
207    BuildRequire:Automake,Autoconf again(see MergeReview discussion)
208
209* Sun Jun  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.3-22
210- updated Requires: coreutils instead of sh-utils fileutils textutils
211- applied new versioning policy
212
213* Sun Jul  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.3-21vl1
214- s/Copyright/License/
215- rebuilt based on Fedora development package 0.6.3-21
216  * Mon May 28 2007 Ondrej Vasik <ovasik@redhat.com> 0.6.3-21
217  - Fixed broken URL (changed to XML entity declarations) (bug #237726)
218  * Tue May 15 2007 Tim Waugh <twaugh@redhat.com> 0.6.3-20
219  - Added dist tag.
220  - Fixed summary.
221  - Removed build dependency on autoconf/automake.
222  * Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com> 0.6.3-19
223  - Removed stale URL (bug #210848).
224
225* Tue Jun  3 2003 Jun Nishii <jun@vinelinux.org> 0.6.3-14vl2
226- added install-catalog process in post/preun scripts
227
228* Sat Apr 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.6.3-14vl1
229- sync Rawhide 0.6.3-14
230
231* Thu Jan 31 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.6.3-8vl1
232- sync Rawhide 0.6.3-8
233  - added BuildRequires: libxml2 >= 2.4.8
234  - Use (and handle) catalog files with quotes in install-catalog.
235    (sgml-common-quotes.patch)
236  - added sgml-common-xmldir.patch
237  - use rpmmacros
238- obsoleted sgml-common-oldsyntax.patch ( upstream merged )
239
240
241* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.5-7vl1
242- Rebuild for Vine.
243- Added a script to remove old catalog file.
244
245* Wed May 23 2001 Tim Waugh <twaugh@redhat.com> 0.5-7
246- Remove execute bit from data files.
247
248* Mon May 21 2001 Tim Waugh <twaugh@redhat.com> 0.5-6
249- install-catalog needs to make sure that it creates world-readable files
250  (bug #41552).
251
252* Wed Mar 14 2001 Tim Powers <timp@redhat.com> 0.5-5
253- fixed license
254
255* Wed Jan 24 2001 Tim Waugh <twaugh@redhat.com>
256- Make install-catalog quieter during normal operation.
257
258* Tue Jan 23 2001 Tim Waugh <twaugh@redhat.com>
259- Require textutils, fileutils, grep (bug #24719).
260
261* Wed Jan 17 2001 Tim Waugh <twaugh@redhat.com>
262- Require sh-utils.
263
264* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
265- Don't play so many macro games.
266- Fix typo in install-catalog patch.
267
268* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
269- Change group.
270- Install by hand (man/en/...).  Use %%{_mandir}.
271- Use %%{_tmppath}.
272- Make install-catalog fail silently if given the old syntax.
273- Add CHANGES file.
274- Change Copyright: to License:.
275- Remove Packager: line.
276
277* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
278- Based on Eric Bischoff's new-trials packages.
Note: See TracBrowser for help on using the repository browser.