source: projects/specs/trunk/s/sg3_utils/sg3_utils-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define rescan_version 1.29
2
3Summary: Utilities for devices that use SCSI command sets
4Summary(ja): SCSIコマンドセットを利用するデバイスのためのユーティリティ
5Name: sg3_utils
6Version: 1.27
7Release: 1%{?_dist_release}
8License: GPLv2+ and BSD
9Group: Applications/System
10Source0: http://sg.danny.cz/sg/p/sg3_utils-%{version}.tgz
11Source1: http://www.garloff.de/kurt/linux/rescan-scsi-bus.sh-%{rescan_version}
12URL: http://sg.danny.cz/sg/sg3_utils.html
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14Requires: %{name}-libs = %{version}-%{release}
15
16
17%description
18Collection of Linux utilities for devices that use the SCSI command set.
19Includes utilities to copy data based on "dd" syntax and semantics (called
20sg_dd, sgp_dd and sgm_dd); check INQUIRY data and VPD pages (sg_inq); check
21mode and log pages (sginfo, sg_modes and sg_logs); spin up and down
22disks (sg_start); do self tests (sg_senddiag); and various other functions.
23See the README, CHANGELOG and COVERAGE files. Requires the linux kernel 2.4
24series or later. In the 2.4 series SCSI generic device names (e.g. /dev/sg0)
25must be used. In the 2.6 series other device names may be used as
26well (e.g. /dev/sda).
27
28Warning: Some of these tools access the internals of your system
29and the incorrect usage of them may render your system inoperable.
30
31%package libs
32Summary: Shared library for %{name}
33Summary(ja): %{name} の共有ライブラリ
34Group: System Environment/Libraries
35
36%description libs
37This package contains the shared library for %{name}.
38
39%package devel
40Summary: Development library and header files for the sg3_utils library
41Summary(ja): %{name} ライブラリの開発ファイル
42Group: Development/Libraries
43Requires: %{name}-libs = %{version}-%{release}
44Requires: glibc-headers
45
46%description devel
47This package contains the %{name} library and its header files for
48developing applications.
49
50%prep
51%setup -q
52
53
54%build
55%configure --disable-static
56
57# Don't use rpath!
58sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
59sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
60
61make %{?_smp_mflags}
62
63
64%install
65make install DESTDIR=$RPM_BUILD_ROOT
66rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
67
68install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/rescan-scsi-bus.sh
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%post libs -p /sbin/ldconfig
76
77%postun libs -p /sbin/ldconfig
78
79
80%files
81%defattr(-,root,root)
82%doc ChangeLog COVERAGE CREDITS INSTALL README README.sg_start
83%attr(755,root,root) %{_bindir}/*
84%{_mandir}/man8/*
85
86%files libs
87%defattr(-,root,root)
88%{_libdir}/*.so.*
89
90%files devel
91%defattr(-,root,root)
92%{_includedir}/scsi/*.h
93%{_libdir}/*.so
94
95 
96%changelog
97* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-1
98- initial build for Vine Linux
99
100* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.27-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
102
103* Tue Apr 28 2009 Dan Horák <dan@danny.cz> - 1.27-1
104- update to version 1.27
105- changelog: http://sg.danny.cz/sg/p/sg3_utils.ChangeLog
106
107* Tue Mar 31 2009 Dan Horák <dan@danny.cz> - 1.26-4
108- add dependency between the libs subpackage and the main package (#492921)
109
110* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.26-3
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
112
113* Mon Nov  3 2008 Dan Horák <dan@danny.cz> - 1.26-2
114- update URL
115- include rescan-scsi-bus script 1.29
116
117* Mon Jun 30 2008 Dan Horák <dan@danny.cz> - 1.26-1
118- update to upstream version 1.26
119
120* Fri Mar 28 2008 Phil Knirsch <pknirsch@redhat.com> - 1.25-4
121- Dropped really unnecessary Provides of sg_utils (#226414)
122- Use --disable-static in configure (#226414)
123
124* Thu Mar 27 2008 Phil Knirsch <pknirsch@redhat.com> - 1.25-3
125- Specfile cleanup, removal of static development libraries (#226414)
126
127* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.25-2
128- Autorebuild for GCC 4.3
129
130* Mon Oct 22 2007 Phil Knirsch <pknirsch@redhat.com> - 1.25-1
131- Fixed URLs
132- Updated to sg3_utils-1.25
133
134* Thu Aug 16 2007 Phil Knirsch <pknirsch@redhat.com> - 1.23-2
135- License review and update
136
137* Fri Feb 02 2007 Phil Knirsch <pknirsch@redhat.com> - 1.23-1
138- Update to sg3_utils-1.23
139- Updated summary
140
141* Mon Nov 13 2006 Phil Knirsch <pknirsch@redhat.com> - 1.22-1
142- Update to sg3_utils-1.22
143
144* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.20-2.1
145- rebuild
146
147* Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 1.20-2
148- Fixed rebuild problem on latest toolchain
149- Added missing buildprereqs
150
151* Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com> - 1.20-1
152- Update to sg3_utils-1.20.
153
154* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.19-1.1
155- bump again for double-long bug on ppc(64)
156
157* Fri Feb 10 2006 Phil Knirsch <pknirsch@redhat.com> - 1.19-1
158- Update to sg3_utils-1.19.
159- Fixed rebuild problem on 64bit archs.
160
161* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.17-1.1
162- rebuilt for new gcc4.1 snapshot and glibc changes
163
164* Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 1.17-1
165- Update to sg3-utils-1.17
166- Split package up into 3 subpackages: sg3_utils, devel and libs
167- Some minor updates to the specfile
168
169* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.06-5
170- bump release and rebuild with gcc 4
171
172* Fri Feb 18 2005 Phil Knirsch <pknirsch@redhat.com> 1.06-4
173- rebuilt
174
175* Tue Aug 03 2004 Phil Knirsch <pknirsch@redhat.com> 1.06-3
176- rebuilt
177
178* Thu Mar 11 2004 Tim Powers <timp@redhat.com> 1.06-2
179- rebuild
180
181* Wed Feb 18 2004 Phil Knirsch <pknirsch@redhat.com> 1.06-1
182- Initial version for RHEL3 U2.
183
184* Fri Jan 09 2004 - dgilbert@interlog.com
185- sg3_utils.spec for mandrake; more sginfo work, sg_scan, sg_logs
186  * sg3_utils-1.06
187
188* Wed Nov 12 2003 - dgilbert@interlog.com
189- sg_readcap: sizes; sg_logs: double fetch; sg_map 256 sg devices; sginfo
190  * sg3_utils-1.05
191
192* Tue May 13 2003 - dgilbert@interlog.com
193- default sg_turs '-n=' to 1, sg_logs gets '-t' for temperature, CREDITS
194  * sg3_utils-1.04
195
196* Wed Apr 02 2003 - dgilbert@interlog.com
197- 6 byte CDBs for sg_modes, sg_start on block devs, sg_senddiag, man pages
198  * sg3_utils-1.03
199
200* Wed Jan 01 2003 - dgilbert@interlog.com
201- interwork with block SG_IO, fix in sginfo, '-t' for sg_turs
202  * sg3_utils-1.02
203
204* Wed Aug 14 2002 - dgilbert@interlog.com
205- raw switch in sg_inq
206  * sg3_utils-1.01
207
208* Sun Jul 28 2002 - dgilbert@interlog.com
209- decode sg_logs pages, add dio to sgm_dd, drop "gen=1" arg, "of=/dev/null"
210  * sg3_utils-1.00
211
212* Sun Mar 17 2002 - dgilbert@interlog.com
213- add sg_modes+sg_logs for sense pages, expand sg_inq, add fua+sync to sg_dd++
214  * sg3_utils-0.99
215
216* Sat Feb 16 2002 - dgilbert@interlog.com
217- resurrect sg_reset; snprintf cleanup, time,gen+cdbsz args to sg_dd++
218  * sg3_utils-0.98
219
220* Sun Dec 23 2001 - dgilbert@interlog.com
221- move isosize to archive directory; now found in util-linux-2.10s and later
222  * sg3_utils-0.97
223
224* Fri Dec 21 2001 - dgilbert@interlog.com
225- add sgm_dd, sg_read, sg_simple4 and sg_simple16 [add mmap-ed IO support]
226  * sg3_utils-0.96
227
228* Sun Sep 15 2001 - dgilbert@interlog.com
229- sg_map can do inquiry; sg_dd, sgp_dd + sgq_dd dio help
230  * sg3_utils-0.95
231
232* Sun Apr 19 2001 - dgilbert@interlog.com
233- add sg_start, improve sginfo and sg_map [Kurt Garloff]
234  * sg3_utils-0.94
235
236* Sun Mar 5 2001 - dgilbert@interlog.com
237- add scsi_devfs_scan, add sg_include.h, 'coe' more general in sgp_dd
238  * sg3_utils-0.93
239
240* Tue Jan 16 2001 - dgilbert@interlog.com
241- clean sg_err.h include dependencies, bug fixes, Makefile in archive directory
242  * sg3_utils-0.92
243
244* Mon Dec 21 2000 - dgilbert@interlog.com
245- signals for sg_dd, man pages and additions for sg_rbuf and isosize
246  * sg3_utils-0.91
247
248* Mon Dec 11 2000 - dgilbert@interlog.com
249- Initial creation of package, containing
250  * sg3_utils-0.90
Note: See TracBrowser for help on using the repository browser.