source: projects/specs/trunk/s/setuptool/setuptool-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A text mode system configuration tool
2Summary(ja): テキストモードのシステム設定ツール
3# the name is "setuptool" because we already have a package
4# named "setup".  Oh, well.
5Name: setuptool
6Version: 1.19.4
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/System
10Source: %{name}-%{version}.tar.gz
11Source10: %{name}-1.19.4-ja.po
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17Requires: usermode
18BuildRequires: newt-devel, desktop-file-utils
19
20%description
21Setuptool is a user-friendly text mode menu utility which allows you
22to access all of the text mode configuration programs included in the
23Vine Linux operating system.
24
25%description -l ja
26setuptool は Vine Linux オペレーティングシステムに含まれる全ての
27テキストモード設定プログラムにアクセスするためのユーザフレンドリーな
28テキストモードのメニューユーティリティーです。
29
30%prep
31if [ -e %{buildroot} ] ; then
32    [ "%{buildroot}" != "/" ] && %{__rm} -r %{buildroot}
33fi
34
35%setup -q
36
37cp -f %{SOURCE10} po/ja.po
38
39%build
40%configure
41%{__make}
42%{__make} setuptool.desktop
43
44%install
45%{__rm} -rf $RPM_BUILD_ROOT
46%{__make} install DESTDIR=$RPM_BUILD_ROOT
47
48desktop-file-install --dir $RPM_BUILD_ROOT%{_datadir}/applications setuptool.desktop
49
50%find_lang setup
51
52%post
53if [ -x %{_bindir}/update-desktop-database ] ; then
54    %{_bindir}/update-desktop-database %{_datadir}/applications
55fi
56
57%postun
58if [ -x %{_bindir}/update-desktop-database ] ; then
59    %{_bindir}/update-desktop-database %{_datadir}/applications
60fi
61
62
63%clean
64%{__rm} -rf %{buildroot}
65
66%files -f setup.lang
67%defattr(-,root,root)
68%doc README
69%{_sysconfdir}/pam.d/setup
70%{_sysconfdir}/security/console.apps/setup
71%dir %{_sysconfdir}/setuptool.d
72%{_sysconfdir}/setuptool.d/*
73%{_bindir}/*
74%{_sbindir}/*
75%{_datadir}/applications/*
76
77
78%changelog
79* Wed Aug 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19.4-1
80- new upstream release
81
82* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.2-6vl5
83- applied new versioning policy, spec in utf-8
84
85* Wed Feb 20 2008 Takuya Kobayashi <ruby11@cocoa.ocn.ne.jp> 1.2-5vl9
86- rebuild for Vine Seed
87
88* Wed Feb 20 2008 Takuya Kobayashi <ruby11@cocoa.ocn.ne.jp> 1.2-5vl8
89- update desktop entry file <BTS:VineLinux:509>
90-  merge Source10,Source11 into new Source10
91-  add %{_sbindir}/setup-with-su for xfce
92-  update Source1(setuptool-ja.po) for %{_sbindir}/setup-with-su
93- update Spec File
94-  update %%description
95-  add %%check, %%post, and %%postun for desktop entry file
96-  update %%prep and %%install for deleting unnecessary files
97-  add Requires: newt
98-  add BuildRequires: newt-devel desktop-file-utils
99-  use macros
100
101* Sun Sep 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-5vl7
102- use alsaconf instead of sndconfig
103- add lokkit
104
105* Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-5vl6
106- use License instead of Copyright
107
108* Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-5vl5
109- add Japanese translation for desktopfile. (SOURCE11)
110- add setuptool icon. (SOURCE10)
111
112* Sun Jul 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org>
113- 1.2-5vl4
114- added Patch12
115    - Xconfigurator -> Xautoconfig4 for ppc
116    - disable sndconfig for ppc
117
118* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
119- 1.2-5vl3
120- change checkbox color
121- use better macros
122
123* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
124- wmconfig -> desktop
125
126* Thu Feb  3 2000 Nalin Dahyabhai <nalin@redhat.com>
127- rebuilt in new environment
128
129* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
130- rebuilt against newt 0.50
131
132* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
133- strip binary
134
135* Fri Mar 26 1999 Bill Nottingham <notting@redhat.com>
136- port to C, so we can get python out of base component
137
138* Tue Mar 16 1999 Bill Nottingham <notting@redhat.com>
139- add support for authconfig, remove cabaret
140
141* Wed Nov 05 1997 Michael K. Johnson <johnsonm@redhat.com>
142- initial version
143
Note: See TracBrowser for help on using the repository browser.