source: projects/specs/trunk/s/sed/sed-vl.spec @ 521

Revision 521, 6.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%ifos linux
2%define _bindir /bin
3%endif
4
5Summary: A GNU stream text editor.
6Summary(ja): GNU ストリームテキストエディタ
7Name: sed
8Version: 4.2.1
9Release: 2%{?_dist_release}
10License: GPLv2+
11Group: Applications/Text
12Source0: ftp://ftp.gnu.org/pub/gnu/sed/sed-%{version}.tar.bz2
13Patch0: sed-4.2.1-dummyparam.diff
14Patch1: sed-4.2.1-multibyte.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: glibc-devel
18BuildRequires: libacl-devel
19Requires(post,preun): /sbin/install-info
20
21%description
22The sed (Stream EDitor) editor is a stream or batch (non-interactive)
23editor.  Sed takes text as input, performs an operation or set of
24operations on the text and outputs the modified text.  The operations
25that sed performs (substitutions, deletions, insertions, etc.) can be
26specified in a script file or from the command line.
27
28%description -l ja
29sed (Stream Editor) エディタはストリームまたはバッチ(非インタラクティブ)
30エディタです。sed は入力としてテキストを用い、テキストの操作または
31操作のセットをテキストとに対して行い、修正されたテキストを出力します。
32sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
33コマンドラインから指定されます。
34
35%prep
36%setup -q
37%patch0 -p1
38%patch1 -p1 -b .mb
39
40%build
41export LANG=C
42%configure --without-included-regex
43make %{_smp_mflags}
44
45echo ====================TESTING=========================
46make check
47echo ====================TESTING END=====================
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52%makeinstall
53rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
54
55%find_lang %{name}
56
57%post
58/sbin/install-info %{_infodir}/sed.info.gz %{_infodir}/dir
59
60%preun
61if [ $1 = 0 ]; then
62   /sbin/install-info --delete %{_infodir}/sed.info.gz %{_infodir}/dir
63fi
64
65%clean
66rm -rf ${RPM_BUILD_ROOT}
67
68%files -f %{name}.lang
69%defattr(-,root,root)
70%doc BUGS NEWS THANKS README AUTHORS
71%{_bindir}/sed
72%{_infodir}/*.info*
73%{_mandir}/man*/*
74
75%changelog
76* Mon Dec 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-2
77- added Patch1 from Debian (#551075)
78  Apply patch from WANG Yunfeng to treat incomplete multibyte
79  sequences as a single-byte character.
80
81* Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-1
82- new upstream release, dropped Patch1 and 2
83- added Patch0 from Fedora
84  * Mon Jun 29 2009  Jiri Moskovcak <jmoskovc@redhat.com>
85  - added patch to maintain backwards compatibility for scripts using -c/--copy
86  - Resolves: #502934
87
88* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.5-3
89- rebuilt against current toolchain
90- spec in UTF-8
91
92* Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-2vl5
93- dropped Patch0
94
95* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-1vl5
96- added Patch0-2 from Fedora
97  * Mon Sep  4 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-5
98  - Fix handling of relative symlinks (#205122)
99  * Wed Aug  3 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-4
100  - remove superfluous multibyte processing in str_append for UTF-8
101    encoding (thanks Paolo Bonzini, #177246)
102  * Thu Jun 29 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-2
103  - #185374:
104    - Follow symlinks before rename (avoid symlink overwrite)
105    - Add -c flag for copy instead of rename (avoid ownership change)
106
107* Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-0vl1
108- new upstream release
109- run 'make check' on non-English locale
110
111* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-0vl2
112- s/Copyright/License/
113- rebuilt for x86_64 architecture support
114
115* Wed Oct 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-0vl1
116- new upstream release
117
118* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-0vl1
119- new upstream release
120- remove obsolete patch
121
122* Sat Apr 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.8-4vl2
123- rebuilt for Vine
124  * Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 4.0.8-3
125  - if not -n, print current buffer after N command on the last line
126    unless POSIXLY_CORRECT (#112952)
127  - adjust XFAIL_TESTS for the improved glibc regex implementation
128    (#112642)
129
130  * Fri Nov 14 2003 Jakub Jelinek <jakub@redhat.com> 4.0.8-2
131  - enable --without-included-regex again
132  - use fastmap for regex searching
133
134  * Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de>
135  - update to 4.0.8
136  - simplify specfile
137  - disable --without-included-regex to pass the testsuite
138
139  * Sat Apr 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
140  - update to 4.0.7
141  - use "--without-included-regex"
142  - do not gzip info pages in spec file, "TODO" is not present anymore
143
144  * Thu Jan 23 2003 Jakub Jelinek <jakub@redhat.com> 4.0.5-1
145  - update to 4.0.5
146
147  * Tue Oct 22 2002 Jakub Jelinek <jakub@redhat.com>
148  - rebuilt to fix x86-64 miscompilation
149  - run make check in %%build
150
151  * Fri Apr  5 2002 Jakub Jelinek <jakub@redhat.com>
152  - Remove stale URLs from documentation (#62519)
153
154  * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
155  - Bump release + rebuild.
156
157  * Mon Dec 18 2000 Yukihiro Nakai <ynakai@redhat.com>
158  - Update to 2000.11.28 patch
159  - Rebuild for 7.1 tree
160
161  * Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
162  - FHS packaging.
163
164  * Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
165  - compress man pages.
166
167  * Tue Jan 18 2000 Jakub Jelinek <jakub@redhat.com>
168  - rebuild with glibc 2.1.3 to fix an mmap64 bug in sys/mman.h
169
170* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.02_mb1.09-0vl1
171- mb patch updated to 1.09
172
173* Tue May 29 2001 <sagami@vinelinux.org>
174- 3.02_mb1.08-1vl2: use better macros
175
176* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
177- 3.02_mb1.08-1vl1
178- modified %files section to handle compressed man page(s)
179
180* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
181- auto rebuild in the new build environment (release 4)
182
183* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
184- update to 3.02
185
186* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
187- update to 3.01
188
189* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
190- translations modified for de, fr, tr
191
192* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
193- removed references to the -g option from the man page that we add
194
195* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
196- spec file cleanups
197- added BuildRoot
198
199* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
200- built against glibc
Note: See TracBrowser for help on using the repository browser.