source: projects/specs/trunk/s/secondlife/secondlife-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Second Life client
2Summary(ja): ¥»¥«¥ó¥É¥é¥¤¥Õ ¥¯¥é¥¤¥¢¥ó¥È
3Name:    secondlife
4Version: 1.18.0.6
5Release: 0vl2
6Group:     Applications/Games
7License:   GPL
8URL:       http://secondlife.com/
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11Source0: http://secondlife.com/developers/opensource/downloads/2007/07/slviewer-src-%{version}.tar.gz
12Source1: http://secondlife.com/developers/opensource/downloads/2007/07/slviewer-artwork-%{version}.zip
13Source2: secondlife.png
14Source3: lindenlab-secondlife.desktop
15Source4: secondlife.sh
16Source5: secondlife.sysconfig
17#Source10: slviewer-1.17.1.0-png-support-missing-files.tar.bz2
18
19# Build fixes
20Patch1: slviewer-1.17.3.0-fix-buildsystem.patch
21Patch3: slviewer-1.13.3.57837-systempaths.patch
22Patch6: slviewer-1.14.0.1-no-crash-reports.patch
23Patch7: slviewer-1.14.0.1-fonts.patch
24Patch8: slviewer-1.14.0.1-llfasttimer-no-asm.patch
25Patch9: slviewer-1.16.0.5-no-updater.patch
26Patch10: slviewer-1.14.0.1-gnome-open.patch
27Patch11: slviewer-1.17.3.0-llstatusbar-extra-qualification.patch
28Patch12: slviewer-1.17.1.0-no-Werror.patch
29Patch13: slviewer-1.17.3.0-no-llresolv6.patch
30
31# Bug fixes
32Patch100: slviewer-1.17.1.0-linked_list.patch
33Patch102: slviewer-1.17.2.0-fix-AllowIdleAFK.patch
34Patch103: slviewer-1.17.3.0-VWR-1475.patch
35Patch105: VWR-1465-hires_snapshot_crash_v3.patch
36Patch106: slviewer-1.17.0.12-fix-mismatched-delete.patch
37Patch107: slviewer-1.18.0.6-VWR-1354_lldrawpool_crash_V2.patch
38
39# Enhancements
40Patch200: slviewer-1.17.2.0-no-evil.patch
41Patch201: slviewer-1.17.3.0-openal.patch
42Patch210: slviewer-1.16.0.5-new-gpu.patch
43
44BuildRequires: scons
45BuildRequires: bison
46BuildRequires: flex
47BuildRequires: SDL-devel
48BuildRequires: gtk2-devel
49BuildRequires: libjpeg-devel
50BuildRequires: openjpeg-devel >= 1.2
51BuildRequires: libvorbis-devel
52BuildRequires: libogg-devel
53BuildRequires: apr-util-devel
54BuildRequires: libboost-devel
55BuildRequires: curl-devel
56BuildRequires: xmlrpc-epi-devel
57BuildRequires: openldap-devel
58BuildRequires: openal-devel >= 1:0.0.8
59BuildRequires: freealut-devel
60BuildRequires: elfio
61BuildRequires: desktop-file-utils
62
63#BuildRequires: gcc3-c++ = 3.3.6
64
65ExclusiveArch: i686 x86_64
66
67%description
68The Second Life client for Linux, currently in alpha testing.
69
70%prep
71%setup -q -b 1 -n linden
72# Build fixes
73%patch1 -p1 -b .buildfix
74%patch3 -p1 -b .systempath
75%patch6 -p1 -b .no-crash-reports
76%patch7 -p1 -b .fonts
77%patch8 -p1 -b .llfasttimer-no-asm
78%patch9 -p1 -b .no-updater
79%patch10 -p1 -b .gnome-open
80%patch11 -p1 -b .llstatusbar-extra-qualification
81%patch12 -p1 -b .no-Werror
82%patch13 -p1 -b .no-llresolv6
83
84# Bugfixes
85%patch100 -p1 -b .linked_list
86%patch102 -p1 -b .allowidleafk
87%patch103 -p1 -b .vwr-1475
88%patch105 -p1 -b .vwr-1465
89%patch106 -p1 -b .fix-mismatched-delete
90%patch107 -p1 -b .vwr-1354
91
92# Enhancements
93%patch200 -p1 -b .no-evil
94%patch201 -p1 -b .openal
95%patch210 -p1 -b .new-gpu
96
97sed -i 's/g++-3.4/g++/g' indra/SConstruct
98
99%build
100pushd indra
101  scons BUILD=release BTARGET=client MOZLIB=no FMOD=no DISTCC=no CXX=g++ ARCH=%{_target_cpu} %{?_smp_mflags}
102popd
103
104%install
105rm -rf %{buildroot}
106
107install -D -p -m 755 indra/newview/secondlife-%{_target_cpu}-bin-globalsyms \
108                     %{buildroot}%{_bindir}/secondlife.bin
109
110install -m 755 %{SOURCE4} %{buildroot}%{_bindir}/secondlife
111
112install -d %{buildroot}%{_datadir}/secondlife
113pushd indra/newview
114cp -pr app_settings \
115       character \
116       res-sdl \
117       skins \
118       featuretable.txt \
119       featuretable_linux.txt \
120       gpu_table.txt \
121       %{buildroot}%{_datadir}/secondlife/
122popd
123
124install -d %{buildroot}%{_libdir}/secondlife
125install -m755 indra/lib_release_client/%{_target_cpu}-linux/*.so %{buildroot}%{_libdir}/secondlife
126
127install -d %{buildroot}%{_sysconfdir}/sysconfig
128install -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/secondlife
129
130
131# Make rpmlint stop complaining
132find %{buildroot}%{_datadir}/secondlife/skins/ -type f|xargs chmod 644
133
134install -p -m 644 scripts/messages/message_template.msg %{buildroot}%{_datadir}/secondlife/app_settings/
135
136mkdir -p %{buildroot}%{_datadir}/secondlife/fonts
137ln -s /usr/X11R6/lib/X11/fonts/TTF/Vera.ttf \
138      %{buildroot}%{_datadir}/secondlife/fonts/sans.ttf
139ln -s /usr/X11R6/lib/X11/fonts/TTF/VeraBd.ttf \
140      %{buildroot}%{_datadir}/secondlife/fonts/sansbold.ttf
141ln -s /usr/X11R6/lib/X11/fonts/TTF/VeraMono.ttf \
142      %{buildroot}%{_datadir}/secondlife/fonts/mono.ttf
143ln -s /usr/X11R6/lib/X11/fonts/TrueType/VL-PGothic-Regular.ttf \
144      %{buildroot}%{_datadir}/secondlife/fonts/unicode.ttf
145
146mkdir -p %{buildroot}%{_datadir}/icons/hicolor/192x192
147cp -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/192x192/secondlife.png
148
149desktop-file-install --vendor lindenlab \
150                     --dir ${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
151
152%clean
153rm -rf %{buildroot}
154
155%files
156%defattr(-,root,root,-)
157%doc LICENSE-source.txt LICENSE-logos.txt doc/*
158%doc indra/newview/linux_tools/client-readme.txt
159%doc indra/newview/lsl_guide.html
160%doc indra/newview/releasenotes.txt
161%config %{_sysconfdir}/sysconfig/secondlife
162%{_bindir}/secondlife*
163%{_datadir}/applications/lindenlab-secondlife.desktop
164%{_datadir}/icons/hicolor/192x192/secondlife.png
165%{_datadir}/secondlife/
166%{_libdir}/secondlife
167
168%changelog
169* Tue Jul 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0.6-0vl2
170- add Patch107 to fix VWR-1354
171
172* Fri Jul 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.0.6-0vl1
173- new upstream release
174
175* Sat Jul 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.3.0-0vl1
176- new upstream release
177- add Patch103 to use lossy encoding with openjpeg(VWR-1475)
178
179* Thu Jun 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.2.0-0vl2
180- add patch101 to fix VWR-1203
181- add patch102 to fix AllowIdleAFK
182
183* Thu Jun 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.2.0-0vl1
184- new upstream release
185
186* Wed Jun 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.1.0-0vl2
187- add VWR-1396 patches
188- build with openjpeg-1.2
189
190* Tue Jun 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.1.0-0vl1
191- new upstream release
192
193* Tue Jun 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.0.12-0vl1
194- new upstream release
195
196* Sat Jun 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.0.5-0vl2
197- add patch210 to support GeForce8500/8600
198
199* Sat Jun 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.0.5-0vl1
200- initial build for Vine Linux
201- update to 1.16.0.5
202- use Bitstream Vera instead of DejaVu LGC
203
204* Thu Apr 26 2007 Callum Lerwick <seg@haxxed.com> 1.15.0.2-1
205- New upstream.
206- Non-redistributable fonts are no longer included, substitute DejaVu LGC
207  for now.
208
209* Thu Apr 19 2007 Callum Lerwick <seg@haxxed.com> 1.14.0.1-1
210- New upstream.
211
212* Thu Mar 29 2007 Callum Lerwick <seg@haxxed.com> 1.14.0.0-1
213- New upstream.
214
215* Sun Mar 25 2007 Callum Lerwick <seg@haxxed.com> 1.13.4.8-0.1.20070321a
216- First submission to Fedora.
217
218* Sat Feb 10 2007 Callum Lerwick <seg@haxxed.com> 1.13.3.3-1
219- Initial packaging.
Note: See TracBrowser for help on using the repository browser.