source: projects/specs/trunk/s/seahorse/seahorse-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A GNOME2 frontend for GnuPG
2Summary(ja):    GnuPG の GNOME2 フロントエンド
3Name:           seahorse
4Version:        2.28.1
5Release:        1%{?_dist_release}
6License:        GPL
7Group:          User Interface/Desktops
8URL:            http://seahorse.sourceforge.net/
9Source0:        http://ftp.gnome.org/pub/GNOME/sources/seahorse/2.26/%{name}-%{version}.tar.bz2
10#Patch0:        seahorse-0.8.2-Makefile.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  libgnome-devel >= 2.14.0
14BuildRequires:  libgnomeui-devel
15BuildRequires:  GConf2-devel
16BuildRequires:  libglade2-devel
17BuildRequires:  gtk2-devel >= 2.10.0
18BuildRequires:  gnupg >= 1.2.4
19BuildRequires:  gpgme-devel >= 1.0.0
20BuildRequires:  openldap-devel
21BuildRequires:  libsoup-devel >= 2.4.0
22BuildRequires:  nautilus >= 2.9.0
23BuildRequires:  gnome-keyring-devel >= 2.25.5
24BuildRequires:  avahi-glib-devel >= 0.6
25BuildRequires:  dbus-glib-devel >= 0.35
26BuildRequires:  libnotify-devel
27BuildRequires:  openssh
28BuildRequires:  gnome-doc-utils >= 0.3.2
29BuildRequires:  libSM-devel
30BuildRequires:  docbook-dtds
31Requires(post):   GConf2, scrollkeeper
32Requires(pre):    GConf2
33Requires(preun):  GConf2
34Requires(postun): scrollkeeper
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38
39%description
40Seahorse is a GNOME2 front end for th GNU Privacy Guard (GnuPG).
41It is a tool for secure communications and data storage. Data encryption
42and digital signature creation can easily be performed through a GUI, and
43Key Management operations also can be performed.
44
45%description -l ja
46Seahorse は GNU Privacy Guard (GnuPG) の GNOME2 フロントエンドです。
47安全なコミュニケーションとデータ保管のためのツールです。データの暗号化や復号、
48デジタル署名の作成・検証を GUI で容易に行うことができます。また、鍵の管理も行
49うことができます。
50
51%package        devel
52Summary:        Development files for %{name}
53Group:          Development/Libraries
54Requires:       %{name} = %{version}-%{release}
55Requires:       pkgconfig
56
57%description    devel
58The %{name}-devel package contains libraries and header files for
59developing applications that use %{name}.
60
61%prep
62%setup -q
63
64%build
65%configure \
66    --disable-schemas-install \
67    --disable-update-mime-database \
68    --disable-static
69make %{?_smp_mflags}
70
71%install
72[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
73
74export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
75make install DESTDIR=$RPM_BUILD_ROOT
76unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
77
78rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
79
80%find_lang %{name}
81
82%clean
83[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
84
85%post
86/sbin/ldconfig
87%{_bindir}/scrollkeeper-update -q ||:
88export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
89gconftool-2 --makefile-install-rule \
90    %{_sysconfdir}/gconf/schemas/seahorse.schemas > /dev/null ||:
91
92%pre
93if [ "$1" -gt 1 ]; then
94  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95  gconftool-2 --makefile-uninstall-rule \
96      %{_sysconfdir}/gconf/schemas/seahorse.schemas > /dev/null ||:
97fi
98
99%preun
100if [ "$1" -eq 0 ]; then
101  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102  gconftool-2 --makefile-uninstall-rule \
103      %{_sysconfdir}/gconf/schemas/seahorse.schemas > /dev/null ||:
104fi
105
106%postun
107/sbin/ldconfig
108%{_bindir}/scrollkeeper-update -q ||:
109
110%files -f %{name}.lang
111%defattr(-,root,root)
112%doc AUTHORS COPYING ChangeLog NEWS README TODO
113%{_sysconfdir}/xdg/autostart/*.desktop
114%{_sysconfdir}/gconf/schemas/*
115%{_bindir}/seahorse
116%{_bindir}/seahorse-daemon
117%{_libdir}/lib*.so.*
118%{_libdir}/seahorse
119%{_datadir}/applications/*.desktop
120%{_datadir}/dbus-1/services/*
121%{_datadir}/gnome/help/*
122%{_datadir}/omf/*
123%{_datadir}/icons/*
124%{_datadir}/seahorse
125%{_datadir}/pixmaps/*
126%{_mandir}/man1/*
127
128%files devel
129%defattr(-,root,root)
130%{_includedir}/libcryptui
131%{_libdir}/lib*.so
132%{_libdir}/pkgconfig/*.pc
133%{_datadir}/gtk-doc/html/libcryptui
134%{_datadir}/gtk-doc/html/libseahorse
135
136%changelog
137* Mon Mar 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
138- new upstream release
139- add BuildRequires: gnome-doc-utils >= 0.3.2, libSM-devel, docbook-dtds
140
141* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-1
142- new upstream release
143- built with openldap-2.4.11
144- spec in UTF-8
145- made devel subpackage
146
147* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
148- new upstream release
149
150* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.2-0vl2
151- rebuild with gnutls-1.4.1
152
153* Sat Sep 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.2-0vl1
154- new upstream release
155- enable LDAP support
156- add --disable-update-mime-database option to %%configure
157- update Makefile.patch (patch0)
158- update dependencies
159
160* Tue Feb 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8-0vl1
161- new upstream release
162- drop obsolete gedit.patch (patch1)
163- remove unneeded files
164
165* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.9-0vl1
166- new upstream release
167- dropped SOURCE1 (merged into source)
168- added Patch1 for building with gedit 2.12
169- rebuild with libsoup 2.2.6.1
170
171* Fri May 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.7.8-0vl2
172- add BuildRequires: libsoup >= 2.2 for HKP keyserver support
173
174* Thu May 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.7.8-0vl1
175- upstream release
176- update ja.po, Makefile.patch
177- update files list
178
179* Sun Mar 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.7.6-0vl1
180- initial build for Vine Linux
181- update ja.po
182
183* Wed Oct 26 2004 Nate Nielsen <nielsen@memberwebs.com>
184- Remove *.a and *.la from RPM_BUILD_ROOT
185- Remove updated mime database from RPM_BUILD_ROOT
186
187* Wed Oct 13 2004 Nate Nielsen <nielsen@memberwebs.com>
188- Added new mime info
189
190* Tue Oct 12 2004 Nate Nielsen <nielsen@memberwebs.com>
191- Added the gedit plugin to the default manifest
192
193* Fri May 02 2003 Yanko Kaneti <yaneti@declera.com>
194- Add some new files to the manifest
195
196* Wed Jan 15 2002 Jean Schurger <yshark@schurger.org>
197- Scrollkeeper stuff
198- locales install by %find_lang
199- secure use of rm -rf
200
201* Tue Jan 14 2002 Yanko Kaneti <yaneti@declera.com>
202- First spec
Note: See TracBrowser for help on using the repository browser.