source: projects/specs/trunk/s/seahorse-plugins/seahorse-plugins-vl.spec @ 4650

Revision 4650, 8.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.5

Line 
1# Basic Information
2Name:           seahorse-plugins
3Version:        2.30.1
4Release:        4%{?_dist_release}
5License:        GPL-2
6Group:          Applications/Accessories
7Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
8Patch1:         seahorse-plugins-2.30.1-git20110607.patch
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13Packager:       yasumichi
14
15Summary:        plugins and utilities for encryption in GNOME
16Summary(ja):    GNOMEにおける暗号化のためのプラグインとユーティリティ
17
18# Dependency
19Requires:       GConf2
20Requires:       glib2
21Requires:       gtk3 >= 3.0.0
22Requires:       gnupg
23Requires:       gpgme
24Requires:       libgnome-keyring
25Requires:       dbus-glib
26Requires:       libnotify
27Requires:       evolution-data-server
28Requires:       seahorse
29Requires(post,postun):  shared-mime-info
30
31BuildRequires:  gnome-doc-utils
32BuildRequires:  pkgconfig
33BuildRequires:  GConf2-devel
34BuildRequires:  glib2-devel
35BuildRequires:  gtk3-devel >= 3.0.0
36BuildRequires:  gnupg
37BuildRequires:  gpgme-devel
38BuildRequires:  libgnome-keyring-devel
39BuildRequires:  dbus-glib-devel
40BuildRequires:  libcryptui-devel
41BuildRequires:  libnotify-devel
42BuildRequires:  evolution-data-server
43
44Provides: %{name}-gedit < 2.30.1-3
45Obsoletes: %{name}-gedit < 2.30.1-3
46
47%description
48Seahorse is integrated into the GNOME Desktop Environment and allows users to
49perform operations from their regular applications, like nautilus .
50The effective use of this package, please install the following packages.
51
52* seahorse-plugins-applet
53* seahorse-plugins-nautilus
54
55%description -l ja
56SeahorseがGNOMEデスクトップ環境に統合され、Nautilusのようなユーザが
57よく使うアプリケーションから操作を実行することができます。
58このパッケージの有効利用には、以下のパッケージをインストールしてください。
59
60* seahorse-plugins-applet
61* seahorse-plugins-nautilus
62
63#
64# sub package: applet
65#
66%package applet
67Summary:        Applet for GnomePanel  to encrypt/decrypt/sign text easily
68Summary(ja):    テキストを簡単に暗号化/復号化/署名するためのGNOMEパネルアプレット
69Group:          Applications/Accessories
70Requires:       %{name} = %{version}-%{release}
71Requires:       libbonoboui
72Requires:       gnome-panel-libs
73BuildRequires:  libbonoboui-devel
74BuildRequires:  gnome-panel-devel
75
76%description applet
77Encryption Applet performs the various encryption operations using standard
78OpenPGP methods. You will need to have already created an OpenPGP key with
79Encryption Key Manager and imported the public keys of those you want to
80encrypt to or verify signatures of.
81
82%description applet -l ja
83暗号化アプレットは、標準的なOpenPGP手法を使って様々な暗号化の操作を行えます。
84あなたは暗号鍵マネージャによってOpenPGP鍵を既に作成し、暗号化や署名の検証を
85行いたい相手の公開鍵をインポートしている必要があります。
86
87#
88# sub package: gedit
89#
90#%package gedit
91#Summary:       Adds functionality to Gedit to encrypt/decrypt/sign text
92#Summary:       geditにテキストを暗号化/復号化/署名するための機能を追加します。
93#Group:         Applications/Accessories
94#Requires:       %{name} = %{version}-%{release}
95#Requires:      gedit
96#BuildRequires: gedit-devel
97
98#%description gedit
99#The Text Encryption plugin adds functionality to Gedit, the GNOME text
100#editor, to encrypt/decrypt/sign text
101
102#%description gedit -l ja
103#テキスト暗号化プラグインは、GNOMEテキストエディタGeditにテキストを
104#暗号化/復号化/署名するための機能を追加します。
105
106#
107# sub package: nautilus
108#
109%package nautilus
110Summary:        Contains code for calling seahorse-tool from Nautilus
111Summary(ja):    Nautilusから、seahorse-toolを呼ぶためのコードが含まれています。
112Group:          Applications/Accessories
113Requires:       %{name} = %{version}-%{release}
114Requires:       nautilus
115BuildRequires:  nautilus-devel
116
117%description nautilus
118Encryption and Keyrings integrates with Nautilus.  You can encrypt, decrypt,
119sign and verify files as well as import public keys from the file manager
120window without launching Encryption and Keyrings.
121
122%description nautilus -l ja
123パスワードと暗号化が、Nautilusに統合されます。パスワードと暗号化を起動する
124ことなく、ファイルマネージャからファイルの暗号化、復号化、署名及び公開鍵の
125インポートを行うことができます。
126
127#
128# script section
129#
130%prep
131%setup -q
132%patch1 -p1 -b .git20110607
133
134%build
135libtoolize --force --copy
136autoreconf
137%configure \
138        --with-gtk=3.0 \
139        --disable-gedit \
140        --disable-update-mime-database \
141        --disable-epiphany \
142        --disable-applet
143%{__make} %{?_smp_mflags}
144
145%install
146%{__rm} -rf ${RPM_BUILD_ROOT}
147
148export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
149%{__make} install DESTDIR=${RPM_BUILD_ROOT}
150unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
151
152%find_lang %{name}
153
154# treat not install file
155find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
156find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
157
158%clean
159%{__rm} -rf ${RPM_BUILD_ROOT}
160
161%post
162/sbin/ldconfig
163%{_bindir}/scrollkeeper-update -q ||:
164export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
165gconftool-2 --makefile-install-rule \
166    %{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas > /dev/null ||:
167update-mime-database %{_datadir}/mime/
168
169#%post gedit
170#export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
171#gconftool-2 --makefile-install-rule \
172#    %{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas > /dev/null ||:
173
174%pre
175if [ "$1" -gt 1 ]; then
176  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
177  gconftool-2 --makefile-uninstall-rule \
178      %{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas > /dev/null ||:
179fi
180
181#%pre gedit
182#if [ "$1" -gt 1 ]; then
183#  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
184#  gconftool-2 --makefile-uninstall-rule \
185#      %{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas > /dev/null ||:
186#fi
187
188%preun
189if [ "$1" -eq 0 ]; then
190  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
191  gconftool-2 --makefile-uninstall-rule \
192      %{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas > /dev/null ||:
193fi
194
195#%preun gedit
196#if [ "$1" -eq 0 ]; then
197#  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198#  gconftool-2 --makefile-uninstall-rule \
199#      %{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas > /dev/null ||:
200#fi
201
202%postun
203/sbin/ldconfig
204%{_bindir}/scrollkeeper-update -q ||:
205update-mime-database %{_datadir}/mime/
206
207
208%files -f %{name}.lang
209%defattr(-,root,root)
210%doc COPYING ChangeLog NEWS README
211%{_sysconfdir}/gconf/schemas/seahorse-plugins.schemas
212%{_bindir}/seahorse-preferences
213%{_bindir}/seahorse-tool
214%{_datadir}/applications/seahorse-pgp-encrypted.desktop
215%{_datadir}/applications/seahorse-pgp-keys.desktop
216%{_datadir}/applications/seahorse-pgp-preferences.desktop
217%{_datadir}/applications/seahorse-pgp-signature.desktop
218%{_datadir}/gnome/help/seahorse-plugins/
219%{_datadir}/man/man1/seahorse-tool.1.gz
220%{_datadir}/mime/packages/seahorse.xml
221%{_datadir}/omf/seahorse-plugins/
222%{_datadir}/pixmaps/seahorse-plugins/
223%{_datadir}/seahorse-plugins/ui/
224
225%exclude %{_datadir}/pixmaps/seahorse-plugins/22x22/seahorse-applet-*.png
226%exclude %{_datadir}/pixmaps/seahorse-plugins/48x48/seahorse-applet*.png
227%exclude %{_datadir}/pixmaps/seahorse-plugins/scalable/seahorse-applet*.svg
228
229%files applet
230%defattr(-, root, root)
231#%{_libdir}/bonobo/servers/GNOME_SeahorseApplet.server
232#%{_libdir}/seahorse/seahorse-applet
233#%{_datadir}/gnome-2.0/ui/GNOME_SeahorseApplet.xml
234#%{_datadir}/gnome/help/seahorse-applet/
235%{_datadir}/icons/hicolor/48x48/apps/seahorse-applet.png
236%{_datadir}/icons/hicolor/scalable/apps/seahorse-applet.svg
237#%{_datadir}/omf/seahorse-applet/
238%{_datadir}/pixmaps/seahorse-applet.svg
239%{_datadir}/pixmaps/seahorse-plugins/22x22/seahorse-applet-*.png
240%{_datadir}/pixmaps/seahorse-plugins/48x48/seahorse-applet*.png
241%{_datadir}/pixmaps/seahorse-plugins/scalable/seahorse-applet*.svg
242#%{_datadir}/seahorse-plugins/ui/seahorse-applet-preferences.xml
243
244#%files gedit
245#%defattr(-, root, root)
246#%{_sysconfdir}/gconf/schemas/seahorse-gedit.schemas
247#%{_libdir}/gedit-2/plugins/libseahorse-pgp.so
248#%{_libdir}/gedit-2/plugins/seahorse-pgp.gedit-plugin
249
250%files nautilus
251%defattr(-, root, root)
252%{_libdir}/nautilus/extensions-3.0/libnautilus-seahorse.so
253
254%changelog
255* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-4
256- rebuild package
257
258* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-3
259- delete Patch0
260- add Patch1 (seahorse-plugins-2.30.1-git20110607.patch)
261- change BuildRequires: gtk3-devel instead of gtk2-devel
262- change BuildRequires: libcryptui-devel instead of seahorse-devel
263- remove -gedit sub package
264
265* Sun Apr 17 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.1-2
266- rebuild with rpm-4.8.1
267- update R,BR
268- add Patch0 from https://bugzilla.gnome.org/show_bug.cgi?id=600804
269
270* Fri Jun 18 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.1-1
271- initial build for Vine Linux
272
Note: See TracBrowser for help on using the repository browser.