source: projects/specs/trunk/s/scribus/scribus-vl.spec @ 7346

Revision 7346, 15.4 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1# -*- encoding: utf-8 -*-
2Name:           scribus
3Version:        1.4.2
4Release:        1%{?_dist_release}
5
6Summary:        DeskTop Publishing application written in Qt
7
8Group:          Applications/Productivity
9License:        GPLv2+
10URL:            http://www.scribus.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
12
13# patch for Vine
14Patch1001:              scribus-1.4.2-prefsdialog.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  cmake
19
20BuildRequires:  cups-devel
21BuildRequires:  desktop-file-utils
22BuildRequires:  lcms-devel
23BuildRequires:  libart_lgpl-devel
24BuildRequires:  libjpeg-devel
25BuildRequires:  libpng-devel
26BuildRequires:  libtiff-devel
27BuildRequires:  libxml2-devel
28BuildRequires:  openssl-devel
29BuildRequires:  python-devel
30BuildRequires:  python-imaging
31BuildRequires:  qt4-devel
32BuildRequires:  zlib-devel
33BuildRequires:  freetype-devel
34BuildRequires:  gnutls-devel
35BuildRequires:  cairo-devel
36BuildRequires:  aspell-devel
37BuildRequires:  libboost-devel
38BuildRequires:  podofo-devel
39BuildRequires:  hyphen-devel
40Requires:       ghostscript
41Requires:       python
42Requires:       python-imaging
43Requires:       tkinter
44Requires:       shared-mime-info
45Requires:       %{name}-doc = %{version}-%{release}
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: iwaim
50
51%description
52Scribus is an desktop open source page layout program with
53the aim of producing commercial grade output in PDF and
54Postscript, primarily, though not exclusively for Linux.
55
56While the goals of the program are for ease of use and simple easy to
57understand tools, Scribus offers support for professional publishing
58features, such as CMYK color, easy PDF creation, Encapsulated Postscript
59import/export and creation of color separations.
60
61
62%package        devel
63Summary:        Header files for Scribus
64Group:          Development/Libraries
65Requires:       %{name} = %{version}-%{release}
66
67%description    devel
68Header files for Scribus.
69
70%package        doc
71Summary:        Documentation files for Scribus
72Group:          Development/Tools
73Requires:       %{name} = %{version}-%{release}
74BuildArch:      noarch
75
76
77%description    doc
78%{summary}
79
80%prep
81%setup -q -n %{name}-%{version}
82%patch1001 -p1 -b .pref
83
84# recode man page to UTF-8
85pushd scribus/manpages
86iconv -f ISO8859-2 -t UTF-8 scribus.1.pl > tmp
87touch -r scribus.1.pl tmp
88mv tmp scribus.1.pl
89popd
90
91# fix permissions
92chmod a-x scribus/pageitem_latexframe.h
93
94# drop shebang lines from python scripts
95for f in scribus/plugins/scriptplugin/{samples,scripts}/*.py
96do
97    sed '1{/#!\/usr\/bin\/env\|#!\/usr\/bin\/python/d}' $f > $f.new
98    touch -r $f $f.new
99    mv $f.new $f
100done
101
102
103%build
104mkdir build
105pushd build
106%cmake ..
107
108%ifnarch s390x
109make VERBOSE=1 %{?_smp_mflags}
110%else
111# we can't use parallel build on s390x, because g++ eats almost all memory
112# in the builder (2+0.5 GB) when compiling scribus134format.cpp
113make VERBOSE=1
114%endif
115popd
116
117
118%install
119rm -rf ${RPM_BUILD_ROOT}
120pushd build
121make install DESTDIR=$RPM_BUILD_ROOT
122popd
123
124install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribus.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/scribus.png
125install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribusdoc.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/x-scribus.png
126
127find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
128
129# install the global desktop file
130rm -f ${RPM_BUILD_ROOT}%{_datadir}/mimelnk/application/*scribus.desktop
131desktop-file-install                                    \
132    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications     \
133    scribus.desktop
134
135%clean
136rm -rf ${RPM_BUILD_ROOT}
137
138
139%post
140update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
141
142
143%postun
144update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
145
146
147%files
148%defattr(-,root,root,-)
149%doc AUTHORS ChangeLog ChangeLogSVN COPYING README TODO
150%{_bindir}/%{name}
151%{_libdir}/%{name}
152%{_datadir}/applications/%{name}.desktop
153%{_datadir}/mime/packages/%{name}.xml
154%{_datadir}/pixmaps/*
155%{_datadir}/%{name}
156#%exclude %{_datadir}/%{name}/samples/*.py[co]
157#%exclude %{_datadir}/%{name}/scripts/*.py[co]
158%{_mandir}/man1/*
159%{_mandir}/pl/man1/*
160%{_mandir}/de/man1/*
161
162%files devel
163%defattr(-,root,root,-)
164%doc AUTHORS COPYING
165%{_includedir}/%{name}
166
167%files doc
168%defattr(-,root,root,-)
169%{_datadir}/doc/%{name}
170
171
172%changelog
173* Mon Jan 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
174- new upstream release
175- add Patch1001 (scribus-1.4.2-prefsdialog.patch)
176
177* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
178- new upstream release
179
180* Fri Mar 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.0-3
181- rebuild with podofo-0.9.1
182
183* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
184- rebuild with python-2.7.2
185
186* Tue Jan 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
187- new upstream release
188- remove old patches
189
190* Tue Jun  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
191- initial build for Vine Linux: based Fedora 1.3.6-4.fc14
192
193* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-4
194- fix build with podofo 0.8.0
195
196* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-3
197- rebuilt for podofo 0.8.0
198
199* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-2
200- added 2 patches for rawhide
201
202* Mon Mar 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
203- update to final 1.3.6
204
205* Wed Nov 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-5
206- fixed a crash when closing a hyphenator object (#537677)
207
208* Thu Aug 27 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.5.1-4
209- rebuilt with new openssl
210
211* Tue Aug 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-3
212- drop shebang line from python scripts
213- don't package precompiled python scripts
214
215* Thu Aug 20 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-1
216- update to final 1.3.5.1
217- drop the upstreamed "install-headers" patch
218- always install doc subpackage (#446148)
219- full changelog: http://www.scribus.net/?q=node/193
220
221* Wed Jul 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.17.rc3
222- don't use parallel build on s390x
223
224* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.16.rc3
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
226
227* Tue Jul 21 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.15.rc3
228- update to 1.3.5-rc3
229- use system hyphen library (#506074)
230- fix update path for the doc subpackage (#512498)
231- preserve directories when installing headers (#511800)
232
233* Thu Jun  4 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.14.rc2
234- update to 1.3.5-rc2
235
236* Mon May 18 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.13.beta
237- rebuilt with podofo enabled
238
239* Wed Apr 22 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.12.beta
240- update to 1.3.5.beta
241- make docs subpackage noarch
242- drop outdated Obsoletes/Provides
243
244* Sun Mar 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.11.20090329svn13359
245- update to revision 13359
246- add aspell-devel and boost-devel as BR
247- update release tag to conform to the pre-release versioning guideline
248
249* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.10.12516svn
250- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
251
252* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.4-0.9.12516svn
253- rebuild with new openssl
254
255* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.8.12516svn
256- Rebuild for Python 2.6
257
258* Tue Dec  2 2008 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.7.12516svn
259- fix directory ownership in doc subpackage (#474041)
260
261* Sun Nov 30 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.6.12516svn
262- Rebuild for Python 2.6
263
264* Mon Oct 13 2008 Dan Horák <dan[AT]danny.cz> 1.3.5-0.5.12516svn
265- install global desktop file instead of KDE-only one (#461124)
266- little cleanup
267
268* Fri Sep 05 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
269- 1.3.5-0.4.12516svn
270- new svn snapshot
271
272* Sun Jul 27 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
273- 1.3.5-0.3.12419svn
274- new svn snapshot
275
276* Mon Jul 21 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
277- 1.3.5-0.2.12404svn
278- svn snapshot
279
280* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3.4-5
281- Autorebuild for GCC 4.3
282
283* Mon Feb 11 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> - 1.3.4-4
284- Rebuilt for gcc43
285
286* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
287- 1.3.4-3
288- fix inclusion of python scripts as proposed by Todd Zullinger (#312091)
289- fix desktop file
290
291* Thu Aug 23 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
292- 1.3.4-2
293- rebuild for buildid
294- new license tag
295
296* Sat Jun 02 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
2971.3.4
298- version upgrade
299
300* Mon Dec 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3011.3.3.6-1
302- version upgrade
303
304* Sat Nov 11 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3051.3.3.5-1
306- version upgrade
307
308* Wed Oct 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3091.3.3.4-1
310- version upgrade
311
312* Fri Sep 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3131.3.3.3-1
314- version upgrade (#205962)
315
316* Sun Jun 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3171.3.3.2-2
318- bump
319
320* Tue May 30 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3211.3.3.2-1
322- version upgrade
323
324* Sat Apr 22 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3251.3.3.1-1
326- version upgrade
327
328* Tue Mar 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3291.3.3-1
330- version upgrade
331- add BR gnutls-devel
332
333* Sat Mar 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3341.3.2-1
335- upgrade to beta version
336
337* Thu Feb 16 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3381.2.4.1-4
339- Rebuild for Fedora Extras 5
340
341* Wed Feb 08 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3421.2.4.1-3
343- add missing requires python-imaging
344
345* Sat Jan 21 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3461.2.4.1-2
347- rebuild (#178494)
348
349* Wed Jan 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3501.2.4.1-1
351- version upgrade
352
353* Thu Jul 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.2.2.1-2
354- use dist tag for sanity between branches
355
356* Tue Jul 5 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2.1-1
357- 1.2.2.1 released to fix crash on open with certain 1.2.1 docs
358
359* Sun Jul 3 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2-0.fc4
360- 1.2.2 final
361
362* Tue Jun 28 2005 P Linnell <mrdocs AT scribus.info>- 1.2.2cvs-0
363- test build for 1.2.2cvs
364- Add freetype2 explicit build requirement
365- Add obsoletes. See PACKAGING in the source tarball
366- Change the description per PACKAGING
367- Bump required python. 2.2 is no longer supported.
368
369
370* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.2.1-5
371- rebuild on all arches
372
373* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
374- rebuilt
375
376* Sun Feb 06 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-3
377- Bumped BR on qt-devel to 3.3.
378
379* Thu Feb  3 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.1-2
380- Fix x86_64 build and summary.
381
382* Sun Jan 09 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-1
383- 1.2.1.
384
385* Sat Dec 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-0.1.cvs20041118
386- cvs snapshot.
387
388* Wed Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.3
389- Redirect output in post/postun, to avoid failure.
390
391* Wed Nov 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.2
392- Mime-type corrections for FC3.
393- Dropped redundent BR XFree86-devel.
394
395* Thu Aug 26 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.1
396- 1.2.
397- Dropping old obsoletes/provides (don't know of anyone using them).
398
399* Thu Aug 19 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.0.RC1
400- 1.2RC1.
401
402* Sat Aug 07 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.4
403- mime info/icon for .sla files.
404
405* Fri Jul 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.3
406- BuildReq openssl-devel (#1727).
407
408* Thu Jun 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.2
409- Source0 allows direct download (#1727).
410- Req tkinter (#1727).
411
412* Sun Jun 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.1
413- Updated to 1.1.7.
414- Re-added _smp_mflags.
415
416* Mon May 24 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.3
417- Add Application Category to desktop entry.
418
419* Sun Apr 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.2
420- Bump ghostscript Req to 7.07.
421- URL scribus.net.
422
423* Tue Apr 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.1
424- Updated to 1.1.6.
425- Using upstream desktop entry.
426
427* Sat Feb 14 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.5-0.fdr.1
428- Updated to 1.1.5.
429
430* Sun Dec 21 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.4-0.fdr.1
431- Updated to 1.1.4.
432
433* Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.2
434- Dropped LDFLAGS="-lm"
435- Added --with-pythondir=%%{_prefix}
436- Req ghostscript.
437
438* Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.1
439- Updated to 1.1.3.
440- Removed _smp_mflags.
441
442* Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.2
443- Req python.
444- Provides scribus-scripting.
445
446* Sun Nov 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.1
447- Updated to 1.1.2.
448- Obsoletes scribus-scripting.
449
450* Sat Oct 11 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.2
451- BuildReq littlecms-devel -> lcms-devel.
452
453* Thu Oct 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.1
454- Updated to 1.1.1.
455- BuildReq littlecms-devel.
456- BuildReq libart_lgpl-devel.
457
458* Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0.1-0.fdr.1
459- Updated to 1.0.1.
460- Split off devel package for headers.
461- No longer Obsoletes scribus-i18n-en
462
463* Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.3
464- desktop entry terminal=0 -> false.
465
466* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.2
467- Added Obsoletes scribus-i18n-en.
468
469* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.1
470- Updated to 1.0.
471
472* Tue Jul 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.0.1.rc1
473- Updated to 1.0RC1.
474
475* Fri Jun 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.11.1-0.fdr.1
476- Updated to 0.9.11.1.
477- Added obsoletes scribus-svg.
478
479* Sun May 25 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.3
480- Using make DESTDIR= workaround for plugin issue.
481- Removed post/postun ldconfig.
482- Removed devel subpackage.
483
484* Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.2
485- Explicitly set file permission on icon.
486- Created devel package.
487- Removed .la files.
488- Added ChangeLog to Documentation.
489
490* Sun May 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.1
491- Updated to 0.9.10.
492- buildroot -> RPM_BUILD_ROOT.
493
494* Sat Apr 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.3
495- Added BuildRequires for cups-devel.
496
497* Thu Apr 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.2
498- Added BuildRequires for libtiff-devel.
499- Added line to help package find tiff.
500
501* Sun Apr 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.1
502- Updated to 0.9.9.
503- Added line for QT.
504
505* Thu Apr 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.3.rh90
506- Added missing BuildRequires.
507- Corrected Group.
508
509* Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.2
510- Added desktop-file-utils to BuildRequires.
511- Changed category to X-Fedora-Extra.
512- Added Epoch:0.
513
514* Thu Mar 27 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.9.8-0.fdr.1
515- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.