source: projects/specs/trunk/s/scribus/scribus-vl.spec @ 5114

Revision 5114, 16.3 KB checked in by iwaim, 13 years ago (diff)

scribus 1.3.6-1

Line 
1# -*- encoding: utf-8 -*-
2Name:           scribus
3Version:        1.3.6
4Release:        1%{?_dist_release}
5
6Summary:        DeskTop Publishing application written in Qt
7
8Group:          Applications/Productivity
9License:        GPLv2+
10URL:            http://www.scribus.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12# https://bugzilla.redhat.com/show_bug.cgi?id=506074
13# http://bugs.scribus.net/view.php?id=8232
14Patch0:         %{name}-1.3.5-system-hyphen.patch
15# fix version variable for buildsystem
16Patch1:         %{name}-1.3.6-version.patch
17# fix QString initialization in Qt 4.7
18Patch2:         %{name}-1.3.6-qstring.patch
19# fix linking with --no-add-needed
20Patch3:         %{name}-1.3.6-linker.patch
21# fix build with podofo 0.8.0
22Patch4:         %{name}-1.3.6-podofo-0.8.0.patch
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24
25BuildRequires:  cmake
26
27BuildRequires:  cups-devel
28BuildRequires:  desktop-file-utils
29BuildRequires:  lcms-devel
30BuildRequires:  libart_lgpl-devel
31BuildRequires:  libjpeg-devel
32BuildRequires:  libpng-devel
33BuildRequires:  libtiff-devel
34BuildRequires:  libxml2-devel
35BuildRequires:  openssl-devel
36BuildRequires:  python-devel
37BuildRequires:  python-imaging
38BuildRequires:  qt4-devel
39BuildRequires:  zlib-devel
40BuildRequires:  freetype-devel
41BuildRequires:  gnutls-devel
42BuildRequires:  cairo-devel
43BuildRequires:  aspell-devel
44BuildRequires:  libboost-devel
45BuildRequires:  podofo-devel
46BuildRequires:  hyphen-devel
47Requires:       ghostscript
48Requires:       python
49Requires:       python-imaging
50Requires:       tkinter
51Requires:       shared-mime-info
52Requires:       %{name}-doc = %{version}-%{release}
53
54Vendor: Project Vine
55Distribution: Vine Linux
56Packager: iwaim
57
58%description
59Scribus is an desktop open source page layout program with
60the aim of producing commercial grade output in PDF and
61Postscript, primarily, though not exclusively for Linux.
62
63While the goals of the program are for ease of use and simple easy to
64understand tools, Scribus offers support for professional publishing
65features, such as CMYK color, easy PDF creation, Encapsulated Postscript
66import/export and creation of color separations.
67
68
69%package        devel
70Summary:        Header files for Scribus
71Group:          Development/Libraries
72Requires:       %{name} = %{version}-%{release}
73
74%description    devel
75Header files for Scribus.
76
77%package        doc
78Summary:        Documentation files for Scribus
79Group:          Development/Tools
80Requires:       %{name} = %{version}-%{release}
81%if 0%{?fedora} > 9
82BuildArch:      noarch
83Obsoletes:      %{name}-doc < 1.3.5-0.12.beta
84%endif
85
86
87%description    doc
88%{summary}
89
90%prep
91%setup -q -n %{name}-%{version}
92%patch0 -p1 -b .system-hyphen
93%patch1 -p1 -b .version
94%patch2 -p1 -b .qstring
95%patch3 -p1 -b .linker
96%patch4 -p2 -b .podofo
97
98# recode man page to UTF-8
99pushd scribus/manpages
100iconv -f ISO8859-2 -t UTF-8 scribus.1.pl > tmp
101touch -r scribus.1.pl tmp
102mv tmp scribus.1.pl
103popd
104
105# fix permissions
106chmod a-x scribus/pageitem_latexframe.h
107
108# drop shebang lines from python scripts
109for f in scribus/plugins/scriptplugin/{samples,scripts}/*.py
110do
111    sed '1{/#!\/usr\/bin\/env\|#!\/usr\/bin\/python/d}' $f > $f.new
112    touch -r $f $f.new
113    mv $f.new $f
114done
115
116
117%build
118mkdir build
119pushd build
120%cmake ..
121
122%ifnarch s390x
123make VERBOSE=1 %{?_smp_mflags}
124%else
125# we can't use parallel build on s390x, because g++ eats almost all memory
126# in the builder (2+0.5 GB) when compiling scribus134format.cpp
127make VERBOSE=1
128%endif
129popd
130
131
132%install
133rm -rf ${RPM_BUILD_ROOT}
134pushd build
135make install DESTDIR=$RPM_BUILD_ROOT
136popd
137
138install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribus.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/scribus.png
139install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribusdoc.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/x-scribus.png
140
141find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
142
143# install the global desktop file
144rm -f ${RPM_BUILD_ROOT}%{_datadir}/mimelnk/application/*scribus.desktop
145desktop-file-install --vendor="fedora"                      \
146    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications         \
147    scribus.desktop
148
149
150%clean
151rm -rf ${RPM_BUILD_ROOT}
152
153
154%post
155update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
156
157
158%postun
159update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
160
161
162%files
163%defattr(-,root,root,-)
164%doc %{_datadir}/doc/%{name}-%{version}/AUTHORS
165%doc %{_datadir}/doc/%{name}-%{version}/ChangeLog
166%doc %{_datadir}/doc/%{name}-%{version}/ChangeLogSVN
167%doc %{_datadir}/doc/%{name}-%{version}/COPYING
168%doc %{_datadir}/doc/%{name}-%{version}/README
169%doc %{_datadir}/doc/%{name}-%{version}/TODO
170%{_bindir}/%{name}
171%{_libdir}/%{name}
172%{_datadir}/applications/fedora-%{name}.desktop
173%{_datadir}/mime/packages/%{name}.xml
174%{_datadir}/pixmaps/*
175%{_datadir}/%{name}
176#%exclude %{_datadir}/%{name}/samples/*.py[co]
177#%exclude %{_datadir}/%{name}/scripts/*.py[co]
178%{_mandir}/man1/*
179%{_mandir}/pl/man1/*
180%{_mandir}/de/man1/*
181
182%files devel
183%defattr(-,root,root,-)
184%doc AUTHORS COPYING
185%{_includedir}/%{name}
186
187%files doc
188%defattr(-,root,root,-)
189%dir %{_datadir}/doc/%{name}-%{version}
190%lang(cs) %{_datadir}/doc/%{name}-%{version}/cs
191%lang(de) %{_datadir}/doc/%{name}-%{version}/de
192%lang(en) %{_datadir}/doc/%{name}-%{version}/en
193%lang(fr) %{_datadir}/doc/%{name}-%{version}/fr
194%lang(pl) %{_datadir}/doc/%{name}-%{version}/pl
195%{_datadir}/doc/%{name}-%{version}/BUILDING
196%{_datadir}/doc/%{name}-%{version}/NEWS
197%{_datadir}/doc/%{name}-%{version}/README*
198%{_datadir}/doc/%{name}-%{version}/PACKAGING
199%{_datadir}/doc/%{name}-%{version}/LINKS
200%{_datadir}/doc/%{name}-%{version}/TRANSLATION
201
202
203%changelog
204* Tue Jun  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
205- initial build for Vine Linux: based Fedora 1.3.6-4.fc14
206
207* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-4
208- fix build with podofo 0.8.0
209
210* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-3
211- rebuilt for podofo 0.8.0
212
213* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-2
214- added 2 patches for rawhide
215
216* Mon Mar 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
217- update to final 1.3.6
218
219* Wed Nov 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-5
220- fixed a crash when closing a hyphenator object (#537677)
221
222* Thu Aug 27 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.5.1-4
223- rebuilt with new openssl
224
225* Tue Aug 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-3
226- drop shebang line from python scripts
227- don't package precompiled python scripts
228
229* Thu Aug 20 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-1
230- update to final 1.3.5.1
231- drop the upstreamed "install-headers" patch
232- always install doc subpackage (#446148)
233- full changelog: http://www.scribus.net/?q=node/193
234
235* Wed Jul 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.17.rc3
236- don't use parallel build on s390x
237
238* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.16.rc3
239- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
240
241* Tue Jul 21 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.15.rc3
242- update to 1.3.5-rc3
243- use system hyphen library (#506074)
244- fix update path for the doc subpackage (#512498)
245- preserve directories when installing headers (#511800)
246
247* Thu Jun  4 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.14.rc2
248- update to 1.3.5-rc2
249
250* Mon May 18 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.13.beta
251- rebuilt with podofo enabled
252
253* Wed Apr 22 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.12.beta
254- update to 1.3.5.beta
255- make docs subpackage noarch
256- drop outdated Obsoletes/Provides
257
258* Sun Mar 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.11.20090329svn13359
259- update to revision 13359
260- add aspell-devel and boost-devel as BR
261- update release tag to conform to the pre-release versioning guideline
262
263* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.10.12516svn
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
265
266* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.4-0.9.12516svn
267- rebuild with new openssl
268
269* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.8.12516svn
270- Rebuild for Python 2.6
271
272* Tue Dec  2 2008 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.7.12516svn
273- fix directory ownership in doc subpackage (#474041)
274
275* Sun Nov 30 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.6.12516svn
276- Rebuild for Python 2.6
277
278* Mon Oct 13 2008 Dan Horák <dan[AT]danny.cz> 1.3.5-0.5.12516svn
279- install global desktop file instead of KDE-only one (#461124)
280- little cleanup
281
282* Fri Sep 05 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
283- 1.3.5-0.4.12516svn
284- new svn snapshot
285
286* Sun Jul 27 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
287- 1.3.5-0.3.12419svn
288- new svn snapshot
289
290* Mon Jul 21 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
291- 1.3.5-0.2.12404svn
292- svn snapshot
293
294* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3.4-5
295- Autorebuild for GCC 4.3
296
297* Mon Feb 11 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> - 1.3.4-4
298- Rebuilt for gcc43
299
300* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
301- 1.3.4-3
302- fix inclusion of python scripts as proposed by Todd Zullinger (#312091)
303- fix desktop file
304
305* Thu Aug 23 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
306- 1.3.4-2
307- rebuild for buildid
308- new license tag
309
310* Sat Jun 02 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3111.3.4
312- version upgrade
313
314* Mon Dec 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3151.3.3.6-1
316- version upgrade
317
318* Sat Nov 11 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3191.3.3.5-1
320- version upgrade
321
322* Wed Oct 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3231.3.3.4-1
324- version upgrade
325
326* Fri Sep 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3271.3.3.3-1
328- version upgrade (#205962)
329
330* Sun Jun 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3311.3.3.2-2
332- bump
333
334* Tue May 30 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3351.3.3.2-1
336- version upgrade
337
338* Sat Apr 22 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3391.3.3.1-1
340- version upgrade
341
342* Tue Mar 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3431.3.3-1
344- version upgrade
345- add BR gnutls-devel
346
347* Sat Mar 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3481.3.2-1
349- upgrade to beta version
350
351* Thu Feb 16 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3521.2.4.1-4
353- Rebuild for Fedora Extras 5
354
355* Wed Feb 08 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3561.2.4.1-3
357- add missing requires python-imaging
358
359* Sat Jan 21 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3601.2.4.1-2
361- rebuild (#178494)
362
363* Wed Jan 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3641.2.4.1-1
365- version upgrade
366
367* Thu Jul 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.2.2.1-2
368- use dist tag for sanity between branches
369
370* Tue Jul 5 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2.1-1
371- 1.2.2.1 released to fix crash on open with certain 1.2.1 docs
372
373* Sun Jul 3 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2-0.fc4
374- 1.2.2 final
375
376* Tue Jun 28 2005 P Linnell <mrdocs AT scribus.info>- 1.2.2cvs-0
377- test build for 1.2.2cvs
378- Add freetype2 explicit build requirement
379- Add obsoletes. See PACKAGING in the source tarball
380- Change the description per PACKAGING
381- Bump required python. 2.2 is no longer supported.
382
383
384* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.2.1-5
385- rebuild on all arches
386
387* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
388- rebuilt
389
390* Sun Feb 06 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-3
391- Bumped BR on qt-devel to 3.3.
392
393* Thu Feb  3 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.1-2
394- Fix x86_64 build and summary.
395
396* Sun Jan 09 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-1
397- 1.2.1.
398
399* Sat Dec 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-0.1.cvs20041118
400- cvs snapshot.
401
402* Wed Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.3
403- Redirect output in post/postun, to avoid failure.
404
405* Wed Nov 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.2
406- Mime-type corrections for FC3.
407- Dropped redundent BR XFree86-devel.
408
409* Thu Aug 26 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.1
410- 1.2.
411- Dropping old obsoletes/provides (don't know of anyone using them).
412
413* Thu Aug 19 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.0.RC1
414- 1.2RC1.
415
416* Sat Aug 07 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.4
417- mime info/icon for .sla files.
418
419* Fri Jul 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.3
420- BuildReq openssl-devel (#1727).
421
422* Thu Jun 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.2
423- Source0 allows direct download (#1727).
424- Req tkinter (#1727).
425
426* Sun Jun 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.1
427- Updated to 1.1.7.
428- Re-added _smp_mflags.
429
430* Mon May 24 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.3
431- Add Application Category to desktop entry.
432
433* Sun Apr 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.2
434- Bump ghostscript Req to 7.07.
435- URL scribus.net.
436
437* Tue Apr 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.1
438- Updated to 1.1.6.
439- Using upstream desktop entry.
440
441* Sat Feb 14 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.5-0.fdr.1
442- Updated to 1.1.5.
443
444* Sun Dec 21 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.4-0.fdr.1
445- Updated to 1.1.4.
446
447* Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.2
448- Dropped LDFLAGS="-lm"
449- Added --with-pythondir=%%{_prefix}
450- Req ghostscript.
451
452* Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.1
453- Updated to 1.1.3.
454- Removed _smp_mflags.
455
456* Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.2
457- Req python.
458- Provides scribus-scripting.
459
460* Sun Nov 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.1
461- Updated to 1.1.2.
462- Obsoletes scribus-scripting.
463
464* Sat Oct 11 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.2
465- BuildReq littlecms-devel -> lcms-devel.
466
467* Thu Oct 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.1
468- Updated to 1.1.1.
469- BuildReq littlecms-devel.
470- BuildReq libart_lgpl-devel.
471
472* Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0.1-0.fdr.1
473- Updated to 1.0.1.
474- Split off devel package for headers.
475- No longer Obsoletes scribus-i18n-en
476
477* Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.3
478- desktop entry terminal=0 -> false.
479
480* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.2
481- Added Obsoletes scribus-i18n-en.
482
483* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.1
484- Updated to 1.0.
485
486* Tue Jul 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.0.1.rc1
487- Updated to 1.0RC1.
488
489* Fri Jun 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.11.1-0.fdr.1
490- Updated to 0.9.11.1.
491- Added obsoletes scribus-svg.
492
493* Sun May 25 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.3
494- Using make DESTDIR= workaround for plugin issue.
495- Removed post/postun ldconfig.
496- Removed devel subpackage.
497
498* Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.2
499- Explicitly set file permission on icon.
500- Created devel package.
501- Removed .la files.
502- Added ChangeLog to Documentation.
503
504* Sun May 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.1
505- Updated to 0.9.10.
506- buildroot -> RPM_BUILD_ROOT.
507
508* Sat Apr 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.3
509- Added BuildRequires for cups-devel.
510
511* Thu Apr 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.2
512- Added BuildRequires for libtiff-devel.
513- Added line to help package find tiff.
514
515* Sun Apr 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.1
516- Updated to 0.9.9.
517- Added line for QT.
518
519* Thu Apr 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.3.rh90
520- Added missing BuildRequires.
521- Corrected Group.
522
523* Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.2
524- Added desktop-file-utils to BuildRequires.
525- Changed category to X-Fedora-Extra.
526- Added Epoch:0.
527
528* Thu Mar 27 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.9.8-0.fdr.1
529- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.