source: projects/specs/trunk/s/scribus/scribus-vl.spec @ 10488

Revision 10488, 15.6 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1# -*- encoding: utf-8 -*-
2Name:           scribus
3Version:        1.4.5
4Release:        2%{?_dist_release}
5
6Summary:        DeskTop Publishing application written in Qt
7
8Group:          Applications/Productivity
9License:        GPLv2+
10URL:            http://www.scribus.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12
13# patch for Vine
14Patch1001:              scribus-1.4.2-prefsdialog.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  cmake
19
20BuildRequires:  cups-devel
21BuildRequires:  desktop-file-utils
22BuildRequires:  lcms-devel
23BuildRequires:  libart_lgpl-devel
24BuildRequires:  libjpeg-devel
25BuildRequires:  libpng-devel
26BuildRequires:  libtiff-devel
27BuildRequires:  libxml2-devel
28BuildRequires:  openssl-devel
29BuildRequires:  python-devel
30BuildRequires:  python-imaging
31BuildRequires:  qt4-devel
32BuildRequires:  zlib-devel
33BuildRequires:  freetype-devel
34BuildRequires:  gnutls-devel
35BuildRequires:  cairo-devel
36BuildRequires:  aspell-devel
37BuildRequires:  libboost-devel
38BuildRequires:  podofo-devel
39BuildRequires:  hyphen-devel
40Requires:       ghostscript
41Requires:       python
42Requires:       python-imaging
43Requires:       tkinter
44Requires:       shared-mime-info
45Requires:       %{name}-doc = %{version}-%{release}
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: iwaim
50
51%description
52Scribus is an desktop open source page layout program with
53the aim of producing commercial grade output in PDF and
54Postscript, primarily, though not exclusively for Linux.
55
56While the goals of the program are for ease of use and simple easy to
57understand tools, Scribus offers support for professional publishing
58features, such as CMYK color, easy PDF creation, Encapsulated Postscript
59import/export and creation of color separations.
60
61
62%package        devel
63Summary:        Header files for Scribus
64Group:          Development/Libraries
65Requires:       %{name} = %{version}-%{release}
66
67%description    devel
68Header files for Scribus.
69
70%package        doc
71Summary:        Documentation files for Scribus
72Group:          Development/Tools
73Requires:       %{name} = %{version}-%{release}
74BuildArch:      noarch
75
76
77%description    doc
78%{summary}
79
80%prep
81%setup -q -n %{name}-%{version}
82%patch1001 -p1 -b .pref
83
84# recode man page to UTF-8
85pushd scribus/manpages
86iconv -f ISO8859-2 -t UTF-8 scribus.1.pl > tmp
87touch -r scribus.1.pl tmp
88mv tmp scribus.1.pl
89popd
90
91# fix permissions
92chmod a-x scribus/pageitem_latexframe.h
93
94# drop shebang lines from python scripts
95for f in scribus/plugins/scriptplugin/{samples,scripts}/*.py
96do
97    sed '1{/#!\/usr\/bin\/env\|#!\/usr\/bin\/python/d}' $f > $f.new
98    touch -r $f $f.new
99    mv $f.new $f
100done
101
102
103%build
104mkdir build
105pushd build
106%cmake ..
107
108%ifnarch s390x
109make VERBOSE=1 %{?_smp_mflags}
110%else
111# we can't use parallel build on s390x, because g++ eats almost all memory
112# in the builder (2+0.5 GB) when compiling scribus134format.cpp
113make VERBOSE=1
114%endif
115popd
116
117
118%install
119rm -rf ${RPM_BUILD_ROOT}
120pushd build
121make install DESTDIR=$RPM_BUILD_ROOT
122popd
123
124install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribus.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/scribus.png
125install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribusdoc.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/x-scribus.png
126
127find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
128
129# install the global desktop file
130rm -f ${RPM_BUILD_ROOT}%{_datadir}/mimelnk/application/*scribus.desktop
131desktop-file-install                                    \
132    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications     \
133    scribus.desktop
134
135%clean
136rm -rf ${RPM_BUILD_ROOT}
137
138
139%post
140update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
141
142
143%postun
144update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
145
146
147%files
148%defattr(-,root,root,-)
149%doc AUTHORS ChangeLog ChangeLogSVN COPYING README TODO
150%{_bindir}/%{name}
151%{_libdir}/%{name}
152%{_datadir}/applications/%{name}.desktop
153%{_datadir}/mime/packages/%{name}.xml
154%{_datadir}/pixmaps/*
155%{_datadir}/%{name}
156#%exclude %{_datadir}/%{name}/samples/*.py[co]
157#%exclude %{_datadir}/%{name}/scripts/*.py[co]
158%{_mandir}/man1/*
159%{_mandir}/pl/man1/*
160%{_mandir}/de/man1/*
161
162%files devel
163%defattr(-,root,root,-)
164%doc AUTHORS COPYING
165%{_includedir}/%{name}
166
167%files doc
168%defattr(-,root,root,-)
169%{_datadir}/doc/%{name}
170
171
172%changelog
173* Fri Jul 01 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-2
174- rebuild with gcc-5.4.0
175
176* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
177- new upstream release
178
179* Mon Jan 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
180- new upstream release
181- add Patch1001 (scribus-1.4.2-prefsdialog.patch)
182
183* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
184- new upstream release
185
186* Fri Mar 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.0-3
187- rebuild with podofo-0.9.1
188
189* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
190- rebuild with python-2.7.2
191
192* Tue Jan 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
193- new upstream release
194- remove old patches
195
196* Tue Jun  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
197- initial build for Vine Linux: based Fedora 1.3.6-4.fc14
198
199* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-4
200- fix build with podofo 0.8.0
201
202* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-3
203- rebuilt for podofo 0.8.0
204
205* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-2
206- added 2 patches for rawhide
207
208* Mon Mar 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
209- update to final 1.3.6
210
211* Wed Nov 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-5
212- fixed a crash when closing a hyphenator object (#537677)
213
214* Thu Aug 27 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.5.1-4
215- rebuilt with new openssl
216
217* Tue Aug 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-3
218- drop shebang line from python scripts
219- don't package precompiled python scripts
220
221* Thu Aug 20 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-1
222- update to final 1.3.5.1
223- drop the upstreamed "install-headers" patch
224- always install doc subpackage (#446148)
225- full changelog: http://www.scribus.net/?q=node/193
226
227* Wed Jul 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.17.rc3
228- don't use parallel build on s390x
229
230* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.16.rc3
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
232
233* Tue Jul 21 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.15.rc3
234- update to 1.3.5-rc3
235- use system hyphen library (#506074)
236- fix update path for the doc subpackage (#512498)
237- preserve directories when installing headers (#511800)
238
239* Thu Jun  4 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.14.rc2
240- update to 1.3.5-rc2
241
242* Mon May 18 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.13.beta
243- rebuilt with podofo enabled
244
245* Wed Apr 22 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.12.beta
246- update to 1.3.5.beta
247- make docs subpackage noarch
248- drop outdated Obsoletes/Provides
249
250* Sun Mar 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.11.20090329svn13359
251- update to revision 13359
252- add aspell-devel and boost-devel as BR
253- update release tag to conform to the pre-release versioning guideline
254
255* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.10.12516svn
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
257
258* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.4-0.9.12516svn
259- rebuild with new openssl
260
261* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.8.12516svn
262- Rebuild for Python 2.6
263
264* Tue Dec  2 2008 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.7.12516svn
265- fix directory ownership in doc subpackage (#474041)
266
267* Sun Nov 30 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.6.12516svn
268- Rebuild for Python 2.6
269
270* Mon Oct 13 2008 Dan Horák <dan[AT]danny.cz> 1.3.5-0.5.12516svn
271- install global desktop file instead of KDE-only one (#461124)
272- little cleanup
273
274* Fri Sep 05 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
275- 1.3.5-0.4.12516svn
276- new svn snapshot
277
278* Sun Jul 27 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
279- 1.3.5-0.3.12419svn
280- new svn snapshot
281
282* Mon Jul 21 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
283- 1.3.5-0.2.12404svn
284- svn snapshot
285
286* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3.4-5
287- Autorebuild for GCC 4.3
288
289* Mon Feb 11 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> - 1.3.4-4
290- Rebuilt for gcc43
291
292* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
293- 1.3.4-3
294- fix inclusion of python scripts as proposed by Todd Zullinger (#312091)
295- fix desktop file
296
297* Thu Aug 23 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
298- 1.3.4-2
299- rebuild for buildid
300- new license tag
301
302* Sat Jun 02 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3031.3.4
304- version upgrade
305
306* Mon Dec 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3071.3.3.6-1
308- version upgrade
309
310* Sat Nov 11 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3111.3.3.5-1
312- version upgrade
313
314* Wed Oct 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3151.3.3.4-1
316- version upgrade
317
318* Fri Sep 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3191.3.3.3-1
320- version upgrade (#205962)
321
322* Sun Jun 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3231.3.3.2-2
324- bump
325
326* Tue May 30 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3271.3.3.2-1
328- version upgrade
329
330* Sat Apr 22 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3311.3.3.1-1
332- version upgrade
333
334* Tue Mar 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3351.3.3-1
336- version upgrade
337- add BR gnutls-devel
338
339* Sat Mar 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3401.3.2-1
341- upgrade to beta version
342
343* Thu Feb 16 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3441.2.4.1-4
345- Rebuild for Fedora Extras 5
346
347* Wed Feb 08 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3481.2.4.1-3
349- add missing requires python-imaging
350
351* Sat Jan 21 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3521.2.4.1-2
353- rebuild (#178494)
354
355* Wed Jan 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3561.2.4.1-1
357- version upgrade
358
359* Thu Jul 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.2.2.1-2
360- use dist tag for sanity between branches
361
362* Tue Jul 5 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2.1-1
363- 1.2.2.1 released to fix crash on open with certain 1.2.1 docs
364
365* Sun Jul 3 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2-0.fc4
366- 1.2.2 final
367
368* Tue Jun 28 2005 P Linnell <mrdocs AT scribus.info>- 1.2.2cvs-0
369- test build for 1.2.2cvs
370- Add freetype2 explicit build requirement
371- Add obsoletes. See PACKAGING in the source tarball
372- Change the description per PACKAGING
373- Bump required python. 2.2 is no longer supported.
374
375
376* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.2.1-5
377- rebuild on all arches
378
379* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
380- rebuilt
381
382* Sun Feb 06 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-3
383- Bumped BR on qt-devel to 3.3.
384
385* Thu Feb  3 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.1-2
386- Fix x86_64 build and summary.
387
388* Sun Jan 09 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-1
389- 1.2.1.
390
391* Sat Dec 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-0.1.cvs20041118
392- cvs snapshot.
393
394* Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.3
395- Redirect output in post/postun, to avoid failure.
396
397* Wed Nov 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.2
398- Mime-type corrections for FC3.
399- Dropped redundent BR XFree86-devel.
400
401* Thu Aug 26 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.1
402- 1.2.
403- Dropping old obsoletes/provides (don't know of anyone using them).
404
405* Thu Aug 19 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.0.RC1
406- 1.2RC1.
407
408* Sat Aug 07 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.4
409- mime info/icon for .sla files.
410
411* Sat Jul 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.3
412- BuildReq openssl-devel (#1727).
413
414* Thu Jun 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.2
415- Source0 allows direct download (#1727).
416- Req tkinter (#1727).
417
418* Sun Jun 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.1
419- Updated to 1.1.7.
420- Re-added _smp_mflags.
421
422* Mon May 24 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.3
423- Add Application Category to desktop entry.
424
425* Sun Apr 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.2
426- Bump ghostscript Req to 7.07.
427- URL scribus.net.
428
429* Tue Apr 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.1
430- Updated to 1.1.6.
431- Using upstream desktop entry.
432
433* Sat Feb 14 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.5-0.fdr.1
434- Updated to 1.1.5.
435
436* Sun Dec 21 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.4-0.fdr.1
437- Updated to 1.1.4.
438
439* Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.2
440- Dropped LDFLAGS="-lm"
441- Added --with-pythondir=%%{_prefix}
442- Req ghostscript.
443
444* Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.1
445- Updated to 1.1.3.
446- Removed _smp_mflags.
447
448* Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.2
449- Req python.
450- Provides scribus-scripting.
451
452* Sun Nov 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.1
453- Updated to 1.1.2.
454- Obsoletes scribus-scripting.
455
456* Sat Oct 11 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.2
457- BuildReq littlecms-devel -> lcms-devel.
458
459* Thu Oct 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.1
460- Updated to 1.1.1.
461- BuildReq littlecms-devel.
462- BuildReq libart_lgpl-devel.
463
464* Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0.1-0.fdr.1
465- Updated to 1.0.1.
466- Split off devel package for headers.
467- No longer Obsoletes scribus-i18n-en
468
469* Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.3
470- desktop entry terminal=0 -> false.
471
472* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.2
473- Added Obsoletes scribus-i18n-en.
474
475* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.1
476- Updated to 1.0.
477
478* Tue Jul 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.0.1.rc1
479- Updated to 1.0RC1.
480
481* Fri Jun 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.11.1-0.fdr.1
482- Updated to 0.9.11.1.
483- Added obsoletes scribus-svg.
484
485* Sun May 25 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.3
486- Using make DESTDIR= workaround for plugin issue.
487- Removed post/postun ldconfig.
488- Removed devel subpackage.
489
490* Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.2
491- Explicitly set file permission on icon.
492- Created devel package.
493- Removed .la files.
494- Added ChangeLog to Documentation.
495
496* Sun May 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.1
497- Updated to 0.9.10.
498- buildroot -> RPM_BUILD_ROOT.
499
500* Sat Apr 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.3
501- Added BuildRequires for cups-devel.
502
503* Thu Apr 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.2
504- Added BuildRequires for libtiff-devel.
505- Added line to help package find tiff.
506
507* Sun Apr 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.1
508- Updated to 0.9.9.
509- Added line for QT.
510
511* Thu Apr 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.3.rh90
512- Added missing BuildRequires.
513- Corrected Group.
514
515* Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.2
516- Added desktop-file-utils to BuildRequires.
517- Changed category to X-Fedora-Extra.
518- Added Epoch:0.
519
520* Thu Mar 27 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.9.8-0.fdr.1
521- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.