source: projects/specs/trunk/s/scribus/scribus-vl.spec @ 9336

Revision 9336, 15.5 KB checked in by Takemikaduchi, 9 years ago (diff)

eudev: fix udev-post.init
others: new upstream release

Line 
1# -*- encoding: utf-8 -*-
2Name:           scribus
3Version:        1.4.5
4Release:        1%{?_dist_release}
5
6Summary:        DeskTop Publishing application written in Qt
7
8Group:          Applications/Productivity
9License:        GPLv2+
10URL:            http://www.scribus.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12
13# patch for Vine
14Patch1001:              scribus-1.4.2-prefsdialog.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17
18BuildRequires:  cmake
19
20BuildRequires:  cups-devel
21BuildRequires:  desktop-file-utils
22BuildRequires:  lcms-devel
23BuildRequires:  libart_lgpl-devel
24BuildRequires:  libjpeg-devel
25BuildRequires:  libpng-devel
26BuildRequires:  libtiff-devel
27BuildRequires:  libxml2-devel
28BuildRequires:  openssl-devel
29BuildRequires:  python-devel
30BuildRequires:  python-imaging
31BuildRequires:  qt4-devel
32BuildRequires:  zlib-devel
33BuildRequires:  freetype-devel
34BuildRequires:  gnutls-devel
35BuildRequires:  cairo-devel
36BuildRequires:  aspell-devel
37BuildRequires:  libboost-devel
38BuildRequires:  podofo-devel
39BuildRequires:  hyphen-devel
40Requires:       ghostscript
41Requires:       python
42Requires:       python-imaging
43Requires:       tkinter
44Requires:       shared-mime-info
45Requires:       %{name}-doc = %{version}-%{release}
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: iwaim
50
51%description
52Scribus is an desktop open source page layout program with
53the aim of producing commercial grade output in PDF and
54Postscript, primarily, though not exclusively for Linux.
55
56While the goals of the program are for ease of use and simple easy to
57understand tools, Scribus offers support for professional publishing
58features, such as CMYK color, easy PDF creation, Encapsulated Postscript
59import/export and creation of color separations.
60
61
62%package        devel
63Summary:        Header files for Scribus
64Group:          Development/Libraries
65Requires:       %{name} = %{version}-%{release}
66
67%description    devel
68Header files for Scribus.
69
70%package        doc
71Summary:        Documentation files for Scribus
72Group:          Development/Tools
73Requires:       %{name} = %{version}-%{release}
74BuildArch:      noarch
75
76
77%description    doc
78%{summary}
79
80%prep
81%setup -q -n %{name}-%{version}
82%patch1001 -p1 -b .pref
83
84# recode man page to UTF-8
85pushd scribus/manpages
86iconv -f ISO8859-2 -t UTF-8 scribus.1.pl > tmp
87touch -r scribus.1.pl tmp
88mv tmp scribus.1.pl
89popd
90
91# fix permissions
92chmod a-x scribus/pageitem_latexframe.h
93
94# drop shebang lines from python scripts
95for f in scribus/plugins/scriptplugin/{samples,scripts}/*.py
96do
97    sed '1{/#!\/usr\/bin\/env\|#!\/usr\/bin\/python/d}' $f > $f.new
98    touch -r $f $f.new
99    mv $f.new $f
100done
101
102
103%build
104mkdir build
105pushd build
106%cmake ..
107
108%ifnarch s390x
109make VERBOSE=1 %{?_smp_mflags}
110%else
111# we can't use parallel build on s390x, because g++ eats almost all memory
112# in the builder (2+0.5 GB) when compiling scribus134format.cpp
113make VERBOSE=1
114%endif
115popd
116
117
118%install
119rm -rf ${RPM_BUILD_ROOT}
120pushd build
121make install DESTDIR=$RPM_BUILD_ROOT
122popd
123
124install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribus.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/scribus.png
125install -p -D -m0644 ${RPM_BUILD_ROOT}%{_datadir}/scribus/icons/scribusdoc.png ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/x-scribus.png
126
127find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
128
129# install the global desktop file
130rm -f ${RPM_BUILD_ROOT}%{_datadir}/mimelnk/application/*scribus.desktop
131desktop-file-install                                    \
132    --dir=${RPM_BUILD_ROOT}%{_datadir}/applications     \
133    scribus.desktop
134
135%clean
136rm -rf ${RPM_BUILD_ROOT}
137
138
139%post
140update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
141
142
143%postun
144update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
145
146
147%files
148%defattr(-,root,root,-)
149%doc AUTHORS ChangeLog ChangeLogSVN COPYING README TODO
150%{_bindir}/%{name}
151%{_libdir}/%{name}
152%{_datadir}/applications/%{name}.desktop
153%{_datadir}/mime/packages/%{name}.xml
154%{_datadir}/pixmaps/*
155%{_datadir}/%{name}
156#%exclude %{_datadir}/%{name}/samples/*.py[co]
157#%exclude %{_datadir}/%{name}/scripts/*.py[co]
158%{_mandir}/man1/*
159%{_mandir}/pl/man1/*
160%{_mandir}/de/man1/*
161
162%files devel
163%defattr(-,root,root,-)
164%doc AUTHORS COPYING
165%{_includedir}/%{name}
166
167%files doc
168%defattr(-,root,root,-)
169%{_datadir}/doc/%{name}
170
171
172%changelog
173* Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
174- new upstream release
175
176* Mon Jan 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
177- new upstream release
178- add Patch1001 (scribus-1.4.2-prefsdialog.patch)
179
180* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
181- new upstream release
182
183* Fri Mar 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.4.0-3
184- rebuild with podofo-0.9.1
185
186* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
187- rebuild with python-2.7.2
188
189* Tue Jan 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
190- new upstream release
191- remove old patches
192
193* Tue Jun  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.3.6-1
194- initial build for Vine Linux: based Fedora 1.3.6-4.fc14
195
196* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-4
197- fix build with podofo 0.8.0
198
199* Thu Apr 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-3
200- rebuilt for podofo 0.8.0
201
202* Wed Mar 31 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-2
203- added 2 patches for rawhide
204
205* Mon Mar 29 2010 Dan Horák <dan[AT]danny.cz> - 1.3.6-1
206- update to final 1.3.6
207
208* Wed Nov 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-5
209- fixed a crash when closing a hyphenator object (#537677)
210
211* Thu Aug 27 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.5.1-4
212- rebuilt with new openssl
213
214* Tue Aug 25 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-3
215- drop shebang line from python scripts
216- don't package precompiled python scripts
217
218* Thu Aug 20 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5.1-1
219- update to final 1.3.5.1
220- drop the upstreamed "install-headers" patch
221- always install doc subpackage (#446148)
222- full changelog: http://www.scribus.net/?q=node/193
223
224* Wed Jul 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.17.rc3
225- don't use parallel build on s390x
226
227* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.16.rc3
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
229
230* Tue Jul 21 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.15.rc3
231- update to 1.3.5-rc3
232- use system hyphen library (#506074)
233- fix update path for the doc subpackage (#512498)
234- preserve directories when installing headers (#511800)
235
236* Thu Jun  4 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.14.rc2
237- update to 1.3.5-rc2
238
239* Mon May 18 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.13.beta
240- rebuilt with podofo enabled
241
242* Wed Apr 22 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.12.beta
243- update to 1.3.5.beta
244- make docs subpackage noarch
245- drop outdated Obsoletes/Provides
246
247* Sun Mar 29 2009 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.11.20090329svn13359
248- update to revision 13359
249- add aspell-devel and boost-devel as BR
250- update release tag to conform to the pre-release versioning guideline
251
252* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-0.10.12516svn
253- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
254
255* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.4-0.9.12516svn
256- rebuild with new openssl
257
258* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.8.12516svn
259- Rebuild for Python 2.6
260
261* Tue Dec  2 2008 Dan Horák <dan[AT]danny.cz> - 1.3.5-0.7.12516svn
262- fix directory ownership in doc subpackage (#474041)
263
264* Sun Nov 30 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.5-0.6.12516svn
265- Rebuild for Python 2.6
266
267* Mon Oct 13 2008 Dan Horák <dan[AT]danny.cz> 1.3.5-0.5.12516svn
268- install global desktop file instead of KDE-only one (#461124)
269- little cleanup
270
271* Fri Sep 05 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
272- 1.3.5-0.4.12516svn
273- new svn snapshot
274
275* Sun Jul 27 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
276- 1.3.5-0.3.12419svn
277- new svn snapshot
278
279* Mon Jul 21 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
280- 1.3.5-0.2.12404svn
281- svn snapshot
282
283* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3.4-5
284- Autorebuild for GCC 4.3
285
286* Mon Feb 11 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> - 1.3.4-4
287- Rebuilt for gcc43
288
289* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
290- 1.3.4-3
291- fix inclusion of python scripts as proposed by Todd Zullinger (#312091)
292- fix desktop file
293
294* Thu Aug 23 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
295- 1.3.4-2
296- rebuild for buildid
297- new license tag
298
299* Sat Jun 02 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3001.3.4
301- version upgrade
302
303* Mon Dec 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3041.3.3.6-1
305- version upgrade
306
307* Sat Nov 11 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3081.3.3.5-1
309- version upgrade
310
311* Wed Oct 04 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3121.3.3.4-1
313- version upgrade
314
315* Fri Sep 15 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3161.3.3.3-1
317- version upgrade (#205962)
318
319* Sun Jun 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3201.3.3.2-2
321- bump
322
323* Tue May 30 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3241.3.3.2-1
325- version upgrade
326
327* Sat Apr 22 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3281.3.3.1-1
329- version upgrade
330
331* Tue Mar 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3321.3.3-1
333- version upgrade
334- add BR gnutls-devel
335
336* Sat Mar 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3371.3.2-1
338- upgrade to beta version
339
340* Thu Feb 16 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3411.2.4.1-4
342- Rebuild for Fedora Extras 5
343
344* Wed Feb 08 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3451.2.4.1-3
346- add missing requires python-imaging
347
348* Sat Jan 21 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3491.2.4.1-2
350- rebuild (#178494)
351
352* Wed Jan 18 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
3531.2.4.1-1
354- version upgrade
355
356* Thu Jul 7 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.2.2.1-2
357- use dist tag for sanity between branches
358
359* Tue Jul 5 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2.1-1
360- 1.2.2.1 released to fix crash on open with certain 1.2.1 docs
361
362* Sun Jul 3 2005 P Linnell <mrdocs AT scribus.info> - 1.2.2-0.fc4
363- 1.2.2 final
364
365* Tue Jun 28 2005 P Linnell <mrdocs AT scribus.info>- 1.2.2cvs-0
366- test build for 1.2.2cvs
367- Add freetype2 explicit build requirement
368- Add obsoletes. See PACKAGING in the source tarball
369- Change the description per PACKAGING
370- Bump required python. 2.2 is no longer supported.
371
372
373* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.2.1-5
374- rebuild on all arches
375
376* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
377- rebuilt
378
379* Sun Feb 06 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-3
380- Bumped BR on qt-devel to 3.3.
381
382* Thu Feb  3 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.1-2
383- Fix x86_64 build and summary.
384
385* Sun Jan 09 2005 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-1
386- 1.2.1.
387
388* Sat Dec 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2.1-0.1.cvs20041118
389- cvs snapshot.
390
391* Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.3
392- Redirect output in post/postun, to avoid failure.
393
394* Wed Nov 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 1.2-0.fdr.2
395- Mime-type corrections for FC3.
396- Dropped redundent BR XFree86-devel.
397
398* Thu Aug 26 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.1
399- 1.2.
400- Dropping old obsoletes/provides (don't know of anyone using them).
401
402* Thu Aug 19 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.2-0.fdr.0.RC1
403- 1.2RC1.
404
405* Sat Aug 07 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.4
406- mime info/icon for .sla files.
407
408* Sat Jul 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.3
409- BuildReq openssl-devel (#1727).
410
411* Thu Jun 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.2
412- Source0 allows direct download (#1727).
413- Req tkinter (#1727).
414
415* Sun Jun 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.7-0.fdr.1
416- Updated to 1.1.7.
417- Re-added _smp_mflags.
418
419* Mon May 24 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.3
420- Add Application Category to desktop entry.
421
422* Sun Apr 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.2
423- Bump ghostscript Req to 7.07.
424- URL scribus.net.
425
426* Tue Apr 06 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.6-0.fdr.1
427- Updated to 1.1.6.
428- Using upstream desktop entry.
429
430* Sat Feb 14 2004 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.5-0.fdr.1
431- Updated to 1.1.5.
432
433* Sun Dec 21 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.4-0.fdr.1
434- Updated to 1.1.4.
435
436* Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.2
437- Dropped LDFLAGS="-lm"
438- Added --with-pythondir=%%{_prefix}
439- Req ghostscript.
440
441* Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.3-0.fdr.1
442- Updated to 1.1.3.
443- Removed _smp_mflags.
444
445* Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.2
446- Req python.
447- Provides scribus-scripting.
448
449* Sun Nov 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.2-0.fdr.1
450- Updated to 1.1.2.
451- Obsoletes scribus-scripting.
452
453* Sat Oct 11 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.2
454- BuildReq littlecms-devel -> lcms-devel.
455
456* Thu Oct 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.1.1-0.fdr.1
457- Updated to 1.1.1.
458- BuildReq littlecms-devel.
459- BuildReq libart_lgpl-devel.
460
461* Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0.1-0.fdr.1
462- Updated to 1.0.1.
463- Split off devel package for headers.
464- No longer Obsoletes scribus-i18n-en
465
466* Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.3
467- desktop entry terminal=0 -> false.
468
469* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.2
470- Added Obsoletes scribus-i18n-en.
471
472* Tue Jul 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.1
473- Updated to 1.0.
474
475* Tue Jul 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:1.0-0.fdr.0.1.rc1
476- Updated to 1.0RC1.
477
478* Fri Jun 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.11.1-0.fdr.1
479- Updated to 0.9.11.1.
480- Added obsoletes scribus-svg.
481
482* Sun May 25 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.3
483- Using make DESTDIR= workaround for plugin issue.
484- Removed post/postun ldconfig.
485- Removed devel subpackage.
486
487* Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.2
488- Explicitly set file permission on icon.
489- Created devel package.
490- Removed .la files.
491- Added ChangeLog to Documentation.
492
493* Sun May 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.10-0.fdr.1
494- Updated to 0.9.10.
495- buildroot -> RPM_BUILD_ROOT.
496
497* Sat Apr 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.3
498- Added BuildRequires for cups-devel.
499
500* Thu Apr 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.2
501- Added BuildRequires for libtiff-devel.
502- Added line to help package find tiff.
503
504* Sun Apr 20 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.9-0.fdr.1
505- Updated to 0.9.9.
506- Added line for QT.
507
508* Thu Apr 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.3.rh90
509- Added missing BuildRequires.
510- Corrected Group.
511
512* Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0:0.9.8-0.fdr.2
513- Added desktop-file-utils to BuildRequires.
514- Changed category to X-Fedora-Extra.
515- Added Epoch:0.
516
517* Thu Mar 27 2003 Phillip Compton <pcompton[AT]proteinmedia.com> - 0.9.8-0.fdr.1
518- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.