source: projects/specs/trunk/s/screenlets/screenlets-vl.spec @ 1454

Revision 1454, 2.5 KB checked in by kazutaka, 14 years ago (diff)

add new package

Line 
1%define pyver %(python -c 'import sys;print(sys.version[0:3])')
2%define pysite %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
3
4Summary:        Widget-like mini-applications for Linux-desktop
5Summary(ja):    Linux デスクトップ向けのウィジェット風ミニアプリケーション
6Name:           screenlets
7Version:        0.1.2
8Release:        1%{?_dist_release}
9Source0:        %{name}-%{version}.tar.bz2
10Source1:        screenlets-manager-ja.po
11Source2:        screenlets-ja.po
12License:        GPL
13Group:          Applications/Accessories
14URL:            http://www.screenlets.org/
15
16Requires:       pyxdg
17Requires:       dbus-python
18Requires:       gnome-python
19Requires:       gnome-python-desktop
20Requires:       gnome-python-rsvg
21Requires:       gnome-python-libwnck
22Requires:       gnome-python-gnomekeyring
23Requires:       librsvg2
24BuildRequires:  python-devel
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildArch:      noarch
27
28Packager:       kazutaka
29
30%description
31Screenlets (short form of "Screen-Applets") are small owner-drawn
32applications that can be described as "the virtual representation
33of things lying/standing around on your desk": Sticknotes, clocks,
34rulers, ... the possibilities are endless.
35
36Screenlets work without composite window manager (like Compiz),
37but it works better with them.
38
39%description -l ja
40Screenlets ("Screen-Applets"の略) は、あなたの身の回りにある
41色々な道具(付箋や時計、定規等々)を仮想的に表現する、ウィジェット
42風のミニアプリケーションです。
43
44Screenlets は (Compiz のような)コンポジットウィンドウマネージャ
45が無くても問題なく動作しますが、透過表示等はコンポジット環境の
46方が綺麗に表示されます。
47
48
49%prep
50%setup -q -n %{name}
51# install updated japanese translation
52%{__cp} %{SOURCE1} po
53%{__cp} %{SOURCE2} po
54
55
56%build
57%{__python} setup.py build
58
59%install
60%{__rm} -rf $RPM_BUILD_ROOT
61%{__python} setup.py install --root %{buildroot}
62%find_lang %{name}
63%find_lang %{name}-manager
64cat %{name}-manager.lang >> %{name}.lang
65
66# Remove useless egg-info file
67%{__rm} -f %{buildroot}%{pysite}/*.egg-info
68
69%clean
70%{__rm} -rf $RPM_BUILD_ROOT
71
72
73%files -f %{name}.lang
74%defattr(-,root,root)
75%doc
76%{_bindir}/%{name}
77%{_bindir}/%{name}-daemon
78%{_bindir}/%{name}-manager
79%{_bindir}/%{name}-packager
80%{_bindir}/screenletsd
81%{_datadir}/%{name}
82%{_datadir}/%{name}-manager
83%{pysite}/%{name}
84%{_datadir}/applications/%{name}-manager.desktop
85%{_datadir}/icons/%{name}.svg
86
87%changelog
88* Mon Jul 26 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.1.2-1
89- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.