source: projects/specs/trunk/s/screen/screen-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A screen manager that supports multiple logins on one terminal.
2Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
3Name: screen
4Version: 4.0.3
5Release: 2%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source0: ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-%{version}.tar.gz
9Patch6: screen-3.9.8-hascrypt.patch
10Patch11: screen-3.9.11-utf8-install.patch
11# obtained Patch11 from redhat
12Patch12: screen-4.0.3-stropts.patch
13
14Requires: ncurses
15Requires(post,preun): /sbin/install-info
16BuildRequires: ncurses-devel, texinfo, perl
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23The screen utility allows you to have multiple logins on just one
24terminal.  Screen is useful for users who telnet into a machine or
25are connected via a dumb terminal, but want to use more than just
26one login.
27
28Install the screen package if you need a screen manager that can
29support multiple logins on one terminal.
30
31
32%description -l ja
33一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
34ユーティリティです。telnetで操作しているユーザやダムターミナルから
35接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
36便利なプログラムです。
37
38
39%prep
40%setup -q
41
42# avoid duplicated type declaration of crypt.
43%patch6 -p1 -b .hascrypt
44
45# to make directories under $RPM_BUILD_ROOT
46%patch11 -p1 -b .utf8
47
48# do not include <sys/stropts.h>
49%patch12 -p1 -b .stropts
50
51%build
52
53autoconf
54
55%configure \
56        --enable-pam \
57        --enable-locate \
58        --enable-telnet \
59        --enable-colors256 \
60        --with-sys-screenrc=%{_sysconfdir}/screenrc
61
62# configure can figure out these values.
63#perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
64#perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
65
66perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
67
68perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
69perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
70rm doc/screen.info*
71
72make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77mkdir -p $RPM_BUILD_ROOT/etc/skel
78perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
79
80%makeinstall DDESTDIR=$RPM_BUILD_ROOT
81
82( cd $RPM_BUILD_ROOT
83#  gzip -9nf .%{_infodir}/screen.info*
84#  strip .%{_bindir}/screen-%{version}
85
86  rm -f .%{_bindir}/screen.old .%{_bindir}/screen
87  mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
88)
89
90install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
91install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post
97/sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen).             Terminal multiplexer."
98
99if [ -d /tmp/screens ]; then
100    # we're not setuid root anymore
101    chmod 777 /tmp/screens
102fi
103
104%preun
105if [ $1 = 0 ]; then
106    /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen).             Terminal multiplexer."
107fi
108
109%files
110%defattr(-,root,root)
111%doc COPYING NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
112#%attr(755,root,root) %{_bindir}/screen
113%{_bindir}/screen
114%{_mandir}/man1/screen.*
115%{_infodir}/screen.info*
116%{_datadir}/screen
117%config(noreplace) /etc/screenrc
118%config /etc/skel/.screenrc
119
120
121%changelog
122* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
123- spec in UTF-8
124- add Patch12 to build against glibc-2.8
125- fix typo (from --enable-color256 to --enable-colors256)
126  thanks Minematsu Hiroki-san for pointing this out
127
128* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
129- used %%{?_dist_release}
130
131* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
132- rebuild for VineSeed
133
134* Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
135- rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
136
137* Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
138- add BuildRequires: texinfo, perl
139
140* Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
141- upstream release with security fix (build for Vine 4.0)
142
143* Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
144- use License instead of Copyright
145
146* Sat Jun  5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
147- new upstream release
148- add %%{_datadir}/screen in %%files
149- no replace configuration file: /etc/screenrc
150
151* Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
152- eliminate %%{_bindir} from %%files section
153 
154* Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
155- update to 3.9.13
156- add FAQ instead of a symbolic link to FAQ
157- remove unnecessary patches
158
159* Thu Nov  1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
160- update to 3.9.10 (security update)
161
162* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
163- update to 3.9.9
164- rebuild by current Seed
165- remove makeinfo patch, jbj patch
166
167* Sat Mar 10 2001 sagami@vinelinux.org
168- made minor spec fixes
169
170* Fri Mar  2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
171- update to 3.9.8
172- update 3.9.5-jbj.patch for 3.9.8
173- add hascrypt patch
174
175* Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
176- 3.9.5-1vl3
177- built with gcc-2.95.3
178- partially used rpmmacros
179
180* Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
181- 3.9.5-1vl2
182- fixed %files section to handle compressed man page
183
184* Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
185- updated to 3.9.5
186
187* Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
188- 3.9.4-5vl1
189- merged missing patches from screen-3.9.4-3 on Red Hat 6.1
190
191* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
192- you know, we weren't just patching in Unix98 pty support for fun.
193
194* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
195- put screendir in ~
196
197* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
198- update to 3.9.4.
199
200* Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
201- force tty permissions/group
202
203* Wed Jun 5 1999 Dale Lovelace <dale@redhat.com>
204- permissions on /etc/skel/.screenrc to 644
205
206* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
207- take out warning of directory permissions so root can still use screen
208
209* Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
210- take out warning of directory ownership so root can still use screen
211
212* Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
213- patched in utempter support, turned off setuid bit
214
215* Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
216- fixed unix98 pty support
217
218* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
219- auto rebuild in the new build environment (release 3)
220
221* Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
222- add patch for Unix98 pty support
223
224* Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
225- update to 3.7.6.
226
227* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
228- build root
229
230* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
231- translations modified for de, fr, tr
232
233* Wed Oct 21 1997 Cristian Gafton <gafton@redhat.com>
234- upgraded to 3.7.4
235
236* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
237- removed glibc 1.99 specific patch
238
239* Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
240- added install-info support
241
242* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
243- built against glibc
Note: See TracBrowser for help on using the repository browser.