source: projects/specs/trunk/s/screen/screen-vl.spec @ 11619

Revision 11619, 7.8 KB checked in by iwamoto, 6 years ago (diff)

screen: update to 4.6.2

Line 
1Summary: A screen manager that supports multiple logins on one terminal.
2Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
3Name: screen
4Version: 4.6.2
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8Source0: ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-%{version}.tar.gz
9Source1:        screen.pam
10
11Patch1:         screen-4.3.1-libs.patch
12Patch2:         screen-4.3.1-screenrc.patch
13Patch3:         screen-E3.patch
14Patch4:         screen-4.3.1-suppress_remap.patch
15Patch5:         screen-4.3.1-crypt.patch
16
17Requires: ncurses
18Requires(post,preun): /sbin/install-info
19BuildRequires: ncurses-devel, texinfo, perl
20BuildRequires: pam-devel
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27The screen utility allows you to have multiple logins on just one
28terminal.  Screen is useful for users who telnet into a machine or
29are connected via a dumb terminal, but want to use more than just
30one login.
31
32Install the screen package if you need a screen manager that can
33support multiple logins on one terminal.
34
35
36%description -l ja
37一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
38ユーティリティです。telnetで操作しているユーザやダムターミナルから
39接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
40便利なプログラムです。
41
42
43%prep
44%setup -q
45%autosetup -p1
46
47%build
48autoconf
49
50%configure \
51        --enable-pam \
52        --enable-locate \
53        --enable-telnet \
54        --enable-colors256 \
55        --with-sys-screenrc=%{_sysconfdir}/screenrc
56
57# configure can figure out these values.
58#perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
59#perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
60
61perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
62
63perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
64perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
65rm -f doc/screen.info*
66
67# fails with %{?_smp_mflags}
68make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73mkdir -p $RPM_BUILD_ROOT/etc/skel
74perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
75
76%makeinstall DDESTDIR=$RPM_BUILD_ROOT
77
78( cd $RPM_BUILD_ROOT
79#  gzip -9nf .%{_infodir}/screen.info*
80#  strip .%{_bindir}/screen-%{version}
81
82  rm -f .%{_bindir}/screen.old .%{_bindir}/screen
83  mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
84)
85
86install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
87install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
88
89# Better not forget to copy the pam file around
90mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
91install -p -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/screen
92# Remove files from the buildroot which we don't want packaged
93rm -f $RPM_BUILD_ROOT%{_infodir}/dir
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post
99/sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen).             Terminal multiplexer."
100
101if [ -d /tmp/screens ]; then
102    # we're not setuid root anymore
103    chmod 777 /tmp/screens
104fi
105
106%preun
107if [ $1 = 0 ]; then
108    /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen).             Terminal multiplexer."
109fi
110
111%files
112%defattr(-,root,root)
113%doc COPYING NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
114#%attr(755,root,root) %{_bindir}/screen
115%{_bindir}/screen
116%{_mandir}/man1/screen.*
117%{_infodir}/screen.info*
118%{_datadir}/screen
119%config(noreplace) %{_sysconfdir}/screenrc
120%config(noreplace) %{_sysconfdir}/pam.d/screen
121%config /etc/skel/.screenrc
122
123
124%changelog
125* Fri Apr 20 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.6.2-1
126- update to 4.6.2
127- change License
128- sync fc28 package
129
130* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.3-4
131- rebuild with VineSeed environment
132
133* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.3-3vl6
134- build on current VineSeed
135- add execvpe patch (Patch0) based upstream git
136
137* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
138- spec in UTF-8
139- add Patch12 to build against glibc-2.8
140- fix typo (from --enable-color256 to --enable-colors256)
141  thanks Minematsu Hiroki-san for pointing this out
142
143* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
144- used %%{?_dist_release}
145
146* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
147- rebuild for VineSeed
148
149* Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
150- rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
151
152* Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
153- add BuildRequires: texinfo, perl
154
155* Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
156- upstream release with security fix (build for Vine 4.0)
157
158* Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
159- use License instead of Copyright
160
161* Sat Jun  5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
162- new upstream release
163- add %%{_datadir}/screen in %%files
164- no replace configuration file: /etc/screenrc
165
166* Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
167- eliminate %%{_bindir} from %%files section
168 
169* Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
170- update to 3.9.13
171- add FAQ instead of a symbolic link to FAQ
172- remove unnecessary patches
173
174* Thu Nov  1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
175- update to 3.9.10 (security update)
176
177* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
178- update to 3.9.9
179- rebuild by current Seed
180- remove makeinfo patch, jbj patch
181
182* Sat Mar 10 2001 sagami@vinelinux.org
183- made minor spec fixes
184
185* Fri Mar  2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
186- update to 3.9.8
187- update 3.9.5-jbj.patch for 3.9.8
188- add hascrypt patch
189
190* Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
191- 3.9.5-1vl3
192- built with gcc-2.95.3
193- partially used rpmmacros
194
195* Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
196- 3.9.5-1vl2
197- fixed %files section to handle compressed man page
198
199* Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
200- updated to 3.9.5
201
202* Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
203- 3.9.4-5vl1
204- merged missing patches from screen-3.9.4-3 on Red Hat 6.1
205
206* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
207- you know, we weren't just patching in Unix98 pty support for fun.
208
209* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
210- put screendir in ~
211
212* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
213- update to 3.9.4.
214
215* Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
216- force tty permissions/group
217
218* Sat Jun 5 1999 Dale Lovelace <dale@redhat.com>
219- permissions on /etc/skel/.screenrc to 644
220
221* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
222- take out warning of directory permissions so root can still use screen
223
224* Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
225- take out warning of directory ownership so root can still use screen
226
227* Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
228- patched in utempter support, turned off setuid bit
229
230* Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
231- fixed unix98 pty support
232
233* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
234- auto rebuild in the new build environment (release 3)
235
236* Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
237- add patch for Unix98 pty support
238
239* Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
240- update to 3.7.6.
241
242* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
243- build root
244
245* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
246- translations modified for de, fr, tr
247
248* Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
249- upgraded to 3.7.4
250
251* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
252- removed glibc 1.99 specific patch
253
254* Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
255- added install-info support
256
257* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
258- built against glibc
Note: See TracBrowser for help on using the repository browser.