source: projects/specs/trunk/s/screen/screen-vl.spec @ 8915

Revision 8915, 7.5 KB checked in by Takemikaduchi, 10 years ago (diff)

dash,liboil,libutempter,virtuoso-opensource,wavpack: new upstream release
others: rebuild

Line 
1Summary: A screen manager that supports multiple logins on one terminal.
2Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
3Name: screen
4Version: 4.0.3
5Release: 4%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source0: ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-%{version}.tar.gz
9# based http://git.savannah.gnu.org/gitweb/?p=screen.git;a=commit;h=97059b7ad521cf796daee07397c658d9716dd1e7
10Patch0: screen-4.0.3-execvpe.patch
11Patch6: screen-3.9.8-hascrypt.patch
12Patch11: screen-3.9.11-utf8-install.patch
13# obtained Patch11 from redhat
14Patch12: screen-4.0.3-stropts.patch
15
16Requires: ncurses
17Requires(post,preun): /sbin/install-info
18BuildRequires: ncurses-devel, texinfo, perl
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25The screen utility allows you to have multiple logins on just one
26terminal.  Screen is useful for users who telnet into a machine or
27are connected via a dumb terminal, but want to use more than just
28one login.
29
30Install the screen package if you need a screen manager that can
31support multiple logins on one terminal.
32
33
34%description -l ja
35一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
36ユーティリティです。telnetで操作しているユーザやダムターミナルから
37接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
38便利なプログラムです。
39
40
41%prep
42%setup -q
43%patch0 -p1 -b .execvpe
44
45# avoid duplicated type declaration of crypt.
46%patch6 -p1 -b .hascrypt
47
48# to make directories under $RPM_BUILD_ROOT
49%patch11 -p1 -b .utf8
50
51# do not include <sys/stropts.h>
52%patch12 -p1 -b .stropts
53
54%build
55
56autoconf
57
58%configure \
59        --enable-pam \
60        --enable-locate \
61        --enable-telnet \
62        --enable-colors256 \
63        --with-sys-screenrc=%{_sysconfdir}/screenrc
64
65# configure can figure out these values.
66#perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
67#perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
68
69perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
70
71perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
72perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
73rm doc/screen.info*
74
75make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80mkdir -p $RPM_BUILD_ROOT/etc/skel
81perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
82
83%makeinstall DDESTDIR=$RPM_BUILD_ROOT
84
85( cd $RPM_BUILD_ROOT
86#  gzip -9nf .%{_infodir}/screen.info*
87#  strip .%{_bindir}/screen-%{version}
88
89  rm -f .%{_bindir}/screen.old .%{_bindir}/screen
90  mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
91)
92
93install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
94install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post
100/sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen).             Terminal multiplexer."
101
102if [ -d /tmp/screens ]; then
103    # we're not setuid root anymore
104    chmod 777 /tmp/screens
105fi
106
107%preun
108if [ $1 = 0 ]; then
109    /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen).             Terminal multiplexer."
110fi
111
112%files
113%defattr(-,root,root)
114%doc COPYING NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
115#%attr(755,root,root) %{_bindir}/screen
116%{_bindir}/screen
117%{_mandir}/man1/screen.*
118%{_infodir}/screen.info*
119%{_datadir}/screen
120%config(noreplace) /etc/screenrc
121%config /etc/skel/.screenrc
122
123
124%changelog
125* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.3-4
126- rebuild with VineSeed environment
127
128* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.3-3vl6
129- build on current VineSeed
130- add execvpe patch (Patch0) based upstream git
131
132* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
133- spec in UTF-8
134- add Patch12 to build against glibc-2.8
135- fix typo (from --enable-color256 to --enable-colors256)
136  thanks Minematsu Hiroki-san for pointing this out
137
138* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
139- used %%{?_dist_release}
140
141* Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
142- rebuild for VineSeed
143
144* Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
145- rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
146
147* Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
148- add BuildRequires: texinfo, perl
149
150* Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
151- upstream release with security fix (build for Vine 4.0)
152
153* Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
154- use License instead of Copyright
155
156* Sat Jun  5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
157- new upstream release
158- add %%{_datadir}/screen in %%files
159- no replace configuration file: /etc/screenrc
160
161* Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
162- eliminate %%{_bindir} from %%files section
163 
164* Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
165- update to 3.9.13
166- add FAQ instead of a symbolic link to FAQ
167- remove unnecessary patches
168
169* Thu Nov  1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
170- update to 3.9.10 (security update)
171
172* Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
173- update to 3.9.9
174- rebuild by current Seed
175- remove makeinfo patch, jbj patch
176
177* Sat Mar 10 2001 sagami@vinelinux.org
178- made minor spec fixes
179
180* Fri Mar  2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
181- update to 3.9.8
182- update 3.9.5-jbj.patch for 3.9.8
183- add hascrypt patch
184
185* Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
186- 3.9.5-1vl3
187- built with gcc-2.95.3
188- partially used rpmmacros
189
190* Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
191- 3.9.5-1vl2
192- fixed %files section to handle compressed man page
193
194* Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
195- updated to 3.9.5
196
197* Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
198- 3.9.4-5vl1
199- merged missing patches from screen-3.9.4-3 on Red Hat 6.1
200
201* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
202- you know, we weren't just patching in Unix98 pty support for fun.
203
204* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
205- put screendir in ~
206
207* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
208- update to 3.9.4.
209
210* Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
211- force tty permissions/group
212
213* Sat Jun 5 1999 Dale Lovelace <dale@redhat.com>
214- permissions on /etc/skel/.screenrc to 644
215
216* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
217- take out warning of directory permissions so root can still use screen
218
219* Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
220- take out warning of directory ownership so root can still use screen
221
222* Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
223- patched in utempter support, turned off setuid bit
224
225* Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
226- fixed unix98 pty support
227
228* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
229- auto rebuild in the new build environment (release 3)
230
231* Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
232- add patch for Unix98 pty support
233
234* Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
235- update to 3.7.6.
236
237* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
238- build root
239
240* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
241- translations modified for de, fr, tr
242
243* Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
244- upgraded to 3.7.4
245
246* Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
247- removed glibc 1.99 specific patch
248
249* Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
250- added install-info support
251
252* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
253- built against glibc
Note: See TracBrowser for help on using the repository browser.