source: projects/specs/trunk/s/scim-bridge/scim-bridge-vl.spec @ 2020

Revision 2020, 11.5 KB checked in by munepi, 14 years ago (diff)

updated scim-bridge-vl.spec

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name scim-bridge
4%define version 0.4.16
5%define release 12%{?_dist_release}
6
7%define qt3_ver 3.3.8
8%define qt4_ver 4.6.3
9
10# build qt3 immodule ("--without qt3" to disable qt3)
11%bcond_without qt3
12# Qt3 version auto-detection -- inagaki
13%define _qt3_version %(rpm -q --queryformat "%%{version}" qt-devel 2>/dev/null || echo %{qt3_ver})
14%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
15%define _qt3_plugindir %{_qt3_prefix}/plugins
16
17# build qt4 immodule ("--without qt4" to disable qt4)
18%bcond_without qt4
19# Qt4 version auto-detection -- inagaki
20%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
21%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
22%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
23
24
25Summary: yet another IM client of SCIM
26Summary(ja): もう一つ別の SCIM IM クライアント
27Name: %{name}
28Version: %{version}
29Release: %{release}
30Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
31
32# Patch from Fedora 10
33Patch0: scim-bridge-0.4.15-fix-gdm.patch
34Patch1: scim-bridge-0.4.15-bz461373.patch
35
36# Patch from Mandriva 2009
37Patch2: bug-351920-should-return-retval.patch
38Patch3: scim-bridge-0.4.15.2-linkage.patch
39
40# Patch from Fedora development
41Patch4: scim-bridge-0.4.15-EOF.patch
42Patch5: scim-bridge-0.4.15-hotkey-help.patch
43Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
44Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
45
46URL: http://www.scim-im.org/projects/scim_bridge
47License: GPL/LGPL
48Group: System Environment/Libraries
49BuildRoot: %{_tmppath}/%{name}-%{version}-root
50Prefix: %{_prefix}
51Requires: scim >= 1.4
52BuildRequires: scim-devel >= 1.4
53BuildRequires: pkgconfig >= 0.9.0
54BuildRequires: gtk2-devel >= 2.14.0
55
56%description
57Scim-bridge is yet another IM client of SCIM.
58The im-module of scim-bridge communicates with scim via socket.
59
60%description -l ja
61scim-bridge は、もう一つ別の SCIM IM クライアントです。
62scim-bridge の im-module はソケット経由で SCIM と通信します。
63
64%package gtk
65Summary:        SCIM Bridge GTK IM Module
66Summary(ja):    SCIM Bridge GTK IM モジュール
67Group:          System Environment/Libraries
68Requires:       %{name} = %{version}-%{release}
69Requires:       gtk2 >= 2.14.0
70Requires(post): gtk2 >= 2.14.0
71Requires(postun): gtk2 >= 2.14.0
72Obsoletes:      %{name} <= 0.1.7
73
74%description gtk
75This package provides the SCIM Bridge GTK IM module.
76
77%description -l ja gtk
78このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
79
80%if !%{without qt3}
81%package qt
82Summary:        SCIM Bridge Qt IM Module
83Summary(ja):    SCIM Bridge Qt IM モジュール
84Group:          System Environment/Libraries
85Requires:       %{name} = %{version}-%{release}
86Requires:       qt = %{_qt3_version}
87BuildRequires:  qt-devel
88
89%description qt
90This package provides the SCIM Bridge Qt IM module.
91
92%description -l ja qt
93このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
94%endif
95
96%if !%{without qt4}
97%package qt4
98Summary:        SCIM Bridge Qt4 IM Module
99Summary(ja):    SCIM Bridge Qt4 IM モジュール
100Group:          System Environment/Libraries
101Requires:       %{name} = %{version}-%{release}
102Requires:       qt4 = %{_qt4_version}
103BuildRequires:  qt4-devel
104
105%description qt4
106This package provides the SCIM Bridge Qt4 IM module.
107
108%description -l ja qt4
109このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
110%endif
111
112## to build compat32 for x86_64 architecture support
113%package -n compat32-%{name}-gtk
114Summary:        SCIM Bridge GTK IM Module
115Summary(ja):    SCIM Bridge GTK IM モジュール
116Group:          System Environment/Libraries
117Requires:       %{name} = %{version}-%{release}
118Requires:       gtk2 >= 2.14.0
119Requires(post): gtk2 >= 2.14.0
120Requires(postun): gtk2 >= 2.14.0
121
122%description -n compat32-%{name}-gtk
123This package provides the SCIM Bridge GTK IM module.
124
125%description -l ja -n compat32-%{name}-gtk
126このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
127
128%if !%{without qt3}
129%package -n compat32-%{name}-qt
130Summary:        SCIM Bridge Qt IM Module
131Summary(ja):    SCIM Bridge Qt IM モジュール
132Group:          System Environment/Libraries
133Requires:       %{name} = %{version}-%{release}
134Requires:       qt = %{_qt3_version}
135BuildRequires:  qt-devel
136
137%description -n compat32-%{name}-qt
138This package provides the SCIM Bridge Qt IM module.
139
140%description -l ja -n compat32-%{name}-qt
141このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
142%endif
143
144%if !%{without qt4}
145%package -n compat32-%{name}-qt4
146Summary:        SCIM Bridge Qt4 IM Module
147Summary(ja):    SCIM Bridge Qt4 IM モジュール
148Group:          System Environment/Libraries
149Requires:       %{name} = %{version}-%{release}
150Requires:       qt4 = %{_qt4_version}
151BuildRequires:  qt4-devel
152
153%description -n compat32-%{name}-qt4
154This package provides the SCIM Bridge Qt4 IM module.
155
156%description -l ja -n compat32-%{name}-qt4
157このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
158%endif
159
160
161
162%prep
163%setup -q
164%patch0 -p1 -b .0-fix-gdm
165%patch1 -p1
166%patch2 -p1
167%patch3
168%patch4 -p1
169%patch5 -p1
170pushd client-gtk
171%patch6 -p0
172popd
173%patch7 -p1
174
175%build
176%if !%{without qt3}
177export QT3_PREFIX=%{_qt3_prefix}
178%endif
179%if !%{without qt4}
180export QT4_PREFIX=%{_qt4_prefix}
181%endif
182
183%configure --disable-static \
184%if %{without qt3}
185        --disable-qt3-immodule \
186%else
187        --enable-qt3-immodule \
188%endif
189%if %{without qt4}
190        --disable-qt4-immodule \
191%else
192        --enable-qt4-immodule \
193%endif
194        --enable-gtk2-immodule
195
196%__make %{?_smp_mflags}
197
198%install
199%__rm -rf %{buildroot}
200#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
201%__make DESTDIR=%{buildroot} install
202
203# remove unneeded files
204%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
205%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
206%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
207
208%clean
209%__rm -rf %{buildroot}
210
211%post gtk
212%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
213
214%postun gtk
215%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
216
217%post -n compat32-%{name}-gtk
218%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
219
220%postun -n compat32-%{name}-gtk
221%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
222
223%files
224%defattr(-,root,root)
225%doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
226%{_bindir}/scim-bridge
227
228%files gtk
229%defattr(-,root,root)
230%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
231
232%if !%{without qt3}
233%files qt
234%defattr(-,root,root)
235%{_qt3_plugindir}/inputmethods/*.so
236%endif
237
238%if !%{without qt4}
239%files qt4
240%defattr(-,root,root)
241%{_qt4_plugindir}/inputmethods/*.so
242%endif
243
244## to build compat32 for x86_64 architecture support
245%if %{build_compat32}
246%files -n compat32-%{name}-gtk
247%defattr(-,root,root)
248%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
249
250%if !%{without qt3}
251%files -n compat32-%{name}-qt
252%defattr(-,root,root)
253%{_qt3_plugindir}/inputmethods/*.so
254%endif
255
256%if !%{without qt4}
257%files -n compat32-%{name}-qt4
258%defattr(-,root,root)
259%{_qt4_plugindir}/inputmethods/*.so
260%endif
261%endif
262
263
264%changelog
265* Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
266- added compat32-* packages for x86_64 architecture support
267
268* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
269- rebuilt with qt4-4.6.3
270
271* Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
272- used %{?_smp_mflags} macro on build
273- deleted in unused log in changelog
274  - Patch8 was none, forgot to delete...
275
276* Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
277- added Patch6,7 from Fedora development
278  - to fix Text input in firefox becomes increasingly sluggish (Patch6)
279  - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
280- added configure --disable-static option
281
282* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
283- updated Qt version detection macros to build properly
284
285* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
286- rebuilt with qt4-4.6.1
287
288* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
289- rebuilt with qt4-4.5.3
290
291* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
292- cleaned up spec
293- renumbered patch
294- added Patch5 from Fedora
295
296* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
297- rebuild with qt4-4.5.2
298
299* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
300- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
301
302* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
303- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
304
305* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
306- new upstream release
307- dropt Pacth3,4,5 (these patches are merged)
308
309* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
310- spec in UTF-8
311- fixed description in scim-bridge-qt4
312- added patch6,7 (import Fedora, Mandriva patches)
313
314* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
315- new upstream release
316- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
317
318* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
319- rebuild with qt4-4.4.2
320
321* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
322- add qt4 immodule
323  - build gtk,qt3,qt4 immodule by default
324
325* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
326- rebuild with gtk+-2.14
327
328* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
329- new upstream release
330- apply new versioning policy
331
332* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
333- drop unnecessary BuildRequires for qt3-immodule package
334- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
335
336* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
337- new upstream release
338- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
339- update BuildRequires
340  - drop doxygen
341  - add XOrg-gl-devel for building qt3-immodule
342  - move libmng-devel for building qt3-immodule
343
344* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
345- rebuild for Vine Linux 4.2.
346
347* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
348- add patch0 to fix symbol lookup error with qt3.
349
350* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
351- rebuild for Vine Linux 4.2.
352
353* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
354- new upstrm release
355- detect qt version at build time.
356- add --disable-qt4-immodule configure option.
357- add BuildRequires libmng-devel.
358
359* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
360- rebuild with libstdc++34
361
362* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
363- new upstream release
364
365* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
366- change License to GPL/LGPL
367- add doc/LICENSE.* as documents
368
369* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
370- new upstream release
371- add BuildRequires: doxygen, qt-devel
372- add new sub-packages:
373  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
374  - qt:  Qt IM module
375
376* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
377- new upstream release
378- add documents
379- running gtk-query-immodules-2.0 in post and postun scripts
380- add PreReq: gtk2 > 2.2
381
382* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
383- new upstream release
384
385* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
386- initial release
387
Note: See TracBrowser for help on using the repository browser.