source: projects/specs/trunk/s/scim-bridge/scim-bridge-vl.spec @ 10553

Revision 10553, 12.3 KB checked in by tomop, 8 years ago (diff)

scim-bridge-0.4.16-19

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define name scim-bridge
4%define version 0.4.16
5%define release 19%{?_dist_release}
6
7%define qt3_ver 3.3.8
8%define qt4_ver 4.8.6
9
10# build qt3 immodule ("--without qt3" to disable qt3)
11%bcond_without qt3
12%define _qt3_version 3.3.8
13%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
14%define _qt3_plugindir %{_qt3_prefix}/plugins
15
16# build qt4 immodule ("--without qt4" to disable qt4)
17%bcond_without qt4
18# Qt4 version auto-detection -- inagaki
19%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
20%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
21%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
22
23
24Summary: yet another IM client of SCIM
25Summary(ja): もう一つ別の SCIM IM クライアント
26Name: %{name}
27Version: %{version}
28Release: %{release}
29
30Group: System Environment/Libraries
31License: GPL/LGPL
32URL: http://www.scim-im.org/projects/scim_bridge
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37Source0: http://jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
38
39# Patch from Fedora 10
40Patch0: scim-bridge-0.4.15-fix-gdm.patch
41Patch1: scim-bridge-0.4.15-bz461373.patch
42
43# Patch from Mandriva 2009
44Patch2: bug-351920-should-return-retval.patch
45Patch3: scim-bridge-0.4.15.2-linkage.patch
46
47# Patch from Fedora development
48Patch4: scim-bridge-0.4.15-EOF.patch
49Patch5: scim-bridge-0.4.15-hotkey-help.patch
50Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
51Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
52
53Patch100: scim-bridge-0.4.16-header.patch
54
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56BuildRequires: scim-devel >= 1.4
57BuildRequires: pkgconfig >= 0.9.0
58BuildRequires: gtk2-devel >= 2.14.0
59
60Requires: scim >= 1.4
61
62%description
63Scim-bridge is yet another IM client of SCIM.
64The im-module of scim-bridge communicates with scim via socket.
65
66%description -l ja
67scim-bridge は、もう一つ別の SCIM IM クライアントです。
68scim-bridge の im-module はソケット経由で SCIM と通信します。
69
70%package gtk
71Summary:        SCIM Bridge GTK IM Module
72Summary(ja):    SCIM Bridge GTK IM モジュール
73Group:          System Environment/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       gtk2 >= 2.14.0
76Requires(post): gtk2 >= 2.14.0
77Requires(postun): gtk2 >= 2.14.0
78Obsoletes:      %{name} <= 0.1.7
79
80%description gtk
81This package provides the SCIM Bridge GTK IM module.
82
83%description -l ja gtk
84このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
85
86%if !%{without qt3}
87%package qt
88Summary:        SCIM Bridge Qt IM Module
89Summary(ja):    SCIM Bridge Qt IM モジュール
90Group:          System Environment/Libraries
91Requires:       %{name} = %{version}-%{release}
92Requires:       qt = %{_qt3_version}
93BuildRequires:  qt-devel
94BuildRequires:  libXmu-devel
95
96%description qt
97This package provides the SCIM Bridge Qt IM module.
98
99%description -l ja qt
100このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
101%endif
102
103%if !%{without qt4}
104%package qt4
105Summary:        SCIM Bridge Qt4 IM Module
106Summary(ja):    SCIM Bridge Qt4 IM モジュール
107Group:          System Environment/Libraries
108Requires:       %{name} = %{version}-%{release}
109Requires:       qt4 >= %{_qt4_version}
110BuildRequires:  qt4-devel
111
112%description qt4
113This package provides the SCIM Bridge Qt4 IM module.
114
115%description -l ja qt4
116このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
117%endif
118
119## to build compat32 for x86_64 architecture support
120%package -n compat32-%{name}-gtk
121Summary:        SCIM Bridge GTK IM Module
122Summary(ja):    SCIM Bridge GTK IM モジュール
123Group:          System Environment/Libraries
124Requires:       %{name} = %{version}-%{release}
125Requires:       compat32-gtk2 >= 2.14.0
126Requires(post): gtk2 >= 2.14.0
127Requires(postun): gtk2 >= 2.14.0
128
129%description -n compat32-%{name}-gtk
130This package provides the SCIM Bridge GTK IM module.
131
132%description -l ja -n compat32-%{name}-gtk
133このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
134
135%if !%{without qt3}
136%package -n compat32-%{name}-qt
137Summary:        SCIM Bridge Qt IM Module
138Summary(ja):    SCIM Bridge Qt IM モジュール
139Group:          System Environment/Libraries
140Requires:       %{name} = %{version}-%{release}
141Requires:       compat32-qt >= %{_qt3_version}
142BuildRequires:  qt-devel
143
144%description -n compat32-%{name}-qt
145This package provides the SCIM Bridge Qt IM module.
146
147%description -l ja -n compat32-%{name}-qt
148このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
149%endif
150
151%if !%{without qt4}
152%package -n compat32-%{name}-qt4
153Summary:        SCIM Bridge Qt4 IM Module
154Summary(ja):    SCIM Bridge Qt4 IM モジュール
155Group:          System Environment/Libraries
156Requires:       %{name} = %{version}-%{release}
157Requires:       compat32-qt4 >= %{_qt4_version}
158BuildRequires:  qt4-devel
159
160%description -n compat32-%{name}-qt4
161This package provides the SCIM Bridge Qt4 IM module.
162
163%description -l ja -n compat32-%{name}-qt4
164このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
165%endif
166
167
168%prep
169%setup -q
170%patch0 -p1 -b .0-fix-gdm
171%patch1 -p1
172%patch2 -p1
173%patch3
174%patch4 -p1
175%patch5 -p1
176pushd client-gtk
177%patch6 -p0
178popd
179%patch7 -p1
180
181%patch100 -p1
182
183%build
184%if !%{without qt3}
185export QT3_PREFIX=%{_qt3_prefix}
186%endif
187%if !%{without qt4}
188export QT4_PREFIX=%{_qt4_prefix}
189%endif
190
191%configure --disable-static \
192%if %{without qt3}
193        --disable-qt3-immodule \
194%else
195        --enable-qt3-immodule \
196%endif
197%if %{without qt4}
198        --disable-qt4-immodule \
199%else
200        --enable-qt4-immodule \
201%endif
202        --enable-gtk2-immodule
203
204%__make %{?_smp_mflags}
205
206%install
207%__rm -rf %{buildroot}
208#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
209%__make DESTDIR=%{buildroot} install
210
211# remove unneeded files
212%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
213%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
214%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
215
216%clean
217%__rm -rf %{buildroot}
218
219%post gtk
220%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
221
222%postun gtk
223%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
224
225%post -n compat32-%{name}-gtk
226%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
227
228%postun -n compat32-%{name}-gtk
229%{_bindir}/gtk-query-immodules-2.0-32 > %{_sysconfdir}/gtk-2.0/i386/gtk.immodules
230
231%files
232%defattr(-,root,root)
233%license COPYING doc/LICENSE*
234%doc AUTHORS ChangeLog NEWS README
235%{_bindir}/scim-bridge
236
237%files gtk
238%defattr(-,root,root)
239%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
240
241%if !%{without qt3}
242%files qt
243%defattr(-,root,root)
244%{_qt3_plugindir}/inputmethods/*.so
245%endif
246
247%if !%{without qt4}
248%files qt4
249%defattr(-,root,root)
250%{_qt4_plugindir}/inputmethods/*.so
251%endif
252
253## to build compat32 for x86_64 architecture support
254%if %{build_compat32}
255%files -n compat32-%{name}-gtk
256%defattr(-,root,root)
257%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
258
259%if !%{without qt3}
260%files -n compat32-%{name}-qt
261%defattr(-,root,root)
262%{_qt3_plugindir}/inputmethods/*.so
263%endif
264
265%if !%{without qt4}
266%files -n compat32-%{name}-qt4
267%defattr(-,root,root)
268%{_qt4_plugindir}/inputmethods/*.so
269%endif
270%endif
271
272
273%changelog
274* Fri Jul  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.16-19
275- rebuilt with new toolchain.
276
277* Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.16-18
278- fixed compat32 Requires
279
280* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-17
281- rebuild with VineSeed environment
282- add Patch100 (scim-bridge-0.4.16-header.patch)
283
284* Tue Jan 10 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-16
285- rebuilt with qt4-4.8.0
286
287* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-15
288- rebuilt with qt4-4.7.2
289
290* Sat Feb  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-14
291- added BR: libXmu-devel to qt package
292
293* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-13
294- rebuilt with qt4-4.7.1
295
296* Sat Oct 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.16-12
297- added compat32-* packages for x86_64 architecture support
298
299* Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
300- rebuilt with qt4-4.6.3
301
302* Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
303- used %{?_smp_mflags} macro on build
304- deleted in unused log in changelog
305  - Patch8 was none, forgot to delete...
306
307* Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
308- added Patch6,7 from Fedora development
309  - to fix Text input in firefox becomes increasingly sluggish (Patch6)
310  - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
311- added configure --disable-static option
312
313* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
314- updated Qt version detection macros to build properly
315
316* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
317- rebuilt with qt4-4.6.1
318
319* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
320- rebuilt with qt4-4.5.3
321
322* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
323- cleaned up spec
324- renumbered patch
325- added Patch5 from Fedora
326
327* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
328- rebuild with qt4-4.5.2
329
330* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
331- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
332
333* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
334- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
335
336* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
337- new upstream release
338- dropt Pacth3,4,5 (these patches are merged)
339
340* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
341- spec in UTF-8
342- fixed description in scim-bridge-qt4
343- added patch6,7 (import Fedora, Mandriva patches)
344
345* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
346- new upstream release
347- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
348
349* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
350- rebuild with qt4-4.4.2
351
352* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
353- add qt4 immodule
354  - build gtk,qt3,qt4 immodule by default
355
356* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
357- rebuild with gtk+-2.14
358
359* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
360- new upstream release
361- apply new versioning policy
362
363* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
364- drop unnecessary BuildRequires for qt3-immodule package
365- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
366
367* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
368- new upstream release
369- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
370- update BuildRequires
371  - drop doxygen
372  - add XOrg-gl-devel for building qt3-immodule
373  - move libmng-devel for building qt3-immodule
374
375* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
376- rebuild for Vine Linux 4.2.
377
378* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
379- add patch0 to fix symbol lookup error with qt3.
380
381* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
382- rebuild for Vine Linux 4.2.
383
384* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
385- new upstrm release
386- detect qt version at build time.
387- add --disable-qt4-immodule configure option.
388- add BuildRequires libmng-devel.
389
390* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
391- rebuild with libstdc++34
392
393* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
394- new upstream release
395
396* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
397- change License to GPL/LGPL
398- add doc/LICENSE.* as documents
399
400* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
401- new upstream release
402- add BuildRequires: doxygen, qt-devel
403- add new sub-packages:
404  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
405  - qt:  Qt IM module
406
407* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
408- new upstream release
409- add documents
410- running gtk-query-immodules-2.0 in post and postun scripts
411- add PreReq: gtk2 > 2.2
412
413* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
414- new upstream release
415
416* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
417- initial release
418
Note: See TracBrowser for help on using the repository browser.