source: projects/specs/trunk/s/scim-bridge/scim-bridge-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name scim-bridge
2%define version 0.4.16
3%define release 7%{?_dist_release}
4
5# build qt3 immodule ("--without qt3" to disable qt3)
6%bcond_without qt3
7%define qt3ver %(rpm -q --queryformat '%%{version}' qt)
8%define qt3rel %(rpm -q --queryformat '%%{release}' qt)
9%define qt3dir %{_libdir}/qt-%{qt3ver}
10
11# build qt4 immodule ("--without qt4" to disable qt4)
12%bcond_without qt4
13%define qt4ver %(rpm -q --queryformat '%%{version}' qt4)
14%define qt4rel %(rpm -q --queryformat '%%{release}' qt4)
15%define _qt4_prefix %(pkg-config --variable prefix Qt)
16%define _qt4_plugindir %(pkg-config --variable plugindir Qt)
17
18Summary: yet another IM client of SCIM
19Summary(ja): もう一つ別の SCIM IM クライアント
20Name: %{name}
21Version: %{version}
22Release: %{release}
23Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
24
25# Patch from Fedora 10
26Patch0: scim-bridge-0.4.15-fix-gdm.patch
27Patch1: scim-bridge-0.4.15-bz461373.patch
28
29# Patch from Mandriva 2009
30Patch2: bug-351920-should-return-retval.patch
31Patch3: scim-bridge-0.4.15.2-linkage.patch
32
33# Patch from Fedora development
34Patch4: scim-bridge-0.4.15-EOF.patch
35
36Patch5: scim-bridge-0.4.15-hotkey-help.patch
37
38Url: http://www.scim-im.org/projects/scim_bridge
39License: GPL/LGPL
40Group: System Environment/Libraries
41BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
42Prefix: %{_prefix}
43Requires: scim >= 1.4
44BuildRequires: scim-devel >= 1.4 pkgconfig >= 0.9.0, gtk2-devel >= 2.14.0
45
46%description
47Scim-bridge is yet another IM client of SCIM.
48The im-module of scim-bridge communicates with scim via socket.
49
50%description -l ja
51scim-bridge は、もう一つ別の SCIM IM クライアントです。
52scim-bridge の im-module はソケット経由で SCIM と通信します。
53
54%package gtk
55Summary:        SCIM Bridge GTK IM Module
56Summary(ja):    SCIM Bridge GTK IM モジュール
57Group:          System Environment/Libraries
58Requires:       %{name} = %{version}-%{release}
59Requires:       gtk2 >= 2.14.0
60PreReq:         gtk2 >= 2.14.0
61Obsoletes:      %{name} <= 0.1.7
62
63%description gtk
64This package provides the SCIM Bridge GTK IM module.
65
66%description -l ja gtk
67このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
68
69%if !%{without qt3}
70%package qt
71Summary:        SCIM Bridge Qt IM Module
72Summary(ja):    SCIM Bridge Qt IM モジュール
73Group:          System Environment/Libraries
74Requires:       %{name} = %{version}-%{release}
75#Requires:       qt = %{qt3ver}-%{qt3rel}
76Requires:       qt = %{qt3ver}
77BuildRequires:  qt-devel >= %{qt3ver}-%{qt3rel}
78
79%description qt
80This package provides the SCIM Bridge Qt IM module.
81
82%description -l ja qt
83このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
84%endif
85
86%if !%{without qt4}
87%package qt4
88Summary:        SCIM Bridge Qt4 IM Module
89Summary(ja):    SCIM Bridge Qt4 IM モジュール
90Group:          System Environment/Libraries
91Requires:       %{name} = %{version}-%{release}
92#Requires:       qt4 = %{qt4ver}-%{qt4rel}
93Requires:       qt4 = %{qt4ver}
94BuildRequires:  qt4-devel >= %{qt4ver}-%{qt4rel}
95
96%description qt4
97This package provides the SCIM Bridge Qt4 IM module.
98
99%description -l ja qt4
100このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
101%endif
102
103%prep
104%setup -q
105%patch0 -p1 -b .0-fix-gdm
106%patch1 -p1
107%patch2 -p1
108%patch3
109%patch4 -p1
110%patch5 -p1
111
112%build
113%if !%{without qt3}
114export QT3_PREFIX=%{qt3dir}
115%endif
116%if !%{without qt4}
117export QT4_PREFIX=%{_qt4_prefix}
118%endif
119
120%configure \
121%if %{without qt3}
122        --disable-qt3-immodule \
123%else
124        --enable-qt3-immodule \
125%endif
126%if %{without qt4}
127        --disable-qt4-immodule \
128%else
129        --enable-qt4-immodule \
130%endif
131        --enable-gtk2-immodule
132
133%__make
134
135%install
136%__rm -rf %{buildroot}
137#%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
138%__make DESTDIR=%{buildroot} install
139
140# remove unneeded files
141%__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
142%__rm -f %{buildroot}%{qt3dir}/plugins/inputmethods/*.{a,la}
143%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
144
145%clean
146%__rm -rf %{buildroot}
147
148%post gtk
149%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
150
151%postun gtk
152%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
153
154%files
155%defattr(-,root,root)
156%doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
157%{_bindir}/scim-bridge
158
159%files gtk
160%defattr(-,root,root)
161%{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
162
163%if !%{without qt3}
164%files qt
165%defattr(-,root,root)
166%{qt3dir}/plugins/inputmethods/*.so
167%endif
168
169%if !%{without qt4}
170%files qt4
171%defattr(-,root,root)
172%{_qt4_plugindir}/inputmethods/*.so
173%endif
174
175%changelog
176* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
177- rebuilt with qt4-4.6.1
178
179* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
180- rebuilt with qt4-4.5.3
181
182* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
183- cleaned up spec
184- renumbered patch
185- added Patch5 from Fedora
186
187* Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
188- rebuild with qt4-4.5.2
189
190* Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
191- dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
192
193* Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
194- rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
195
196* Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
197- new upstream release
198- dropt Pacth3,4,5 (these patches are merged)
199
200* Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
201- spec in UTF-8
202- fixed description in scim-bridge-qt4
203- added patch6,7 (import Fedora, Mandriva patches)
204
205* Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
206- new upstream release
207- added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
208
209* Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
210- rebuild with qt4-4.4.2
211
212* Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
213- add qt4 immodule
214  - build gtk,qt3,qt4 immodule by default
215
216* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
217- rebuild with gtk+-2.14
218
219* Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
220- new upstream release
221- apply new versioning policy
222
223* Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
224- drop unnecessary BuildRequires for qt3-immodule package
225- fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
226
227* Wed Jan  9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
228- new upstream release
229- drop unnecessary Qt fix patch ( Patch0 ): upstream merged
230- update BuildRequires
231  - drop doxygen
232  - add XOrg-gl-devel for building qt3-immodule
233  - move libmng-devel for building qt3-immodule
234
235* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
236- rebuild for Vine Linux 4.2.
237
238* Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
239- add patch0 to fix symbol lookup error with qt3.
240
241* Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
242- rebuild for Vine Linux 4.2.
243
244* Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
245- new upstrm release
246- detect qt version at build time.
247- add --disable-qt4-immodule configure option.
248- add BuildRequires libmng-devel.
249
250* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
251- rebuild with libstdc++34
252
253* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
254- new upstream release
255
256* Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
257- change License to GPL/LGPL
258- add doc/LICENSE.* as documents
259
260* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
261- new upstream release
262- add BuildRequires: doxygen, qt-devel
263- add new sub-packages:
264  - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
265  - qt:  Qt IM module
266
267* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
268- new upstream release
269- add documents
270- running gtk-query-immodules-2.0 in post and postun scripts
271- add PreReq: gtk2 > 2.2
272
273* Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
274- new upstream release
275
276* Thu Apr  6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
277- initial release
278
Note: See TracBrowser for help on using the repository browser.