source: projects/specs/trunk/s/scilab/scilab-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The open source platform for numerical computation
2Summary(ja): オープンソースの数値計算システム
3Name: scilab
4Version: 4.1.2
5Release: 2%{?_dist_release}
6License: INRIA
7Group: Applications/Engineering
8URL: http://scilabsoft.inria.fr/
9
10Source: http://scilabsoft.inria.fr/download/stable/scilab-%{version}-src.tar.gz
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires: tcl tk perl Xaw3d-devel libpng-devel
14BuildRequires: gtkhtml2-devel gtk2-devel
15BuildRequires: libxslt vte-devel readline-devel
16BuildRequires: gcc-c++
17%if %{?_dist_release}!="vl4"
18BuildRequires: gcc-gfortran
19%else
20BuildRequires: gcc-g77
21%endif
22BuildRequires: pkgconfig
23
24%description
25Scilab a numerical computation system similiar to matlab or simulink. Scilab
26includes hundreds of mathematical functions, and programs from various
27languages (such as C or Fortran) can be added interactively. It has
28sophisticated data structures (including lists, polynomials, rational
29functions, and linear systems), an interpreter, and a high-level programming
30language. Scilab has been designed to be an open system where the user can
31define new data types and operations on these data types by using
32overloading. A number of toolboxes are available with the system.
33
34%prep
35%setup -q
36
37%build
38perl -pi.orig -e 's|-fwritable-strings||g;' configure
39%configure \
40        --with-gcc \
41        --with-gfortran \
42        --with-gnu \
43        --with-gtk2 \
44        --with-x \
45        --without-java \
46        --with-tcl-library="%{_libdir}"
47# ../include/pvmtev.h nodig in pvm3/src/global.h
48(echo '#include "../include/pvmtev.h"'; cat pvm3/src/global.h) > pvm3/src/global.h.temp
49mv pvm3/src/global.h.temp pvm3/src/global.h
50#make %{?_smp_mflags} all
51make all
52
53%install
54rm -rf %{buildroot}
55install -d %{buildroot}%{_libdir} \
56        %{buildroot}%{_bindir}
57perl -pi.orig -e '
58        s|/usr/bin|%{buildroot}%{_bindir}|g;
59        s|ln -fs \$\(PREFIX\)/lib|ln -fs %{_libdir}|g;
60        ' Makefile
61
62perl -pi -e '
63        s|/bin/sh5|/bin/sh|g;
64        ' bin/dold
65
66%makeinstall PREFIX=%{buildroot}%{_prefix} LIBPREFIX=%{buildroot}%{_libdir}
67
68perl -pi -e '
69        s|%{buildroot}||g;
70        ' %{buildroot}%{_libdir}/scilab-%{version}/bin/* \
71        config/configuration \
72        util/Blatdoc* Makefile* Path.incl
73
74
75%clean
76rm -rf %{buildroot}
77
78%files
79%doc ACKNOWLEDGEMENTS CHANGES README_Unix Version.incl licence.txt
80%defattr(-, root, root, 0755)
81%{_bindir}/*
82#%{_libdir}/scilab-%{version}/
83#%exclude %{_libdir}/scilab-%{version}/examples/mex-examples/mexglx
84%{_prefix}/lib/scilab-%{version}/
85%exclude %{_prefix}/lib/scilab-%{version}/examples/mex-examples/mexglx
86
87%changelog
88* Tue Jul 14 2009 Shu KONNO <owa@bg.wakwak.com> 4.1.2-2
89- fix %%files: %%{_libdir}/scilab... to %%{_prefix}/lib/scilab...
90
91* Tue Apr 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
92- applied new versioning policy
93- updated to 4.1.2
94
95* Sun Jun 03 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.1.1-0vl2
96- don't use smp_mflags on compilation
97
98* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.1-0vl1
99- new upstream release
100- rebuilt with gfortran
101
102* Thu Jul 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-2vl3
103- rebuilt with Xaw3d-1.5-17vl3
104
105* Wed Apr 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-2vl2
106- rebuilt with readline 5.1
107
108* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.1-2vl1
109- update to 3.1.1 based on DAG packages
110  (http://dag.wieers.com/packages/scilab/)
111  * Mon Aug 01 2005 Dries Verachtert <dries@ulyssis.org> - 3.1.1-2 - 3450/dries
112  - Rebuild.
113  * Thu Jun 09 2005 Dries Verachtert <dries@ulyssis.org> - 3.1.1-1
114  - Update to release 3.1.1.
115  * Wed Jul 14 2004 Dries Verachtert <dries@ulyssis.org> - 3.0-1
116  - Initial package.
117
118* Fri May  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-0vl1
119- update to 2.7
120- dropped scilab-2.6-ppc.patch
121
122* Fri Mar 22 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6-0vl2
123- removed obsolete ppc patch
124
125* Sun Mar  3 2002 Jun Nishii <jun@vinelinux.org> 2.6-0v1
126- ver.up
127
128* Wed Sep 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
129- 2.4.1-4vl2
130- added a patch for ppc archtecture
131
132* Wed Aug 18 1999 Tim Powers <timp@redhat.com>
133- exludearch alpha
134
135* Wed Jul 21 1999 Tim Powers <timp@redhat.com>
136- rebuilt for 6.1
137
138* Wed May 12 1999 Bill Nottingham <notting@redhat.com>
139- clean up dependencies
140
141* Wed May 05 1999 Bill Nottingham <notting@redhat.com>
142- update to 2.4.1
143
144* Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
145- Upgrade to 2.4.
146
147* Thu Oct 22 1998 Jeff Johnson <jbj@redhat.com>
148- Fixes to permit compile on alpha.
149- Eliminate lurking dependencies on /bin/sh5 and SCILABGS.
150- Modify default value of SCI variable to be correct for users.
151- Add /usr/bin/scilab symlink.
152
153* Sat Jul 11 1998 Jeff Johnson <jbj@redhat.com>
154- Create powertools package.
Note: See TracBrowser for help on using the repository browser.