source: projects/specs/trunk/s/sbcl/sbcl-vl.spec @ 10382

Revision 10382, 2.3 KB checked in by ara_t, 8 years ago (diff)

update to 1.3.6

Line 
1%define pkg_name    sbcl
2%define pkg_version 1.3.6
3%define pkg_release 1%{?_dist_release}
4
5%define sbcl 1
6
7Summary: Steel Bank Common Lisp
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License: A mixture of BSD-style and public domain
13Group:   Applications/Languages
14URL:     http://www.sbcl.org/
15SOURCE:  sbcl-%{version}-source.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19%if !%{sbcl}
20BuildRequires: clisp
21%else
22BuildRequires: sbcl
23%endif
24
25BuildRequires: texinfo
26BuildRequires: texlive-common
27%if %{?_dist_release} == "vl6"
28BuildRequires: texlive-collection-texinfo
29%else
30BuildRequires: texlive-collection-plainextra
31BuildRequires: texlive-collection-fontsrecommended
32%endif
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: ara_t
37
38
39%description
40Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
41It is open source / free software, with a permissive license.
42In addition to the compiler and runtime system for ANSI Common Lisp,
43it provides an interactive environment including a debugger,
44a statistical profiler, a code coverage tool, and many other extensions.
45
46
47%prep
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%setup -q
50
51%build
52%if !%{sbcl}
53sh make.sh "clisp" --prefix=%{_usr}
54%else
55sh make.sh --prefix=%{_usr}
56%endif
57
58cd doc/manual
59%{__make} pdf html info
60
61%install
62export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
63sh install.sh
64
65%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
66%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
67        ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
68
69%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
70        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
71
72%post
73for doc in asdf sbcl; do
74    file=%{_infodir}/${doc}.info.gz
75    if [ -e ${file} ]; then
76        /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
77    fi
78done
79
80%preun
81if [ $1 = 0 ]; then
82    for doc in asdf sbcl; do
83        file=%{_infodir}/${doc}.info.gz
84        if [ -e ${file} ]; then
85            /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
86        fi
87    done
88fi
89
90%clean
91%{__rm} -rf ${RPM_BUILD_ROOT}
92
93
94%files
95%defattr(-, root, root)
96%{_bindir}/
97/usr/lib/sbcl/
98%{_docdir}/sbcl-%{version}
99%{_infodir}/
100%{_mandir}/man1/
101
102
103%changelog
104* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.6-1
105- update to 1.3.6
106- make PDF files for VineSeed
107
108* Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
109- new package
Note: See TracBrowser for help on using the repository browser.