source: projects/specs/trunk/s/sbcl/sbcl-vl.spec @ 10186

Revision 10186, 2.0 KB checked in by ara_t, 8 years ago (diff)
Line 
1%define pkg_name    sbcl
2%define pkg_version 1.3.4
3%define pkg_release 1%{?_dist_release}
4
5Summary: Steel Bank Common Lisp
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: A mixture of BSD-style and public domain
11Group:   Applications/Languages
12URL:     http://www.sbcl.org/
13SOURCE:  sbcl-%{version}-source.tar.bz2
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: clisp
17BuildRequires: texinfo
18%if %{?_dist_release} == "vl6"
19BuildRequires: texlive-common
20BuildRequires: texlive-collection-texinfo
21%endif
22
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: ara_t
27
28
29%description
30Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
31It is open source / free software, with a permissive license.
32In addition to the compiler and runtime system for ANSI Common Lisp,
33it provides an interactive environment including a debugger,
34a statistical profiler, a code coverage tool, and many other extensions.
35
36
37%prep
38%{__rm} -rf ${RPM_BUILD_ROOT}
39%setup -q
40
41%build
42sh make.sh "clisp" --prefix=%{_usr}
43
44cd doc/manual
45%{__make} html info
46%if %{?_dist_release} == "vl6"
47%{__make} pdf
48%endif
49
50%install
51export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
52sh install.sh
53
54%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
55%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
56        ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
57
58%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
59        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
60
61%post
62for doc in asdf sbcl; do
63    file=%{_infodir}/${doc}.info.gz
64    if [ -e ${file} ]; then
65        /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
66    fi
67done
68
69%preun
70if [ $1 = 0 ]; then
71    for doc in asdf sbcl; do
72        file=%{_infodir}/${doc}.info.gz
73        if [ -e ${file} ]; then
74            /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
75        fi
76    done
77fi
78
79%clean
80%{__rm} -rf ${RPM_BUILD_ROOT}
81
82
83%files
84%defattr(-, root, root)
85%{_bindir}/
86/usr/lib/sbcl/
87%{_docdir}/sbcl-%{version}
88%{_infodir}/
89%{_mandir}/man1/
90
91
92%changelog
93* Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
94- new package
Note: See TracBrowser for help on using the repository browser.