source: projects/specs/trunk/s/sbcl/sbcl-vl.spec @ 11963

Revision 11963, 3.8 KB checked in by ara_t, 5 years ago (diff)

sbcl: update to 1.4.14

RevLine 
[10186]1%define pkg_name    sbcl
[11963]2%define pkg_version 1.4.14
[10835]3%define pkg_release 1%{?_dist_release}
[10186]4
[10382]5%define sbcl 1
6
[10186]7Summary: Steel Bank Common Lisp
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License: A mixture of BSD-style and public domain
[10806]13Group:   Development/Languages
[10186]14URL:     http://www.sbcl.org/
[10865]15SOURCE:  %{name}-%{version}-source.tar.bz2
[10186]16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
[10382]18
19%if !%{sbcl}
[10186]20BuildRequires: clisp
[10382]21%else
22BuildRequires: sbcl
23%endif
24
[10186]25BuildRequires: texinfo
[10382]26BuildRequires: texlive-common
[11122]27BuildRequires: texlive-collection-plaingeneric
[10382]28BuildRequires: texlive-collection-fontsrecommended
[10186]29
[11687]30
[10186]31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: ara_t
34
35
36%description
37Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
38It is open source / free software, with a permissive license.
39In addition to the compiler and runtime system for ANSI Common Lisp,
40it provides an interactive environment including a debugger,
41a statistical profiler, a code coverage tool, and many other extensions.
42
43
44%prep
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%setup -q
47
48%build
[10382]49%if !%{sbcl}
[10186]50sh make.sh "clisp" --prefix=%{_usr}
[10382]51%else
52sh make.sh --prefix=%{_usr}
53%endif
[10186]54
55cd doc/manual
[10382]56%{__make} pdf html info
[10186]57
58%install
59export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
60sh install.sh
61
62%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
63%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
64        ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
65
66%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
67        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
68
69%post
70for doc in asdf sbcl; do
71    file=%{_infodir}/${doc}.info.gz
72    if [ -e ${file} ]; then
[10744]73        %{_syssbindir}/install-info ${file} %{_infodir}/dir 2>/dev/null
[10186]74    fi
75done
76
77%preun
78if [ $1 = 0 ]; then
79    for doc in asdf sbcl; do
80        file=%{_infodir}/${doc}.info.gz
81        if [ -e ${file} ]; then
[10744]82            %{_syssbindir}/install-info --delete ${file} %{_infodir}/dir \
83             2>/dev/null
[10186]84        fi
85    done
86fi
87
88%clean
89%{__rm} -rf ${RPM_BUILD_ROOT}
90
91
92%files
93%defattr(-, root, root)
94%{_bindir}/
95/usr/lib/sbcl/
96%{_docdir}/sbcl-%{version}
97%{_infodir}/
98%{_mandir}/man1/
99
100
101%changelog
[11963]102* Thu Dec 06 2018 Toshiaki Ara <ara_t@384.jp> 1.4.14-1
103- new upstream release
104
[11687]105* Fri Jun 01 2018 Toshiaki Ara <ara_t@384.jp> 1.4.8-1
106- new upstream release
107
[11220]108* Wed Nov 01 2017 Toshiaki Ara <ara_t@384.jp> 1.4.1-1
109- new upstream release
110
[11194]111* Sun Oct 01 2017 Toshiaki Ara <ara_t@384.jp> 1.4.0-1
112- new upstream release
113
[11154]114* Sat Sep 02 2017 Toshiaki Ara <ara_t@384.jp> 1.3.21-1
115- new upstream release
116
[11687]117* Tue Aug 01 2017 Toshiaki Ara <ara_t@384.jp> 1.3.20-1
[11141]118- new upstream release
119
[11122]120* Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 1.3.19-1
121- new upstream release
122- change to BuildRequires: texlive-collection-plaingeneric
123
[11089]124* Sat Jun 03 2017 Toshiaki Ara <ara_t@384.jp> 1.3.18-1
125- new upstream release
126
[11057]127* Wed May 03 2017 Toshiaki Ara <ara_t@384.jp> 1.3.17-1
128- new upstream release
129
[11025]130* Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 1.3.16-1
131- new upstream release
132
[10870]133* Sat Jan 28 2017 Toshiaki Ara <ara_t@384.jp> 1.3.14-1
134- new upstream release
135
[10865]136* Sat Dec 31 2016 Toshiaki Ara <ara_t@384.jp> 1.3.13-1
137- new upstream release
138
[10835]139* Wed Nov 30 2016 Toshiaki Ara <ara_t@384.jp> 1.3.12-1
140- new upstream release
141
[10806]142* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.3.11-2
143- change Group to Development/Languages
144
[10802]145* Wed Nov 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.11-1
146- update to 1.3.11
147
[10798]148* Sun Oct 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.10-1
149- update to 1.3.10
150
[10756]151* Wed Aug 31 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-1
152- update to 1.3.9
153
[10744]154* Tue Aug 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.8-1
155- update to 1.3.8
156
[10638]157* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 1.3.7-1
158- update to 1.3.7
159
[10382]160* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.6-1
161- update to 1.3.6
162- make PDF files for VineSeed
163
[10186]164* Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
165- new package
Note: See TracBrowser for help on using the repository browser.