source: projects/specs/trunk/s/sbcl/sbcl-vl.spec @ 10870

Revision 10870, 3.0 KB checked in by ara_t, 7 years ago (diff)

sbcl: update to 1.3.14

RevLine 
[10186]1%define pkg_name    sbcl
[10870]2%define pkg_version 1.3.14
[10835]3%define pkg_release 1%{?_dist_release}
[10186]4
[10382]5%define sbcl 1
6
[10186]7Summary: Steel Bank Common Lisp
8Name:    %{pkg_name}
9Version: %{pkg_version}
10Release: %{pkg_release}
11
12License: A mixture of BSD-style and public domain
[10806]13Group:   Development/Languages
[10186]14URL:     http://www.sbcl.org/
[10865]15SOURCE:  %{name}-%{version}-source.tar.bz2
[10186]16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
[10382]18
19%if !%{sbcl}
[10186]20BuildRequires: clisp
[10382]21%else
22BuildRequires: sbcl
23%endif
24
[10186]25BuildRequires: texinfo
[10382]26BuildRequires: texlive-common
[10186]27%if %{?_dist_release} == "vl6"
28BuildRequires: texlive-collection-texinfo
[10382]29%else
30BuildRequires: texlive-collection-plainextra
31BuildRequires: texlive-collection-fontsrecommended
[10186]32%endif
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: ara_t
37
38
39%description
40Steel Bank Common Lisp (SBCL) is a high performance Common Lisp compiler.
41It is open source / free software, with a permissive license.
42In addition to the compiler and runtime system for ANSI Common Lisp,
43it provides an interactive environment including a debugger,
44a statistical profiler, a code coverage tool, and many other extensions.
45
46
47%prep
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%setup -q
50
51%build
[10382]52%if !%{sbcl}
[10186]53sh make.sh "clisp" --prefix=%{_usr}
[10382]54%else
55sh make.sh --prefix=%{_usr}
56%endif
[10186]57
58cd doc/manual
[10382]59%{__make} pdf html info
[10186]60
61%install
62export INSTALL_ROOT=${RPM_BUILD_ROOT}%{_prefix}
63sh install.sh
64
65%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
66%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl/*.html \
67        ${RPM_BUILD_ROOT}%{_docdir}/sbcl/html
68
69%{__mv} ${RPM_BUILD_ROOT}%{_docdir}/sbcl \
70        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
71
72%post
73for doc in asdf sbcl; do
74    file=%{_infodir}/${doc}.info.gz
75    if [ -e ${file} ]; then
[10744]76        %{_syssbindir}/install-info ${file} %{_infodir}/dir 2>/dev/null
[10186]77    fi
78done
79
80%preun
81if [ $1 = 0 ]; then
82    for doc in asdf sbcl; do
83        file=%{_infodir}/${doc}.info.gz
84        if [ -e ${file} ]; then
[10744]85            %{_syssbindir}/install-info --delete ${file} %{_infodir}/dir \
86             2>/dev/null
[10186]87        fi
88    done
89fi
90
91%clean
92%{__rm} -rf ${RPM_BUILD_ROOT}
93
94
95%files
96%defattr(-, root, root)
97%{_bindir}/
98/usr/lib/sbcl/
99%{_docdir}/sbcl-%{version}
100%{_infodir}/
101%{_mandir}/man1/
102
103
104%changelog
[10870]105* Sat Jan 28 2017 Toshiaki Ara <ara_t@384.jp> 1.3.14-1
106- new upstream release
107
[10865]108* Sat Dec 31 2016 Toshiaki Ara <ara_t@384.jp> 1.3.13-1
109- new upstream release
110
[10835]111* Wed Nov 30 2016 Toshiaki Ara <ara_t@384.jp> 1.3.12-1
112- new upstream release
113
[10806]114* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.3.11-2
115- change Group to Development/Languages
116
[10802]117* Wed Nov 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.11-1
118- update to 1.3.11
119
[10798]120* Sun Oct 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.10-1
121- update to 1.3.10
122
[10756]123* Wed Aug 31 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-1
124- update to 1.3.9
125
[10744]126* Tue Aug 02 2016 Toshiaki Ara <ara_t@384.jp> 1.3.8-1
127- update to 1.3.8
128
[10638]129* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 1.3.7-1
130- update to 1.3.7
131
[10382]132* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.3.6-1
133- update to 1.3.6
134- make PDF files for VineSeed
135
[10186]136* Sun Apr 17 2016 Toshiaki Ara <ara_t@384.jp> 1.3.4-1
137- new package
Note: See TracBrowser for help on using the repository browser.