source: projects/specs/trunk/s/sane-clients/sane-clients-vl.spec @ 521

Revision 521, 6.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define sane_ver %(/usr/bin/sane-config --version 2> /dev/null)
2%define gimpdirs %(/bin/ls -d %{_libdir}/gimp/*/plug-ins 2> /dev/null)
3
4Summary:        SANE (Scanner Access Now Easy) clients
5Summary(ja):SANE (Scanner Access Now Easy) クライアント
6Group:          Applications/Multimedia
7Name:           sane-clients
8Version:        1.0.14
9Release:        1%{?_dist_release}
10URL:            http://www.mostang.com/sane/
11Source:         ftp://ftp.mostang.com/pub/sane/sane-frontends-%{version}.tar.gz
12%{?nosrc:NoSource: 0}
13License:        GPL (programs), relaxed LGPL (libraries), and public domain (docs)
14
15BuildPrereq: sane-devel = %{sane_ver}
16BuildPreReq: gtk+ >= 1.2.0
17BuildPreReq: gimp >= 1.1
18Requires: sane = %{sane_ver}
19Requires: gtk+ >= 1.2.0
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21Vendor: Project Vine
22Distribution: Vine Linux
23
24
25%description
26The clients,'xscanimage' and 'xcam', those use the SANE modules.
27
28%description -l ja
29SANE モジュールを使うGUIクライアントxscanimageとxcamを収録しています。
30
31%prep
32%setup -q -n sane-frontends-%{version}
33
34%build
35%configure --datadir=%{_datadir}/sane
36make %{?_smp_mflags}
37
38%install
39rm -rf $RPM_BUILD_ROOT
40%makeinstall datadir=$RPM_BUILD_ROOT%{_datadir}
41
42if (echo "%{gimpdirs}" | grep -q plug-ins) ;then
43        for D in %{gimpdirs} ; do
44                mkdir -p $RPM_BUILD_ROOT${D}
45                %__ln_s -f %{_bindir}/xscanimage $RPM_BUILD_ROOT${D}/xscanimage
46        done
47fi
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52
53%files
54%defattr(-,root,root)
55%{_bindir}/*
56%config %{_datadir}/sane/sane-style.rc
57%{_mandir}/man1/*
58%doc README* AUTHORS COPYING Changelog INSTALL NEWS PROBLEMS
59%{_libdir}/gimp/*/plug-ins/*
60
61
62%changelog
63* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.14-1vl5
64- applied new versioning policy, spec in utf-8
65
66* Mon Dec 24 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.14-0vl1
67- updated sane-frontends to 1.0.14
68- defined macro 'sane_ver' by sane-config
69- s/Copyright/License/
70
71* Fri Oct 25 2002 Tomoya TAKA <taka@vinelinux.org> 1.0.8-0vl1
72- new upstream release
73
74* Wed Apr 4 2002 Masaki Shinomiya <shino@pos.to>
75- 1.0.7-0vl1 for Vine Linux-2.x
76- 1.0.7-0.1
77- symlink for gimp listed in %file section
78- set %_sysconfdir to /etc for RedHat6.x/Vine2.x
79
80* Wed Mar 6 2002 Masaki SHINOMIYA <shino@pos.to>
81- 1.0.7-0
82
83* Sun Dec 23 2001 Masaki SHINOMIYA <shino@pos.to>
84- 1.0.6-0.2: %config sane-style.rc
85
86* Fri Dec 21 2001 Masaki SHINOMIYA <shino@pos.to>
87- 1.0.6-0.1
88- use macros as possible
89- %{_datadir}/sane/sane-style.rc
90
91* Wed Jul 4 2001 Masaki SHINOMIYA <shino@pos.to>
92- 1.0.5
93
94* Wed May 17 2001 Masaki SHINOMIYA <shino@pos.to>
95- 1.0.4
96- sane-clients seperated from sane package
97
98* Wed May 17 2001 Masaki SHINOMIYA <shino@pos.to>
99- 1.0.4 + epson backend ver.20010331
100- 'scanimage' is included in the binary'sane-1.0.4-1.i386.rpm'package.
101- refined script for gimp plug-in setup
102- html documents shall be installed in the directory '/usr/share/sane'
103- automatically make device the file /dev/usb/scanner0
104
105* Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
106- 1.0.3-0vl8
107- included missing "sane-config" script for sane
108
109* Tue Oct 17 2000 Jun Nishii <jun@vinelinux.org>
110- 1.0.3-0vl7
111- merge xscanimage patch
112
113* Mon Oct 16 2000 Jun Nishii <jun@vinelinux.org>
114- 1.0.3-0vl6
115- build with gimp-1.1.27
116
117* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
118- 1.0.3-0vl5
119- fixed group
120
121* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
122- 1.0.3-0vl4
123- added %defattr in clients
124
125* Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org>
126- 1.0.3-0vl3
127- build with gimp-1.1.26
128
129* Mon Sep 25 2000 Jun Nishii <jun@vinelinux.org>
130- 1.0.3-0vl2
131- build with gimp-1.1.25
132
133* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
134- 1.0.3-0vl1
135
136* Thu Jun  8 2000 Jun Nishii <jun@vinelinux.org>
137- 1.0.2-0vl1
138
139* Mon Jan 17 2000 Jun Nishii <jun@vinelinux.org>
140- build for Vine Linux 2.0
141- added find-scanner, xerox
142
143* Fri Apr 23 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
144- Fixed packaging a bit.
145
146* Wed Apr 21 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
147- Updated package to 1.01
148
149* Fri Apr 09 1999 Hugo van der Kooij <hvdkooij@caiw.nl>
150- Split off the clients
151- Fixed a Alpha system anomaly by removing the specific backend.
152
153* Mon Nov 23 1998 Jonathan Miller <jlm@mvhi.com>
154 [1.00-1]
155- upgraded to 1.00 (and made description less space-consuming)
156- included the post 1.00 fixed "configure" script available 22 Nov 1998.
157
158* Sat Aug 08 1998 Arne Coucheron <arneco@online.no>
159  [0.74-3]
160- added /etc/sane.d to %dir in file list
161
162* Sat Aug 01 1998 Arne Coucheron <arneco@online.no>
163  [0.74-2]
164- devel Group: reverted back to Development/Libraries
165- some changes to the %defattr and %attr usage in file list
166
167* Tue Jul 28 1998 Binaire <binaire@binaire.ml.org>
168  [0.74-1]
169
170* Fri May 22 1998 Arne Coucheron <arneco@online.no>
171  [0.73-3]
172- added use of %%{name} and %%{version} macros
173- added a %postun for running ldconfig after uninstall
174- using BuildRoot properly now
175- using %defattr and %attr macros in filelist, allows non-root build
176  this means that RPM 2.5 is required to build this spec file now!
177- devel Group: changed to X11/Libraries
178- added using RPM_OPT_FLAGS during make
179- added striping of programs and libraries
180- added Requires: gtk+ >= 0.99.13 to main package
181- added Requires: %%{name} = %%{version} to devel package
182- added a %clean section for removing the buildroot dir
183- simplified the filelist and added %config for sane-style.rc
184- moved lib*.so to %files devel and dropped the *.la files
185- added -q parameter to %setup
186- removed some older changelog entries
187- removed the "fix ldconfig brokenness..." stuff
188- removed the Packager: line; use /etc/rpmrc if you want your name in
189- if GIMP is installed, make symlink from xscanimage to plug-ins dir
190- install the find-scanner program from the tools dir
191
192* Mon May 18 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
193- Version 0.73 was created: May 13 1998
194- gimp (original was build against 0.99.29)
195- gtk+ (original was build against 1.0.1)
196- dlh (original was build against 0.7d)
197- X11 development tree including xpm libraries.
198
199* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
200- Binaries are now BuildRoot proof.
201
202* Wed Apr 22 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
203- Binaries are not BuildRoot proof. release 3 is done without BuildRoot!
204
205* Tue Apr 21 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
206- Temp. fix for some documentations problems with BuildRoot.
207
208* Sat Apr 11 1998 Hugo van der Kooij <hvdkooij@caiw.nl>
209- Formal 0.72 now made as RPM! (Build against GTK+ 0.99.10 and GIMP 0.99.24)
210- Original package was released: Tue Apr 7 1998
Note: See TracBrowser for help on using the repository browser.