source: projects/specs/trunk/s/sablotron/sablotron-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name sablotron
2%define version 1.0.3
3%define release 2%{?_dist_release}
4
5%define altname Sablot
6%define builddir $RPM_BUILD_DIR/%{altname}-%{version}
7%define lib_name_orig libsablotron
8%define lib_major 0
9%define lib_name %{lib_name_orig}%{lib_major}
10
11Summary:                XSLT processor
12Summary(ja):            XSLT プロセッサ
13Name:                   %{name}
14Version:                %{version}
15Release:                %{release}
16License:                MPL/GPL
17Group:                  Applications/Text
18#URL:                   http://www.gingerall.cz
19#Source:                http://www.gingerall.com:/perl/rd?url=sablot/%{altname}-%{version}.tar.gz
20#Source0:               http://download-1.gingerall.cz/download/sablot/%{altname}-%{version}.tar.gz
21URL:                    http://sourceforge.net/projects/sablotron/
22Source0:                %{url}/files/sablotron-%{version}/Sablot-%{version}.tar.gz
23Patch:                  sablot-lib-0.71.patch.bz2
24Requires:               expat >= 1.95.2
25Requires:               %{lib_name}
26BuildRequires:          expat-devel >= 1.95.2
27BuildRequires:          perl-XML-Parser
28
29BuildRoot:              %{_tmppath}/%{name}-%{version}-root
30
31%description
32Sablotron is a fast, compact and portable XML toolkit
33implementing XSLT, DOM and XPath.
34
35The goal of this project is to create a lightweight,
36reliable and fast XML library processor conforming to the W3C
37specification, which is available for public and can be used as a base
38for multi-platform XML applications.
39
40%package -n %{lib_name}
41Summary:        Main library for sablotron
42Summary(ja):    sablotron ライブラリ
43Group:          System Environment/Libraries
44Provides:       %{name} = %{version}-%{release}
45
46%description -n %{lib_name}
47Contains the library for sablotron.
48
49%package -n %{lib_name}-devel
50Summary:        The development libraries and header files for Sablotron
51Summary(ja):    Sablotron の開発ライブラリおよびヘッダファイル
52Requires:       sablotron = %{version}
53Group:          Development/Libraries
54Requires:       %{lib_name} = %{version}
55Provides:       %{lib_name_orig}-devel = %{version}-%{release}
56
57%description -n %{lib_name}-devel
58These are the development libraries and header files for Sablotron
59
60%prep
61%setup -q -n %{altname}-%{version}
62#%patch
63
64%build
65export CXXFLAGS="${RPM_OPT_FLAGS}"
66./configure --prefix=%{_prefix}
67make
68
69%install
70%makeinstall prefix=$RPM_BUILD_ROOT/%{_prefix}
71## remove unuse files
72rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
73
74
75%files
76%defattr(755,root,root)
77%{_bindir}/sabcmd
78%{_mandir}/man1/sabcmd.*
79
80%files -n %{lib_name}
81%defattr(-,root,root)
82%{_libdir}/libsablot.so.*
83%doc README RELEASE
84
85%files -n %{lib_name}-devel
86%defattr(-,root,root)
87%{_bindir}/sablot-config
88%{_libdir}/lib*.a
89#%{_libdir}/lib*.la
90%{_libdir}/lib*.so
91%{_includedir}/*.h
92
93%clean
94[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
95
96%post -n %{lib_name} -p /sbin/ldconfig
97
98%postun -n %{lib_name} -p /sbin/ldconfig
99
100%changelog
101* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.3-2
102- rebuilt with new toolchain
103
104* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
105- applied new versioning policy, spec in utf-8
106- removed *.la
107
108* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl2
109- rebuild with expat-2.0.1
110
111* Sun Jan  6 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-0vl1
112- updated Sablot to 1.0.3
113- dropt sablot-lib-0.71.patch.bz2
114
115* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl5
116- rebuilt with new toolchain
117
118* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl4
119- changed Group to Applications/Text
120
121* Sat Mar 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl3
122- added Japanese summary
123- changed Group:
124
125* Sat Jan 25 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.97-0vl2
126- added BuildRequires: perl-XML-Parser
127
128* Thu Jan 21 2003 Satoshi MACHINO <machino@vinelinux.org> 0.97-0vl1
129- new upstream version
130
131* Thu May 16 2002 Satoshi MACHINO <machino@vinelinux.org> 0.90-1vl1
132- build on Vine Linux
133        -- modified spec
134
135* Wed Apr 03 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.90-1mdk
136- release 0.90.
137- patch to add -lexpat and -lstdc++ in libsablot.so (required for php4)
138
139* Mon Feb 04 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.82-1mdk
140- release 0.82.
141
142* Wed Jan 16 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.81-1mdk
143- release 0.81.
144- Removed patch for 0.80.
145
146* Tue Jan 15 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.80-1mdk
147- release 0.80.
148
149* Wed Nov 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.71-1mdk
150- release 0.71.
151- bzip2 the source.
152- remove the patch.
153
154* Tue Nov 06 2001 Philippe Libat <philippe@mandrakesoft.com> 0.70-2mdk
155- %macros
156- move sabcmd in sablotron rpm
157
158* Mon Nov 05 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.70-1mdk
159- first mdk release.
160
161* Tue Sep 18 2001 Petr Cimprich <petr@gingerall.cz>
162- sablotron 0.70 RPM release 1
163
164* Wed Aug 15 2001 Petr Cimprich <petr@gingerall.cz>
165- sablotron 0.65 RPM release 1
166
167* Thu Jun 14 2001 Petr Cimprich <petr@gingerall.cz>
168- sablotron 0.60 RPM release 1
169- build under RedHat 7.1 with rpm 4.0.2
170
171* Wed Apr 22 2001 Petr Cimprich <petr@gingerall.cz>
172- sablotron 0.52 RPM release 1
173- based on 0.51-5 spec by Henri Gomez
174
175* Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
176- sablotron 0.51 RPM release 5
177- apply patch to add -lexpat and -lstdc++ in libsablot.so
178  REQUIRED for use with PHP4
179
180* Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
181- sablotron 0.51 RPM release 4
182- follow Redhat way to dispatch between pack and pack-devel
183
184* Tue Feb 20 2001 Henri Gomez <hgomez@slib.fr>
185- sablotron 0.51 RPM release 3
186- added ldconfig is post/preun and cleanup stuff
187- build under Redhat 6.2 + updates with rpm 3.0.5
188
189* Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
190- sablotron 0.51 RPM release 2
191- added Requires expat >= 1.95.1
192
193* Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
194- sablotron 0.51 RPM release 1
195- updated spec file
196
Note: See TracBrowser for help on using the repository browser.