source: projects/specs/trunk/s/sablotron/sablotron-vl.spec @ 10771

Revision 10771, 5.9 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define name sablotron
2%define version 1.0.3
3%define release 5%{?_dist_release}
4
5%define altname Sablot
6%define builddir $RPM_BUILD_DIR/%{altname}-%{version}
7%define lib_name_orig libsablotron
8%define lib_major 0
9%define lib_name %{lib_name_orig}%{lib_major}
10
11Summary:                XSLT processor
12Summary(ja):            XSLT プロセッサ
13Name:                   %{name}
14Version:                %{version}
15Release:                %{release}
16License:                MPL/GPL
17Group:                  Applications/Text
18URL:                    http://sourceforge.net/projects/sablotron/
19
20Source0:                %{url}/files/sablotron-%{version}/Sablot-%{version}.tar.gz
21
22BuildRoot:              %{_tmppath}/%{name}-%{version}-root
23BuildRequires:          expat-devel >= 1.95.2
24BuildRequires:          perl-XML-Parser
25Requires:               expat >= 1.95.2
26Requires:               %{lib_name}
27
28%description
29Sablotron is a fast, compact and portable XML toolkit
30implementing XSLT, DOM and XPath.
31
32The goal of this project is to create a lightweight,
33reliable and fast XML library processor conforming to the W3C
34specification, which is available for public and can be used as a base
35for multi-platform XML applications.
36
37%package -n %{lib_name}
38Summary:        Main library for sablotron
39Summary(ja):    sablotron ライブラリ
40Group:          System Environment/Libraries
41Provides:       %{name} = %{version}-%{release}
42
43%description -n %{lib_name}
44Contains the library for sablotron.
45
46%package -n %{lib_name}-devel
47Summary:        The development libraries and header files for Sablotron
48Summary(ja):    Sablotron の開発ライブラリおよびヘッダファイル
49Requires:       sablotron = %{version}
50Group:          Development/Libraries
51Requires:       %{lib_name} = %{version}
52Provides:       %{lib_name_orig}-devel = %{version}-%{release}
53
54%description -n %{lib_name}-devel
55These are the development libraries and header files for Sablotron
56
57%prep
58%setup -q -n %{altname}-%{version}
59
60%build
61export CXXFLAGS="${RPM_OPT_FLAGS}"
62%configure --disable-static
63make %{?_smp_mflags}
64
65%install
66[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67
68make install DESTDIR=$RPM_BUILD_ROOT
69## remove unuse files
70rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
71
72# docs
73rm -rf _docs_to_include
74mkdir -p _docs_to_include
75mv $RPM_BUILD_ROOT/%{_docdir}/html/* _docs_to_include
76
77%clean
78[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
79
80%post -n %{lib_name} -p /sbin/ldconfig
81
82%postun -n %{lib_name} -p /sbin/ldconfig
83
84
85%files
86%defattr(755,root,root)
87%doc _docs_to_include/*
88%{_bindir}/sabcmd
89%{_mandir}/man1/sabcmd.*
90#{_docdir}/html/jsdom-ref
91#{_docdir}/html/sablot
92#{_docdir}/html/sxp
93
94%files -n %{lib_name}
95%defattr(-,root,root)
96%{_libdir}/libsablot.so.*
97%doc README RELEASE
98
99%files -n %{lib_name}-devel
100%defattr(-,root,root)
101%{_bindir}/sablot-config
102#{_libdir}/lib*.a
103#{_libdir}/lib*.la
104%{_libdir}/lib*.so
105%{_includedir}/*.h
106
107%changelog
108* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.0.3-5
109- rebuild with gcc-5.4.0
110
111* Mon Dec 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.3-4
112- rebuilt on current VineSeed
113- excluded static library from libsablotron-devel package
114- moved html document to %{_docdir}/%{name}-%{version}
115
116* Sun Feb 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
117- rebuild with Vine6 environment
118
119* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.3-2
120- rebuilt with new toolchain
121
122* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
123- applied new versioning policy, spec in utf-8
124- removed *.la
125
126* Wed Feb 27 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl2
127- rebuild with expat-2.0.1
128
129* Sun Jan  6 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-0vl1
130- updated Sablot to 1.0.3
131- dropt sablot-lib-0.71.patch.bz2
132
133* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl5
134- rebuilt with new toolchain
135
136* Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl4
137- changed Group to Applications/Text
138
139* Sat Mar 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.97-0vl3
140- added Japanese summary
141- changed Group:
142
143* Sat Jan 25 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.97-0vl2
144- added BuildRequires: perl-XML-Parser
145
146* Thu Jan 21 2003 Satoshi MACHINO <machino@vinelinux.org> 0.97-0vl1
147- new upstream version
148
149* Thu May 16 2002 Satoshi MACHINO <machino@vinelinux.org> 0.90-1vl1
150- build on Vine Linux
151        -- modified spec
152
153* Wed Apr 03 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.90-1mdk
154- release 0.90.
155- patch to add -lexpat and -lstdc++ in libsablot.so (required for php4)
156
157* Mon Feb 04 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.82-1mdk
158- release 0.82.
159
160* Wed Jan 16 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.81-1mdk
161- release 0.81.
162- Removed patch for 0.80.
163
164* Tue Jan 15 2002 Christian Belisle <cbelisle@mandrakesoft.com> 0.80-1mdk
165- release 0.80.
166
167* Wed Nov 21 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.71-1mdk
168- release 0.71.
169- bzip2 the source.
170- remove the patch.
171
172* Tue Nov 06 2001 Philippe Libat <philippe@mandrakesoft.com> 0.70-2mdk
173- %macros
174- move sabcmd in sablotron rpm
175
176* Mon Nov 05 2001 Christian Belisle <cbelisle@mandrakesoft.com> 0.70-1mdk
177- first mdk release.
178
179* Tue Sep 18 2001 Petr Cimprich <petr@gingerall.cz>
180- sablotron 0.70 RPM release 1
181
182* Wed Aug 15 2001 Petr Cimprich <petr@gingerall.cz>
183- sablotron 0.65 RPM release 1
184
185* Thu Jun 14 2001 Petr Cimprich <petr@gingerall.cz>
186- sablotron 0.60 RPM release 1
187- build under RedHat 7.1 with rpm 4.0.2
188
189* Wed Apr 22 2001 Petr Cimprich <petr@gingerall.cz>
190- sablotron 0.52 RPM release 1
191- based on 0.51-5 spec by Henri Gomez
192
193* Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
194- sablotron 0.51 RPM release 5
195- apply patch to add -lexpat and -lstdc++ in libsablot.so
196  REQUIRED for use with PHP4
197
198* Thu Feb 22 2001 Henri Gomez <hgomez@slib.fr>
199- sablotron 0.51 RPM release 4
200- follow Redhat way to dispatch between pack and pack-devel
201
202* Tue Feb 20 2001 Henri Gomez <hgomez@slib.fr>
203- sablotron 0.51 RPM release 3
204- added ldconfig is post/preun and cleanup stuff
205- build under Redhat 6.2 + updates with rpm 3.0.5
206
207* Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
208- sablotron 0.51 RPM release 2
209- added Requires expat >= 1.95.1
210
211* Mon Feb 19 2001 Henri Gomez <hgomez@slib.fr>
212- sablotron 0.51 RPM release 1
213- updated spec file
214
Note: See TracBrowser for help on using the repository browser.