source: projects/specs/trunk/r/rxvt/rxvt-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A color VT102 terminal emulator for the X Window System.
2Summary(ja): X Window System のカラー VT102 端末エミュレータ
3Name: rxvt
4Version: 2.7.3
5Release: 1%{?_dist_release}
6License: distributable
7Group: User Interface/X
8URL: http://www.rxvt.org
9#Source: ftp://ftp.rxvt.org/pub/rxvt/%{name}-%{version}.tar.gz
10Source: %{name}-%{version}.tar.bz2
11%define conf rxvt-vine-%{version}
12Source1: %{conf}.tar.gz
13Patch0: rxvt-2.7.3-bsdel.patch
14Patch1: rxvt-2.7.3-xim.patch
15Patch2: rxvt-2.7.3-ximfix.patch
16Patch3: rxvt-2.7.3-mbwrap.patch
17# security fix patch(es)
18# modified rxvt-2.7.8-security.patch for RedHat-2.7.8-3.6.2.1
19Patch10: rxvt-2.7.3-security.patch
20Buildroot: %{_tmppath}/%{name}-root
21Distribution: Vine Linux
22Vendor: Project Vine
23BuildRequires: autoconf213
24
25%description
26Rxvt is a color VT102 terminal emulator for the X Window System.  Rxvt
27is intended to be an xterm replacement for users who don't need the
28more esoteric features of xterm, like Tektronix 4014 emulation,
29session logging and toolkit style configurability.  Since it doesn't
30support those features, rxvt uses much less swap space than xterm
31uses.  This is a significant advantage on a machine which is serving a
32large number of X sessions.
33
34The rxvt package should be installed on any machine which serves a
35large number of X sessions, if you'd like to improve that machine's
36performance.
37
38%description -l ja
39Rxvt は軽く高機能な X ターミナルソフトです。背景に画像をはり
40つけたり、 メニューを設定したりすることができます。
41
42%prep
43%setup -q -a 1
44%patch0 -p1
45%patch1 -p1
46%patch2 -p1
47%patch3 -p1
48%patch10 -p1
49
50autoconf-2.13 -l autoconf autoconf/configure.in > configure
51
52%build
53%configure \
54%if 1
55        --prefix=%{_prefix} \
56        --exec-prefix=%{_prefix} \
57        --mandir=%{_mandir} \
58%else
59        --prefix=%{_prefix}/X11R6 \
60        --exec-prefix=%{_prefix}/X11R6 \
61        --mandir=%{_prefix}/X11R6/man \
62%endif
63        --enable-utmp --enable-xpm-background \
64        --enable-xgetdefault --enable-ttygid \
65        --enable-transparency --enable-menubar \
66        --enable-languages --with-encoding=eucj \
67        --enable-xim --enable-kanji \
68        --enable-delete-key --enable-backspace-key
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73#mkdir -p $RPM_BUILD_ROOT%{_prefix}/X11R6/lib/X11/app-defaults
74#mkdir -p $RPM_BUILD_ROOT%{_prefix}/X11R6/man/man1
75#%makeinstall \
76#       DESTDIR=$RPM_BUILD_ROOT \
77#       bindir=%{_prefix}/X11R6/bin \
78#       mandir=%{_prefix}/X11R6/man/man1
79
80mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/X11/app-defaults
81mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
82%makeinstall DESTDIR=$RPM_BUILD_ROOT bindir=%{_bindir} mandir=%{_mandir}/man1
83
84#install -m644 doc/rxvt.1 $RPM_BUILD_ROOT/%{_prefix}/X11R6/man/man1
85#mkdir -p $RPM_BUILD_ROOT/etc/X11/applnk/Utilities
86#cat > $RPM_BUILD_ROOT/etc/X11/applnk/Utilities/rxvt.desktop <<EOF
87install -m644 doc/rxvt.1 $RPM_BUILD_ROOT/%{_mandir}/man1
88mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
89cat > $RPM_BUILD_ROOT%{_datadir}/applications/rxvt.desktop <<EOF
90[Desktop Entry]
91Name=Rxvt
92Type=Application
93Comment=small, fast X terminal application
94Icon=rterm.xpm
95MiniIcon=mini-sh1.xpm
96Exec=rxvt
97EOF
98
99# Extract configuration files for Vine
100cd %{conf}
101make DESTDIR=$RPM_BUILD_ROOT install
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%files
107%defattr(-,root,root)
108%doc doc/*
109%attr(2755,root,utmp) %config(missingok) %{_bindir}/rxvt
110%{_bindir}/rclock
111%{_mandir}/man*/*
112%attr(644,root,root) %config(missingok) %{_datadir}/applications/rxvt.desktop
113
114%{_prefix}/X11R6/lib/X11/rxvt/vine.menu
115%{_prefix}/X11R6/lib/X11/rxvt/terminal.menu
116%{_prefix}/X11R6/lib/X11/app-defaults/Rxvt
117
118%changelog
119* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.3-1vl5
120- applied new versioning policy, spec in utf-8
121- updated configure options
122
123* Mon Aug 20 2007 Shu KONNO <owa@bg.wakwak.com> 2.7.3-0vl12
124- s/Copyright/License/
125
126* Thu Apr  3 2003 IWAI Masaharu <iwai@alib.jp> 2.7.3-0vl11
127- SECURITY FIX: add rxvt-2.7.3-security.patch (Patch10)
128    -  modified rxvt-2.7.8-security.patch for RedHat-2.7.8-3.6.2.1
129- fix typo in %%changelog :)
130
131* Tue Apr  1 2003 IWAI Masaharu <iwai@alib.jp> 2.7.3-0vl10
132- rebuild with new toolchain
133- add BuildRequires: autoconf213
134- using autoconf-2.13
135
136* Fri Nov 30 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 2.7.3-0vl9
137- change key code of backspace and delete
138  fixed XIM
139  fixed a bug of multi byte character wrap
140
141* Wed Apr 11 2001 Jun Nishii <jun@vinelinux.org> 2.7.3-0vl8
142- put scroll bar on right side
143
144* Sat Feb 24 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
145- fixed: install location of man [2.7.3-0vl7]
146
147* Thu Feb 15 2001 Kunio Murasawa <murasawa@marineroad.com>
148- 2.7.3-0vl6
149- fixed files section changed attribute of rxvt
150
151* Mon Feb 05 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
152- fixed files section so as not to own mandir itself
153
154* Thu Feb 01 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
155- rebuild for VineSeed
156
157* Wed Jan 31 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
158- use better macros
159- --enable-delete-key --enable-backspace-key
160- fixed Rxvt resource around xim (kinput2)
161
162* Tue Jul 18 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
163- 2.7.3-0vl1
164- lynx -> w3m, mule -> emacs
165
166* Tue Jun 20 2000 Jun Nishii <jun@vinelinux.org>
167- 2.7.3-0vl1
168
169* Thu Feb 23 2000 Preston Brown <pbrown@redhat.com>
170- remove app defaults file, we patched keys in the source
171
172* Mon Feb 21 2000 Preston Brown <pbrown@redhat.com>
173- complies with debian keyboard bindings / xterm
174
175* Fri Feb 11 2000 Preston Brown <pbrown@redhat.com>
176- fix scrolling behaviour when scrollbar at bottom of range (#9335)
177
178* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
179- color approximation patch for 8bpp from Hans (bug #9171)
180- gzip man pages
181- app defaults not config files
182- wmconfig -> desktop
183
184* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
185- fix up key bindings
186
187* Thu Jan 13 2000 Preston Brown <pbrown@redhat.com>
188- fix man page doc error (#6098)
189
190* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
191- get rid of the stupid %configure macro that scrwed up the UTMP support in
192  rxvt (--enable-everything was a devel release option only, should've
193  checked that is still valid before reverting!!!)
194- why did we revert in the first place?
195
196* Mon Aug 30 1999 Preston Brown <pbrown@redhat.com>
197- downgraded to rxvt 2.6.1.  2.7.x is the devel. branch!
198- removed meta-key hotkey patch, phasing this nonstandard patch out.
199
200* Mon Aug  9 1999 Jeff Johnson <jbj@redhat.com>
201- upgrade to 2.7.0.
202
203* Thu Jun 16 1999 Bill Nottingham <notting@redhat.com>
204- turn on some stuff in configure
205
206* Tue Jun 14 1999 Bill Nottingham <notting@redhat.com>
207- use --enable-ttygid
208
209* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
210- update to 2.6.0.
211- add --enable-xgetdefault (#3309).
212
213* Thu Mar 25 1999 Erik Troan <ewt@redhat.com>
214- added unix98 pty support
215
216* Wed Mar 24 1999 Erik Troan <ewt@redhat.com>
217- updated for utmpwrap
218
219* Tue Mar 23 1999 Michael Johnson <johnsonm@redhat.com>
220- added back the "old" alt-< and alt-> font change behaviour
221- put the manpage in the right place
222
223* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
224- auto rebuild in the new build environment (release 2)
225
226* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
227- upgraded to 2.6.PRE2.  Marked as unstable, but rxvt is always unstable...
228
229* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
230- Injected new description and group.
231
232* Wed Dec 30 1998 Jeff Johnson <jbj@redhat.com>
233- fix glibc-2.1 utmpx compilation problem -- add -D_GNU_SOURCE (#638).
234
235* Mon Dec 21 1998 Preston Brown <pbrown@redhat.com>
236- bumped spec # for 6.0 build
237
238* Wed Sep 30 1998 Bill Nottingham <notting@redhat.com>
239- fix to enable keypad
240
241* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
242- version 2.4.7
243- old version used to be called 2.20, so now we are Serial: 1
244
245* Thu May 07 1998 Prospector System <bugs@redhat.com>
246- translations modified for de, fr, tr
247
248* Fri Nov 07 1997 Michael K. Johnson <johnsonm@redhat.com>
249- no paths in wmconfig files.
250
251* Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
252- added wmconfig
253
254* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
255- built against glibc
256
257* Mon Mar 31 1997 Michael K. Johnson <johnsonm@redhat.com>
258- make rxvt use standard XGetDefault instead of built-in one.
Note: See TracBrowser for help on using the repository browser.