source: projects/specs/trunk/r/rwho/rwho-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     Displays who is logged in to local network machines.
2Summary(ja): ローカルネットワーク機に誰がログインしているか表示する
3Name: rwho
4Version: 0.17
5Release: 26%{?_dist_release}
6License: BSD
7Group: Applications/Internet
8Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-rwho-%{version}.tar.gz
9Source1: rwhod.init
10Patch0: netkit-rwho-0.15-alpha.patch
11Patch1: netkit-rwho-0.17-bug22014.patch
12Patch2: rwho-0.17-fixbcast.patch
13Patch3: rwho-0.17-fixhostname.patch
14Patch4: netkit-rwho-0.17-strip.patch
15Patch5: netkit-rwho-0.17-include.patch
16Patch6: netkit-rwho-0.17-wd_we.patch
17Patch7: netkit-rwho-0.17-time.patch
18Patch8: netkit-rwho-0.17-gcc4.patch
19Patch9: netkit-rwho-0.17-getloadavg.patch
20#Requires: /sbin/chkconfig /etc/init.d
21Requires: /sbin/chkconfig
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24
25%description
26The rwho command displays output similar to the output of the who
27command (it shows who is logged in) for all machines on the local
28network running the rwho daemon.
29
30Install the rwho command if you need to keep track of the users who
31are logged in to your local network.
32
33%description -l ja
34rwho コマンドは who コマンド (誰がログインしているかを表示します) の
35出力に似た表示をするプログラムで,rwho デーモンが動作しているローカル
36ネットワーク上の全マシンの情報を出力します.
37
38あなたのローカルネットワーク上のマシンに誰がログインしているかを
39知りたい場合は rwho コマンドをインストールして下さい.
40
41
42%prep
43%setup -q -n netkit-rwho-%{version}
44%patch0 -p1 -b .alpha
45%patch1 -p1 -b .bug22014
46%patch2 -p1 -b .fixbcast
47%patch3 -p1 -b .fixhostname
48%patch4 -p1 -b .strip
49%patch9 -p0 -b .getloadavg
50
51%build
52sh configure
53perl -pi -e '
54    s,^CC=.*$,CC=cc,;
55    s,-O2,\$(RPM_OPT_FLAGS),;
56    s,^BINDIR=.*$,BINDIR=%{_bindir},;
57    s,^MANDIR=.*$,MANDIR=%{_mandir},;
58    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
59    ' MCONFIG
60
61make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
62
63
64%install
65rm -rf ${RPM_BUILD_ROOT}
66mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
67mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
68mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
69mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
70mkdir -p ${RPM_BUILD_ROOT}/var/spool/rwho
71
72make INSTALLROOT=${RPM_BUILD_ROOT} install
73make INSTALLROOT=${RPM_BUILD_ROOT} install -C ruptime
74
75install -m 755 $RPM_SOURCE_DIR/rwhod.init ${RPM_BUILD_ROOT}%{_initdir}/rwhod
76
77
78%clean
79rm -rf ${RPM_BUILD_ROOT}
80
81
82%post
83/sbin/chkconfig --add rwhod
84
85
86%preun
87if [ $1 = 0 ]; then
88    /sbin/chkconfig --del rwhod
89fi
90
91
92%files
93%defattr(-,root,root)
94%{_bindir}/ruptime
95%{_mandir}/man1/ruptime.1*
96%{_bindir}/rwho
97%{_mandir}/man1/rwho.1*
98
99%{_sbindir}/rwhod
100%{_mandir}/man8/rwhod.8*
101/var/spool/rwho
102%config %{_initdir}/rwhod
103
104
105%changelog
106* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-26vl5
107- added netkit-rwho-0.17-getloadavg.patch
108- applied new versioning policy, spec in utf-8
109
110* Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-19vl1
111- added Patch5, 6, 7 and 8 from Fedora 0.17-25.2.1
112  * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 0.17-25
113  - gcc4 rebuild fixes
114  * Fri Oct 22 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-23
115  - Fixed long standig bug with only 42 entries per host showing up (#27643)
116  - Fixed some warnings of missing prototypes.
117  * Wed May 12 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-21
118  - Enabled PIE for server and application.
119- changed Group to Applications/Internet
120
121* Mon Jul 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-19vl1
122- based on Redhat Rawhide 0.17-19
123- added Patch2, 3 and 4
124- rebuild with new toolchains
125
126* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
127- 0.17-7vl1
128- based on 0.17-7 from Rawhide
129- use better macros (%%{_initdir})
130- added Japanese summary and description
131
132* Wed Dec 27 2000 Jeff Johnson <jhbj@redhat.com>
133- use glibc's <protocols/rwhod.h>, internal version broken on alpha (#22014).
134
135* Thu Aug 10 2000 Bill Nottingham <notting@redhat.com>
136- fix broken init script
137
138* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
139- condrestart fixes
140
141* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
142- move initscript back
143
144* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
145- automatic rebuild
146
147* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
148- move initscript
149
150* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
151- FHS packaging.
152- update to 0.17.
153
154* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
155- compress man pages.
156
157* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
158- update to 0.16.
159
160* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
161- postun should have been preun.
162
163* Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
164- fix unaligned trap on alpha.
165- update to 0.15.
166
167* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
168- initscript munging
169
170* Fri Apr  9 1999 Jeff Johnson <jbj@redhat.com>
171- add ruptime (#2023)
172
173* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
174- auto rebuild in the new build environment (release 22)
175
176* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
177- compile for 6.0.
178
179* Tue May 05 1998 Prospector System <bugs@redhat.com>
180- translations modified for de, fr, tr
181
182* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
183- enhanced initscripts
184
185* Mon Nov 03 1997 Donnie Barnes <djb@redhat.com>
186- added /var/spool/rwho
187
188* Fri Oct 31 1997 Donnie Barnes <djb@redhat.com>
189- fixed init script
190
191* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
192- added an init script
193- uses chkconfig
194- uses %attr tags
195
196* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
197- initial build
Note: See TracBrowser for help on using the repository browser.