source: projects/specs/trunk/r/rust/rust-vl.spec @ 12521

Revision 12521, 27.4 KB checked in by tomop, 3 years ago (diff)

updated 11 packages

dnsmasq-2.84-1

firefox-78.7.0-1

kernel-5.4.93-1

libmaxminddb-1.5.0-1

nsd-4.3.5-1

openldap-2.4.57-1

python-pillow-8.1.0-1

rust-1.49.0-1

samba-4.13.4-1

sudo-1.9.5p2-1

thunderbird-78.7.0-1

Line 
1%bcond_with bootstrap
2%bcond_with test
3%bcond_with newrpm
4%bcond_without clang
5%bcond_without bundled_libgit2
6%bcond_without bundled_libssh2
7
8# Some sub-packages are versioned independently of the rust compiler and runtime itself.
9# Also beware that if any of these are not changed in a version bump, then the release
10# number should still increase, not be reset to 1!
11%global rustc_version 1.49.0
12%global cargo_version %{rustc_version}
13%global rustfmt_version %{rustc_version}
14%global rls_version %{rustc_version}
15%global clippy_version %{rustc_version}
16
17# The channel can be stable, beta, or nightly
18%{!?channel: %global channel stable}
19
20# Only x86_64 and i686 are Tier 1 platforms at this time.
21# https://forge.rust-lang.org/platform-support.html
22%global rust_arches x86_64 i686
23
24# To bootstrap from scratch, set the channel and date from src/stage0.txt
25# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
26# or nightly wants some beta-YYYY-MM-DD
27%global bootstrap_rust 1.46.0
28%global bootstrap_cargo 1.46.0
29%global bootstrap_channel %{bootstrap_rust}
30
31# Only the specified arches will use bootstrap binaries.
32%if %{with bootstrap}
33%global bootstrap_arches %%{rust_arches}
34%endif
35
36# We generally don't want llvm-static present at all, since llvm-config will
37# make us link statically.  But we can opt in, e.g. to aid LLVM rebases.
38# FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
39# *want* static we'll have to force it with "llvm-config --link-static".
40# See also https://github.com/rust-lang/rust/issues/36854
41# The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
42%bcond_with llvm_static
43
44# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
45# is insufficient.  Rust currently requires LLVM 3.7+.
46%bcond_with bundled_llvm
47
48# LLDB only works on some architectures
49%ifarch %{arm} aarch64 %{ix86} x86_64
50# LLDB isn't available everywhere...
51%bcond_without lldb
52%else
53%bcond_with lldb
54%endif
55
56Summary:        The Rust Programming Language
57Name:           rust
58Version:        %{rustc_version}
59Release:        1%{?_dist_release}
60Group:          programming
61Vendor:         Project Vine
62Distribution:   Vine Linux
63
64License:        (ASL 2.0 or MIT) and (BSD and ISC and MIT)
65# ^ written as: (rust itself) and (bundled libraries)
66URL:            https://www.rust-lang.org
67
68ExclusiveArch:  %{rust_arches}
69
70%if "%{channel}" == "stable"
71%global rustc_package rustc-%{version}-src
72%else
73%global rustc_package rustc-%{channel}-src
74%endif
75Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
76
77# Get the Rust triple for any arch.
78%{lua: function rust_triple(arch)
79  local abi = "gnu"
80  if arch == "armv7hl" then
81    arch = "armv7"
82    abi = "gnueabihf"
83  elseif arch == "ppc64" then
84    arch = "powerpc64"
85  elseif arch == "ppc64le" then
86    arch = "powerpc64le"
87  end
88  return arch.."-unknown-linux-"..abi
89end}
90
91%global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
92
93%if %defined bootstrap_arches
94# For each bootstrap arch, add an additional binary Source.
95# Also define bootstrap_source just for the current target.
96%{lua: do
97  local bootstrap_arches = {}
98  for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
99    table.insert(bootstrap_arches, arch)
100  end
101  local base = rpm.expand("https://static.rust-lang.org/dist"
102                          .."/rust-%{bootstrap_channel}")
103  local target_arch = rpm.expand("%{_target_cpu}")
104  for i, arch in ipairs(bootstrap_arches) do
105    print(string.format("Source%d: %s-%s.tar.gz\n",
106                        i, base, rust_triple(arch)))
107    if arch == target_arch then
108      rpm.define("bootstrap_source "..i)
109    end
110  end
111end}
112%endif
113
114%ifarch %{bootstrap_arches}
115%global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
116%global local_rust_root %{_builddir}/%{bootstrap_root}/usr
117Provides:       bundled(%{name}-bootstrap) = %{bootstrap_rust}
118%else
119BuildRequires:  cargo >= %{bootstrap_cargo}
120BuildRequires:  %{name} >= %{bootstrap_rust}
121BuildConflicts: %{name} > %{version}
122%global local_rust_root %{_prefix}
123%endif
124
125BuildRequires:  cmake
126BuildRequires:  make
127%if %{with clang}
128BuildRequires:  clang
129BuildRequires:  lld
130%else
131BuildRequires:  gcc
132BuildRequires:  gcc-c++
133%endif
134%if %{without bundled_libgit2}
135BuildRequires:  libgit2-devel
136%endif
137%if %{without bundled_libssh2}
138BuildRequires:  libssh2-devel
139%endif
140BuildRequires:  ncurses-devel
141BuildRequires:  openssl-devel
142BuildRequires:  zlib-devel
143BuildRequires:  python3
144BuildRequires:  python3-rpm-macros
145BuildRequires:  curl
146BuildRequires:  curl-devel
147BuildRequires:  xz-devel
148
149%if %{with bundled_llvm}
150BuildRequires:  cmake
151BuildRequires:  git
152Provides:       bundled(llvm) = 6.0
153%else
154BuildRequires:  cmake
155%if %defined llvm
156%global llvm_root %{_libdir}/%{llvm}
157%else
158%global llvm llvm
159%global llvm_root %{_prefix}
160%global llvm_has_filecheck 1
161%endif
162BuildRequires:  %{llvm}-devel >= 11.0.0
163%if %{with llvm_static}
164BuildRequires:  %{llvm}-static
165BuildRequires:  libffi-devel
166%else
167BuildConflicts: %{llvm}-static
168%endif
169%endif
170
171# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
172BuildRequires:  procps
173
174# debuginfo-gdb tests need gdb
175BuildRequires:  gdb
176
177# TODO: work on unbundling these!
178Provides:       bundled(jquery) = 2.1.4
179Provides:       bundled(miniz) = 1.14
180
181# Virtual provides for folks who attempt "dnf install rustc"
182Provides:       rustc = %{version}-%{release}
183Provides:       rustc%{?_isa} = %{version}-%{release}
184
185# Always require our exact standard library
186Requires:       %{name}-std-static%{?_isa} = %{version}-%{release}
187
188# The C compiler is needed at runtime just for linking.  Someday rustc might
189# invoke the linker directly, and then we'll only need binutils.
190# https://github.com/rust-lang/rust/issues/11937
191Requires:       /usr/bin/cc
192
193# ALL Rust libraries are private, because they don't keep an ABI.
194%global _privatelibs lib(.*-[[:xdigit:]]{16}*|rustc.*)[.]so.*
195%global __provides_exclude ^(%{_privatelibs})$
196%global __requires_exclude ^(%{_privatelibs})$
197%global __provides_exclude_from ^(%{_docdir}|%{rustlibdir}/src)/.*$
198%global __requires_exclude_from ^(%{_docdir}|%{rustlibdir}/src)/.*$
199
200%if !%{with newrpm}
201# eu-strip is very eager by default, so we have to limit it to -g, only debugging symbols.
202%global _find_debuginfo_opts -g
203%undefine _include_minidebuginfo
204%else
205# Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
206%global _find_debuginfo_opts --keep-section .rustc
207%endif
208
209# Use hardening ldflags.
210%global rustflags -Clink-arg=-Wl,-z,relro,-z,now
211
212%if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
213# https://github.com/rust-lang/rust/issues/40717
214%global library_path $(%{llvm_root}/bin/llvm-config --libdir)
215%endif
216
217%description
218Rust is a systems programming language that runs blazingly fast, prevents
219segfaults, and guarantees thread safety.
220
221This package includes the Rust compiler and documentation generator.
222
223
224%package std-static
225Summary:        Standard library for Rust
226Group:          programming
227
228%description std-static
229This package includes the standard libraries for building applications
230written in Rust.
231
232
233%package debugger-common
234Summary:        Common debugger pretty printers for Rust
235Group:          programming
236BuildArch:      noarch
237
238%description debugger-common
239This package includes the common functionality for %{name}-gdb and %{name}-lldb.
240
241
242%package gdb
243Summary:        GDB pretty printers for Rust
244Group:          programming
245BuildArch:      noarch
246Requires:       gdb
247Requires:       %{name}-debugger-common = %{version}-%{release}
248
249%description gdb
250This package includes the rust-gdb script, which allows easier debugging of Rust
251programs.
252
253
254%if %{with lldb}
255
256%package lldb
257Summary:        LLDB pretty printers for Rust
258Group:          programming
259
260# It could be noarch, but lldb has limited availability
261#BuildArch:      noarch
262
263Requires:       lldb
264Requires:       python3-lldb
265Requires:       %{name}-debugger-common = %{version}-%{release}
266
267%description lldb
268This package includes the rust-lldb script, which allows easier debugging of Rust
269programs.
270
271%endif
272
273
274%package doc
275Summary:        Documentation for Rust
276Group:          documentation
277# NOT BuildArch:      noarch
278# Note, while docs are mostly noarch, some things do vary by target_arch.
279# Koji will fail the build in rpmdiff if two architectures build a noarch
280# subpackage differently, so instead we have to keep its arch.
281
282%description doc
283This package includes HTML documentation for the Rust programming language and
284its standard library.
285
286
287%package -n cargo
288Summary:        Rust's package manager and build tool
289Version:        %{cargo_version}
290Group:          programming
291# For tests:
292BuildRequires:  git
293# Cargo is not much use without Rust
294Requires:       rust
295
296%description -n cargo
297Cargo is a tool that allows Rust projects to declare their various dependencies
298and ensure that you'll always get a repeatable build.
299
300
301%package -n cargo-doc
302Summary:        Documentation for Cargo
303Version:        %{cargo_version}
304Group:          programming
305BuildArch:      noarch
306# Cargo no longer builds its own documentation
307# https://github.com/rust-lang/cargo/pull/4904
308Requires:       rust-doc = %{rustc_version}-%{release}
309
310%description -n cargo-doc
311This package includes HTML documentation for Cargo.
312
313
314%package -n rustfmt
315Summary:        Tool to find and fix Rust formatting issues
316Version:        %{rustfmt_version}
317Group:          programming
318Requires:       cargo
319Obsoletes:      rustfmt-preview < 1.0.0
320
321%description -n rustfmt
322A tool for formatting Rust code according to style guidelines.
323
324
325%package -n rls
326Summary:        Rust Language Server for IDE integration
327Version:        %{rls_version}
328Group:          programming
329Requires:       rust-analysis
330# /usr/bin/rls is dynamically linked against internal rustc libs
331Requires:       %{name} = %{rustc_version}-%{release}
332Obsoletes:      rls-preview < 1.0.0
333
334%description -n rls
335The Rust Language Server provides a server that runs in the background,
336providing IDEs, editors, and other tools with information about Rust programs.
337It supports functionality such as 'goto definition', symbol search,
338reformatting, and code completion, and enables renaming and refactorings.
339
340
341%package -n clippy
342Summary:        Lints to catch common mistakes and improve your Rust code
343Version:        %{clippy_version}
344Group:          programming
345License:        MPLv2.0
346Requires:       cargo
347# /usr/bin/clippy-driver is dynamically linked against internal rustc libs
348Requires:       %{name} = %{rustc_version}-%{release}
349Obsoletes:      clippy-preview < 1.0.0
350
351%description -n clippy
352A collection of lints to catch common mistakes and improve your Rust code.
353
354
355%package src
356Summary:        Sources for the Rust standard library
357Group:          programming
358BuildArch:      noarch
359
360%description src
361This package includes source files for the Rust standard library.  It may be
362useful as a reference for code completion tools in various editors.
363
364
365%package analysis
366Summary:        Compiler analysis data for the Rust standard library
367Group:          programming
368Requires:       rust-std-static = %{rustc_version}-%{release}
369
370%description analysis
371This package contains analysis data files produced with rustc's -Zsave-analysis
372feature for the Rust standard library. The RLS (Rust Language Server) uses this
373data to provide information about the Rust standard library.
374
375%package miri
376Summary:        An interpreter for Rust's mid-level intermediate representation
377Group:          programming
378Requires:       rust = %{rustc_version}-%{release}
379
380%description miri
381An experimental interpreter for Rust's mid-level intermediate representation
382(MIR). It can run binaries and test suites of cargo projects and detect certain
383classes of undefined behavior.
384
385
386%debug_package
387
388
389%prep
390%ifarch %{bootstrap_arches}
391%setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
392./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
393  --prefix=%{local_rust_root} --disable-ldconfig
394test -f '%{local_rust_root}/bin/cargo'
395test -f '%{local_rust_root}/bin/rustc'
396%endif
397
398%setup -q -n %{rustc_package}
399
400sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
401
402%if %without bundled_llvm
403rm -rf src/llvm-project/
404mkdir -p src/llvm-project/libunwind/
405%endif
406
407# We never enable emscripten.
408rm -rf src/llvm-emscripten/
409
410# Remove other unused vendored libraries
411#rm -rf vendor/curl-sys/curl/
412rm -rf vendor/jemalloc-sys/jemalloc/
413rm -rf vendor/libz-sys/src/zlib/
414rm -rf vendor/lzma-sys/xz-*/
415rm -rf vendor/openssl-src/openssl/
416%if %{without bundled_libgit2}
417rm -rf vendor/libgit2-sys/libgit2/
418%endif
419%if %{without bundled_libssh2}
420rm -rf vendor/libssh2-sys/libssh2/
421%endif
422
423# This only affects the transient rust-installer, but let it use our dynamic xz-libs
424sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
425
426# rename bundled license for packaging
427if [ -e vendor/backtrace-sys/src/libbacktrace/LICENSE ]; then
428  cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
429fi
430
431%if %{with bundled_llvm} && 0%{?epel}
432mkdir -p cmake-bin
433ln -s /usr/bin/cmake cmake-bin/cmake
434%global cmake_path $PWD/cmake-bin
435%endif
436
437%if %{without bundled_llvm} && %{with llvm_static}
438# Static linking to distro LLVM needs to add -lffi
439# https://github.com/rust-lang/rust/issues/34486
440sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
441  src/librustc_llvm/lib.rs
442%endif
443
444# The configure macro will modify some autoconf-related files, which upsets
445# cargo when it tries to verify checksums in those files.  If we just truncate
446# that file list, cargo won't have anything to complain about.
447find vendor -name .cargo-checksum.json \
448  -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
449
450
451%build
452%if %{without bundled_libgit2}
453export LIBGIT2_SYS_USE_PKG_CONFIG=1
454%endif
455%if %{without bundled_libssh2}
456export LIBSSH2_SYS_USE_PKG_CONFIG=1
457%endif
458
459%{?cmake_path:export PATH=%{cmake_path}:$PATH}
460%{?library_path:export LIBRARY_PATH="%{library_path}"}
461%{?rustflags:export RUSTFLAGS="%{rustflags}"}
462
463# We're going to override --libdir when configuring to get rustlib into a
464# common path, but we'll fix the shared libraries during install.
465%global common_libdir %{_prefix}/lib
466%global rustlibdir %{common_libdir}/rustlib
467
468%ifarch x86_64
469%if %{with newrpm}
470%define enable_debuginfo --debuginfo-level=0 --debuginfo-level-std=2
471%else
472%define enable_debuginfo --debuginfo-level=0
473%global debug_package %{nil}
474%endif
475%else
476%define enable_debuginfo --debuginfo-level=0
477%global debug_package %{nil}
478%endif
479
480# Some builders have relatively little memory for their CPU count.
481# At least 2GB per CPU is a good rule of thumb for building rustc.
482ncpus=$(/usr/bin/getconf _NPROCESSORS_ONLN)
483max_cpus=$(( ($(LANG=C free -g | awk '/^Mem:/{print $2}') + 1) / 2 ))
484if [ "$max_cpus" -ge 1 -a "$max_cpus" -lt "$ncpus" ]; then
485  ncpus="$max_cpus"
486fi
487
488%if %{with clang}
489export CC=clang
490export CXX=clang++
491export LDFLAGS="$LDFLAGS -fuse-ld=lld"
492export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
493%endif
494
495# workaround for https://github.com/rust-lang/rust/issues/69953
496#  --set rust.deny-warnings=false
497
498%configure \
499  --disable-option-checking \
500  --libdir=%{common_libdir} \
501  --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
502  --enable-local-rust --local-rust-root=%{local_rust_root} \
503  %{!?with_bundled_llvm: --llvm-root=%{llvm_root} \
504    %{!?llvm_has_filecheck: --disable-codegen-tests} \
505    %{!?with_llvm_static: --enable-llvm-link-shared } } \
506  --disable-rpath \
507  %{enable_debuginfo} \
508  --enable-extended \
509  --enable-vendor \
510  --enable-verbose-tests \
511  --set rust.codegen-units-std=1 \
512  --release-channel=%{channel} \
513  --set rust.deny-warnings=false \
514  %{nil}
515
516RUST_BACKTRACE=1 %{__python3} ./x.py build -j "$ncpus" --stage 2
517%{__python3} ./x.py doc --stage 2
518
519
520%install
521rm -rf %{buildroot}
522
523%{?cmake_path:export PATH=%{cmake_path}:$PATH}
524%{?library_path:export LIBRARY_PATH="%{library_path}"}
525%{?rustflags:export RUSTFLAGS="%{rustflags}"}
526%if %{with clang}
527export CC=clang
528export CXX=clang++
529export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
530%endif
531
532DESTDIR=%{buildroot} ./x.py install
533#DESTDIR=%{buildroot} ./x.py install src
534
535
536# Make sure the shared libraries are in the proper libdir
537%if "%{_libdir}" != "%{common_libdir}"
538mkdir -p %{buildroot}%{_libdir}
539find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
540  -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
541%endif
542
543# The shared libraries should be executable for debuginfo extraction.
544find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
545  -exec chmod -v +x '{}' '+'
546
547# The libdir libraries are identical to those under rustlib/.  It's easier on
548# library loading if we keep them in libdir, but we do need them in rustlib/
549# to support dynamic linking for compiler plugins, so we'll symlink.
550(cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
551 find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
552 while read lib; do
553   if [ -f "${lib##*/}" ]; then
554     # make sure they're actually identical!
555     cmp "$lib" "${lib##*/}"
556     ln -v -f -s -t . "$lib"
557   fi
558 done)
559 
560# Remove installer artifacts (manifests, uninstall scripts, etc.)
561find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
562
563# Remove backup files from %%configure munging
564find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
565
566# https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
567# We don't actually need to ship any of those python scripts in rust-src anyway.
568
569find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
570
571# FIXME: __os_install_post will strip the rlibs
572# -- should we find a way to preserve debuginfo?
573
574# Remove unwanted documentation files (we already package them)
575# Remove unwanted documentation files (we already package them)
576rm -f %{buildroot}%{_docdir}/%{name}/README.md
577rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
578rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
579rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
580rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
581rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
582rm -f %{buildroot}%{_docdir}/%{name}/*.old
583
584# Sanitize the HTML documentation
585find %{buildroot}%{_docdir}/%{name}/html -empty -delete
586find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
587
588# Create the path for crate-devel packages
589mkdir -p %{buildroot}%{_datadir}/cargo/registry
590
591# Cargo no longer builds its own documentation
592# https://github.com/rust-lang/cargo/pull/4904
593mkdir -p %{buildroot}%{_docdir}/cargo
594ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
595
596%if %{without lldb}
597rm -f %{buildroot}%{_bindir}/rust-lldb
598rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
599rm -f %{buildroot}%{rustlibdir}/etc/lldb_commands
600%endif
601
602%if %{with bundled_llvm}
603rm -rf %{buildroot}/home
604%endif
605
606
607%check
608%if %{with test}
609%{?cmake_path:export PATH=%{cmake_path}:$PATH}
610%{?library_path:export LIBRARY_PATH="%{library_path}"}
611%{?rustflags:export RUSTFLAGS="%{rustflags}"}
612%if %{with clang}
613export CC=clang
614export CXX=clang++
615export LD=ld.lld
616export RUSTFLAGS="$RUSTFLAGS -C linker=ld.lld -C link-arg=-fuse-ld=lld"
617%endif
618
619# The results are not stable on koji, so mask errors and just log it.
620%{__python3} ./x.py test --no-fail-fast || :
621%{__python3} ./x.py test --no-fail-fast cargo || :
622%{__python3} ./x.py test --no-fail-fast clippy || :
623%{__python3} ./x.py test --no-fail-fast rls || :
624%{__python3} ./x.py test --no-fail-fast rustfmt || :
625%endif
626
627
628%post -p /sbin/ldconfig
629%postun -p /sbin/ldconfig
630
631
632%files
633%license COPYRIGHT LICENSE-APACHE LICENSE-MIT
634#license src/libbacktrace/LICENSE-libbacktrace
635%doc README.md
636%{_bindir}/rustc
637%{_bindir}/rustdoc
638%{_libdir}/*.so
639%{_mandir}/man1/rustc.1*
640%{_mandir}/man1/rustdoc.1*
641%dir %{rustlibdir}
642%dir %{rustlibdir}/%{rust_triple}
643%dir %{rustlibdir}/%{rust_triple}/lib
644%{rustlibdir}/%{rust_triple}/lib/*.so
645
646%files std-static
647%dir %{rustlibdir}
648%dir %{rustlibdir}/%{rust_triple}
649%dir %{rustlibdir}/%{rust_triple}/lib
650%{rustlibdir}/%{rust_triple}/lib/*.rlib
651
652%files debugger-common
653%dir %{rustlibdir}
654%dir %{rustlibdir}/etc
655%{rustlibdir}/etc/rust_types.py*
656
657%files gdb
658%{_bindir}/rust-gdb
659%{rustlibdir}/etc/gdb_*.py*
660%exclude %{_bindir}/rust-gdbgui
661
662%if %with lldb
663%files lldb
664%{_bindir}/rust-lldb
665%{rustlibdir}/etc/lldb_*.py*
666%{rustlibdir}/etc/lldb_commands
667%endif
668
669%files doc
670%docdir %{_docdir}/%{name}
671%dir %{_docdir}/%{name}
672%dir %{_docdir}/%{name}/html
673%{_docdir}/%{name}/html/*/
674%{_docdir}/%{name}/html/*.html
675%{_docdir}/%{name}/html/*.css
676%{_docdir}/%{name}/html/*.js
677%{_docdir}/%{name}/html/*.png
678%{_docdir}/%{name}/html/*.svg
679%{_docdir}/%{name}/html/*.woff
680%license %{_docdir}/%{name}/html/*.txt
681%license %{_docdir}/%{name}/html/*.md
682
683%files -n cargo
684%license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
685%doc src/tools/cargo/README.md
686%{_bindir}/cargo
687%{_mandir}/man1/cargo*.1*
688%dir %{_sysconfdir}/bash_completion.d
689%{_sysconfdir}/bash_completion.d/cargo
690%dir %{_datadir}/zsh
691%dir %{_datadir}/zsh/site-functions
692%{_datadir}/zsh/site-functions/_cargo
693%dir %{_datadir}/cargo
694%dir %{_datadir}/cargo/registry
695
696%files -n cargo-doc
697%docdir %{_docdir}/cargo
698%dir %{_docdir}/cargo
699%{_docdir}/cargo/html
700
701%files -n rustfmt
702%{_bindir}/rustfmt
703%{_bindir}/cargo-fmt
704%doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
705%license src/tools/rustfmt/LICENSE-{APACHE,MIT}
706
707%files -n rls
708%{_bindir}/rls
709%doc src/tools/rls/{README.md,COPYRIGHT,debugging.md}
710%license src/tools/rls/LICENSE-{APACHE,MIT}
711
712%files -n clippy
713%{_bindir}/cargo-clippy
714%{_bindir}/clippy-driver
715%doc src/tools/clippy/{README.md,CHANGELOG.md}
716%license src/tools/clippy/LICENSE*
717
718%files src
719%dir %{rustlibdir}
720%{rustlibdir}/src
721
722%files analysis
723%{_bindir}/rust-analyzer
724%{rustlibdir}/%{rust_triple}/analysis/
725
726%files miri
727%{_bindir}/miri
728%{_bindir}/cargo-miri
729
730
731%changelog
732* Wed Jan 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.49.0-1
733- new upstream release.
734
735* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.48.0-1
736- new upstream release.
737
738* Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.47.0-1
739- new upstream release.
740
741* Thu Sep 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.46.0-1
742- new upstream release.
743
744* Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.42.0-1
745- new upstream release.
746- separated debuginfo.
747
748* Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.40.0-1
749- new upstream release.
750
751* Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.38.0-1
752- new upstream release.
753- erased "-preview" from the name of subpackages.
754
755* Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
756- new upstream release.
757- dropped Patch1.
758- added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
759
760* Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
761- Update to 1.23.0 (stable).
762
763* Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
764- initial build for Vine Linux.
765- Update to 1.23.0-beta.
766- built a bootstrap rpm.
767
768* Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
769- Update to 1.22.1.
770
771* Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
772- Update to 1.21.0.
773
774* Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
775- ABI fixes for ppc64 and s390x.
776
777* Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
778- Update to 1.20.0.
779- Add a rust-src subpackage.
780
781* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
782- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
783
784* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
785- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
786
787* Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
788- Use find-debuginfo.sh --keep-section .rustc
789
790* Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
791- Update to 1.19.0.
792
793* Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
794- Update to 1.18.0.
795
796* Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
797- Move shared libraries back to libdir and symlink in rustlib
798
799* Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
800- Update to 1.17.0.
801
802* Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
803- Make rust-lldb arch-specific to deal with lldb deps
804
805* Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
806- Limit rust-lldb arches
807
808* Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
809- Update to 1.16.0.
810- Use rustbuild instead of the old makefiles.
811- Update bootstrapping to include rust-std and cargo.
812- Add a rust-lldb subpackage.
813
814* Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
815- Update to 1.15.1.
816- Require rust-rpm-macros for new crate packaging.
817- Keep shared libraries under rustlib/, only debug-stripped.
818- Merge and clean up conditionals for epel7.
819
820* Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
821- Rebuild without bootstrap binaries.
822
823* Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
824- Update to 1.14.0.
825- Rewrite bootstrap logic to target specific arches.
826- Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
827
828* Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
829- Update to 1.13.0.
830- Use hardening flags for linking.
831- Split the standard library into its own package
832- Centralize rustlib/ under /usr/lib/ for multilib integration.
833
834* Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
835- Update to 1.12.1.
836
837* Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
838- Rebuild with LLVM 3.9.
839- Add ncurses-devel for llvm-config's -ltinfo.
840
841* Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
842- Rebuild with llvm-static, preparing for 3.9
843
844* Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
845- Rebuild with fixed eu-strip (rhbz1380961)
846
847* Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
848- Rebuild without bootstrap binaries.
849
850* Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
851- Bootstrap aarch64.
852- Use jemalloc's MALLOC_CONF to work around #36944.
853- Apply pr36933 to really disable armv7hl NEON.
854
855* Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
856- Protect .rustc from rpm stripping.
857
858* Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
859- Update to 1.12.0.
860- Always use --local-rust-root, even for bootstrap binaries.
861- Remove the rebuild conditional - the build system now figures it out.
862- Let minidebuginfo do its thing, since metadata is no longer a note.
863- Let rust build its own compiler-rt builtins again.
864
865* Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
866- Rebuild without bootstrap binaries.
867
868* Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
869- Bootstrap armv7hl, with backported no-neon patch.
870
871* Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
872- Update to 1.11.0.
873- Drop the backported patches.
874- Patch get-stage0.py to trust existing bootstrap binaries.
875- Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
876- Use --local-rust-root to make sure the right bootstrap is used.
877
878* Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
879- Rebuild without bootstrap binaries.
880
881* Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
882- Initial import into Fedora (#1356907), bootstrapped
883- Format license text as suggested in review.
884- Note how the tests already run in parallel.
885- Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
886- Don't let checks fail the whole build.
887- Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
888
889* Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
890- Update -doc directory ownership, and mark its licenses.
891- Package and declare licenses for libbacktrace and hoedown.
892- Set bootstrap_base as a global.
893- Explicitly require python2.
894
895* Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
896- Initial package, bootstrapped
Note: See TracBrowser for help on using the repository browser.