source: projects/specs/trunk/r/rust/rust-vl.spec @ 12320

Revision 12320, 25.7 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

clamav-0.102.2-1

dhcpcd-8.1.1-1

dovecot-2.3.9.3-1

golang-1.13.5-1

llvm-9.0.1-1

libjpeg-turbo-2.0.4-1

libserf-1.3.9-2

libxml2-2.9.10-2

mariadb-10.4.12-1

nodejs-12.16.0-1

php-ext-clearsilver-0.4-15

php73-7.3.14-1

python-pillow-6.2.2-1

rust-1.40.0-1

spamassassin-3.4.4-1

sqlite3-3.31.1-1

squid-4.10-1

sudo-1.8.31-1

Line 
1%bcond_with bootstrap
2%bcond_with test
3%bcond_without clang
4%bcond_without bundled_libgit2
5%bcond_without bundled_libssh2
6
7# Some sub-packages are versioned independently of the rust compiler and runtime itself.
8# Also beware that if any of these are not changed in a version bump, then the release
9# number should still increase, not be reset to 1!
10%global rustc_version 1.40.0
11%global cargo_version %{rustc_version}
12%global rustfmt_version %{rustc_version}
13%global rls_version %{rustc_version}
14%global clippy_version %{rustc_version}
15
16%global llvm_major 9
17
18# The channel can be stable, beta, or nightly
19%{!?channel: %global channel stable}
20
21# Only x86_64 and i686 are Tier 1 platforms at this time.
22# https://forge.rust-lang.org/platform-support.html
23%global rust_arches x86_64 i686
24
25# To bootstrap from scratch, set the channel and date from src/stage0.txt
26# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
27# or nightly wants some beta-YYYY-MM-DD
28%global bootstrap_rust 1.40.0
29%global bootstrap_cargo 1.40.0
30%global bootstrap_channel %{bootstrap_rust}
31
32# Only the specified arches will use bootstrap binaries.
33%if %{with bootstrap}
34%global bootstrap_arches %%{rust_arches}
35%endif
36
37# We generally don't want llvm-static present at all, since llvm-config will
38# make us link statically.  But we can opt in, e.g. to aid LLVM rebases.
39# FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
40# *want* static we'll have to force it with "llvm-config --link-static".
41# See also https://github.com/rust-lang/rust/issues/36854
42# The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
43%bcond_with llvm_static
44
45# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
46# is insufficient.  Rust currently requires LLVM 3.7+.
47%bcond_with bundled_llvm
48
49# LLDB only works on some architectures
50%ifarch %{arm} aarch64 %{ix86} x86_64
51# LLDB isn't available everywhere...
52%bcond_without lldb
53%else
54%bcond_with lldb
55%endif
56
57Name:           rust
58Version:        %{rustc_version}
59Release:        1%{?_dist_release}
60Summary:        The Rust Programming Language
61License:        (ASL 2.0 or MIT) and (BSD and ISC and MIT)
62# ^ written as: (rust itself) and (bundled libraries)
63URL:            https://www.rust-lang.org
64ExclusiveArch:  %{rust_arches}
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68
69%if "%{channel}" == "stable"
70%global rustc_package rustc-%{version}-src
71%else
72%global rustc_package rustc-%{channel}-src
73%endif
74Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
75
76# Get the Rust triple for any arch.
77%{lua: function rust_triple(arch)
78  local abi = "gnu"
79  if arch == "armv7hl" then
80    arch = "armv7"
81    abi = "gnueabihf"
82  elseif arch == "ppc64" then
83    arch = "powerpc64"
84  elseif arch == "ppc64le" then
85    arch = "powerpc64le"
86  end
87  return arch.."-unknown-linux-"..abi
88end}
89
90%global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
91
92%if %defined bootstrap_arches
93# For each bootstrap arch, add an additional binary Source.
94# Also define bootstrap_source just for the current target.
95%{lua: do
96  local bootstrap_arches = {}
97  for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
98    table.insert(bootstrap_arches, arch)
99  end
100  local base = rpm.expand("https://static.rust-lang.org/dist"
101                          .."/rust-%{bootstrap_channel}")
102  local target_arch = rpm.expand("%{_target_cpu}")
103  for i, arch in ipairs(bootstrap_arches) do
104    print(string.format("Source%d: %s-%s.tar.gz\n",
105                        i, base, rust_triple(arch)))
106    if arch == target_arch then
107      rpm.define("bootstrap_source "..i)
108    end
109  end
110end}
111%endif
112
113%ifarch %{bootstrap_arches}
114%global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
115%global local_rust_root %{_builddir}/%{bootstrap_root}/usr
116Provides:       bundled(%{name}-bootstrap) = %{bootstrap_rust}
117%else
118BuildRequires:  cargo >= %{bootstrap_cargo}
119BuildRequires:  %{name} >= %{bootstrap_rust}
120BuildConflicts: %{name} > %{version}
121%global local_rust_root %{_prefix}
122%endif
123
124BuildRequires:  cmake
125BuildRequires:  make
126%if %{with clang}
127BuildRequires:  clang
128BuildRequires:  lld
129%else
130BuildRequires:  gcc
131BuildRequires:  gcc-c++
132%endif
133%if %{without bundled_libgit2}
134BuildRequires:  libgit2-devel
135%endif
136%if %{without bundled_libssh2}
137BuildRequires:  libssh2-devel
138%endif
139BuildRequires:  ncurses-devel
140BuildRequires:  openssl-devel
141BuildRequires:  zlib-devel
142BuildRequires:  python3
143BuildRequires:  python3-rpm-macros
144BuildRequires:  curl
145BuildRequires:  curl-devel
146BuildRequires:  xz-devel
147
148%if %{with bundled_llvm}
149BuildRequires:  cmake
150BuildRequires:  git
151Provides:       bundled(llvm) = 6.0
152%else
153%if %defined llvm
154%global llvm_root %{_libdir}/%{llvm}
155%else
156%global llvm llvm
157%global llvm_root %{_prefix}
158%endif
159BuildRequires:  %{llvm}-devel >= 7.0.0
160%if %{with llvm_static}
161BuildRequires:  %{llvm}-static
162BuildRequires:  libffi-devel
163%else
164# Make sure llvm-config doesn't see it.
165Requires:       %{llvm}%{llvm_major}-libs
166BuildConflicts: %{llvm}-static
167%endif
168%endif
169
170# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
171BuildRequires:  procps
172
173# debuginfo-gdb tests need gdb
174BuildRequires:  gdb
175
176# TODO: work on unbundling these!
177Provides:       bundled(jquery) = 2.1.4
178Provides:       bundled(miniz) = 1.14
179
180# Virtual provides for folks who attempt "dnf install rustc"
181Provides:       rustc = %{version}-%{release}
182Provides:       rustc%{?_isa} = %{version}-%{release}
183
184# Always require our exact standard library
185Requires:       %{name}-std-static%{?_isa} = %{version}-%{release}
186
187# The C compiler is needed at runtime just for linking.  Someday rustc might
188# invoke the linker directly, and then we'll only need binutils.
189# https://github.com/rust-lang/rust/issues/11937
190Requires:       /usr/bin/cc
191
192# ALL Rust libraries are private, because they don't keep an ABI.
193%global _privatelibs lib.*-[[:xdigit:]]*[.]so.*
194%global __provides_exclude ^(%{_privatelibs})$
195%global __requires_exclude ^(%{_privatelibs})$
196%global __provides_exclude_from ^%{_docdir}/.*$
197%global __requires_exclude_from ^%{_docdir}/.*$
198
199# While we don't want to encourage dynamic linking to Rust shared libraries, as
200# there's no stable ABI, we still need the unallocated metadata (.rustc) to
201# support custom-derive plugins like #[proc_macro_derive(Foo)].  But eu-strip is
202# very eager by default, so we have to limit it to -g, only debugging symbols.
203%if 0%{?fedora} >= 27
204# Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
205%global _find_debuginfo_opts --keep-section .rustc
206%else
207%global _find_debuginfo_opts -g
208%undefine _include_minidebuginfo
209%endif
210
211# Use hardening ldflags.
212%global rustflags -Clink-arg=-Wl,-z,relro,-z,now
213
214%if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
215# https://github.com/rust-lang/rust/issues/40717
216%global library_path $(%{llvm_root}/bin/llvm-config --libdir)
217%endif
218
219%description
220Rust is a systems programming language that runs blazingly fast, prevents
221segfaults, and guarantees thread safety.
222
223This package includes the Rust compiler and documentation generator.
224
225
226%package std-static
227Summary:        Standard library for Rust
228
229%description std-static
230This package includes the standard libraries for building applications
231written in Rust.
232
233
234%package debugger-common
235Summary:        Common debugger pretty printers for Rust
236BuildArch:      noarch
237
238%description debugger-common
239This package includes the common functionality for %{name}-gdb and %{name}-lldb.
240
241
242%package gdb
243Summary:        GDB pretty printers for Rust
244BuildArch:      noarch
245Requires:       gdb
246Requires:       %{name}-debugger-common = %{version}-%{release}
247
248%description gdb
249This package includes the rust-gdb script, which allows easier debugging of Rust
250programs.
251
252
253%if %{with lldb}
254
255%package lldb
256Summary:        LLDB pretty printers for Rust
257
258# It could be noarch, but lldb has limited availability
259#BuildArch:      noarch
260
261Requires:       lldb
262Requires:       python-lldb
263Requires:       %{name}-debugger-common = %{version}-%{release}
264
265%description lldb
266This package includes the rust-lldb script, which allows easier debugging of Rust
267programs.
268
269%endif
270
271
272%package doc
273Summary:        Documentation for Rust
274# NOT BuildArch:      noarch
275# Note, while docs are mostly noarch, some things do vary by target_arch.
276# Koji will fail the build in rpmdiff if two architectures build a noarch
277# subpackage differently, so instead we have to keep its arch.
278
279%description doc
280This package includes HTML documentation for the Rust programming language and
281its standard library.
282
283
284%package -n cargo
285Summary:        Rust's package manager and build tool
286Version:        %{cargo_version}
287# For tests:
288BuildRequires:  git
289# Cargo is not much use without Rust
290Requires:       rust
291
292%description -n cargo
293Cargo is a tool that allows Rust projects to declare their various dependencies
294and ensure that you'll always get a repeatable build.
295
296
297%package -n cargo-doc
298Summary:        Documentation for Cargo
299Version:        %{cargo_version}
300BuildArch:      noarch
301# Cargo no longer builds its own documentation
302# https://github.com/rust-lang/cargo/pull/4904
303Requires:       rust-doc = %{rustc_version}-%{release}
304
305%description -n cargo-doc
306This package includes HTML documentation for Cargo.
307
308
309%package -n rustfmt
310Summary:        Tool to find and fix Rust formatting issues
311Version:        %{rustfmt_version}
312Requires:       cargo
313Obsoletes:      rustfmt-preview < 1.0.0
314
315%description -n rustfmt
316A tool for formatting Rust code according to style guidelines.
317
318
319%package -n rls
320Summary:        Rust Language Server for IDE integration
321Version:        %{rls_version}
322Requires:       rust-analysis
323# /usr/bin/rls is dynamically linked against internal rustc libs
324Requires:       %{name} = %{rustc_version}-%{release}
325Obsoletes:      rls-preview < 1.0.0
326
327%description -n rls
328The Rust Language Server provides a server that runs in the background,
329providing IDEs, editors, and other tools with information about Rust programs.
330It supports functionality such as 'goto definition', symbol search,
331reformatting, and code completion, and enables renaming and refactorings.
332
333
334%package -n clippy
335Summary:        Lints to catch common mistakes and improve your Rust code
336Version:        %{clippy_version}
337License:        MPLv2.0
338Requires:       cargo
339# /usr/bin/clippy-driver is dynamically linked against internal rustc libs
340Requires:       %{name} = %{rustc_version}-%{release}
341Obsoletes:      clippy-preview < 1.0.0
342
343%description -n clippy
344A collection of lints to catch common mistakes and improve your Rust code.
345
346
347%package src
348Summary:        Sources for the Rust standard library
349BuildArch:      noarch
350
351%description src
352This package includes source files for the Rust standard library.  It may be
353useful as a reference for code completion tools in various editors.
354
355
356%package analysis
357Summary:        Compiler analysis data for the Rust standard library
358Requires:       rust-std-static = %{rustc_version}-%{release}
359
360%description analysis
361This package contains analysis data files produced with rustc's -Zsave-analysis
362feature for the Rust standard library. The RLS (Rust Language Server) uses this
363data to provide information about the Rust standard library.
364
365
366%prep
367
368%ifarch %{bootstrap_arches}
369%setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
370./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
371  --prefix=%{local_rust_root} --disable-ldconfig
372test -f '%{local_rust_root}/bin/cargo'
373test -f '%{local_rust_root}/bin/rustc'
374%endif
375
376%setup -q -n %{rustc_package}
377
378%if "%{python}" == "python3"
379sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
380%endif
381
382%if %without bundled_llvm
383rm -rf src/llvm-project/
384%endif
385
386# We never enable emscripten.
387rm -rf src/llvm-emscripten/
388
389# Remove other unused vendored libraries
390#rm -rf vendor/curl-sys/curl/
391rm -rf vendor/jemalloc-sys/jemalloc/
392rm -rf vendor/libz-sys/src/zlib/
393rm -rf vendor/lzma-sys/xz-*/
394rm -rf vendor/openssl-src/openssl/
395%if %{without bundled_libgit2}
396rm -rf vendor/libgit2-sys/libgit2/
397%endif
398%if %{without bundled_libssh2}
399rm -rf vendor/libssh2-sys/libssh2/
400%endif
401
402# This only affects the transient rust-installer, but let it use our dynamic xz-libs
403sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
404
405# rename bundled license for packaging
406if [ -e vendor/backtrace-sys/src/libbacktrace/LICENSE ]; then
407  cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
408fi
409
410%if %{with bundled_llvm} && 0%{?epel}
411mkdir -p cmake-bin
412ln -s /usr/bin/cmake cmake-bin/cmake
413%global cmake_path $PWD/cmake-bin
414%endif
415
416%if %{without bundled_llvm} && %{with llvm_static}
417# Static linking to distro LLVM needs to add -lffi
418# https://github.com/rust-lang/rust/issues/34486
419sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
420  src/librustc_llvm/lib.rs
421%endif
422
423# The configure macro will modify some autoconf-related files, which upsets
424# cargo when it tries to verify checksums in those files.  If we just truncate
425# that file list, cargo won't have anything to complain about.
426find vendor -name .cargo-checksum.json \
427  -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
428
429
430%build
431
432%if %{without bundled_libgit2}
433export LIBGIT2_SYS_USE_PKG_CONFIG=1
434%endif
435%if %{without bundled_libssh2}
436export LIBSSH2_SYS_USE_PKG_CONFIG=1
437%endif
438
439%{?cmake_path:export PATH=%{cmake_path}:$PATH}
440%{?library_path:export LIBRARY_PATH="%{library_path}"}
441%{?rustflags:export RUSTFLAGS="%{rustflags}"}
442
443# We're going to override --libdir when configuring to get rustlib into a
444# common path, but we'll fix the shared libraries during install.
445%global common_libdir %{_prefix}/lib
446%global rustlibdir %{common_libdir}/rustlib
447
448%ifarch x86_64
449%define enable_debuginfo --debuginfo-level=0 --debuginfo-level-std=2
450%else
451%define enable_debuginfo --debuginfo-level=0
452%endif
453
454%if %{with clang}
455export CC=clang
456export CXX=clang++
457export LDFLAGS="$LDFLAGS -fuse-ld=lld"
458export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
459%endif
460
461%configure \
462  --disable-option-checking \
463  --libdir=%{common_libdir} \
464  --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
465  --enable-local-rust --local-rust-root=%{local_rust_root} \
466  %{!?with_bundled_llvm: --llvm-root=%{llvm_root} --disable-codegen-tests \
467    %{!?with_llvm_static: --enable-llvm-link-shared } } \
468  --disable-rpath \
469  %{enable_debuginfo} \
470  --enable-extended \
471  --enable-vendor \
472  --enable-verbose-tests \
473  --set rust.codegen-units-std=1 \
474  --release-channel=%{channel}
475
476RUST_BACKTRACE=1 %{__python3} ./x.py build
477%{__python3} ./x.py doc
478
479
480%install
481rm -rf %{buildroot}
482
483%{?cmake_path:export PATH=%{cmake_path}:$PATH}
484%{?library_path:export LIBRARY_PATH="%{library_path}"}
485%{?rustflags:export RUSTFLAGS="%{rustflags}"}
486%if %{with clang}
487export CC=clang
488export CXX=clang++
489export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
490%endif
491
492DESTDIR=%{buildroot} ./x.py install
493#DESTDIR=%{buildroot} ./x.py install src
494
495
496# Make sure the shared libraries are in the proper libdir
497%if "%{_libdir}" != "%{common_libdir}"
498mkdir -p %{buildroot}%{_libdir}
499find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
500  -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
501%endif
502
503# The shared libraries should be executable for debuginfo extraction.
504find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
505  -exec chmod -v +x '{}' '+'
506
507# The libdir libraries are identical to those under rustlib/.  It's easier on
508# library loading if we keep them in libdir, but we do need them in rustlib/
509# to support dynamic linking for compiler plugins, so we'll symlink.
510(cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
511 find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
512 while read lib; do
513   if [ -f "${lib##*/}" ]; then
514     # make sure they're actually identical!
515     cmp "$lib" "${lib##*/}"
516     ln -v -f -s -t . "$lib"
517   fi
518 done)
519 
520# Remove installer artifacts (manifests, uninstall scripts, etc.)
521find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
522
523# Remove backup files from %%configure munging
524find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
525
526# https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
527# We don't actually need to ship any of those python scripts in rust-src anyway.
528
529find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
530
531# FIXME: __os_install_post will strip the rlibs
532# -- should we find a way to preserve debuginfo?
533
534# Remove unwanted documentation files (we already package them)
535# Remove unwanted documentation files (we already package them)
536rm -f %{buildroot}%{_docdir}/%{name}/README.md
537rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
538rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
539rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
540rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
541rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
542rm -f %{buildroot}%{_docdir}/%{name}/*.old
543
544# Sanitize the HTML documentation
545find %{buildroot}%{_docdir}/%{name}/html -empty -delete
546find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
547
548# Create the path for crate-devel packages
549mkdir -p %{buildroot}%{_datadir}/cargo/registry
550
551# Cargo no longer builds its own documentation
552# https://github.com/rust-lang/cargo/pull/4904
553mkdir -p %{buildroot}%{_docdir}/cargo
554ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
555
556%if %{without lldb}
557rm -f %{buildroot}%{_bindir}/rust-lldb
558rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
559%endif
560
561%if %{with bundled_llvm}
562rm -rf %{buildroot}/home
563%endif
564
565
566%check
567%if %{with test}
568%{?cmake_path:export PATH=%{cmake_path}:$PATH}
569%{?library_path:export LIBRARY_PATH="%{library_path}"}
570%{?rustflags:export RUSTFLAGS="%{rustflags}"}
571%if %{with clang}
572export CC=clang
573export CXX=clang++
574export LD=ld.lld
575export RUSTFLAGS="$RUSTFLAGS -C linker=ld.lld -C link-arg=-fuse-ld=lld"
576%endif
577
578# The results are not stable on koji, so mask errors and just log it.
579%{__python} ./x.py test --no-fail-fast || :
580%{__python} ./x.py test --no-fail-fast cargo || :
581%{__python} ./x.py test --no-fail-fast clippy || :
582%{__python} ./x.py test --no-fail-fast rls || :
583%{__python} ./x.py test --no-fail-fast rustfmt || :
584%endif
585
586
587%post -p /sbin/ldconfig
588%postun -p /sbin/ldconfig
589
590
591%files
592%license COPYRIGHT LICENSE-APACHE LICENSE-MIT
593#license src/libbacktrace/LICENSE-libbacktrace
594%doc README.md
595%{_bindir}/rustc
596%{_bindir}/rustdoc
597%{_libdir}/*.so
598%{_mandir}/man1/rustc.1*
599%{_mandir}/man1/rustdoc.1*
600%dir %{rustlibdir}
601%dir %{rustlibdir}/%{rust_triple}
602%dir %{rustlibdir}/%{rust_triple}/lib
603%{rustlibdir}/%{rust_triple}/lib/*.so
604%{rustlibdir}/%{rust_triple}/codegen-backends/
605%exclude %{_bindir}/*miri
606
607
608%files std-static
609%dir %{rustlibdir}
610%dir %{rustlibdir}/%{rust_triple}
611%dir %{rustlibdir}/%{rust_triple}/lib
612%{rustlibdir}/%{rust_triple}/lib/*.rlib
613
614
615%files debugger-common
616%dir %{rustlibdir}
617%dir %{rustlibdir}/etc
618%{rustlibdir}/etc/debugger_*.py*
619
620
621%files gdb
622%{_bindir}/rust-gdb
623%{rustlibdir}/etc/gdb_*.py*
624%exclude %{_bindir}/rust-gdbgui
625
626
627%if %with lldb
628%files lldb
629%{_bindir}/rust-lldb
630%{rustlibdir}/etc/lldb_*.py*
631%endif
632
633
634%files doc
635%docdir %{_docdir}/%{name}
636%dir %{_docdir}/%{name}
637%dir %{_docdir}/%{name}/html
638%{_docdir}/%{name}/html/*/
639%{_docdir}/%{name}/html/*.html
640%{_docdir}/%{name}/html/*.css
641%{_docdir}/%{name}/html/*.ico
642%{_docdir}/%{name}/html/*.js
643%{_docdir}/%{name}/html/*.png
644%{_docdir}/%{name}/html/*.svg
645%{_docdir}/%{name}/html/*.woff
646%{_docdir}/%{name}/html/SourceSerifPro-LICENSE.md
647%license %{_docdir}/%{name}/html/*.txt
648%license %{_docdir}/%{name}/html/*.md
649
650
651%files -n cargo
652%license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
653%doc src/tools/cargo/README.md
654%{_bindir}/cargo
655%{_mandir}/man1/cargo*.1*
656%dir %{_sysconfdir}/bash_completion.d
657%{_sysconfdir}/bash_completion.d/cargo
658%dir %{_datadir}/zsh
659%dir %{_datadir}/zsh/site-functions
660%{_datadir}/zsh/site-functions/_cargo
661%dir %{_datadir}/cargo
662%dir %{_datadir}/cargo/registry
663
664
665%files -n cargo-doc
666%docdir %{_docdir}/cargo
667%dir %{_docdir}/cargo
668%{_docdir}/cargo/html
669
670
671%files -n rustfmt
672%{_bindir}/rustfmt
673%{_bindir}/cargo-fmt
674%doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
675%license src/tools/rustfmt/LICENSE-{APACHE,MIT}
676
677
678%files -n rls
679%{_bindir}/rls
680%doc src/tools/rls/{README.md,COPYRIGHT,debugging.md}
681%license src/tools/rls/LICENSE-{APACHE,MIT}
682
683
684%files -n clippy
685%{_bindir}/cargo-clippy
686%{_bindir}/clippy-driver
687%doc src/tools/clippy/{README.md,CHANGELOG.md}
688%license src/tools/clippy/LICENSE*
689
690
691%files src
692%dir %{rustlibdir}
693%{rustlibdir}/src
694
695
696%files analysis
697%{rustlibdir}/%{rust_triple}/analysis/
698
699%changelog
700* Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.40.0-1
701- new upstream release.
702
703* Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.38.0-1
704- new upstream release.
705- erased "-preview" from the name of subpackages.
706
707* Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
708- new upstream release.
709- dropped Patch1.
710- added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
711
712* Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
713- Update to 1.23.0 (stable).
714
715* Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
716- initial build for Vine Linux.
717- Update to 1.23.0-beta.
718- built a bootstrap rpm.
719
720* Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
721- Update to 1.22.1.
722
723* Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
724- Update to 1.21.0.
725
726* Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
727- ABI fixes for ppc64 and s390x.
728
729* Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
730- Update to 1.20.0.
731- Add a rust-src subpackage.
732
733* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
734- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
735
736* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
737- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
738
739* Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
740- Use find-debuginfo.sh --keep-section .rustc
741
742* Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
743- Update to 1.19.0.
744
745* Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
746- Update to 1.18.0.
747
748* Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
749- Move shared libraries back to libdir and symlink in rustlib
750
751* Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
752- Update to 1.17.0.
753
754* Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
755- Make rust-lldb arch-specific to deal with lldb deps
756
757* Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
758- Limit rust-lldb arches
759
760* Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
761- Update to 1.16.0.
762- Use rustbuild instead of the old makefiles.
763- Update bootstrapping to include rust-std and cargo.
764- Add a rust-lldb subpackage.
765
766* Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
767- Update to 1.15.1.
768- Require rust-rpm-macros for new crate packaging.
769- Keep shared libraries under rustlib/, only debug-stripped.
770- Merge and clean up conditionals for epel7.
771
772* Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
773- Rebuild without bootstrap binaries.
774
775* Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
776- Update to 1.14.0.
777- Rewrite bootstrap logic to target specific arches.
778- Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
779
780* Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
781- Update to 1.13.0.
782- Use hardening flags for linking.
783- Split the standard library into its own package
784- Centralize rustlib/ under /usr/lib/ for multilib integration.
785
786* Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
787- Update to 1.12.1.
788
789* Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
790- Rebuild with LLVM 3.9.
791- Add ncurses-devel for llvm-config's -ltinfo.
792
793* Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
794- Rebuild with llvm-static, preparing for 3.9
795
796* Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
797- Rebuild with fixed eu-strip (rhbz1380961)
798
799* Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
800- Rebuild without bootstrap binaries.
801
802* Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
803- Bootstrap aarch64.
804- Use jemalloc's MALLOC_CONF to work around #36944.
805- Apply pr36933 to really disable armv7hl NEON.
806
807* Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
808- Protect .rustc from rpm stripping.
809
810* Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
811- Update to 1.12.0.
812- Always use --local-rust-root, even for bootstrap binaries.
813- Remove the rebuild conditional - the build system now figures it out.
814- Let minidebuginfo do its thing, since metadata is no longer a note.
815- Let rust build its own compiler-rt builtins again.
816
817* Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
818- Rebuild without bootstrap binaries.
819
820* Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
821- Bootstrap armv7hl, with backported no-neon patch.
822
823* Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
824- Update to 1.11.0.
825- Drop the backported patches.
826- Patch get-stage0.py to trust existing bootstrap binaries.
827- Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
828- Use --local-rust-root to make sure the right bootstrap is used.
829
830* Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
831- Rebuild without bootstrap binaries.
832
833* Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
834- Initial import into Fedora (#1356907), bootstrapped
835- Format license text as suggested in review.
836- Note how the tests already run in parallel.
837- Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
838- Don't let checks fail the whole build.
839- Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
840
841* Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
842- Update -doc directory ownership, and mark its licenses.
843- Package and declare licenses for libbacktrace and hoedown.
844- Set bootstrap_base as a global.
845- Explicitly require python2.
846
847* Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
848- Initial package, bootstrapped
Note: See TracBrowser for help on using the repository browser.