source: projects/specs/trunk/r/rust/rust-vl.spec @ 11321

Revision 11321, 19.0 KB checked in by tomop, 6 years ago (diff)

rust-1.23.0-1, cargo-0.24.0-1

Line 
1%bcond_with bootstrap
2
3%define _unpackaged_files_terminate_build 1
4
5# Only x86_64 and i686 are Tier 1 platforms at this time.
6# https://forge.rust-lang.org/platform-support.html
7%global rust_arches x86_64 i686
8
9# The channel can be stable, beta, or nightly
10%{!?channel: %global channel stable}
11
12# To bootstrap from scratch, set the channel and date from src/stage0.txt
13# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
14# or nightly wants some beta-YYYY-MM-DD
15%global bootstrap_rust 1.22.1
16%global bootstrap_cargo 0.23.0
17%global bootstrap_channel %{bootstrap_rust}
18%global bootstrap_date 2017-10-12
19
20# Only the specified arches will use bootstrap binaries.
21%if %{with bootstrap}
22%global bootstrap_arches %%{rust_arches}
23%endif
24
25# We generally don't want llvm-static present at all, since llvm-config will
26# make us link statically.  But we can opt in, e.g. to aid LLVM rebases.
27# FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
28# *want* static we'll have to force it with "llvm-config --link-static".
29# See also https://github.com/rust-lang/rust/issues/36854
30# The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
31%bcond_with llvm_static
32
33# We can also choose to just use Rust's bundled LLVM, in case the system LLVM
34# is insufficient.  Rust currently requires LLVM 3.7+.
35%bcond_with bundled_llvm
36
37# LLDB only works on some architectures
38%ifarch %{arm} aarch64 %{ix86} x86_64
39# LLDB isn't available everywhere...
40%bcond_without lldb
41%else
42%bcond_with lldb
43%endif
44
45Name:           rust
46Version:        1.23.0
47Release:        1%{?_dist_release}
48Summary:        The Rust Programming Language
49License:        (ASL 2.0 or MIT) and (BSD and ISC and MIT)
50# ^ written as: (rust itself) and (bundled libraries)
51URL:            https://www.rust-lang.org
52ExclusiveArch:  %{rust_arches}
53
54%if "%{channel}" == "stable"
55%global rustc_package rustc-%{version}-src
56%else
57%global rustc_package rustc-%{channel}-src
58%endif
59Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
60
61Patch1:         rust-1.22.0-45566-option-checking.patch
62
63# Get the Rust triple for any arch.
64%{lua: function rust_triple(arch)
65  local abi = "gnu"
66  if arch == "armv7hl" then
67    arch = "armv7"
68    abi = "gnueabihf"
69  elseif arch == "ppc64" then
70    arch = "powerpc64"
71  elseif arch == "ppc64le" then
72    arch = "powerpc64le"
73  end
74  return arch.."-unknown-linux-"..abi
75end}
76
77%global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
78
79%if %defined bootstrap_arches
80# For each bootstrap arch, add an additional binary Source.
81# Also define bootstrap_source just for the current target.
82%{lua: do
83  local bootstrap_arches = {}
84  for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
85    table.insert(bootstrap_arches, arch)
86  end
87  local base = rpm.expand("https://static.rust-lang.org/dist/%{bootstrap_date}"
88                          .."/rust-%{bootstrap_channel}")
89  local target_arch = rpm.expand("%{_target_cpu}")
90  for i, arch in ipairs(bootstrap_arches) do
91    print(string.format("Source%d: %s-%s.tar.gz\n",
92                        i, base, rust_triple(arch)))
93    if arch == target_arch then
94      rpm.define("bootstrap_source "..i)
95    end
96  end
97end}
98%endif
99
100%ifarch %{bootstrap_arches}
101%global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
102%global local_rust_root %{_builddir}/%{bootstrap_root}/usr
103Provides:       bundled(%{name}-bootstrap) = %{bootstrap_rust}
104%else
105BuildRequires:  cargo >= %{bootstrap_cargo}
106BuildRequires:  %{name} >= %{bootstrap_rust}
107BuildConflicts: %{name} > %{version}
108%global local_rust_root %{_prefix}
109%endif
110
111BuildRequires:  cmake
112BuildRequires:  make
113BuildRequires:  gcc
114BuildRequires:  gcc-c++
115BuildRequires:  ncurses-devel
116BuildRequires:  zlib-devel
117BuildRequires:  python
118BuildRequires:  curl
119
120%if %{with bundled_llvm}
121BuildRequires:  cmake
122Provides:       bundled(llvm) = 4.0
123%else
124%if %defined llvm
125%global llvm_root %{_libdir}/%{llvm}
126%else
127%global llvm llvm
128%global llvm_root %{_prefix}
129%endif
130BuildRequires:  %{llvm}-devel >= 3.7
131%if %{with llvm_static}
132BuildRequires:  %{llvm}-static
133BuildRequires:  libffi-devel
134%else
135# Make sure llvm-config doesn't see it.
136BuildConflicts: %{llvm}-static
137%endif
138%endif
139
140# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
141BuildRequires:  procps
142
143# debuginfo-gdb tests need gdb
144BuildRequires:  gdb
145
146# TODO: work on unbundling these!
147Provides:       bundled(hoedown) = 3.0.5
148Provides:       bundled(jquery) = 2.1.4
149Provides:       bundled(libbacktrace) = 6.1.0
150Provides:       bundled(miniz) = 1.14
151
152# Virtual provides for folks who attempt "dnf install rustc"
153Provides:       rustc = %{version}-%{release}
154Provides:       rustc%{?_isa} = %{version}-%{release}
155
156# Always require our exact standard library
157Requires:       %{name}-std-static%{?_isa} = %{version}-%{release}
158
159# The C compiler is needed at runtime just for linking.  Someday rustc might
160# invoke the linker directly, and then we'll only need binutils.
161# https://github.com/rust-lang/rust/issues/11937
162Requires:       /usr/bin/cc
163
164# ALL Rust libraries are private, because they don't keep an ABI.
165%global _privatelibs lib.*-[[:xdigit:]]*[.]so.*
166%global __provides_exclude ^(%{_privatelibs})$
167%global __requires_exclude ^(%{_privatelibs})$
168%global __provides_exclude_from ^%{_docdir}/.*$
169%global __requires_exclude_from ^%{_docdir}/.*$
170
171# While we don't want to encourage dynamic linking to Rust shared libraries, as
172# there's no stable ABI, we still need the unallocated metadata (.rustc) to
173# support custom-derive plugins like #[proc_macro_derive(Foo)].  But eu-strip is
174# very eager by default, so we have to limit it to -g, only debugging symbols.
175%if 0%{?fedora} >= 27
176# Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
177%global _find_debuginfo_opts --keep-section .rustc
178%else
179%global _find_debuginfo_opts -g
180%undefine _include_minidebuginfo
181%endif
182
183# Use hardening ldflags.
184%global rustflags -Clink-arg=-Wl,-z,relro,-z,now
185
186%if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
187# https://github.com/rust-lang/rust/issues/40717
188%global library_path $(%{llvm_root}/bin/llvm-config --libdir)
189%endif
190
191%description
192Rust is a systems programming language that runs blazingly fast, prevents
193segfaults, and guarantees thread safety.
194
195This package includes the Rust compiler and documentation generator.
196
197
198%package std-static
199Summary:        Standard library for Rust
200
201%description std-static
202This package includes the standard libraries for building applications
203written in Rust.
204
205
206%package debugger-common
207Summary:        Common debugger pretty printers for Rust
208BuildArch:      noarch
209
210%description debugger-common
211This package includes the common functionality for %{name}-gdb and %{name}-lldb.
212
213
214%package gdb
215Summary:        GDB pretty printers for Rust
216BuildArch:      noarch
217Requires:       gdb
218Requires:       %{name}-debugger-common = %{version}-%{release}
219
220%description gdb
221This package includes the rust-gdb script, which allows easier debugging of Rust
222programs.
223
224
225%if %{with lldb}
226
227%package lldb
228Summary:        LLDB pretty printers for Rust
229
230# It could be noarch, but lldb has limited availability
231#BuildArch:      noarch
232
233Requires:       lldb
234Requires:       python-lldb
235Requires:       %{name}-debugger-common = %{version}-%{release}
236
237%description lldb
238This package includes the rust-lldb script, which allows easier debugging of Rust
239programs.
240
241%endif
242
243
244%package doc
245Summary:        Documentation for Rust
246# NOT BuildArch:      noarch
247# Note, while docs are mostly noarch, some things do vary by target_arch.
248# Koji will fail the build in rpmdiff if two architectures build a noarch
249# subpackage differently, so instead we have to keep its arch.
250
251%description doc
252This package includes HTML documentation for the Rust programming language and
253its standard library.
254
255
256%package src
257Summary:        Sources for the Rust standard library
258BuildArch:      noarch
259
260%description src
261This package includes source files for the Rust standard library.  It may be
262useful as a reference for code completion tools in various editors.
263
264
265%prep
266
267%ifarch %{bootstrap_arches}
268%setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
269./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
270  --prefix=%{local_rust_root} --disable-ldconfig
271test -f '%{local_rust_root}/bin/cargo'
272test -f '%{local_rust_root}/bin/rustc'
273%endif
274
275%setup -q -n %{rustc_package}
276
277# We're disabling jemalloc, but rust-src still wants it.
278# rm -rf src/jemalloc/
279
280%if %without bundled_llvm
281rm -rf src/llvm/
282%endif
283
284# extract bundled licenses for packaging
285cp src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
286sed -e '/*\//q' src/libbacktrace/backtrace.h \
287  >src/libbacktrace/LICENSE-libbacktrace
288
289# This tests a problem of exponential growth, which seems to be less-reliably
290# fixed when running on older LLVM and/or some arches.  Just skip it for now.
291sed -i.ignore -e '1i // ignore-test may still be exponential...' \
292  src/test/run-pass/issue-41696.rs
293
294%if %{with bundled_llvm} && 0%{?epel}
295mkdir -p cmake-bin
296ln -s /usr/bin/cmake cmake-bin/cmake
297%global cmake_path $PWD/cmake-bin
298%endif
299
300%if %{without bundled_llvm} && %{with llvm_static}
301# Static linking to distro LLVM needs to add -lffi
302# https://github.com/rust-lang/rust/issues/34486
303sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
304  src/librustc_llvm/lib.rs
305%endif
306
307%global _default_patch_fuzz 1
308#%patch1 -p1 -b .option-checking
309
310# The configure macro will modify some autoconf-related files, which upsets
311# cargo when it tries to verify checksums in those files.  If we just truncate
312# that file list, cargo won't have anything to complain about.
313find src/vendor -name .cargo-checksum.json \
314  -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
315
316
317%build
318
319%{?cmake_path:export PATH=%{cmake_path}:$PATH}
320%{?library_path:export LIBRARY_PATH="%{library_path}"}
321%{?rustflags:export RUSTFLAGS="%{rustflags}"}
322
323# We're going to override --libdir when configuring to get rustlib into a
324# common path, but we'll fix the shared libraries during install.
325%global common_libdir %{_prefix}/lib
326%global rustlibdir %{common_libdir}/rustlib
327
328%ifarch %{arm}
329# full debuginfo is exhausting memory; just do libstd for now
330# https://github.com/rust-lang/rust/issues/45854
331%define enable_debuginfo --enable-debuginfo --enable-debuginfo-only-std --disable-debuginfo-lines
332%else
333%define enable_debuginfo --enable-debuginfo --disable-debuginfo-only-std --disable-debuginfo-lines
334%endif
335
336%configure \
337  --enable-full-bootstrap \
338  --disable-option-checking \
339  --libdir=%{common_libdir} \
340  --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
341  --enable-local-rust --local-rust-root=%{local_rust_root} \
342  %{!?with_bundled_llvm: --llvm-root=%{llvm_root} --disable-codegen-tests \
343    %{!?with_llvm_static: --enable-llvm-link-shared } } \
344  --disable-jemalloc \
345  --disable-rpath \
346  %{enable_debuginfo} \
347  --enable-vendor \
348  --release-channel=%{channel}
349
350%ifarch x86_64
351RUST_BACKTRACE=1 ./x.py build
352%else
353RUST_BACKTRACE=1 ./x.py build -i
354%endif
355./x.py doc
356
357
358%install
359%{?cmake_path:export PATH=%{cmake_path}:$PATH}
360%{?library_path:export LIBRARY_PATH="%{library_path}"}
361%{?rustflags:export RUSTFLAGS="%{rustflags}"}
362
363DESTDIR=%{buildroot} ./x.py install
364DESTDIR=%{buildroot} ./x.py install src
365
366
367# Make sure the shared libraries are in the proper libdir
368%if "%{_libdir}" != "%{common_libdir}"
369mkdir -p %{buildroot}%{_libdir}
370find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
371  -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
372%endif
373
374# The shared libraries should be executable for debuginfo extraction.
375find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
376  -exec chmod -v +x '{}' '+'
377
378# The libdir libraries are identical to those under rustlib/.  It's easier on
379# library loading if we keep them in libdir, but we do need them in rustlib/
380# to support dynamic linking for compiler plugins, so we'll symlink.
381(cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
382 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
383   -exec ln -v -f -s -t . '{}' '+')
384
385# Remove installer artifacts (manifests, uninstall scripts, etc.)
386find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
387
388# FIXME: __os_install_post will strip the rlibs
389# -- should we find a way to preserve debuginfo?
390
391# Remove unwanted documentation files (we already package them)
392rm -f %{buildroot}%{_docdir}/%{name}/README.md
393rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
394rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
395rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
396
397# Sanitize the HTML documentation
398find %{buildroot}%{_docdir}/%{name}/html -empty -delete
399find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
400
401%if %{without lldb}
402rm -f %{buildroot}%{_bindir}/rust-lldb
403rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
404%endif
405
406
407%check
408%{?cmake_path:export PATH=%{cmake_path}:$PATH}
409%{?library_path:export LIBRARY_PATH="%{library_path}"}
410%{?rustflags:export RUSTFLAGS="%{rustflags}"}
411
412# The results are not stable on koji, so mask errors and just log it.
413./x.py test --no-fail-fast || :
414
415
416%post -p /sbin/ldconfig
417%postun -p /sbin/ldconfig
418
419
420%files
421%license COPYRIGHT LICENSE-APACHE LICENSE-MIT
422%license src/libbacktrace/LICENSE-libbacktrace
423%license src/rt/hoedown/LICENSE-hoedown
424%doc README.md
425%{_bindir}/rustc
426%{_bindir}/rustdoc
427%{_libdir}/*.so
428%{_mandir}/man1/rustc.1*
429%{_mandir}/man1/rustdoc.1*
430%dir %{rustlibdir}
431%dir %{rustlibdir}/%{rust_triple}
432%dir %{rustlibdir}/%{rust_triple}/lib
433%{rustlibdir}/%{rust_triple}/lib/*.so
434
435
436%files std-static
437%dir %{rustlibdir}
438%dir %{rustlibdir}/%{rust_triple}
439%dir %{rustlibdir}/%{rust_triple}/lib
440%{rustlibdir}/%{rust_triple}/lib/*.rlib
441
442
443%files debugger-common
444%dir %{rustlibdir}
445%dir %{rustlibdir}/etc
446%{rustlibdir}/etc/debugger_*.py*
447
448
449%files gdb
450%{_bindir}/rust-gdb
451%{rustlibdir}/etc/gdb_*.py*
452
453
454%if %with lldb
455%files lldb
456%{_bindir}/rust-lldb
457%{rustlibdir}/etc/lldb_*.py*
458%endif
459
460
461%files doc
462%docdir %{_docdir}/%{name}
463%dir %{_docdir}/%{name}
464%dir %{_docdir}/%{name}/html
465%{_docdir}/%{name}/html/*/
466%{_docdir}/%{name}/html/*.html
467%{_docdir}/%{name}/html/*.css
468%{_docdir}/%{name}/html/*.js
469%{_docdir}/%{name}/html/*.woff
470%license %{_docdir}/%{name}/html/*.txt
471
472
473%files src
474%dir %{rustlibdir}
475%{rustlibdir}/src
476
477
478%changelog
479* Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
480- Update to 1.23.0 (stable).
481
482* Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
483- initial build for Vine Linux.
484- Update to 1.23.0-beta.
485- built a bootstrap rpm.
486
487* Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
488- Update to 1.22.1.
489
490* Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
491- Update to 1.21.0.
492
493* Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
494- ABI fixes for ppc64 and s390x.
495
496* Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
497- Update to 1.20.0.
498- Add a rust-src subpackage.
499
500* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
501- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
502
503* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
504- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
505
506* Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
507- Use find-debuginfo.sh --keep-section .rustc
508
509* Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
510- Update to 1.19.0.
511
512* Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
513- Update to 1.18.0.
514
515* Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
516- Move shared libraries back to libdir and symlink in rustlib
517
518* Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
519- Update to 1.17.0.
520
521* Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
522- Make rust-lldb arch-specific to deal with lldb deps
523
524* Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
525- Limit rust-lldb arches
526
527* Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
528- Update to 1.16.0.
529- Use rustbuild instead of the old makefiles.
530- Update bootstrapping to include rust-std and cargo.
531- Add a rust-lldb subpackage.
532
533* Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
534- Update to 1.15.1.
535- Require rust-rpm-macros for new crate packaging.
536- Keep shared libraries under rustlib/, only debug-stripped.
537- Merge and clean up conditionals for epel7.
538
539* Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
540- Rebuild without bootstrap binaries.
541
542* Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
543- Update to 1.14.0.
544- Rewrite bootstrap logic to target specific arches.
545- Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
546
547* Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
548- Update to 1.13.0.
549- Use hardening flags for linking.
550- Split the standard library into its own package
551- Centralize rustlib/ under /usr/lib/ for multilib integration.
552
553* Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
554- Update to 1.12.1.
555
556* Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
557- Rebuild with LLVM 3.9.
558- Add ncurses-devel for llvm-config's -ltinfo.
559
560* Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
561- Rebuild with llvm-static, preparing for 3.9
562
563* Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
564- Rebuild with fixed eu-strip (rhbz1380961)
565
566* Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
567- Rebuild without bootstrap binaries.
568
569* Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
570- Bootstrap aarch64.
571- Use jemalloc's MALLOC_CONF to work around #36944.
572- Apply pr36933 to really disable armv7hl NEON.
573
574* Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
575- Protect .rustc from rpm stripping.
576
577* Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
578- Update to 1.12.0.
579- Always use --local-rust-root, even for bootstrap binaries.
580- Remove the rebuild conditional - the build system now figures it out.
581- Let minidebuginfo do its thing, since metadata is no longer a note.
582- Let rust build its own compiler-rt builtins again.
583
584* Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
585- Rebuild without bootstrap binaries.
586
587* Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
588- Bootstrap armv7hl, with backported no-neon patch.
589
590* Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
591- Update to 1.11.0.
592- Drop the backported patches.
593- Patch get-stage0.py to trust existing bootstrap binaries.
594- Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
595- Use --local-rust-root to make sure the right bootstrap is used.
596
597* Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
598- Rebuild without bootstrap binaries.
599
600* Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
601- Initial import into Fedora (#1356907), bootstrapped
602- Format license text as suggested in review.
603- Note how the tests already run in parallel.
604- Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
605- Don't let checks fail the whole build.
606- Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
607
608* Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
609- Update -doc directory ownership, and mark its licenses.
610- Package and declare licenses for libbacktrace and hoedown.
611- Set bootstrap_base as a global.
612- Explicitly require python2.
613
614* Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
615- Initial package, bootstrapped
Note: See TracBrowser for help on using the repository browser.