source: projects/specs/trunk/r/rubysdl/rubysdl-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: rubysdl
2Version: 2.0.1b
3Release: 1%{?_dist_release}
4License: LGPL
5Group: Development/Libraries
6Source: http://rubyforge.org/frs/download.php/40059/%{name}-%{version}.tar.gz
7URL: http://www.kmc.gr.jp/~ohai/index.html
8
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: ruby, ruby-devel >= 1.8.1-0vl6
11BuildRequires: SDL-devel, SDL_mixer-devel, SDL_image-devel, SDL_ttf-devel, smpeg-devel
12Summary: Ruby/SDL is the Ruby extension library to use SDL
13Summary(ja): Ruby/SDLはRubyからSDLを使うための拡張ライブラリ
14
15%description
16Ruby/SDL is the ruby extension library to use SDL.  SDL(Simple
17DirectMedia Layer) is a cross-platform multimedia library designed to
18provide fast access to the graphics framebuffer and audio device. See
19http://www.libsdl.org/ if you want to know SDL in detail.
20
21%description -l ja
22Ruby/SDLはRubyからSDLを使うための拡張ライブラリです.SDL(Simple
23DirectMedia Layer)は様々なプラットホームで動作するように作られたマルチ
24メディアライブラリで,グラフィックフレームバッファやオーディオデバイス
25にアクセスすることができます.SDLについての詳しい情報は
26http://www.libsdl.org/から得られます.
27
28%prep
29%setup -q -c
30
31%build
32cd %{name}-%{version}
33ruby extconf.rb
34make
35cd ..
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
40
41# installing binaries ...
42cd %{name}-%{version}
43make DESTDIR=${RPM_BUILD_ROOT} sitelibdir=${RPM_BUILD_ROOT}%{rlibdir} install
44cd ..
45
46(find \
47  $RPM_BUILD_ROOT%{_libdir} \
48      -type f -o -type l) |
49 sort | sed -e "s,^$RPM_BUILD_ROOT,," > rubysdl.files
50
51%clean
52rm -f rubysdl.files
53rm -rf ${RPM_BUILD_ROOT}
54
55%pre
56
57%post
58
59%files -f rubysdl.files
60%defattr(-, root, root)
61%doc %{name}-%{version}/README*
62%doc %{name}-%{version}/*.rd
63%doc %{name}-%{version}/rubysdl_const_list.txt
64%doc %{name}-%{version}/sample
65
66%changelog
67* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1b-1
68- new upstream release
69- applied new versioning policy
70- spec in UTF-8
71
72* Wed May 04 2005 Satoshi MACHINO <machino@vinelinux.org> 0.9.4-0vl2
73- fixed distribted files
74
75* Tue May 03 2005 Satoshi MACHINO <machino@vinelinux.org> 0.9.4-0vl1
76- new upstream version
77
78* Wed May 05 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.2-0vl1
79- new upstream version
80- built by ruby-1.8.1 and SDL-1.2.7
81
82* Sun Oct 13 2002 Satoshi MACHINO <machino@vinelinux.org> 0.8.2-0vl1
83- new upstream version.
84- change URL
85
86* Sat Jul 05 2002 Satoshi MACHINO <machino@vinelinux.org> 0.8.1-0vl1
87- new upstream version.
88
89* Tue Jul 02 2002 Satoshi MACHINO <machino@vinelinux.org> 0.8-0vl1
90- new upstream version.
91
92* Wed Oct 31 2001 akira yamada <akira@vinelinux.org> 0.7-0vl1
93- new upstream version.
94
95* Sat Oct 27 2001 akira yamada <akira@vinelinux.org> 0.6-0vl1
96- Initial packaging.
Note: See TracBrowser for help on using the repository browser.