source: projects/specs/trunk/r/ruby-xmlparser/ruby-xmlparser-vl.spec @ 521

Revision 521, 1.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define oname xmlparser
2%define libdir  %(ruby -r rbconfig -e 'print Config::CONFIG["libdir"]')
3%define archdir %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')
4
5Name: ruby-xmlparser
6Version: 0.6.1
7Release: 0vl2
8Copyright: distributable
9Group: Development/Languages
10Source: http://www.yoshidam.net/%{oname}-%{version}.tar.gz
11URL: http://www.yoshidam.net/Ruby.html#xmlparser
12Prefix: /usr
13BuildRoot: %{_tmppath}/%{oname}-%{version}-root
14BuildPreReq: ruby, ruby-devel >= 1.6.4-0vl3, diffutils
15BuildRequires: expat-devel
16Summary: The interface of expat for the scripting language Ruby.
17Summary(ja): RubyÍѤÎexpat¥¤¥ó¥¿¥Õ¥§¡¼¥¹
18
19%description
20This is the module to access to James Clark's XML Parser Toolkit "expat"
21<URL:http://www.jclark.com/xml/expat.html> from Ruby.
22
23%description -l ja
24Ruby¤«¤éJames Clark¤ÎXML¥Ñ¡¼¥¶¥Ä¡¼¥ë¥­¥Ã¥È¤Ç¤¢¤ëexpat¤òÍøÍѤ¹¤ë¤¿¤á¤Î
25¥¯¥é¥¹¥é¥¤¥Ö¥é¥ê¤Ç¤¹¡¥
26
27%prep
28
29%setup -q -c
30
31%build
32cd %{oname}
33ruby extconf.rb
34make
35cd ..
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
40
41# installing binaries ...
42cd %{oname}
43make install DESTDIR=${RPM_BUILD_ROOT}
44cd ..
45
46(find \
47  $RPM_BUILD_ROOT%{_libdir} \
48      -type f -o -type l) |
49 sort | sed -e "s,^$RPM_BUILD_ROOT,," > ruby-xmlparser.files
50
51# fixing `#!' paths
52mkdir -p tmp/samples
53(cd %{oname}/samples && tar cf - .) | (cd tmp/samples && tar xf -)
54for f in `find tmp/samples -type f`
55do
56  cp -p $f $f.n
57  sed -e 's,^#![        ]*\([^  ]*\)/\(ruby\|with\|perl\|env\),#!/usr/bin/\2,' < $f > $f.n
58  if cmp -s $f $f.n
59  then
60    rm -f $f.n
61  else
62    mv -f $f.n $f
63  fi
64done
65
66%clean
67rm -f ruby-xmlparser.files
68rm -rf tmp
69rm -rf ${RPM_BUILD_ROOT}
70
71%pre
72
73%post
74
75%files -f ruby-xmlparser.files
76%defattr(-, root, root)
77%doc %{oname}/README
78%doc %{oname}/README.ja
79%doc %{oname}/Encodings
80%doc tmp/samples
81
82%changelog
83* Sun Oct 14 2001 akira yamada <akira@vinelinux.org> 0.6.1-0vl2
84- fixed shbang line of sample scripts.
85
86* Sun Oct 14 2001 akira yamada <akira@vinelinux.org> 0.6.1-0vl1
87- Initial packaging.
Note: See TracBrowser for help on using the repository browser.