source: projects/specs/trunk/r/ruby-uconv/ruby-uconv-vl.spec @ 521

Revision 521, 2.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define oname uconv
2
3Name: ruby-uconv
4Version: 0.4.12
5Release: 1%{?_dist_release}
6License: distributable
7Group: Development/Languages
8Source: http://www.yoshidam.net/%{oname}-%{version}.tar.gz
9URL: http://www.yoshidam.net/Ruby_ja.html#uconv
10Prefix: /usr
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildPreReq: ruby, ruby-devel >= 1.6.4-0vl3, diffutils
13Summary: library for Ruby that converts UTF-8/16, UCS-4 <-> EUC-JP/Shift_JIS
14Summary(ja): UTF-8/16, UCS-4とEUC-JP/Shift_JISを相互変換するRubyライブラリ
15
16%description
17Uconv module provides the methods to convert UTF-16, UTF-8 or UCS-4 into
18EUC-JP or CP932, and EUC-JP or CP932 into UTF-16, UTF-8 or UCS-4.
19
20%description -l ja
21UTF-16, UTF-8, UCS-4 と EUC-JP, Shift_JIS を相互に変換します.実際
22Shift_JIS を使うのは Windows の場合が多いので,Windows で使われている
23Shift_JIS の変種である CP932 に対応しています.
24
25%prep
26
27%setup -q -c
28
29%build
30cd %{oname}
31ruby extconf.rb
32make
33cd ..
34
35%install
36rm -rf ${RPM_BUILD_ROOT}
37mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
38
39# installing binaries ...
40cd %{oname}
41make install DESTDIR=${RPM_BUILD_ROOT} sitelibdir=${RPM_BUILD_ROOT}%{rlibdir}
42cd ..
43
44(find \
45  $RPM_BUILD_ROOT%{_libdir} \
46      -type f -o -type l) |
47 sort | sed -e "s,^$RPM_BUILD_ROOT,," > ruby-uconv.files
48
49# fixing `#!' paths
50#mkdir -p tmp/samples
51#(cd %{oname}/samples && tar cf - .) | (cd tmp/samples && tar xf -)
52#for f in `find tmp/samples -type f`
53#do
54#  cp -p $f $f.n
55#  sed -e 's,^#![       ]*\([^  ]*\)/\(ruby\|with\|perl\|env\),#!/usr/bin/\2,' < $f > $f.n
56#  if cmp -s $f $f.n
57#  then
58#    rm -f $f.n
59#  else
60#    mv -f $f.n $f
61#  fi
62#done
63
64%clean
65rm -f ruby-uconv.files
66rm -rf tmp
67rm -rf ${RPM_BUILD_ROOT}
68
69%pre
70
71%post
72
73%files -f ruby-uconv.files
74%defattr(-, root, root)
75%doc %{oname}/README
76%doc %{oname}/README.ja
77#%doc tmp/samples
78
79%changelog
80* Fri Jul 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-1
81- new versioning policy
82
83* Wed Feb 09 2005 Satoshi MACHINO <machino@vinelinux.org> 0.4.12-0vl2
84- fixed %files
85        --added uconv.so
86        --removed samples (don't include in sourcce)
87 
88* Wed Feb 09 2005 Satoshi MACHINO <machino@vinelinux.org> 0.4.12-0vl0.31
89- rebuilt for VineLinux3.1(VinePlus)
90- changed to License from Copylight
91
92* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 0.4.12-0vl1
93- new upstream release
94
95* Tue Feb 12 2002 akira yamada <akira@vinelinux.org> 0.4.9-0vl1
96- new upstream release.
97
98* Tue Dec 11 2001 akira yamada <akira@vinelinux.org> 0.4.8-0vl1
99- new upstream release.
100
101* Sun Oct 14 2001 akira yamada <akira@vinelinux.org> 0.4.6-0vl1
102- Initial packaging.
Note: See TracBrowser for help on using the repository browser.