source: projects/specs/trunk/r/ruby-ldap/ruby-ldap-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: ruby-ldap
2Version: 0.9.7
3Release: 1%{?_dist_release}
4License: BSD
5Group: Development/Libraries
6Source: http://prdownloads.sourceforge.net/ruby-ldap/%{name}-%{version}.tar.gz
7URL: http://ruby-ldap.sourceforge.net
8BuildRoot: %{_tmppath}/%{name}-%{version}-root
9BuildRequires: ruby, ruby-devel >= 1.8
10BuildRequires: openldap-devel >= 2.0
11BuildRequires: openssl-devel
12Summary: Interface to some LDAP libraries for Ruby
13Summary(ja): Ruby 用の LDAP ライブラリへのインタフェース
14
15%description
16Ruby/LDAP is an extension module for Ruby, it provides the interface to some
17LDAP libraries (for example, OpenLDAP, UMich LDAP, Netscape SDK). The common
18API for application developments is described in RFC1823, Most of libraries
19comply with it. Ruby/LDAP supports those libraries.
20
21%description -l ja
22Ruby/LDAP は Ruby 用の拡張ライブラりで,各種 LDAP ライブラリ(OpenLDAP, UMich
23LDAP, Netscape SDKなど)に対するインタフェースを提供します.API は RFC1823 に
24記述されています.
25
26%prep
27%setup -q -c
28
29%build
30cd %{name}-%{version}
31ruby extconf.rb \
32  --with-openldap2 \
33  --with-libssl=/usr/include/openssl
34make
35cd ..
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
40
41# installing binaries ...
42cd %{name}-%{version}
43make install sitedir=${RPM_BUILD_ROOT}%{_libdir}/ruby
44cd ..
45
46(find \
47  $RPM_BUILD_ROOT%{_libdir} \
48      -type f -o -type l) |
49 sort | sed -e "s,^$RPM_BUILD_ROOT,," > ruby-ldap.files
50
51%clean
52rm -f ruby-ldap.files
53rm -rf ${RPM_BUILD_ROOT}
54
55%pre
56
57%post
58
59%files -f ruby-ldap.files
60%defattr(-, root, root)
61%doc %{name}-%{version}/ChangeLog
62%doc %{name}-%{version}/FAQ
63%doc %{name}-%{version}/README
64%doc %{name}-%{version}/TODO
65%doc %{name}-%{version}/example
66%doc %{name}-%{version}/test
67
68%changelog
69* Thu Apr  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-1
70- applied new versioning policy, spec in UTF-8
71- rebuilt with openldap-2.4.11
72
73* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl2
74- rebuilt with openssl-0.9.8e
75
76* Sat Sep 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
77- new upstream version.
78- rebuilt with ruby 1.8.4 and openldap 2.3.27
79
80* Mon Dec 08 2003 akira yamada <akira@vinelinux.org> 0.8.2-0vl1
81- new upstream version.
82- build with Ruby 1.8.
83
84* Thu Jul 25 2002 Satoshi MACHINO <macino@vinelinux.org> 0.7.1-0vl1
85- new upstream version.
86
87* Tue Jul 02 2002 Satoshi MACHINO <macino@vinelinux.org> 0.7.0-0vl1
88- new upstream version.
89
90* Wed Apr 03 2002 Satoshi MACHINO <macino@vinelinux.org> 0.6.1-0vl1
91- new upstream version.
92
93* Mon Mar 18 2002 akira yamada <akira@vinelinux.org> 0.6.0-0vl1
94- new upstream version.
95
96* Wed Jan 09 2002 Satoshi MACHINO <machino@vinelinux.org> 0.5.0-0vl1
97- update ruby-ldap-0.5.0
98- update BuildPreReq's ruby version to 1.6.6-0vl3
99
100* Mon Dec 10 2001 akira yamada <akira@vinelinux.org> 0.4.0-0vl1
101- Initial packaging.
Note: See TracBrowser for help on using the repository browser.