source: projects/specs/trunk/r/rubber/rubber-vl.spec @ 5701

Revision 5701, 3.1 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1# sitelib for noarch packages, sitearch for others (remove the unneeded one)
2%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3
4Name: rubber
5Version: 1.1
6Release: 2%{?_dist_release}
7Summary: An automated system for building LaTeX documents
8
9Group: Applications/Publishing
10License: GPL+
11
12URL: http://rubber.sourceforge.net/
13
14Source0: http://rubber.sourceforge.net/%{name}-%{version}.tar.gz
15
16Patch0: rubber-python26.patch
17
18BuildRoot:  %{_tmppath}/%{name}-%{version}-root
19
20BuildArch: noarch
21
22BuildRequires: python-devel texinfo
23
24Requires: texlive
25
26Requires(post): /sbin/install-info
27Requires(preun): /sbin/install-info
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33This is a building system for LaTeX documents. It is based on a routine that
34runs just as many compilations as necessary. The module system provides a
35great flexibility that virtually allows support for any package with no user
36intervention, as well as pre- and post-processing of the document. The
37standard modules currently provide support for bibtex, dvips, dvipdfm, pdftex,
38makeindex. A good number of standard packages are supported, including
39graphics/graphicx (with automatic conversion between various formats and
40Metapost compilation).
41
42%prep
43%setup -q
44%patch0 -p1
45for file in doc/man-fr/*; do
46iconv -f ISO88591 -t utf8 $file -o $file
47done
48
49%build
50%configure
51%{__make} %{?_smp_mflags}
52
53%install
54%{__rm} -fr %{buildroot}
55%{__python} setup.py install --root  %{buildroot}
56
57%clean
58%{__rm} -fr %{buildroot}
59
60%post
61/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
62
63%preun
64if [ $1 = 0 ]; then
65    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
66fi
67
68%files
69%defattr(-,root,root,-)
70%doc COPYING NEWS README
71%{_bindir}/*
72%{_datadir}/rubber
73%{_datadir}/info/*
74%{python_sitelib}/*
75%{_mandir}/man1/*.gz
76%{_mandir}/fr/man1/*.gz
77
78%changelog
79* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1-2
80- rebuild with python-2.7.2
81
82* Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1-1
83- initial build for Vine Linux
84
85
86* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
88
89* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com>
90- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
91
92* Mon Dec 28 2009 Sergio Pascual <sergiopr@fedoraproject.org>
93- Adding virtual dependency on latex (bz #550792)
94
95* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
97
98* Mon Jun 15 2009 Sergio Pascual <sergiopr@fedoraproject.org>
99- Patch to remove a Deprecation Warning in Python 2.6 (bz #506053)
100
101* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
103
104* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com>
105- Rebuild for Python 2.6
106
107* Wed Sep 17 2008 Sergio Pascual <sergiopr@fedoraproject.org>
108- ***
109
110* Wed Sep 17 2008 Sergio Pascual <sergiopr@fedoraproject.org>
111- Initial specfile
112
Note: See TracBrowser for help on using the repository browser.