source: projects/specs/trunk/r/rpm49/rpm49-vl.spec @ 6824

Revision 6824, 30.4 KB checked in by daisuke, 12 years ago (diff)

new package fot compatibility

Line 
1# new vine linux release number
2%define _dist_release vl%(cat /etc/vine-release | cut -f3 -d" " | cut -f1 -d.)
3
4%define with_python_subpackage  0%{nil}
5%define with_python_version     2.7%{nil}
6%define with_apidocs            0%{nil}
7
8# XXX legacy requires './' payload prefix to be omitted from rpm packages.
9%define _noPayloadPrefix        1
10
11%define __prefix        %{?_prefix}%{!?_prefix:/usr}
12%{?!_lib: %define _lib lib}
13%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
14
15%define __bindir        %{__prefix}/bin
16%define __includedir    %{__prefix}/include
17%define __libdir        %{__prefix}/%{_lib}
18%define __share         %{__prefix}/share
19%define __mandir        %{__share}/man
20
21%define rpmhome         %{_prefix}/lib/rpm
22
23Summary: The RPM package management system.
24Summary(ja): RPM パッケージ管理システム
25Name: rpm49
26Version: 4.9.1.3
27%{expand: %%define rpm_version %{version}}
28Release: 1%{_dist_release}
29Group: System Environment/Base
30License: GPL
31
32Source: http://rpm.org/releases/rpm-4.8.x/rpm-%{version}.tar.bz2
33Source100: rpm-4.9.1.2-ja.po
34Source110: GROUPS_for_vine.txt
35Source120: GROUPS-DESC_for_vine.txt
36Source130: COMPAT32_for_vine
37
38Source200: rpm44-perldeps.pl
39
40Patch1: rpm-4.5.90-pkgconfig-path.patch
41
42#conditionally applied patch for arm hardware floating point
43Patch5: rpm-4.9.0-armhfp.patch
44
45# Patches already in upstream
46Patch100: rpm-4.9.x-fontattr.patch
47Patch101: rpm-4.9.x-elfattr.patch
48Patch102: rpm-4.9.1.2-perl-python-attr.patch
49Patch103: rpm-4.9.x-mpsize.patch
50Patch104: rpm-4.9.x-rpmdb-dsi.patch
51Patch105: rpm-4.9.x-python-memleaks.patch
52Patch106: rpm-4.9.x-verify-output.patch
53Patch107: rpm-4.9.x-include-cond.patch
54Patch108: rpm-4.9.x-exclude-warn.patch
55Patch109: rpm-4.9.x-tstest-fileinfo.patch
56
57# These are not yet upstream
58Patch301: rpm-4.6.0-niagara.patch
59Patch302: rpm-4.7.1-geode-i686.patch
60# Probably to be upstreamed in slightly different form
61Patch304: rpm-4.9.1.1-ld-flags.patch
62# Based on patch from OpenSUSE, without the C-lang related enhancements
63Patch305: rpm-4.9.x-gnome-help.patch
64# Just warn on STABS instead of failing for now
65Patch306: rpm-4.9.x-debugedit-stabs-warn.patch
66# Recognize Perl script as Perl code
67Patch401: rpm-4.9.1.2-perl-script.patch
68
69
70# Patches for Vine Linux
71Patch1100: rpm-4.9.1.2-vine.patch
72Patch1120: rpm-4.0.4-langC.patch
73#Patch1130: rpm-4.8.0-home.patch
74Patch1140: rpm-4.9.1.2-shortcircuit.patch
75Patch1170: rpm-4.9.1.2-legacyaliases.patch
76Patch1180: rpm-4.4.3-no-terminate_build.patch
77Patch1190: rpm-4.9.1.2-disable-python-requires.patch
78#Patch1200: rpm-4.4.2-use-external-depgen.patch
79Patch1210: rpm-4.4.2-deadlock-ppc.patch
80Patch1220: rpm-4.9.1.2-disable-debug.patch
81Patch1230: rpm-4.9.1.2-optflags.patch
82Patch1240: rpm-4.8.0-default-buildarch.patch
83Patch1250: rpm-4.4.2-add-default-srcdefattr.patch
84Patch1260: rpm-4.4.2-man-fix-typo.patch
85Patch1270: rpm-4.4.2-vine-groups.patch
86Patch1290: rpm-4.4.2.3-find-mono-dependencies.patch
87Patch1310: rpm-4.9.1.2-brp-strip-static-archive-find-a-only.patch
88Patch1320: rpm-4.9.1.2-force-v3-sigs.patch
89Patch1330: rpm-4.9.1.2-enable-xz-payload.patch
90Patch1340: rpm-4.9.1.2-disable-rpmbuild-sign.patch
91
92Conflicts: patch < 2.5
93Requires(post): coreutils, shadow-utils
94Requires(postun): coreutils, shadow-utils
95
96Requires: popt >= 1.10.2.1
97Requires: nss >= 3.12.5
98Requires: rpm-libs = %{version}
99Requires: db4-utils
100
101Obsoletes: rpm-perl < %{version}
102
103# XXX necessary only to drag in /usr/lib/libelf.a, otherwise internal elfutils.
104#BuildRequires: elfutils-libelf
105BuildRequires: elfutils-devel
106
107BuildRequires: automake, autoconf
108BuildRequires: sed readline-devel zlib-devel
109BuildRequires: neon-devel
110BuildRequires: sqlite3-devel
111BuildRequires: gettext
112#BuildRequires: nkf
113BuildRequires: cvs
114#BuildRequires: libselinux-devel
115BuildRequires: bzip2-devel >= 0.9.0c-2
116BuildRequires: popt-devel
117BuildRequires: lua-devel
118BuildRequires: libcap-devel
119BuildRequires: libacl-devel
120BuildRequires: nss-devel
121BuildRequires: db4-devel >= 4.8
122BuildRequires: xz-devel
123BuildRequires: file-devel
124
125%if %{with_python_subpackage}
126BuildRequires: python-devel >= %{with_python_version}
127%endif
128
129BuildRoot: %{_tmppath}/%{name}-root
130
131Vendor: Project Vine
132Distribution: Vine Linux
133
134%description
135The RPM Package Manager (RPM) is a powerful command line driven
136package management system capable of installing, uninstalling,
137verifying, querying, and updating software packages. Each software
138package consists of an archive of files along with information about
139the package like its version, a description, etc.
140
141%description -l ja
142RPM パッケージマネージャ (RPM) は,ソフトウェアパッケージを
143インストール/アンインストール/チェック/問い合わせ/アップデート
144する機能を持った高機能パッケージマネージングシステムです.
145各パッケージには,ファイルのアーカイブに加え,名前,バージョン,
146説明などのパッケージ情報が含まれています.
147
148%package libs
149Summary:  Libraries for manipulating RPM packages.
150Summary(ja): RPMパッケージを操作するライブラリ
151Group: Development/Libraries
152Conflicts: rpm-libs < 4.10.0-1
153
154%description libs
155This package contains the RPM shared libraries.
156
157%description libs -l ja
158このパッケージには RPM の共有ライブラリが含まれています。
159
160%package devel
161Summary:  Development files for manipulating RPM packages.
162Summary(ja): RPM ライブラリ用の開発ファイル
163Group: Development/Libraries
164Requires: rpm = %{rpm_version}-%{release}
165Requires: beecrypt >= 4.1.2
166Requires: neon-devel
167Requires: sqlite3-devel
168Requires: popt-devel
169#Requires: libselinux-devel
170#Requires: elfutils-libelf-devel
171
172%description devel
173This package contains the RPM C library and header files. These
174development files will simplify the process of writing programs that
175manipulate RPM packages and databases. These files are intended to
176simplify the process of creating graphical package managers or any
177other tools that need an intimate knowledge of RPM packages in order
178to function.
179
180This package should be installed if you want to develop programs that
181will manipulate RPM packages and databases.
182
183%description devel -l ja
184このパッケージには,RPMパッケージやデータベースを操作するための
185C ライブラリとヘッダが含まれています.これにより,RPMパッケージを
186操作するツールを作成できます.
187
188%package build
189Summary: Scripts and executable programs used to build packages.
190Group: Development/Tools
191Provides: rpmbuild(VendorConfig) = 4.1-1
192Requires: rpm = %{rpm_version}-%{release}
193Requires: elfutils, binutils
194Requires: findutils, sed, grep, gawk, diffutils, file, patch >= 2.5
195Requires: zip, gzip, bzip2, cpio, tar, xz
196
197%description build
198The rpm-build package contains the scripts and executable programs
199that are used to build packages using the RPM Package Manager.
200
201%description build -l ja
202このパッケージには,RPMを使ったパッケージを構築(ビルド)するのに必要な
203スクリプトおよびプログラムが収録されています.
204
205
206%if %{with_python_subpackage}
207%package python
208Summary: Python bindings for apps which will manipulate RPM packages.
209Group: Development/Libraries
210Requires: rpm = %{rpm_version}-%{release}
211Requires: python >= %{with_python_version}
212
213%description python
214The rpm-python package contains a module that permits applications
215written in the Python programming language to use the interface
216supplied by RPM Package Manager libraries.
217
218This package should be installed if you want to develop Python
219programs that will manipulate RPM packages and databases.
220
221%description python -l ja
222rpm-python パッケージには,RPM パッケージマネージャのライブラリに
223アクセスする為の Python モジュールが収録されています.
224
225%endif
226
227
228%prep
229%setup -q -n rpm-%{version}
230%patch1 -p1 -b .pkgconfig-path
231
232%patch100 -p1 -b .fontattr
233%patch101 -p1 -b .elfattr
234%patch102 -p1 -b .perl-python-attr
235%patch103 -p1 -b .mpsize
236%patch104 -p1 -b .rpmdb-dsi
237%patch105 -p1 -b .python-memleaks
238%patch106 -p1 -b .verify-output
239%patch107 -p1 -b .include-cond
240%patch108 -p1 -b .exclude-warn
241%patch109 -p1 -b .tstest-fileinfo
242
243%patch301 -p1 -b .niagara
244%patch302 -p1 -b .geode
245%patch304 -p1 -b .ldflags
246%patch305 -p1 -b .gnome-help
247%patch306 -p1 -b .debugedit-stabs-warn
248
249%patch401 -p1 -b .perl-script
250
251# this patch cant be applied on softfp builds
252%ifnarch armv3l armv4b armv4l armv4tl armv5tel armv5tejl armv6l armv7l
253%patch5 -p1 -b .armhfp
254%endif
255
256# vine patch
257%patch1100 -p1 -b .vine
258%patch1120 -p1 -b .langC
259#%patch1130 -p1 -b .home
260%patch1140 -p1 -b .shortcircuit
261%patch1170 -p1 -b .legacyaliases
262%patch1180 -p1 -b .no-terminate_build
263%patch1190 -p1 -b .disable-pythonreq
264#%patch1200 -p1 -b .use-external-depgen
265%ifarch ppc
266%patch1210 -p1 -b .deadlock-ppc
267%endif
268%patch1220 -p1 -b .disable-debug
269%patch1230 -p1 -b .optflags
270%patch1240 -p1 -b .default-buildarch
271%patch1250 -p1 -b .default-srcdefattr
272%patch1260 -p1 -b .man-fix-typo
273%patch1270 -p1 -b .vine-groups
274%patch1290 -p1 -b .mono-dependencies
275%patch1310 -p1 -b .find-a-only
276%patch1320 -p1 -b .force-v3-sigs
277%patch1330 -p1 -b .enable-xz-payload
278%patch1340 -p1 -b .disable-rpmbuild-sign
279
280# install updated japanese message catalogue
281cp -f po/ja.po po/ja.po.orig
282cp -f %{SOURCE100} po/ja.po
283
284cp %{SOURCE110} %{SOURCE120} .
285
286rm -rf popt/
287
288%build
289
290autoreconf -f -i
291sed -i -e 's|^mkinstalldirs =.*|mkinstalldirs = ../mkinstalldirs|g' po/Makefile*
292
293# XXX rpm needs functioning nptl for configure tests
294unset LD_ASSUME_KERNEL || :
295
296%if %{with_python_subpackage}
297WITH_PYTHON="--enable-python"
298%else
299WITH_PYTHON="--disable-python"
300%endif
301
302CPPFLAGS="$CPPFLAGS $(pkg-config --cflags nss)"
303CFLAGS="$RPM_OPT_FLAGS"
304export CPPFLAGS CFLAGS
305./configure \
306    --prefix=%{__prefix} \
307        --libdir=%{_libdir} \
308    --sysconfdir=/etc \
309    --localstatedir=/var \
310    --infodir='%{__share}/info' \
311    --mandir='%{__share}/man' \
312    $WITH_PYTHON \
313    --with-lua \
314    --with-cap \
315    --with-acl \
316    --enable-posixmutexes \
317    --with-external-db \
318    --without-javaglue \
319    --without-perl \
320    --without-selinux \
321    --disable-plugins
322
323make %{?_smp_mflags}
324make -C po ja.gmo
325
326%install
327# XXX rpm needs functioning nptl for configure tests
328unset LD_ASSUME_KERNEL || :
329
330rm -rf $RPM_BUILD_ROOT
331
332make DESTDIR="$RPM_BUILD_ROOT" install
333
334%clean
335rm -rf $RPM_BUILD_ROOT
336
337%post libs
338/sbin/ldconfig
339
340%postun libs
341/sbin/ldconfig
342
343%files libs
344%defattr(-,root,root)
345%{__libdir}/librpm.so.*
346%{__libdir}/librpmio.so.*
347%{__libdir}/librpmbuild.so.*
348%{__libdir}/librpmsign.so.*
349
350%changelog
351* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.1.3-1
352- rpm49-libs
353  - build libs only as compat package.
354
355* Fri Apr 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.1.3-1
356- update to 4.9.1.3
357
358* Tue Mar 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.1.2-4
359- add patch102-109 from upstream
360
361* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1.2-3
362- rebuild with python-2.7.2
363
364* Fri Dec 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.1.2-2
365- fix vine patch
366  - remove broken/dupreacted macro (__id_u)
367- add patch1340 to disable rpmbuild --sign functionality
368
369* Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.9.1.2-1
370- update to 4.9.1.2
371- add patch1330 to enable xz payload (binary payload)
372- add BR: file-devel
373
374* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.1-3
375- rebuild package (fix typo in /usr/lib/rpm/macros on i686)
376
377* Thu Jan  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.8.1-2
378- add R: xz into rpm-build pkg
379- add BR: xz-devel
380
381* Sun Sep 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.1-1
382- update to 4.8.1
383- add patch1320 to force gpg v3 signature on package signing
384  - add --force-v3-sigs to gpg option
385- use internal dependency generator (upstream default)
386
387* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.0-6
388- drop patch1160 to disable brp-strip-shared (<BTS:954>)
389- update patch1170 (enable legacymacros again)
390- add patch1300 to brp-compress xz/lzma support
391- add patch1310 to find static libs only on brp-strip-static-archive
392
393* Tue Feb 16 2010 KOBAYASHI Taizo <tkoba@vinelinux.org> - 4.8.0-5
394- drop Requires: beecrypt and BuildRequires: beecrypt-devel
395- added Requires: nss
396
397* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.8.0-4
398- rebuilt with gcc-4.4.3-3 on ppc
399
400* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.8.0-3
401- modified Patch1230: add missing ppc-specific optflags, as in 4.4.2.3-12
402
403* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 4.8.0-2
404- add '--libdir=%%{_libdir}' to configure
405
406* Sun Jan 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.0-1
407- update to rpm-4.8.0
408- change default buildarch to i686
409  add BR: lua-devel, lkibcap-devel, libacl-devel, nss-devel
410- build with external Berkeley DB (db4)
411
412* Thu Jul 16 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.4.2.3-12
413- rebuild to fix absolute path of sed in macros <BTS:VineLinux:0723>
414
415* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.4.2.3-11
416- add Patch290 to find mono-dependencies automatically
417
418* Sun Jul  5 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.4.2.3-10
419- update patch100 to add _compat32_arch macro (currently i386)
420- add "_with_compat32 1" into i[356]86, athlon's macro to force compat32 build
421- add BR: cvs
422
423* Sat May 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-9
424- add Patch30 backported from 4.6.0
425  - allocating in even sized chunks helps avoiding crazy memory
426    fragmentation when resizing a lot (rhbz#472507)
427
428* Thu May 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-8
429- add Patch20-25 from upstream
430
431* Tue Apr 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-7
432- remove %ifos from spec file.
433- add python_site{lib,arch}, pyver macros
434- add emacsen_pkgdir macros
435- add macros for font package
436- update auto* files
437
438* Fri Oct 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-6
439- update Patch230
440  - add -fno-strict-aliasing -fno-schedule-insns2 to optflags
441    (VineSeed:16128)
442
443* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-5
444- rebuild with external libpopt
445
446* Mon Jul 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-4
447- rebuild with python-2.5
448
449* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2.3-3
450- rebuilt with neon-0.28.2
451
452* Wed Apr 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-2
453- add Patch280 to fix external dependancy generator(revert patch)
454
455* Mon Apr 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-1
456- new upstream release
457
458* Tue Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.4.2.3-0.rc1.3
459- fix file section for x86_64 build
460
461* Wed Mar 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-0.rc1.2
462- fix typo in Patch100 (_dist_release macro)
463
464* Tue Mar 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.3-0.rc1.1
465- new upstream rc version
466- add new _dist_release macro
467  seed http://trac.vinelinux.org/wiki/VersioningPolicy
468- use new release numbering policy
469
470* Wed Feb 27 2008 Takuya Kobayashi <ruby11@cocoa.ocn.ne.jp> 4.4.2.2-0vl6
471- update Patch260,Source100 <BTS:VineLinux:504>
472- update Patch260 (fix typo in rpmbuild japanese manpage)
473
474* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4.2.2-0vl5
475- rebuild with expat-2.0.1
476
477* Mon Feb 04 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4.2.2-0vl4
478- rebuild
479
480* Sun Feb 03 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4.2.2-0vl3
481- fix Patch230 (remove unnecessary white spaces)
482
483* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.2-0vl2
484- fix vine patch
485
486* Sat Oct 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.2-0vl1
487- new upstream release
488
489* Mon Jul 23 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4.2.1-0vl2
490- fix popt version (1.10.2.1)
491
492* Mon Jul 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2.1-0vl1
493- new upstream release
494- remove obsolete patches
495
496* Wed May 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 4.4.2-0vl25
497- rebuild with neon-0.26.3 (expecially for x86_64)
498
499* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl24
500- add patch 37 to build without neon
501
502* Mon May 14 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4.2-0vl23
503- updated Patch230 (-m32 on ppc, -m64 on ppc64, and likewise)
504
505* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl22
506- use -mtune option instead of -mcpu
507
508* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4.2-0vl21
509- rebuilt with new toolchain
510- disable Patch53
511- add BuildReq: nkf
512
513* Fri Jan 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl20
514- rebuild
515
516* Sun Dec 31 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.4.2-0vl19
517- update patch270. <BTS:VineLinux:448>
518
519* Sun Dec 31 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.4.2-0vl18
520- fix typo in GROUPS-DESC_for_vine.txt <BTS:VineLinux:448>
521
522* Sat Dec 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.4.2-0vl17
523- fix typo in GROUPS*_for_vine.txt <BTS:VineLinux:429>
524
525* Thu Nov 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl16
526- update ja.po and manpage to fix typo (<BTS:278>)
527- update GROUPS for Vine Linux
528- add GROUPS*_for_vine.txt
529
530* Sat Jun 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl15
531- fix changelogname for 4.4.2-0vl14
532  ( was accidentally copied from 0vl13.. )
533
534* Fri Jun 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl14
535- update Patch230
536  - remove "-m64 -mcpu=nocona" from x86_64 optflags
537- add Patch250
538  - add %%_srcdefattr (-,root,root) to default macros
539
540* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.4.2-0vl13
541- fix typo in changelog
542
543* Thu Apr 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.4.2-0vl12
544- rebuild with neon-0.25.5
545
546* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl11
547- update Patch100 to use /var for %%{_localstatedir} instead of /var/lib
548
549* Mon Feb 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl10
550- update ja.po
551  - fix some mistranslations (thanks to NAKAMURA Kenta)
552  - squash some fuzzy translations
553
554* Mon Feb 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl9
555- fix spec bug.
556
557* Sun Feb 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl8
558- update Patch240 to install pentium?-linux/macros on x86_64 arch.
559- added compat32-popt for x86_64 architecture support (NAKAMURA Kenta)
560
561* Wed Feb 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl7
562- add Patch230 to append "-m32/-m64" option to %%optflags in rpmrc
563- add Patch240 to install ix86-linux/macros on x86_64 arch.
564- update Patch100 to use lib/lib64 for %%_lib macro in per-platform
565  macros.
566
567* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl6
568- add Patch220 to remove debug option from optflags (in rpmrc)
569
570* Wed Dec 21 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.4.2-0vl5
571- added Patch210 for PPC deadlock.
572
573* Mon Dec 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl4
574- import Patch51-55 from MDK package.
575
576* Mon Dec 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl3
577- add Requires: popt >= %%{poptversion} to rpm-libs.
578  librpm-4.4 need new popt feature.
579
580* Fri Dec 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl2
581- change manpage kanjicode to euc-jp
582- add Patch190 to disable python_requires
583- add Patch200 to use external dependency generator instead of internal one.
584
585* Wed Dec 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.2-0vl1
586- update to rpm-4.4.3
587- Patche0-14 are imported from FC-devel
588- vine patches are ported from rpm-4.0.5 (Patch100-160)
589- add Patch170 for legacy(rpm-4.0) compatible build mode aliases
590- add Patch180 to disable {missing_doc,unpackaged}_files_terminate_build
591  by default. (This would be reenabled in future release)
592  If you need this feature, please set in your .rpmmacros file.
593
594* Sun Oct 23 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl12
595- rebuild on new environment
596  - use external libtool
597  - update makefile patch to fix build failure
598
599* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.0.5-1vl11
600- rebuild with python-2.4.1-0vl1
601
602* Thu Mar 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl10
603- self rebuilt
604
605* Thu Mar 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl9
606- add brp-strip-shared in build macros
607
608* Wed Jul 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl8
609- remove %%vendor from global rpmmacro settings.
610
611* Mon May 10 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.5-1vl7
612- fix %%pre script, remove bogus ppc* and alpha* macro directories
613
614* Mon May 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl6
615- remove bogus macro directories and symlinks in %%pre script
616
617* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.0.5-1vl5
618- rebuild with python-2.3.3-0vl1
619
620* Sun Apr 11 2004 Shu KONNO <owa@bg.wakwak.com> 4.0.5-1vl4.1
621- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
622
623* Tue Apr  6 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl4
624- remove GPG/PGP key from %%_docdir.
625- add Requires: vine-keyring, the Vine Linux official keyring.
626- add '--keyring' option in macros to use vine keyring.
627
628* Sun Mar  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl3
629- remove "--target" and "--host" from %%configure option.
630  The RPM does not work well on cross compiling, and the options
631  break some compile configurations....
632
633* Thu Feb 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.5-1vl2
634- use internal db only.
635- update Patch100 to fix %%configure macros
636
637* Tue Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.5-1vl1
638- source update for rebuild and current autotools
639- added BuildRequires libtool >= 1.5.2
640- added patch107,200
641  * Tue Mar 25 2003 Jeff Johnson <jbj@redhat.com> 4.0.5-1
642  - bump rpm/popt versions, hardwire 4.0.4 in libraries.
643  - link rpm libraries together, move symbols to achieve forward linkage.
644  - use db-4.1.25, not db-4.0.14, internally.
645  - add rpmdb_loadcvt script, rpmdb_foo utilities.
646  - use current autotools,
647  - use splint, not lclint.
648  - delete rpm-4.1 header-only signatures/digests when signing.
649  - hack out O_DIRECT support in db4 for now.
650
651  * Tue Nov  5 2002 Jeff Johnson <jbj@redhat.com> 4.0.4-7x.26
652  - backport /etc/rpm/platform changes.
653  - backport db-4.1.17 changes.
654  - add _noDirTokens macro for 6x builds.
655
656  * Sat Jun 15 2002 Jeff Johnson <jbj@redhat.com> 4.0.4-7x.24
657  - beecrypt: revert cpu/arch compile option mixup (#66752).
658
659  * Sun Jun  9 2002 Jeff Johnson <jbj@redhat.com> 4.0.4-7x.23
660  - make peace with automake-1.6.1 et al.
661  - backport all beecrypt/rpmio bits from 4.1 that don't break the API.
662  - use /etc/rpm/platform (if it exists), rather than uname(2), for arch.
663  - add /usr/lib/rpm/redhat/* per-vendor configuration.
664
665  * Thu May  2 2002 Jeff Johnson <jbj@redhat.com>
666  - fix: include <sys/time.h> for 6.2 python modules.
667
668  * Fri Apr 26 2002 Jeff Johnson <jbj@redhat.com>
669  - fix: rpmdb iterator memory leak in python bindings.
670
671  * Fri Apr 19 2002 Jeff Johnson <jbj@redhat.com>
672  - fix: packages produced by rpm-4.0 dinna merge signature tags.
673 
674* Fri May 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.4-18vl15
675- rebuild against perl-5.8.0
676- BuildRequires db4-devel
677
678* Wed Mar 12 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl14
679- rebuild against recent toolchain
680
681* Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 4.0.4-18vl13
682- rebuild against python-2.2
683
684* Fri Dec 13 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl12
685- fixed typo in %%files for popt subpackage
686- added BuildRequires: autoconf213, automake14
687
688* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl11
689- update Patch100 again: %%{_infodir} is now set to %%{_datadir}/info.
690
691* Fri Nov 29 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl10
692- added Patch106 for ppc
693  (to fix misdetection of PowerPC 750FX/745x as pSeries. Doh!)
694
695* Fri Nov 22 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl9
696- modified Patch100 for macros.in, platform.in and installplatform
697  (important platform-dependent macros were missing. Fixed.)
698
699* Thu Nov 21 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.4-18vl8
700- add Patch105 to make more short circuit on rpm building.
701
702* Thu Nov 21 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.4-18vl7
703- update Patch100. (use _real_vendor instead of _vendor)
704
705* Thu Nov 21 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.4-18vl6
706- add Patch103 to use mkstemp instead of mktemp.
707- add Patch104 for $HOME expantion.
708
709* Sun Nov 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl5
710- Source100 (rpm-4.0.4-ja.po) updated (small fix)
711
712* Fri Nov 15 2002 Tomoya TAKA <taka@vinelinux.org> 4.0.4-18vl4
713- add Prereq: rpm = %%{rpm_version} to rpm-*
714
715* Fri Nov 15 2002 Tomoya TAKA <taka@vinelinux.org> 4.0.4-18vl3
716- add --with-pic to ./configure on alpha
717- echo notice in %%post
718
719* Sun Nov 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl2
720- added Source100 (Japanese message catalogue file)
721
722* Sun Nov 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl1
723- added Patch102 to get correct "provides" information
724  (for objdump in newer binutils may have translated message catalogues)
725
726* Sat Nov 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.4-18vl0
727- first attempt for rpm-4.0.4 on Vine Linux
728- based on rpm-4.0.4-7x.18 from Red Hat Linux 7.3
729- /usr/src/redhat -> /usr/src/vine
730- use built rpm binary, not preinstalled rpm, when compiling perl module
731- FIXME: more patches and japanese translations would be needed
732
733* Thu Apr 18 2002 Jeff Johnson <jbj@redhat.com>
734- fix: queries that evaluated to "" incorrectly returned NULL.
735
736* Thu Apr 11 2002 Jeff Johnson <jbj@redhat.com>
737- fix: generate config file md5 as ascii, not binary (#62542).
738
739* Fri Apr  5 2002 Jeff Johnson <jbj@redhat.com>
740- non-glibc: on upgrade, mergesort is much faster than quicksort.
741
742* Thu Apr  4 2002 Jeff Johnson <jbj@redhat.com>
743- speedup large queries by ~50%.
744- revert to presentation ordering Yet Again (#62158).
745
746* Wed Mar 27 2002 Jeff Johnson <jbj@redhat.com>
747- fix: look for "/path" in Providename as well as Basenames (#59665).
748- fix: avoid /dev/log installation more carefully (#62012).
749- fix: don't compile beecrypt java bindings (#61992).
750- solaris: save main() envp in global environ for use with gpg.
751- don't add empty md5 strings to Filemd5's index.
752- create Filemd5 index with binary, not ascii, keys.
753
754* Fri Mar 22 2002 Jeff Johnson <jbj@redhat.com>
755- fix: make sure that .rpmsave files are created (#57078).
756
757* Mon Mar 18 2002 Jeff Johnson <jbj@redhat.com>
758- fix: one-step-too-far when searching added package provides (#61388).
759- fix: avoid libio misconfiguration with bleeding edge glibc.
760- fix: add quotes around [:blank:] in linux find-provides.
761- make --addsign and --resign behave exactly the same.
762- *really* dump signature header immutable region.
763- fix: don't overflow result buffer if gpg/pgp gives copious output.
764
765* Fri Mar 15 2002 Jeff Johnson <jbj@redhat.com>
766- re-enable FD_CLOEXEC, the problem is in zlib through mmap.
767- add toy python callbacks for payload unpacking failure(s).
768
769* Wed Feb 13 2002 Jeff Johnson <jbj@redhat.com>
770- don't do close-on-exec, 2 powertools packages cannot be read when doing.
771- reapply Berkeley DB patch #4491.
772
773* Thu Feb  7 2002 Jeff Johnson <jbj@redhat.com>
774- rpm-4.0.4 release candidate.
775- add cpanflute2, another perl.req fiddle.
776- another cpanflute2 patch.
777
778* Mon Feb  4 2002 Jeff Johnson <jbj@redhat.com>
779- generate index for pkgid (aka Sigmd5) tag, query/verify by pkgid.
780- generate index for hdrid (aka Sha1header) tag, query/verify by hdrid.
781- generate index for fileid (aka Filemd5s) tag, query/verify by fileid.
782- query/verify by install transaction id.
783
784* Sun Feb  3 2002 Jeff Johnson <jbj@redhat.com>
785- transaction rollbacks are functional.
786
787* Sat Feb  2 2002 Jeff Johnson <jbj@redhat.com>
788- fix: drop header region when writing repackaged legacy header.
789- bail on %%files macro.
790
791* Fri Feb  1 2002 Jeff Johnson <jbj@redhat.com>
792- macro for %%files, always include %%defattr(), redhat config only.
793
794* Thu Jan 31 2002 Jeff Johnson <jbj@redhat.com>
795- permit args to be hidden within %%__find_{requires,provides}.
796- a couple more perl.{prov,req} fiddles.
797
798* Wed Jan 30 2002 Jeff Johnson <jbj@redhat.com>
799- legacy: configurable whiteout for known Red Hat dependency loops.
800- perl.req: don't mis-generate dependencies like perl(::path/to/foo.pl).
801- use chainsaw algorithm for dependency tree decimation when ordering.
802
803* Tue Jan 29 2002 Jeff Johnson <jbj@redhat.com>
804- transaction rollback code in rpmRollback().
805- Red Hat 6.2 portability cruft.
806
807* Sun Jan 27 2002 Jeff Johnson <jbj@redhat.com>
808- fix: fancy hash fiddles if not a tty.
809- fix: handle /.../ correctly in rpmCleanPath().
810
811* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com>
812- fix: %%exclude functional (again).
813- trap SIGILL for ppc64 inline asm voodoo fix from cross-dressed ppc32.
814- rpm-perl: force numeric comparison on rpm version (#58882).
815
816* Tue Jan 22 2002 Jeff Johnson <jbj@redhat.com>
817- fix: query format qualifiers needed header.c merge.
818- ppc64 arch added (#58634,#58636).
819- turn on auto-generated perl requirements (#58519, #58536, #58537).
820- add internal (customized) version of zlib.
821
822* Mon Jan 21 2002 Jeff Johnson <jbj@redhat.com>
823- sync rpmdb and build with rpm-4.1, lots of splint annotations.
824- add :armor and :base64 query format qualifiers for binary signatures.
825
826* Sat Jan 19 2002 Jeff Johnson <jbj@redhat.com>
827- use beecrypt routines to calculate digests in rpm.
828- dump legacy support for broken md5 signatures.
829- sync popt and rpmio with rpm-4.1, rpmio has OpenPGP API.
830
831* Thu Jan 17 2002 Jeff Johnson <jbj@redhat.com>
832- missing key(s) on keyring when verifying a signature is now an error.
833- remove dependency whiteout.
834- calculate rpm-4.1 ordering/orientation metrics in rpmdepOrder().
835
836* Fri Jan 11 2002 Jeff Johnson <jbj@redhat.com>
837- permit subset installs for %%lang colored hardlink file sets.
838
839* Thu Jan 10 2002 Jeff Johnson <jbj@redhat.com>
840- fix: signing multiple times dinna work, discard immutable region.
841- remove poptmodule.so for separate packaging.
842
843* Wed Jan  9 2002 Jeff Johnson <jbj@redhat.com>
844- permit gpg/pgp/pgp5 execs to be reconfigured.
845
846* Tue Jan  8 2002 Jeff Johnson <jbj@redhat.com>
847- use db-4.0.14 final internally.
848- make rpm-perl package self-hosting (#57748).
849
850* Mon Jan  7 2002 Jeff Johnson <jbj@redhat.com>
851- Depends should use CDB if configured.
852- autodetect python 1.5/2.2.
853
854* Sun Jan  6 2002 Jeff Johnson <jbj@redhat.com>
855- handle lazy db open's in chroot with absolute path, not prefix strip.
856
857* Sat Jan  5 2002 Jeff Johnson <jbj@redhat.com>
858- sparc: make dbenv per-rpmdb, not per-dbi.
859
860* Thu Dec 20 2001 Jeff Johnson <jbj@redhat.com>
861- tru64 compiler message cleanup.
862- add buildarch lines for hppa (#57728).
863
864* Wed Dec 19 2001 Jeff Johnson <jbj@redhat.com>
865- look for PY_VERSION 2.2c1.
866- fix: typo in find-requires.
867
868* Sun Dec  9 2001 Jeff Johnson <jbj@redhat.com>
869- solaris: translate i86pc to i386 (#57182).
870- fix: %%GNUconfigure breaks with single quotes (#57264).
871
872* Mon Dec  3 2001 Jeff Johnson <jbj@redhat.com>
873- rpm-4.0.4 started.
874- turn off rpm-perl until it's self-hosting.
875- jigger up rpm-python with python-2.2b2 for now.
876- remove libtoolize from %%configure for now (#57039).
877- teach find-requires to autogenerate GCC_3.0 dependencies.
Note: See TracBrowser for help on using the repository browser.