source: projects/specs/trunk/r/rpm2html/rpm2html-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Translates an RPM database and dependency information into HTML.
2Summary(ja): RPM パッケージの解説を HTML および RDF 形式にて生成する
3Name: rpm2html
4Version: 1.9.2
5Release: 2%{?_dist_release}
6Group: Applications/System
7License: MIT
8URL: http://rpmfind.net/linux/rpm2html/
9
10Source: ftp://rpmfind.net/pub/%{name}/%{name}-%{version}.tar.gz
11Patch0: rpm2html-1.9.2-db46.patch
12Patch2: rpm2html-1.9.2-jp.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires: rpm-devel, db4-devel
16
17Vendor:        Project Vine
18Distribution:  Vine Linux
19
20
21%description
22The rpm2html utility automatically generates web pages that describe a
23set of RPM packages.  The goals of rpm2html are to identify the
24dependencies between various packages, and to find the package(s) that
25will provide the resources needed to install a given package.
26Rpm2html analyzes the provides and requires of the given set of RPMs,
27and then shows the dependency cross-references using hypertext links.
28Rpm2html can now dump the metadata associated with RPM files into
29standard RDF files.
30
31Install rpm2html if you want a utility for translating information
32from an RPM database into HTML.
33
34%description -l ja
35RPM パッケージのファイル郡からパッケージの情報を取り出して、
36HTML 形式のページと RDF 形式のデータを生成するツール。
37グループやパッケージ名などの索引ページも自動的に生成され、
38依存情報やリソースなども相互にリンクが張られるため、
39必要なパッケージの検索などが素早く行えます。
40
41%prep
42%setup
43%patch0 -p1 -b .db46
44%patch2 -p1 -b .jp
45
46#libtoolize --force --copy
47aclocal -I .
48#autoheader-2.13
49automake -a -c
50autoconf
51
52%build
53%configure
54make
55
56%install
57%{__rm} -rf %{buildroot}
58%{__install} -d -m0755 %{buildroot}%{_bindir} \
59                %{buildroot}%{_sysconfdir} \
60                %{buildroot}%{_datadir}/rpm2html \
61                %{buildroot}%{_mandir}/man1
62%{__install} -s -m0755 rpm2html %{buildroot}%{_bindir}
63%{__install} -m0644 rpm2html.config  %{buildroot}%{_sysconfdir}
64%{__install} -m0644 rpm2html.1  %{buildroot}%{_mandir}/man1
65
66rm -f msg.ja.jp
67
68for i in msg.*; do
69  %{__install} -m0644 $i %{buildroot}%{_datadir}/rpm2html/
70done
71
72%clean
73%{__rm} -rf %{buildroot}
74
75%files
76%defattr(-, root, root, 0755)
77%doc BUGS CHANGES PRINCIPLES README README.jp TODO
78%doc rpm2html-cdrom.config rpm2html-en.config
79%doc %{_mandir}/man1/*
80%config %{_sysconfdir}/rpm2html.config
81%{_bindir}/*
82%{_datadir}/rpm2html/
83
84%changelog
85* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.2-2
86- updated Patch0 for building with db-4.6.21
87
88* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.2-1vl5
89- applied new versioning policy, spec in utf-8
90
91* Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.2-0vl2
92- rebuilt with new toolchain
93- update Patch0
94
95* Wed Dec 21 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.9.2-0vl1
96- source update
97
98* Tue Mar 15 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.7-0vl2
99- fix char-code in this spec file to EUC-JP
100
101* Wed Nov 10 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.7-0vl1
102- source update
103
104* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
105- clean up old global namespace patch for libxml (>1.8)
106
107* Thu Mar 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
108- 1.3-1vl1
109- version number/release theory changed from 1.3_jp-1 to 1.3-1vl1
110- added a patch for a problem with libxml > 1.8
111  (the patch itself is written by Mr. Yasuyuki Furukawa. Thanks!)
112- %prep, %install and %clean section slightly modified
113- added Requires: libxml
114
115* Thu Dec 16 1999 Jun Nishii <jun@vinelinux.org>
116- typo fixed
117- use euc
118- build for Vine Linux 2.0
119
120* Thu Aug  4 1999 Yoshi. Kajiki <kajiki@3dpro.tao.go.jp>
121- Japanese l10n.
122
123* Fri Apr  2 1999 Jeff Johnson <jbj@redhat.com>
124- repackage for Red Hat 6.0.
125
Note: See TracBrowser for help on using the repository browser.