source: projects/specs/trunk/r/rpcbind/rpcbind-vl.spec @ 8067

Revision 8067, 8.4 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%{!?_initddir:%define _initddir /etc/rc.d/init.d}
2
3Name:           rpcbind
4Version:        0.2.0
5Release:                6%{?_dist_release}
6Summary:        Universal Addresses to RPC Program Number Mapper
7Group:          System Environment/Daemons
8License:        GPL
9URL:            http://nfsv4.bullopensource.org
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12Source0:        http://downloads.sourceforge.net/rpcbind/%{name}-%{version}.tar.bz2
13Source1: rpcbind.init
14
15Patch100: rpcbind-0.2.0-usage-fix.patch
16
17Requires: glibc-common setup
18Conflicts: man-pages < 2.43-12
19BuildRequires: automake, autoconf, libtool
20BuildRequires: libtirpc-devel
21BuildRequires: quota
22BuildRequires: tcp_wrappers
23#BuildRequires: quota-devel
24#BuildRequires: tcp_wrappers-devel
25Requires(pre): /usr/sbin/groupadd  /usr/sbin/groupdel
26Requires(pre): /usr/sbin/useradd  /usr/sbin/userdel
27Requires(pre): coreutils
28Requires(post): /sbin/chkconfig
29Requires(post): /sbin/chkconfig
30
31#Provides: portmap = %{version}-%{release}
32Provides: portmap = 4.0-66%{_dist_release}
33Obsoletes: portmap <= 4.0-65.3
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39The rpcbind utility is a server that converts RPC program numbers into
40universal addresses.  It must be running on the host to be able to make
41RPC calls on a server on that machine.
42
43%prep
44%setup -q
45%patch100 -p1
46
47%build
48%ifarch s390 s390x
49PIE="-fPIE"
50%else
51PIE="-fpie"
52%endif
53export PIE
54
55RPCBUSR=rpc
56RPCBDIR=/var/lib/rpcbind
57CFLAGS="`echo $RPM_OPT_FLAGS $ARCH_OPT_FLAGS $PIE`"
58
59autoreconf -fisv
60%configure CFLAGS="$CFLAGS" LDFLAGS="-pie" \
61    --enable-warmstarts \
62    --with-statedir="$RPCBDIR" \
63    --with-rpcuser="$RPCBUSR" \
64    --enable-libwrap \
65    --enable-debug
66
67make all
68
69
70%install
71rm -rf %{buildroot}
72mkdir -p %{buildroot}/sbin
73mkdir -p %{buildroot}/usr/sbin
74mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
75mkdir -p %{buildroot}%{_mandir}/man8
76mkdir -p %{buildroot}/var/lib/rpcbind
77
78install -m 755 src/rpcbind ${RPM_BUILD_ROOT}/sbin
79install -m 755 src/rpcinfo ${RPM_BUILD_ROOT}%{_sbindir}
80install -m 644 man/rpcbind.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
81install -m 644 man/rpcinfo.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
82install -m 755 ${RPM_SOURCE_DIR}/rpcbind.init ${RPM_BUILD_ROOT}%{_initddir}/rpcbind
83
84%clean
85rm -rf %{buildroot}
86
87%pre
88
89# Check the validity of the rpc uid and gid.
90# If they don't exist, create them
91# If they exist but are the wrong value, remove them
92#   and recreate them with the correct value
93# If they exist and are the correct value do nothing
94rpcid=`getent passwd rpc | cut -d: -f 3`
95if [ -n "$rpcid" -a "$rpcid" != "32" ]; then
96        /usr/sbin/userdel  rpc 2> /dev/null || :
97        /usr/sbin/groupdel rpc 2> /dev/null || :
98fi
99if [ -z "$rpcid" -o "$rpcid" != "32" ]; then
100        /usr/sbin/groupadd -o -g 32 rpc > /dev/null 2>&1
101        /usr/sbin/useradd -o -l -c "Rpcbind Daemon" -d /var/lib/rpcbind -g 32 \
102        -M -s /sbin/nologin -u 32 rpc > /dev/null 2>&1
103fi
104%post
105/sbin/chkconfig --add %{name}
106
107%preun
108if [ $1 -eq 0 ]; then
109    service rpcbind stop > /dev/null 2>&1
110    /sbin/chkconfig --del %{name}
111        /usr/sbin/userdel  rpc 2>/dev/null || :
112        /usr/sbin/groupdel rpc 2>/dev/null || :
113        rm -rf /var/lib/rpcbind
114fi
115%postun
116if [ "$1" -ge "1" ]; then
117    service rpcbind condrestart > /dev/null 2>&1
118fi
119
120%files
121%defattr(-,root,root)
122%doc AUTHORS ChangeLog README
123/sbin/rpcbind
124%{_sbindir}/rpcinfo
125%{_mandir}/man8/*
126%config %{_initddir}/rpcbind
127
128%dir %attr(700,rpc,rpc) /var/lib/rpcbind
129
130%changelog
131* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.0-6
132- rebuild with VineSeed environment
133
134* Sun Feb 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.0-5
135- Initial build for Vine Linux
136
137* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-4
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
139
140* Mon Jul 06 2009 Adam Jackson <ajax@redhat.com> 0.2.0-3
141- Requires(pre): coreutils for cut(1).
142
143* Thu Jun 25 2009 Steve Dickson <steved@redhat.com> - 0.2.0-2
144- Fixed pre scriptle failure during upgrades (bz 507364)
145- Corrected the usage info to match what the rpcbind man
146    page says. (bz 466332)
147- Correct package issues (bz 503508)
148
149* Fri May 29 2009 Steve Dickson <steved@redhat.com> - 0.2.0-1
150- Updated to latest upstream release: 0.2.0
151
152* Tue May 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.1.7-3
153- Replace the Sun RPC license with the BSD license, with the explicit permission of Sun Microsystems
154
155* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.7-2
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
157
158* Wed Nov 19 2008 Steve Dickson <steved@redhat.com>  0.1.7-1
159- Update to latest upstream release: 0.1.7
160
161* Tue Sep 30 2008 Steve Dickson <steved@redhat.com>  0.1.6-3
162- Fixed a typo in the rpcbind.init script that stop warm starts
163  from happening with conrestarts
164- Fixed scriptlet failure (bz 462533)
165
166* Tue Sep 16 2008 Steve Dickson <steved@redhat.com> 0.1.6-2
167- Added usptream patches 01 thru 03 that do:
168    * Introduce helpers for ipprot/netid mapping
169    * Change how we decide on the netids to use for portmap
170    * Simplify port live check in pmap_svc.c
171
172* Wed Jul  9 2008 Steve Dickson <steved@redhat.com> 0.1.6-1
173- Updated to latest upstream release 0.1.6
174
175* Wed Jul  2 2008 Steve Dickson <steved@redhat.com> 0.1.5-5
176- Fixed SYNOPSIS section in the rpcinfo man page (bz 453729)
177
178* Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.5-4
179- Removed the documentation about the non-existent
180  '-L' flag (bz 446915)
181
182* Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.5-3
183- Set password and service lookups to be local (bz 447092)
184
185* Mon Jun 23 2008 Steve Dickson <steved@redhat.com> 0.1.5-2
186- rpcbind needs to downgrade to non-priviledgied group.
187
188* Mon Jun 23 2008 Steve Dickson <steved@redhat.com> 0.1.5-1
189- Updated to latest upstream release 0.1.5
190
191* Mon Feb 11 2008 Steve Dickson <steved@redhat.com> 0.1.4-14
192- Fixed a warning in pmap_svc.c
193- Cleaned up warmstarts so uid are longer needed, also
194  changed condrestarts to use warmstarts. (bz 428496)
195
196* Thu Jan 24 2008 Steve Dickson <steved@redhat.com> 0.1.4-13
197- Fixed connectivity with Mac OS clients by making sure handle_reply()
198  sets the correct fromlen in its recvfrom() call (bz 244492)
199
200* Mon Dec 17 2007 Steve Dickson <steved@redhat.com> 0.1.4-12
201- Changed is_loopback() and check_access() see if the calling
202  address is an address on a local interface, just not a loopback
203  address (bz 358621).
204
205* Wed Oct 17 2007 Steve Dickson <steved@redhat.com> 0.1.4-11
206- Reworked logic in initscript so the correct exit is
207  used when networking does not exist or is set up
208  incorrectly.
209
210* Tue Oct 16 2007 Steve Dickson <steved@redhat.com> 0.1.4-10
211- Corrected a typo in the initscript from previous
212  commit.
213
214* Mon Oct 15 2007 Steve Dickson <steved@redhat.com> 0.1.4-9
215- Fixed typo in Summary (bz 331811)
216- Corrected init script (bz 247046)
217
218* Sat Sep 15 2007 Steve Dickson <steved@redhat.com> 0.1.4-8
219- Fixed typo in init script (bz 248285)
220- Added autoconf rules to turn on secure host checking
221  via libwrap. Also turned on host check by default (bz 248284)
222- Changed init script to start service in runlevel 2 (bz 251568)
223- Added a couple missing Requires(pre) (bz 247134)
224
225* Fri May 25 2007 Steve Dickson <steved@redhat.com> 0.1.4-7
226- Fixed condrestarts (bz 241332)
227
228* Tue May 22 2007 Steve Dickson <steved@redhat.com> 0.1.4-6
229- Fixed an ipv6 related segfault on startup (bz 240873)
230
231* Wed Apr 18 2007 Steve Dickson <steved@redhat.com> 0.1.4-5
232- Added dependency on setup which contains the correct
233  rpcbind /etc/service entry which in turns stops
234  rpcbind from haning when NIS is enabled. (bz 236865)
235
236* Wed Apr 11 2007 Jeremy Katz <katzj@redhat.com> - 0.1.4-4
237- change man-pages requires into a conflicts as we don't have to have
238  man-pages installed, but if we do, we need the newer version
239
240* Fri Apr  6 2007 Steve Dickson <steved@redhat.com> 0.1.4-3
241- Fixed the Provides and Obsoletes statments to correctly
242  obsolete the portmap package.
243* Tue Apr  3 2007 Steve Dickson <steved@redhat.com> 0.1.4-2
244- Added dependency on glibc-common which allows the
245  rpcinfo command to be installed in the correct place.
246- Added dependency on man-pages so the rpcinfo man
247  pages don't conflict.
248- Added the creation of /var/lib/rpcbind which will be
249  used to store state files.
250- Make rpcbind run with the 'rpc' uid/gid when it exists.
251
252* Wed Feb 21 2007 Steve Dickson <steved@redhat.com> 0.1.4-1
253- Initial commit
254- Spec reviewed (bz 228894)
255- Added the Provides/Obsoletes which should
256  cause rpcbind to replace portmapper
Note: See TracBrowser for help on using the repository browser.