source: projects/specs/trunk/r/rpcbind/rpcbind-vl.spec @ 9828

Revision 9828, 8.4 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%{!?_initddir:%define _initddir /etc/rc.d/init.d}
2
3Name:           rpcbind
4Version:        0.2.1
5Release:                1%{?_dist_release}
6Summary:        Universal Addresses to RPC Program Number Mapper
7Group:          System Environment/Daemons
8License:        GPL
9URL:            http://nfsv4.bullopensource.org
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12Source0:        http://downloads.sourceforge.net/rpcbind/%{name}-%{version}.tar.bz2
13Source1: rpcbind.init
14
15Requires: glibc-common setup
16Conflicts: man-pages < 2.43-12
17BuildRequires: automake, autoconf, libtool
18BuildRequires: libtirpc-devel
19BuildRequires: quota
20BuildRequires: tcp_wrappers
21#BuildRequires: quota-devel
22#BuildRequires: tcp_wrappers-devel
23Requires(pre): /usr/sbin/groupadd  /usr/sbin/groupdel
24Requires(pre): /usr/sbin/useradd  /usr/sbin/userdel
25Requires(pre): coreutils
26Requires(post): /sbin/chkconfig
27Requires(post): /sbin/chkconfig
28
29#Provides: portmap = %{version}-%{release}
30Provides: portmap = 4.0-66%{_dist_release}
31Obsoletes: portmap <= 4.0-65.3
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37The rpcbind utility is a server that converts RPC program numbers into
38universal addresses.  It must be running on the host to be able to make
39RPC calls on a server on that machine.
40
41%prep
42%setup -q
43
44%build
45%ifarch s390 s390x
46PIE="-fPIE"
47%else
48PIE="-fpie"
49%endif
50export PIE
51
52RPCBUSR=rpc
53RPCBDIR=/var/lib/rpcbind
54CFLAGS="`echo $RPM_OPT_FLAGS $ARCH_OPT_FLAGS $PIE`"
55
56autoreconf -fisv
57%configure CFLAGS="$CFLAGS" LDFLAGS="-pie" \
58    --enable-warmstarts \
59    --with-statedir="$RPCBDIR" \
60    --with-rpcuser="$RPCBUSR" \
61    --enable-libwrap \
62    --enable-debug
63
64make all
65
66
67%install
68rm -rf %{buildroot}
69mkdir -p %{buildroot}/sbin
70mkdir -p %{buildroot}/usr/sbin
71mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
72mkdir -p %{buildroot}%{_mandir}/man8
73mkdir -p %{buildroot}/var/lib/rpcbind
74
75install -m 755 rpcbind ${RPM_BUILD_ROOT}/sbin
76install -m 755 rpcinfo ${RPM_BUILD_ROOT}%{_sbindir}
77install -m 644 man/rpcbind.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
78install -m 644 man/rpcinfo.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
79install -m 755 ${RPM_SOURCE_DIR}/rpcbind.init ${RPM_BUILD_ROOT}%{_initddir}/rpcbind
80
81%clean
82rm -rf %{buildroot}
83
84%pre
85
86# Check the validity of the rpc uid and gid.
87# If they don't exist, create them
88# If they exist but are the wrong value, remove them
89#   and recreate them with the correct value
90# If they exist and are the correct value do nothing
91rpcid=`getent passwd rpc | cut -d: -f 3`
92if [ -n "$rpcid" -a "$rpcid" != "32" ]; then
93        /usr/sbin/userdel  rpc 2> /dev/null || :
94        /usr/sbin/groupdel rpc 2> /dev/null || :
95fi
96if [ -z "$rpcid" -o "$rpcid" != "32" ]; then
97        /usr/sbin/groupadd -o -g 32 rpc > /dev/null 2>&1
98        /usr/sbin/useradd -o -l -c "Rpcbind Daemon" -d /var/lib/rpcbind -g 32 \
99        -M -s /sbin/nologin -u 32 rpc > /dev/null 2>&1
100fi
101%post
102/sbin/chkconfig --add %{name}
103
104%preun
105if [ $1 -eq 0 ]; then
106    service rpcbind stop > /dev/null 2>&1
107    /sbin/chkconfig --del %{name}
108        /usr/sbin/userdel  rpc 2>/dev/null || :
109        /usr/sbin/groupdel rpc 2>/dev/null || :
110        rm -rf /var/lib/rpcbind
111fi
112%postun
113if [ "$1" -ge "1" ]; then
114    service rpcbind condrestart > /dev/null 2>&1
115fi
116
117%files
118%defattr(-,root,root)
119%doc AUTHORS ChangeLog README
120/sbin/rpcbind
121%{_sbindir}/rpcinfo
122%{_mandir}/man8/*
123%config %{_initddir}/rpcbind
124
125%dir %attr(700,rpc,rpc) /var/lib/rpcbind
126
127%changelog
128* Mon Nov 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.1-1
129- update to 0.2.1
130- remove Patch100
131
132* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.2.0-6
133- rebuild with VineSeed environment
134
135* Sun Feb 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2.0-5
136- Initial build for Vine Linux
137
138* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-4
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
140
141* Mon Jul 06 2009 Adam Jackson <ajax@redhat.com> 0.2.0-3
142- Requires(pre): coreutils for cut(1).
143
144* Thu Jun 25 2009 Steve Dickson <steved@redhat.com> - 0.2.0-2
145- Fixed pre scriptle failure during upgrades (bz 507364)
146- Corrected the usage info to match what the rpcbind man
147    page says. (bz 466332)
148- Correct package issues (bz 503508)
149
150* Fri May 29 2009 Steve Dickson <steved@redhat.com> - 0.2.0-1
151- Updated to latest upstream release: 0.2.0
152
153* Tue May 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.1.7-3
154- Replace the Sun RPC license with the BSD license, with the explicit permission of Sun Microsystems
155
156* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.7-2
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
158
159* Wed Nov 19 2008 Steve Dickson <steved@redhat.com>  0.1.7-1
160- Update to latest upstream release: 0.1.7
161
162* Tue Sep 30 2008 Steve Dickson <steved@redhat.com>  0.1.6-3
163- Fixed a typo in the rpcbind.init script that stop warm starts
164  from happening with conrestarts
165- Fixed scriptlet failure (bz 462533)
166
167* Tue Sep 16 2008 Steve Dickson <steved@redhat.com> 0.1.6-2
168- Added usptream patches 01 thru 03 that do:
169    * Introduce helpers for ipprot/netid mapping
170    * Change how we decide on the netids to use for portmap
171    * Simplify port live check in pmap_svc.c
172
173* Wed Jul  9 2008 Steve Dickson <steved@redhat.com> 0.1.6-1
174- Updated to latest upstream release 0.1.6
175
176* Wed Jul  2 2008 Steve Dickson <steved@redhat.com> 0.1.5-5
177- Fixed SYNOPSIS section in the rpcinfo man page (bz 453729)
178
179* Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.5-4
180- Removed the documentation about the non-existent
181  '-L' flag (bz 446915)
182
183* Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.5-3
184- Set password and service lookups to be local (bz 447092)
185
186* Mon Jun 23 2008 Steve Dickson <steved@redhat.com> 0.1.5-2
187- rpcbind needs to downgrade to non-priviledgied group.
188
189* Mon Jun 23 2008 Steve Dickson <steved@redhat.com> 0.1.5-1
190- Updated to latest upstream release 0.1.5
191
192* Mon Feb 11 2008 Steve Dickson <steved@redhat.com> 0.1.4-14
193- Fixed a warning in pmap_svc.c
194- Cleaned up warmstarts so uid are longer needed, also
195  changed condrestarts to use warmstarts. (bz 428496)
196
197* Thu Jan 24 2008 Steve Dickson <steved@redhat.com> 0.1.4-13
198- Fixed connectivity with Mac OS clients by making sure handle_reply()
199  sets the correct fromlen in its recvfrom() call (bz 244492)
200
201* Mon Dec 17 2007 Steve Dickson <steved@redhat.com> 0.1.4-12
202- Changed is_loopback() and check_access() see if the calling
203  address is an address on a local interface, just not a loopback
204  address (bz 358621).
205
206* Wed Oct 17 2007 Steve Dickson <steved@redhat.com> 0.1.4-11
207- Reworked logic in initscript so the correct exit is
208  used when networking does not exist or is set up
209  incorrectly.
210
211* Tue Oct 16 2007 Steve Dickson <steved@redhat.com> 0.1.4-10
212- Corrected a typo in the initscript from previous
213  commit.
214
215* Mon Oct 15 2007 Steve Dickson <steved@redhat.com> 0.1.4-9
216- Fixed typo in Summary (bz 331811)
217- Corrected init script (bz 247046)
218
219* Sat Sep 15 2007 Steve Dickson <steved@redhat.com> 0.1.4-8
220- Fixed typo in init script (bz 248285)
221- Added autoconf rules to turn on secure host checking
222  via libwrap. Also turned on host check by default (bz 248284)
223- Changed init script to start service in runlevel 2 (bz 251568)
224- Added a couple missing Requires(pre) (bz 247134)
225
226* Fri May 25 2007 Steve Dickson <steved@redhat.com> 0.1.4-7
227- Fixed condrestarts (bz 241332)
228
229* Tue May 22 2007 Steve Dickson <steved@redhat.com> 0.1.4-6
230- Fixed an ipv6 related segfault on startup (bz 240873)
231
232* Wed Apr 18 2007 Steve Dickson <steved@redhat.com> 0.1.4-5
233- Added dependency on setup which contains the correct
234  rpcbind /etc/service entry which in turns stops
235  rpcbind from haning when NIS is enabled. (bz 236865)
236
237* Wed Apr 11 2007 Jeremy Katz <katzj@redhat.com> - 0.1.4-4
238- change man-pages requires into a conflicts as we don't have to have
239  man-pages installed, but if we do, we need the newer version
240
241* Fri Apr  6 2007 Steve Dickson <steved@redhat.com> 0.1.4-3
242- Fixed the Provides and Obsoletes statments to correctly
243  obsolete the portmap package.
244* Tue Apr  3 2007 Steve Dickson <steved@redhat.com> 0.1.4-2
245- Added dependency on glibc-common which allows the
246  rpcinfo command to be installed in the correct place.
247- Added dependency on man-pages so the rpcinfo man
248  pages don't conflict.
249- Added the creation of /var/lib/rpcbind which will be
250  used to store state files.
251- Make rpcbind run with the 'rpc' uid/gid when it exists.
252
253* Wed Feb 21 2007 Steve Dickson <steved@redhat.com> 0.1.4-1
254- Initial commit
255- Spec reviewed (bz 228894)
256- Added the Provides/Obsoletes which should
257  cause rpcbind to replace portmapper
Note: See TracBrowser for help on using the repository browser.