source: projects/specs/trunk/r/rp-pppoe/rp-pppoe-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: PPP Over Ethernet (xDSL support)
2Name: rp-pppoe
3Version: 3.10
4Release: 2%{?_dist_release}
5Group: System Environment/Daemons
6License: GPL
7URL: http://www.roaringpenguin.com/pppoe/
8
9Source0: http://www.roaringpenguin.com/pppoe/%{name}-%{version}.tar.gz
10Source1: tkpppoe.desktop
11Source2: rp-pppoe-3.5-ja.msg
12Source3: tkpppoe-html_ja.tar.gz
13Patch0: rp-pppoe-3.2-vine.patch
14Patch1: rp-pppoe-3.5-tkpppoe_help.patch
15Patch2: rp-pppoe-3.5-tkpppoe_i18n.patch
16Patch10: rp-pppoe-3.8-initscripts-7.2.10.patch
17
18Requires: ppp >= 2.3.7
19Prereq: /sbin/chkconfig
20BuildPrereq: nkf >= 2.01
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%package gui
27Summary: GUI wrapper around the rp-pppoe PPPoE client
28Summary(ja): rp-pppoe GUIラッパー
29Group: Applications/Internet
30Requires: %{name} >= 3.0, tk >= 8.4.1
31
32%description
33PPPoE (Point-to-Point Protocol over Ethernet) is a protocol used by
34many ADSL Internet Service Providers. Roaring Penguin has a free
35client for Linux systems to connect to PPPoE service providers.
36
37The client is a user-mode program and does not require any kernel
38modifications. It is fully compliant with RFC 2516, the official PPPoE
39specification.
40
41%description -l ja
42PPPoE (Point-to-Point Protocol over Ethernet)は、多くのADSL,FTTH 
43インターネットサービスプロバイダで用いられているプロトコルです。
44このパッケージは、PPPoE サービスプロバイダに接続するための、
45Linuxシステム用のフリーのクライアントです。
46
47このクライアントはユーザーモードプログラムであり、カーネルの
48修正を一切必要としません。このクライアントは、公式なPPPoEの
49仕様であるRFC 2516に完全に従っています。
50
51%description gui
52This is a graphical wrapper around the rp-pppoe PPPoE client.  PPPoE is
53a protocol used by many DSL Internet Service Providers.
54
55%description -l ja gui
56これはPPPoEクライアント rp-pppoe のGUIラッパーです。PPPoEは多くの
57ADSL,FTTHインターネットサービスプロバイダで用いられているプロトコルです。
58
59PPPoEクライアントをGUIで使いたい場合には、このパッケージをインストール
60してください。tclとtkのパーケージもインストールしておく必要があります。
61
62%prep
63%setup -q -a 3
64%patch0 -p1
65%patch1 -b .org
66%patch2 -b .i18n
67%patch10 -p1 -b .initscripts7210
68(cd gui
69%__install %{SOURCE2} ja.euc
70nkf -E -w ja.euc > ja.msg
71)
72
73%build
74cd src
75%configure
76cd ..
77make -C src
78make -C gui
79
80%install
81%__rm -rf %{buildroot}
82# make install RPM_INSTALL_ROOT=%{buildroot} -C src
83# make install RPM_INSTALL_ROOT=%{buildroot} -C gui
84make -C src install DESTDIR=%{buildroot}
85make -C gui install DESTDIR=%{buildroot}
86
87%__install -m 644 gui/html/* %{buildroot}/%{_datadir}/tkpppoe
88
89%__install -d %{buildroot}/%{_datadir}/applications
90%__install -m 644 %{SOURCE1} %{buildroot}/%{_datadir}/applications/tkpppoe.desktop
91
92# %post
93# /sbin/chkconfig --add pppoe
94
95%preun
96if [ $1 = 0 ]; then
97    /sbin/chkconfig --del pppoe
98    /etc/rc.d/init.d/pppoe stop
99fi
100
101%clean
102# rm -rf %{buildroot}
103
104%files
105%defattr(-,root,root)
106%doc doc/CHANGES doc/HOW-TO-CONNECT doc/LICENSE doc/KERNEL-MODE-PPPOE
107%doc doc/PROBLEMS README
108%config %{_sysconfdir}/rc.d/init.d/pppoe
109%config(noreplace) %{_sysconfdir}/ppp/pppoe.conf
110%config(noreplace) %{_sysconfdir}/ppp/pppoe-server-options
111%config(noreplace) %{_sysconfdir}/ppp/firewall-masq
112%config(noreplace) %{_sysconfdir}/ppp/firewall-standalone
113%{_sysconfdir}/ppp/plugins/*
114%{_sbindir}/pppoe
115%{_sbindir}/pppoe-server
116%{_sbindir}/pppoe-sniff
117%{_sbindir}/pppoe-relay
118%{_sbindir}/pppoe-connect
119%{_sbindir}/pppoe-start
120%{_sbindir}/pppoe-stop
121%{_sbindir}/pppoe-setup
122%{_sbindir}/pppoe-status
123%{_mandir}/man5/*
124%{_mandir}/man8/*
125
126%files gui
127%defattr(-,root,root)
128%doc doc/CHANGES doc/HOW-TO-CONNECT doc/LICENSE doc/KERNEL-MODE-PPPOE
129%doc doc/PROBLEMS README
130%dir /etc/ppp/rp-pppoe-gui
131%{_sbindir}/pppoe-wrapper
132%{_bindir}/tkpppoe
133%{_datadir}/tkpppoe
134%{_mandir}/man1/*
135%config(missingok) %{_datadir}/applications/tkpppoe.desktop
136
137%changelog
138* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.10-2
139- spec in utf-8
140
141* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.10-1
142- new upstream release
143
144* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.8-1vl5
145- applied new versioning policy
146
147* Sun Dec 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-0vl5
148- update patch10 to set DEVNAME in pppoe-connect
149
150* Sat Nov 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-0vl4
151- update pppoe-{start,stop,connect,status} fot initscripts-7.2.10
152  (<BTS:0560>)
153
154* Tue Jan 16 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.8-0vl3
155- separete .desktop as Source1 to use UTF-8 encoding.
156
157* Sat Jan 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.8-0vl2
158- change .desktop installation directory. <BTS:VineLinux:405>
159
160* Mon Sep 11 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8-0vl1
161- rebuild for Vine 4.0/VineSeed
162
163* Mon Jul 24 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8-0vl0.1
164- test package for Vine 3.2
165- new upstream release 3.8
166- change filename adsl-* to pppoe-* in file section
167
168* Sun Jul 20 2003 Masaki Shinomiya <shino@pos.to> 3.5-0vl3
169- ja.msg in UTF-8, japanese html help file
170- both translation originally by Ryoji Kawagishi
171- allow mozilla for help browser, tkpppoe.desktop, i18n.patch
172- group of the gui package to Applications/Internet
173- vendor and distribution
174
175* Sat Mar 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5-0vl2
176- rebuild with new toolchains
177
178* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5-0vl1
179- new upstream release 3.5
180
181* Fri Jun 07 2002 Tomoya TAKA <taka@vinelinux.org> 3.4-0vl1
182- update to 3.4
183- split tkpppoe.desktop from spec file (%%{SOURCE1})
184
185* Sun Feb 24 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-0vl2
186- remove %%post script
187  - do not chkconfig --add at install time, we need some configuration before using.
188
189* Fri Sep 14 2001 Toru Sagami <sagami@vinelinux.org>
190- 3.3-0vl1
191
192* Fri Jul 20 2001 <sagami@vinelinux.org>
193- 3.2-0vl1: added patch for vine-release and erased BuildPreReq
194
195* Thu Jul 05 2001 <sagami@vinelinux.org>
196- 3.1-0vl1
197- use more (not better!) macros
198- added BuildPreReq /etc/redhat-release (trick of a kind)
199
200* Wed Jun 27 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
201- 3.0-1vl2
202- add %%config(noreplace)
203- add /etc/X11/applnk/Internet/tkpppoe.desktop to rp-pppoe-gui
204- add Prereq: /sbin/chkconfig
205
206* Wed Apr 18 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
207- 3.0-1vl1
208- first package tailored for Vine Linux 2.x
209- merge rp-pppoe-gui-3.0-1
Note: See TracBrowser for help on using the repository browser.