source: projects/specs/trunk/r/routed/routed-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     The routing daemon which maintains routing tables.
2Summary(ja): ルーティングテーブルを保持するデーモン
3Name: routed
4Version: 0.17
5Release: 16%{?_dist_release}
6License: BSD
7Group: System Environment/Daemons
8Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/netkit-routed-%{version}.tar.bz2
9Source1: routed.init
10Patch0: netkit-routed-0.16-jbj.patch
11Patch1: netkit-routed-0.17-bero.patch
12Patch2: netkit-routed-0.17-nonstrip.patch
13Prereq: /sbin/chkconfig /etc/init.d
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15
16
17%description
18The routed routing daemon handles incoming RIP traffic and broadcasts
19outgoing RIP traffic about network traffic routes, in order to
20maintain current routing tables.  These routing tables are essential
21for a networked computer, so that it knows where packets need to be
22sent.
23
24The routed package should be installed on any networked machine.
25
26%description -l ja
27routed ルーティングデーモンは,マシンに入って来たり出てゆく
28ネットワーク経路情報である RIP トラフィックを扱い,
29ルーティングテーブルを保持します.
30ルーティングテーブルはネットワーク接続されたコンピュータにとっては
31パケットをどこに送信するべきかを知る上で非常に重要なものです.
32
33routed パッケージはネットワーク接続されたマシンには必ず
34インストールされている必要があります.
35
36
37%prep
38%setup -q -n netkit-routed-%{version}
39%patch0 -p1 -b .jbj
40%patch1 -p1 -b .bero
41%patch2 -p1 -b .nonstrip
42
43%build
44sh configure
45perl -pi -e '
46    s,^CC=.*$,CC=cc,;
47    s,-O2,\$(RPM_OPT_FLAGS),;
48    s,^BINDIR=.*$,BINDIR=%{_bindir},;
49    s,^MANDIR=.*$,MANDIR=%{_mandir},;
50    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
51    ' MCONFIG
52
53make
54
55
56%install
57rm -rf ${RPM_BUILD_ROOT}
58mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
59mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
60mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
61
62make INSTALLROOT=${RPM_BUILD_ROOT} install
63install -m 755 $RPM_SOURCE_DIR/routed.init ${RPM_BUILD_ROOT}%{_initdir}/routed
64
65
66%clean
67rm -rf ${RPM_BUILD_ROOT}
68
69
70%post
71/sbin/chkconfig --add routed
72
73
74%preun
75if [ $1 = 0 ]; then
76    /sbin/chkconfig --del routed
77fi
78
79
80%files
81%defattr(-,root,root)
82%{_sbindir}/routed
83#%{_sbindir}/ripquery
84%{_mandir}/man8/routed.*
85#%{_mandir}/man8/ripquery.*
86%config %{_initdir}/routed
87
88
89%changelog
90* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-16vl5
91- applied new versioning policy, spec in utf-8
92
93* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-15vl1
94- rebuilt with new toolchains
95- s/Copyright/License/
96- based on 0.17-15 from Rawhide
97  - Fri Jul 19 2002 Akira TAGOH <tagoh@redhat.com> 0.17-12
98  - netkit-routed-0.17-nonstrip.patch: applied to fix
99    the stripped binary issue.
100
101  - Wed Aug  1 2001 Adrian Havill <havill@redhat.com>
102  - init script gettext-friendly fix (bug 26563)
103
104  - Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
105  - i18nize init scripts (#26079)
106  - bzip2 source
107  - fix "egcs" compiler hardcode in configure script
108
109* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
110- 0.17-5vl1
111- based on 0.17-5 from Rawhide
112- use better macros (%%{_initdir})
113- added Japanese summary and description
114
115* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
116- condrestart fixes
117
118* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
119- move initscript back
120
121* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
122- automatic rebuild
123
124* Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
125- move initscript
126
127* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
128- FHS packaging.
129- update to 0.17.
130
131* Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
132- remove ripquery, the gated ripquery (and gated itself) is preferred.
133
134* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
135- init script marked config.
136
137* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
138- compress man pages.
139
140* Mon Jan  3 2000 Bill Nottingham <notting@redhat.com>
141- fix hang on startup
142
143* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
144- update to 0.16.
145
146* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
147- chkconfig --del in %preun, not %postun
148
149* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
150- initscript munging
151
152* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
153- auto rebuild in the new build environment (release 14)
154
155* Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
156- check for /etc/sysconfig/routed before sourcing.
157
158* Tue Dec 22 1998 Jeff Johnson <jbj@redhat.com>
159- use stderr if no trace file specified (#423).
160- use FD_ISSET not fds_bits (glibc-2.1).
161
162* Tue Jun 16 1998 Jeff Johnson <jbj@redhat.com>
163- add offset to get aligned ifreq's on alpha. This should be
164  fixed in the kernel eventually.
165
166* Tue May 19 1998 Prospector System <bugs@redhat.com>
167- translations modified for de
168
169* Sun May 10 1998 Alan Cox <alan@redhat.com>
170- Fixed the trace bug. Traces must now go into /var/log/routed/*
171
172* Mon May 04 1998 Michael K. Johnson <johnsonm@redhat.com>
173- Added /etc/sysconfig/routed parsing to init script
174
175* Sat May 02 1998 Prospector System <bugs@redhat.com>
176- translations modified for de, fr, tr
177
178* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
179- enhanced initscripts
180
181* Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
182- fixed init script (wasn't including function library)
183
184* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
185- added init script, chkconfig support
186
187* Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
188- initial build
Note: See TracBrowser for help on using the repository browser.