source: projects/specs/trunk/r/rootfiles/rootfiles-vl.spec @ 521

Revision 521, 3.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define date 20090501
2
3Summary: The basic required files for the root user's directory.
4Summary(ja): rootユーザのためのデフォルトファイル
5Name: rootfiles
6Version: 8.0
7Release: 1%{?_dist_release}
8License: Public Domain
9Group: System Environment/Base
10Source: rootfiles-vine-%{date}.tar.bz2
11BuildArchitectures: noarch
12BuildRoot: %{_tmppath}/%{name}-root
13
14%description
15The rootfiles package contains basic required files that are placed
16in the root user's account.  These files are basically the same
17as the files found in the etcskel package, which are placed in regular
18users' home directories.
19
20%description -l ja
21rootfiles パッケージは root ユーザアカウントに必要とされる基本的な
22ファイルを含んでいます。これらのファイルは etcskel に含まれる通常の
23ユーザ用のファイルと基本的に同じです。
24
25%prep
26%setup -q -n rootfiles-vine-%{date}
27
28%install
29rm -rf $RPM_BUILD_ROOT
30make install DESTDIR=$RPM_BUILD_ROOT
31
32%clean
33rm -rf $RPM_BUILD_ROOT
34
35%pre
36# we used to put .Xclients in this package -- back it up if it's been
37# customized
38cd /root
39if [ -f .Xclients -a -x /bin/awk ]; then
40    m=`md5sum .Xclients | awk '{ print $1 }'`
41    if [ $m != "506b9496f2853fc9fee6c6b1c5f3ee48" ]; then
42        mv .Xclients .Xclients.rpmsave
43    fi
44fi
45
46%files
47%defattr(640,root,root)
48%attr(750,root,root) %dir /root/.xemacs
49%attr(700,root,root) %dir /root/.gnupg
50%config /root/.[A-z]*
51
52%changelog
53* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0-1
54- synced with etcskel-4.0.0
55
56* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 7.8-1vl5
57- applied new versioning policy, spec in utf-8
58
59* Sun Jan 28 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 7.8-0vl2
60- fix typo in spec <BTS:VineLinux:425>
61- add japanese description
62
63* Thu Nov 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 7.8-0vl1
64- remove .rpmmacros
65
66* Thu Oct 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 7.7-0vl1
67- synced with etcskel-3.4.0
68- add .rpmmacros
69- use License: tag
70
71* Wed Aug 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.6-0vl1
72- add .gnupg directory for first run of apt-get update
73- synced with etcskel-3.0-0vl3
74
75* Wed Jul 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-0vl1
76- synced with etcskel-3.0-0vl2
77
78* Tue Jun 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-0vl1
79- synced with etcskel-2.9-0vl3
80
81* Mon Jun 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
82- synced with etcskel-2.9-0vl2
83
84* Tue Nov 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
85- synced with etcskel-2.6-1vl1
86
87* Sat Apr 21 2001 <sagami@vinelinux.org>
88- 6.2-0vl1 from 5.2-5vl4: what comes from 5.2?? /etc/redhat-release !?
89- imported some files from etcskel-2.3-1vl12 (Xdefaults, emacs.el ,canna...)
90
91* Tue Jan 23 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
92- fixed "eng" alias (LC_ALL)
93- defattr 640
94- added Makefile to be lazy...
95
96* Wed Mar 15 2000 Jun Nishii <jun@vinelinux.org>
97- update .Xdefaults and inport .canna
98
99* Sun Mar  5 2000 Jun Nishii <jun@vinelinux.org>
100- inport dot-files from etcskel
101
102* Thu Oct 21 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
103- 5.2-5vl1
104- add .emacs, .emacs.el, .xemacs.el and .canna onto 5.2-5
105
106* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
107- auto rebuild in the new build environment (release 5)
108
109* Tue Jan 12 1999 Jeff Johnson <jbj@redhat.com>
110- add %clean (#719)
111
112* Tue Dec 29 1998 Cristian Gafton <gafton@redhat.com>
113- build for 6.0
114
115* Wed Oct  9 1998 Bill Nottingham <notting@redhat.com>
116- remove /root from %files (it's in filesystem)
117
118* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
119- portability fix for .cshrc (problem #235)
120- change version to be same as release.
121
122* Tue Sep 09 1997 Erik Troan <ewt@redhat.com>
123- made a noarch package
124
125* Thu Mar 20 1997 Erik Troan <ewt@redhat.com>
126- Removed .Xclients and .Xsession from package, added %pre to back up old
127  .Xclients if necessary.
Note: See TracBrowser for help on using the repository browser.