source: projects/specs/trunk/r/rocs/rocs-vl.spec @ 7801

Revision 7801, 3.9 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.11.1

Line 
1Name: rocs
2Summary: Graph theory IDE
3Summary(ja): グラフ理論向け IDE
4Version: 4.11.1
5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group: Applications/Edutainment
9URL: http://edu.kde.org/rocs/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13## upstream patches
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: desktop-file-utils
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: libboost-devel
19BuildRequires: libboost-graph
20BuildRequires: soprano-devel
21BuildRequires: grantlee-devel
22
23Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
24Requires: kwrite
25
26Conflicts: kdeedu4 < 4.6.50
27
28%description
29Rocs aims to be a Graph Theory IDE for helping professors to show
30the results of a graph algorithm and also helping students to do
31the algorithms.
32
33Rocs has a scripting module, done in Qt Script, that interacts with
34the drawn graph and every change in the graph with the script is
35reflected on the drawn one.
36
37This package is part of the KDE education module.
38
39%package libs
40Summary: Runtime libraries for %{name}
41Summary(ja): %{name} のランタイムライブラリ
42Group:   System Environment/Libraries
43Conflicts: kdeedu4-math-libs < 4.6.50
44
45%description libs
46%{summary}.
47
48%package devel
49Summary: Development files for %{name}
50Summary(ja): %{name} の開発用ファイル
51Group: Development/Libraries
52Requires: %{name}-libs = %{version}-%{release}
53Conflicts: kdeedu4-devel < 4.6.50
54
55%description devel
56Header files for developing applications using %{name}.
57
58%prep
59%setup -q
60
61%build
62# uniform_int_distribution error
63sed -i "s|add_subdirectory(GenerateGraph)|#add_subdirectory(GenerateGraph)|" VisualEditor/Tools/CMakeLists.txt
64
65mkdir -p %{_target_platform}
66pushd %{_target_platform}
67%cmake \
68    -DCMAKE_BUILD_TYPE=release \
69    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
70    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
71    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
72    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
73    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
74    ..
75popd
76
77make %{?_smp_mflags} -C %{_target_platform}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%check
87for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
88    desktop-file-validate $f
89done
90
91
92%posttrans
93update-desktop-database -q &> /dev/null ||:
94
95%postun
96if [ $1 -eq 0 ] ; then
97    update-desktop-database -q &> /dev/null ||:
98fi
99
100%post libs -p /sbin/ldconfig
101
102%postun libs -p /sbin/ldconfig
103
104
105%files
106%defattr(-,root,root)
107%doc COPYING COPYING.DOC
108%{_bindir}/rocs
109%{_libdir}/kde4/rocs_*.so
110%{_datadir}/applications/kde4/rocs.desktop
111%{_datadir}/config/rocs.knsrc
112%{_datadir}/config.kcfg/rocs.kcfg
113%{_datadir}/icons/hicolor/*/*/*
114%{_datadir}/kde4/apps/rocs
115%{_datadir}/kde4/apps/rocs_rootedtree
116%{_datadir}/kde4/services/rocs_*.desktop
117%{_datadir}/kde4/servicetypes/Rocs*.desktop
118%doc %{_docdir}/HTML/en/rocs/
119
120%files libs
121%defattr(-,root,root)
122%{_libdir}/librocscore.so.*
123%{_libdir}/librocsvisualeditor.so.*
124
125%files devel
126%defattr(-,root,root)
127%{_includedir}/kde4/rocs
128%{_libdir}/librocscore.so
129%{_libdir}/librocsvisualeditor.so
130
131
132%changelog
133* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
134- new upstream release
135- add BuildRequires: grantlee-devel
136
137* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
138- new upstream release
139
140* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
141- new upstream release
142
143* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
144- new upstream release
145
146* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
147- new upstream release
148
149* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
150- new upstream release
151
152* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
153- new upstream release
154- add BuildRequires: libboost-graph
155
156* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
157- split from kdeedu
158
Note: See TracBrowser for help on using the repository browser.