source: projects/specs/trunk/r/rocs/rocs-vl.spec @ 7105

Revision 7105, 3.3 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.3, etc

Line 
1Name: rocs
2Summary: Graph theory IDE
3Summary(ja): グラフ理論向け IDE
4Version: 4.9.3
5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group: Applications/Edutainment
9URL: http://edu.kde.org/rocs/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
12
13## upstream patches
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: desktop-file-utils
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: libboost-devel
19BuildRequires: libboost-graph
20BuildRequires: soprano-devel
21
22Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
23Requires: kwrite
24
25Conflicts: kdeedu4 < 4.6.50
26
27%description
28Rocs aims to be a Graph Theory IDE for helping professors to show
29the results of a graph algorithm and also helping students to do
30the algorithms.
31
32Rocs has a scripting module, done in Qt Script, that interacts with
33the drawn graph and every change in the graph with the script is
34reflected on the drawn one.
35
36This package is part of the KDE education module.
37
38%package libs
39Summary: Runtime libraries for %{name}
40Summary(ja): %{name} のランタイムライブラリ
41Group:   System Environment/Libraries
42Conflicts: kdeedu4-math-libs < 4.6.50
43
44%description libs
45%{summary}.
46
47%package devel
48Summary: Development files for %{name}
49Summary(ja): %{name} の開発用ファイル
50Group: Development/Libraries
51Requires: %{name}-libs = %{version}-%{release}
52Conflicts: kdeedu4-devel < 4.6.50
53
54%description devel
55Header files for developing applications using %{name}.
56
57%prep
58%setup -q
59
60%build
61mkdir -p %{_target_platform}
62pushd %{_target_platform}
63%cmake \
64    -DCMAKE_BUILD_TYPE=release \
65    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
66    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
67    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
68    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
69    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
70    ..
71popd
72
73make %{?_smp_mflags} -C %{_target_platform}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%check
83for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
84    desktop-file-validate $f
85done
86
87
88%posttrans
89update-desktop-database -q &> /dev/null ||:
90
91%postun
92if [ $1 -eq 0 ] ; then
93    update-desktop-database -q &> /dev/null ||:
94fi
95
96%post libs -p /sbin/ldconfig
97
98%postun libs -p /sbin/ldconfig
99
100
101%files
102%defattr(-,root,root)
103%doc COPYING COPYING.DOC
104%{_bindir}/rocs
105%{_libdir}/kde4/rocs_*.so
106%{_datadir}/applications/kde4/rocs.desktop
107%{_datadir}/config/rocs.knsrc
108%{_datadir}/config.kcfg/rocs.kcfg
109%{_datadir}/kde4/apps/rocs
110%{_datadir}/kde4/apps/rocs_rootedtree
111%{_datadir}/kde4/services/rocs_*.desktop
112%{_datadir}/kde4/servicetypes/Rocs*.desktop
113%doc %{_docdir}/HTML/en/rocs/
114
115%files libs
116%defattr(-,root,root)
117%{_libdir}/librocslib.so.*
118
119%files devel
120%defattr(-,root,root)
121%{_includedir}/kde4/rocs
122%{_libdir}/librocslib.so
123
124
125%changelog
126* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
127- new upstream release
128
129* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
130- new upstream release
131
132* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
133- new upstream release
134
135* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
136- new upstream release
137- add BuildRequires: libboost-graph
138
139* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
140- split from kdeedu
141
Note: See TracBrowser for help on using the repository browser.