source: projects/specs/trunk/r/rocs/rocs-vl.spec @ 4743

Revision 4743, 2.9 KB checked in by inagaki, 13 years ago (diff)

NEW: KDE Educational packages
update: kdeplasma-addons

Line 
1Name: rocs
2Summary: Graph theory IDE
3Summary(ja): グラフ理論向け IDE
4Version: 4.7.0
5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group: Applications/Edutainment
9URL: http://edu.kde.org/rocs/
10
11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
12
13## upstream patches
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: desktop-file-utils
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: libboost-devel
19BuildRequires: soprano-devel
20
21Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
22Requires: kwrite
23
24Conflicts: kdeedu4 < 4.6.50
25
26%description
27Rocs aims to be a Graph Theory IDE for helping professors to show
28the results of a graph algorithm and also helping students to do
29the algorithms.
30
31Rocs has a scripting module, done in Qt Script, that interacts with
32the drawn graph and every change in the graph with the script is
33reflected on the drawn one.
34
35This package is part of the KDE education module.
36
37%package libs
38Summary: Runtime libraries for %{name}
39Summary(ja): %{name} のランタイムライブラリ
40Group:   System Environment/Libraries
41Conflicts: kdeedu4-math-libs < 4.6.50
42
43%description libs
44%{summary}.
45
46%package devel
47Summary: Development files for %{name}
48Summary(ja): %{name} の開発用ファイル
49Group: Development/Libraries
50Requires: %{name}-libs = %{version}-%{release}
51Conflicts: kdeedu4-devel < 4.6.50
52
53%description devel
54Header files for developing applications using %{name}.
55
56%prep
57%setup -q
58
59%build
60mkdir -p %{_target_platform}
61pushd %{_target_platform}
62unset QTDIR || : ; . /etc/profile.d/qt4.sh
63%cmake \
64    -DCMAKE_BUILD_TYPE=release \
65    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
66    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
67    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
68    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
69    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
70    ..
71popd
72
73make %{?_smp_mflags} -C %{_target_platform}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%check
83for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
84    desktop-file-validate $f
85done
86
87
88%posttrans
89update-desktop-database -q &> /dev/null ||:
90
91%postun
92if [ $1 -eq 0 ] ; then
93    update-desktop-database -q &> /dev/null ||:
94fi
95
96%post libs -p /sbin/ldconfig
97
98%postun libs -p /sbin/ldconfig
99
100
101%files
102%defattr(-,root,root)
103%doc COPYING COPYING.DOC
104%{_bindir}/rocs
105%{_libdir}/kde4/rocs_*.so
106%{_datadir}/applications/kde4/rocs.desktop
107%{_datadir}/config/rocs.knsrc
108%{_datadir}/config.kcfg/rocs.kcfg
109%{_datadir}/kde4/apps/rocs
110%{_datadir}/kde4/services/rocs_*.desktop
111%{_datadir}/kde4/servicetypes/Rocs*.desktop
112%doc %{_docdir}/HTML/en/rocs/
113
114%files libs
115%defattr(-,root,root)
116%{_libdir}/librocslib.so.*
117
118%files devel
119%defattr(-,root,root)
120%{_includedir}/kde4/rocs
121%{_libdir}/librocslib.so
122
123
124%changelog
125* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
126- split from kdeedu
127
Note: See TracBrowser for help on using the repository browser.